#libreoffice-qa Meeting

Meeting started by jmadero at 14:10:02 UTC (full logs).

Meeting summary

  1. People Present (jmadero, 14:10:59)
    1. Bjoern, Joel, Petr (jmadero, 14:11:09)
    2. Rob (jmadero, 14:12:33)

  2. BSA Localization (jmadero, 14:12:48)
    1. Translation needed & E-Mail feature (jmadero, 14:13:39)
    2. take string for l10n from the website, no canonical list in source (Sweetshark, 14:13:56)
    3. goal is to have this done before the end of the year (jmadero, 14:14:50)
    4. timeline: hopefully before the end of the year, so should be good for 4.0.0 (Sweetshark, 14:14:51)
    5. ACTION: Bjoern e-mail contact in French community to get a translation done (jmadero, 14:15:53)
    6. ACTION: give infra guys a shot over the bow about the BSA changes (Sweetshark, 14:18:17)

  3. BSA regression issues (jmadero, 14:19:44)
    1. regression checks already implemented (Sweetshark, 14:20:21)
    2. should fix 90% of the false positives (Sweetshark, 14:20:39)
    3. other BSA improvements pending UX input (Sweetshark, 14:22:18)

  4. BSA Version in Comments (jmadero, 14:24:47)
    1. Rob said that this wouldn't be hard at all but we still have to decide what to do with version field (jmadero, 14:25:08)
    2. ACTION: Rob make version go into comments when reported from BSA (jmadero, 14:25:21)

  5. Old Bugs (Greater Than 6 Months Old) (jmadero, 14:27:31)
  6. OpenID Alternatives and other Alternatives (jmadero, 14:27:53)
    1. not sure right now about status, ongoing (jmadero, 14:28:39)

  7. Bugzilla Contract Items (jmadero, 14:28:50)
    1. most active bug wranglers, etc... do these before the OpenID stuff (jmadero, 14:29:56)

  8. Twitter Feed for FDO (Marketing) (jmadero, 14:30:20)
    1. ACTION: Bjoern find rss feed for twitter feed (jmadero, 14:30:49)

  9. realistic goals (jmadero, 14:31:05)
    1. punt until after release of 4 (jmadero, 14:31:12)

  10. hard hacks (jmadero, 14:31:15)
    1. no new items (jmadero, 14:31:27)

  11. contest for triaging (jmadero, 14:31:38)
    1. board hasn't made an explicit vote on this but shouldn't be a problem at all (jmadero, 14:31:58)
    2. sending out the items can be difficult, expensive to mail (jmadero, 14:32:15)

  12. funding wish list (jmadero, 14:32:28)
    1. board agreed that we should make a funding wish list so that it's easier to plan and budget (jmadero, 14:32:53)
    2. AGREED: make regular funding wish list (jmadero, 14:33:18)
    3. prize of a netbook is a possibility, but shipping is still an issue (jmadero, 14:33:43)
    4. possibility of a shipping budget (jmadero, 14:35:24)
    5. for people in Europe, hackfest could be good exchange location (jmadero, 14:36:01)
    6. ACTION: find a solution for shipping items worldwide (jmadero, 14:36:29)

  13. test week marathon (jmadero, 14:36:48)
    1. priority for more experienced triagers (jmadero, 14:38:29)
    2. bibisect, and playing around with beta 1 (jmadero, 14:39:28)
    3. priority for less experienced users - try to verify bugs and verify fixes (jmadero, 14:39:39)
    4. experienced triagers - helping newcomers, if no one is around to teach/mentor then move on to bibisect & finding new bugs (jmadero, 14:40:45)
    5. newcomers - direct to a page that has new features to test (jmadero, 14:41:10)
    6. ACTION: Joel will make a list of new features that are easy to read for testing purposes (jmadero, 14:42:54)

  14. WFM Status (jmadero, 14:43:58)
    1. AGREED: if one triager matches platform and has the same or a newer version, closing as WFM with a comment asking reporter to reopen if it's still an issue for them (jmadero, 14:46:13)
    2. AGREED: needinfo status should be used liberally also, especially for newer bugs that can't be reproduced (jmadero, 14:51:31)
    3. AGREED: WFM can be used more liberally if triager is using a newer version than the reporter reported (jmadero, 14:54:11)

  15. BSA - Reproducible Steps Lacking (jmadero, 14:56:21)
    1. AGREED: put in NEEDINFO (jmadero, 14:56:26)

  16. bibisect for version 4 (jmadero, 15:00:45)
    1. good and ready to go (jmadero, 15:01:12)
    2. slow download speeds (jmadero, 15:01:51)
    3. ACTION: look into mirrors for bibisect (jmadero, 15:01:57)
    4. ACTION: Joel will look into torrenting bibisect (jmadero, 15:02:10)

  17. Crash Reporting (Auto Report) (jmadero, 15:03:52)
    1. very hard infrastructure wise & legal wise (jmadero, 15:04:09)
    2. https://errors.ubuntu.com/ (Sweetshark, 15:04:28)
    3. symbols also missing, so a lot would be needed to enable it (too much developer time) (jmadero, 15:06:52)
    4. AGREED: Too much involved to implement this ourselves, Linux has similar systems already, on Windows would be very difficult and cause legal problems (jmadero, 15:07:08)

  18. IRC Lightning Talks for Test Marathon (jmadero, 15:08:10)
    1. stuff for newcomers to talk about (jmadero, 15:08:31)
    2. verify bugs, verify fixes, etc... (jmadero, 15:08:40)
    3. ACTION: ALL come with a few slides for discussions with newcomers (jmadero, 15:09:11)
    4. 10-15 minutes to talk on IRC (jmadero, 15:09:31)

  19. Windows Parallel Install (jmadero, 15:10:26)
    1. Florian has already made this for Windows (jmadero, 15:11:49)
    2. on Ubuntu - bibisect version is a possibility because it doesn't touch stable version (jmadero, 15:12:14)
    3. no clear answer for Linux platform as a whole (jmadero, 15:12:27)
    4. on Suse, installing upstream and another version from LibreOffice (such as Beta) work perfectly, unsure about on Ubuntu (jmadero, 15:15:30)
    5. ACTION: Joel -- add a note on Wiki about parallel installs (jmadero, 15:17:30)
    6. IDEA: for next release possibility of making virtual box release (jmadero, 15:18:30)

  20. Version on FDO (jmadero, 15:19:55)
    1. counter-intuitive to do what we're doing now, but might be only useful information (jmadero, 15:20:40)
    2. if the bug is still open we can assume it's still on latest release (jmadero, 15:20:53)
    3. really depends on what the developers are looking at - Version, vs Comments vs. Last Modified (jmadero, 15:23:47)
    4. AGREED: before any change in policy we need more discussion between users, developers and QA (jmadero, 15:26:55)
    5. FDO contract has something about Version - if someone updates Version to newer release, they get a message about this (jmadero, 15:28:16)
    6. AGREED: we will discuss this again during IRC meeting (jmadero, 15:28:59)

  21. Next Meeting Date (jmadero, 15:31:18)
    1. AGREED: skip next meeting because of holidays (jmadero, 15:31:31)


Meeting ended at 15:31:33 UTC (full logs).

Action items

  1. Bjoern e-mail contact in French community to get a translation done
  2. give infra guys a shot over the bow about the BSA changes
  3. Rob make version go into comments when reported from BSA
  4. Bjoern find rss feed for twitter feed
  5. find a solution for shipping items worldwide
  6. Joel will make a list of new features that are easy to read for testing purposes
  7. look into mirrors for bibisect
  8. Joel will look into torrenting bibisect
  9. ALL come with a few slides for discussions with newcomers
  10. Joel -- add a note on Wiki about parallel installs


People present (lines said)

  1. jmadero (81)
  2. Sweetshark (8)
  3. IZBot (2)
  4. jorendc (1)
  5. yipper (1)


Generated by MeetBot 0.1.4.