#libreoffice-qa Meeting

Meeting started by jmadero at 19:39:40 UTC (full logs).

Meeting summary

  1. Completed Action Items [Thanks To] (jmadero, 19:40:26)
    1. BSA: Invitation to participate with triaging after a user submits a bug [Rob] (jmadero, 19:41:00)
    2. Wiki: Basic instructions for triaging with links to more involved instructions [Joel & Petr] (jmadero, 19:41:27)
    3. FDO: Rename/Merge 3.7 Master with 4.0 Master [Joel] (jmadero, 19:41:44)

  2. FDO: Old/Inactive Bugs (jmadero, 19:42:27)
    1. Bugs that have gone more than 6 months without any activity are starting to build up in FDO, options discussed to figure out how to deal with these (jmadero, 19:43:32)
    2. concern that these bugs are no longer actually bugs with current releases but that the bugs were fixed independent of the bug report and therefore never marked as RESOLVED -> FIXED (jmadero, 19:43:57)
    3. IDEA: New White Board Status ("Inactive") (jmadero, 19:44:11)
    4. IDEA: Lower Priority Automatically After X Time (jmadero, 19:44:32)
    5. AGREED: Lowering bug priority automatically is a bad idea (jmadero, 19:44:46)
    6. IDEA: Using Enhancement Status More (jmadero, 19:45:20)
    7. concern that bugs will be marked as enhancements incorrectly, enhancements status already used relatively frequent (jmadero, 19:45:48)
    8. Any option will require communcation with bug submitter to request further testing on new stable releases (jmadero, 19:47:03)
    9. AGREED: Not an urgent matter, any solution should be well thought out before implementation (jmadero, 19:47:23)

  3. FDO: Identifying Most/Least Active Bugs (jmadero, 19:48:03)
    1. identifying the most and least active bugs internally may help organization of bugs quite a bit (jmadero, 19:48:17)
    2. IDEA: try to use FDO data along with Calc to implement something similar to Canonical's "bug heat" (jmadero, 19:48:51)
    3. ACTION: Joel will try to make a prototype for "bug heat" from FDO data (jmadero, 19:49:43)

  4. Bugzilla: Open ID Alternatives (jmadero, 19:50:12)
    1. OpenID is not an option because of technical reasons (jmadero, 19:50:26)
    2. ACTION: Bjoern will look into alternatives for OpenID, will discuss with Tolef (jmadero, 19:50:53)
    3. goal to have one authenticator is unlikely to occur (jmadero, 19:51:02)
    4. Florian showed support for Google Login, other options include Facebook & Twitter (jmadero, 19:51:25)

  5. BSA: Localization (jmadero, 19:51:50)
    1. Rob discussed this during hackfest, said sounds good and should be doable (jmadero, 19:52:07)
    2. ACTION: Joel will contact Rob about BSA Localization to get an update (jmadero, 19:52:17)

  6. Marketing: Twitter Feed (jmadero, 19:52:43)
    1. twitter feed to announce bug fixed in order to promote more people following LibO and possibly getting involved with QA/Development (jmadero, 19:53:07)
    2. twitter has a max per hour but this shouldn't be an issue for us (jmadero, 19:53:21)
    3. ACTION: Bjoern will continue looking into creating twitter feed for bug fixes, will ping Florian about this (jmadero, 19:53:44)

  7. Goals (jmadero, 19:53:53)
    1. punt until after release of version 4 (jmadero, 19:54:00)

  8. Hard Hacks (jmadero, 19:54:06)
    1. Everyone will keep an eye out for hard hacks (jmadero, 19:54:14)
    2. acknowledgment that this will slow down until after release of version 4 (jmadero, 19:54:26)
    3. AGREED: Hard Hacks wiki is relatively well known so we should keep it up to date and not let it go stagnant (jmadero, 19:54:45)
    4. ACTION: Joel will add bug 57619 to hard hack wiki (jmadero, 19:54:57)

  9. meetbot (jmadero, 19:55:32)
    1. meetbot is set up and Bjoern/Joel played around with it, weren't quite comfortable enough to use it yet (jmadero, 19:55:52)
    2. not very functional for making agendas (jmadero, 19:55:57)
    3. Minutes uploaded to TDF server, not Wiki but Joel will create links on Wiki (jmadero, 19:56:14)
    4. AGREED: attempt to use meetbot for next meeting (jmadero, 19:56:31)

  10. Funding Wish List (jmadero, 19:56:41)
    1. http://www.wiki.documentfoundation.org/Marketing/Funding_Priorities (jmadero, 19:57:41)
    2. Going to be a short list from QA because the money/hardware is available for most of our needs, really need volunteers more than funding (jmadero, 19:58:14)
    3. QA Travel Expenses: Not really needed because money isn't separated, travel expenses reimbursed from general fund (jmadero, 19:58:53)
    4. FDO Improvements: Possibly pay someone to implement some of the changes that are on wiki page (jmadero, 19:59:24)
    5. http://www.wiki.documentfoundation.org/How_to_Improve_Bugzilla (jmadero, 19:59:40)
    6. ACTION: Bjoern will look through bugzilla improvement list to prioritize and figure out if we could use some funding for these items (jmadero, 20:00:31)
    7. Prizes/Thank You's possible for most active QA members per quarter or some other period of time (jmadero, 20:01:16)
    8. AGREED: prizes possible but a concrete plan needs to be created before we can request funding (jmadero, 20:01:35)

  11. Leadership Structure/"Board of Quality Assurance (jmadero, 20:02:05)
    1. Is a leadership team needed with QA (jmadero, 20:02:23)
    2. AGREED: first thing is to get the QA bi-weekly conference call correct and to get more people involved (jmadero, 20:02:38)
    3. ACTION: Joel will announce next meeting over user list to test if this can work (jmadero, 20:02:55)

  12. Triage Contest (jmadero, 20:03:12)
    1. AGREED: This is a good idea (jmadero, 20:03:17)
    2. date is a concern, right after final release of 4 might be good, avoids holidays plus more user interest right after major release (jmadero, 20:03:39)
    3. ACTION: Bjoern will talk to TDF Board about funding triage contest (jmadero, 20:03:47)
    4. Next meeting we will discuss more details (jmadero, 20:03:59)
    5. ACTION: Bjoern and Joel should talk to Cor Nouws & Italo Vignoli about their experience with running a contest (jmadero, 20:04:28)
    6. http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0-1 (jmadero, 20:05:02)


Meeting ended at 20:05:10 UTC (full logs).

Action items

  1. Joel will try to make a prototype for "bug heat" from FDO data
  2. Bjoern will look into alternatives for OpenID, will discuss with Tolef
  3. Joel will contact Rob about BSA Localization to get an update
  4. Bjoern will continue looking into creating twitter feed for bug fixes, will ping Florian about this
  5. Joel will add bug 57619 to hard hack wiki
  6. Bjoern will look through bugzilla improvement list to prioritize and figure out if we could use some funding for these items
  7. Joel will announce next meeting over user list to test if this can work
  8. Bjoern will talk to TDF Board about funding triage contest
  9. Bjoern and Joel should talk to Cor Nouws & Italo Vignoli about their experience with running a contest


People present (lines said)

  1. jmadero (66)
  2. IZBot (2)


Generated by MeetBot 0.1.4.