#libreoffice-dev: ESC call 2013-01-24

Meeting started by Sweetshark at 15:12:52 UTC (full logs).

Meeting summary

  1. Last-time Action Items (Sweetshark, 15:14:00)
    1. ACTION: find person who can write and add off-line help for impress-remote (Thorsten) (Sweetshark, 15:14:48)
    2. in progress: get tshirts / hoodies printed (kendy) (Sweetshark, 15:15:33)
    3. ACTION: create/request mail alias for certification (Bjoern) (Sweetshark, 15:15:51)
    4. ACTION: inprogress: Bugzilla attachments not set to autodetect (Bjoern) (Sweetshark, 15:16:02)
    5. ACTION: Update gsoc ideas page before FOSDEM (Sweetshark, 15:16:29)
    6. https://wiki.documentfoundation.org/Development/Gsoc/Ideas (all) (Sweetshark, 15:16:51)
    7. ACTION: in progress: Investigate native build/env scripts for SDK (Bjoern) (Sweetshark, 15:17:22)
    8. sberg and Sweetshark will look at SDK together (Sweetshark, 15:19:23)
    9. ACTION: in progress: completing generic / Linux builds -> RedHat (Caolan) (Sweetshark, 15:20:18)

  2. Pending Action Items (Sweetshark, 15:20:25)
    1. completed: decision on whether to switch back to old floppy save (Astron) (Sweetshark, 15:22:58)
    2. ACTION: regression catching on tinderbox, Figure out time-out issues (Markus) (Sweetshark, 15:23:31)
    3. completed: FOSDEM: misc. new interop. feature and their development, Markus will write to Italo to add Eilidh's talk (Markus) (Sweetshark, 15:23:48)
    4. https://fosdem.org/2013/schedule/track/libreoffice/ (moggi, 15:23:59)
    5. ACTION: Presenter console patches 4-0 backport (Michael M) (Sweetshark, 15:24:21)
    6. completed: come up with / improve the existing concrete funding request for build hardware => board budget (Thorsten) (Sweetshark, 15:25:13)
    7. ACTION: STLPort removal - release-note: Document dropping the DLL and the VS run-time on the system in the release-notes (Fridrich) (Sweetshark, 15:25:32)
    8. ACTION: full-word selection / editing ergonomics cf. UX-advise https://bugs.freedesktop.org/show_bug.cgi?id=46517 pending input from Caolan / Cedric / Michael S (Sweetshark, 15:26:08)
    9. ACTION: create a new AmbitiousHacks wiki page, based on GSOC page (Michael M) (Sweetshark, 15:26:20)
    10. ACTION: in progress: investigate re-using Win32 binary signing for Mac (Thorsten) (Sweetshark, 15:27:35)
    11. ACTION: on-line help for impress-remote would be useful, help appreciated (Sweetshark, 15:28:41)
    12. https://bugs.freedesktop.org/show_bug.cgi?id=58699 (Sweetshark, 15:28:53)
    13. ACTION: add off-line help and it'll appear on-line (kendy) (Sweetshark, 15:29:59)
    14. might be better next week with new stuff by floeff (Sweetshark, 15:29:59)
    15. ACTION: minimal triage for good mentors for proposed easy hacks (Bjoern) (Sweetshark, 15:30:03)
    16. ACTION: disable Rhino / Beanshell unless in experimental mode (Michael M) (Sweetshark, 15:30:06)
    17. ACTION: tweak the configure defaults, no submodules by default, no gnome-vfs (Kendy) (Sweetshark, 15:30:13)

  3. Release Engineering update (Petr) (Sweetshark, 15:30:22)
    1. 4.0.0 rc ready and pushed to mirror (Sweetshark, 15:33:05)
    2. Jan 28 rc3 date, triple review, lets be careful (Sweetshark, 15:33:06)
    3. any known issues? (Sweetshark, 15:33:06)
    4. android remote to 4.0.0 or 4.0 branch (Thorsten) (Sweetshark, 15:33:06)
    5. AGREED: android to 4.0 branch, not 4.0.0 -- more relaxed reviews (Sweetshark, 15:34:43)
    6. template manager remote repos moved to experimental features ( schoinobates ) (Sweetshark, 15:36:01)
    7. 3.6.5 rc2 will go final next week if there are no issues. if you know about regressions speak up now (Sweetshark, 15:37:06)

  4. UX Update (Astron) (Sweetshark, 15:37:31)
    1. template manager progress (Sweetshark, 15:37:39)
    2. restore menu entries? no, we shouldnt at all (Astron) (Sweetshark, 15:38:33)
    3. https://gerrit.libreoffice.org/1787 (Sweetshark, 15:39:03)
    4. (Thorsten) has string changes, might cause trouble/extra work (Sweetshark, 15:40:41)
    5. Andras: also not happty about string changes (Sweetshark, 15:41:15)
    6. ACCEPTED: reject patch for now/postpone the patch (Sweetshark, 15:42:49)
    7. personas punted, kendy not in the call -- some issue need to be disccussed (Sweetshark, 15:43:46)
    8. Ubuntu font excluded so far on licensing ground, forbid renaming is a blocker/problem (Sweetshark, 15:45:57)
    9. ACTION: clarify at Canonical (Bjoern) (Sweetshark, 15:46:18)
    10. not available on most distros because of legal review (Sweetshark, 15:47:30)

  5. FOSDEM Update (Markus) (Sweetshark, 15:48:22)
    1. https://wiki.documentfoundation.org/Marketing/Events/Fosdem2013Stand (moggi, 15:48:33)
    2. bring hardware to FOSDEM! (Sweetshark, 15:49:49)
    3. poke Thorsten for that. (Sweetshark, 15:50:34)

  6. Features (Sweetshark, 15:50:47)
    1. please update: http://wiki.documentfoundation.org/ReleaseNotes/4.0 (Sweetshark, 15:50:51)

  7. 4.0 pending tasks (Sweetshark, 15:51:35)
    1. MySQL connector compat issues (Sweetshark, 15:51:39)
    2. comments on the bugs: recompile against 4.0 for stlport drop (Sweetshark, 15:52:38)
    3. who releases, publishes that? TDF would host. if someone would build? Thorsten: maybe not even then, needs further resaerch. (Sweetshark, 15:54:57)
    4. FLOSS license exception from MySQL homepage (mst) (Sweetshark, 15:55:46)
    5. ACTION: Thorsten looking into the MySQL stuff (Sweetshark, 15:56:53)
    6. binfilter: warn on legacy file-types with helpful dialog (no owner) (Sweetshark, 15:57:03)
    7. drop Mozilla mess in the tree: lots of cleanup in configure (Sweetshark, 15:57:55)
    8. https://bugs.freedesktop.org/show_bug.cgi?id=56902 (Sweetshark, 15:57:55)
    9. we need Outlook/O Express drivers for windows to completely drop it. (Sweetshark, 15:59:15)
    10. Unix / LDAP addressbook support disappeared, close that wontfix & release-note it ? (Sweetshark, 15:59:23)
    11. https://bugs.freedesktop.org/show_bug.cgi?id=57417 (Sweetshark, 15:59:26)
    12. no major distro uses that (Sweetshark, 16:01:07)
    13. evolution2 enabled in the upstream TDF build (Sweetshark, 16:01:58)
    14. OSX state unknown (Sweetshark, 16:02:12)

  8. Proposed easy-hacks -> Easy Hacks (Joel) (Sweetshark, 16:02:44)
    1. devs to to build code-pointers or clear proposed easy-hack for these: (Sweetshark, 16:02:45)
    2. https://bugs.freedesktop.org/buglist.cgi?list_id=147895&status_whiteboard_type=anywordssubstr&query_format=advanced&status_whiteboard=ProposedEasyHack&bug_status=NEW&bug_status=REOPENED&product=LibreOffice (Sweetshark, 16:02:48)
    3. make them real EAsyHacks or unpropose them (Sweetshark, 16:03:38)

  9. HardHacks (Joel) (Sweetshark, 16:03:49)
    1. http://wiki.documentfoundation.org/HardHacks (Sweetshark, 16:03:49)
    2. mostly suspended until post 4.0 release. (Sweetshark, 16:03:49)
    3. on hold (Sweetshark, 16:04:09)

  10. google play account created (Sweetshark, 16:04:16)
    1. who wants access? (Sweetshark, 16:04:16)
    2. thorsten raises hand for impress remote (thorsten, 16:05:04)

  11. QA update (Joel) (Sweetshark, 16:05:28)
    1. REOPENED vs. UNCONFIRMED discussion (Sweetshark, 16:05:28)
    2. discussion needs to be reopened (Sweetshark, 16:07:02)
    3. https://bugs.freedesktop.org/buglist.cgi?list_id=205374&query_format=advanced&bug_status=UNCONFIRMED&bug_status=REOPENED&version=4.0.0.0.alpha0%2B%20Master&version=4.0.0.0.alpha1&version=4.0.0.0.beta1&version=4.1.0.0.alpha0%2B%20Master&version=4.0.0.0.beta2&version=4.0.0.1%20rc&produc (jmadero, 16:07:15)
    4. current consensus doesnt work too well (Sweetshark, 16:07:16)
    5. please look at these: (Sweetshark, 16:07:40)
    6. https://bugs.freedesktop.org/buglist.cgi?list_id=205374&query_format=advanced&bug_status=UNCONFIRMED&bug_status=REOPENED&version=4.0.0.0.alpha0%2B%20Master&version=4.0.0.0.alpha1&version=4.0.0.0.beta1&version=4.1.0.0.alpha0%2B%20Master&version=4.0.0.0.beta2&version=4.0.0.1%20rc&produc (Sweetshark, 16:07:49)
    7. we can now "ban" abusive users on fdo (Sweetshark, 16:08:36)
    8. hope we never need it (Sweetshark, 16:08:43)
    9. https://wiki.documentfoundation.org/FreeDesktop_Rules_Procedures (jmadero, 16:08:45)

  12. poll for libreoffice conference (Sweetshark, 16:12:13)
    1. ACTION: all member: do your duty and vote! (Sweetshark, 16:12:32)

  13. GSOC updates (Sweetshark, 16:13:37)
    1. ACTION: update your GSoC stuff (Sweetshark, 16:13:52)


Meeting ended at 16:14:08 UTC (full logs).

Action items

  1. find person who can write and add off-line help for impress-remote (Thorsten)
  2. create/request mail alias for certification (Bjoern)
  3. inprogress: Bugzilla attachments not set to autodetect (Bjoern)
  4. Update gsoc ideas page before FOSDEM
  5. in progress: Investigate native build/env scripts for SDK (Bjoern)
  6. in progress: completing generic / Linux builds -> RedHat (Caolan)
  7. regression catching on tinderbox, Figure out time-out issues (Markus)
  8. Presenter console patches 4-0 backport (Michael M)
  9. STLPort removal - release-note: Document dropping the DLL and the VS run-time on the system in the release-notes (Fridrich)
  10. full-word selection / editing ergonomics cf. UX-advise https://bugs.freedesktop.org/show_bug.cgi?id=46517 pending input from Caolan / Cedric / Michael S
  11. create a new AmbitiousHacks wiki page, based on GSOC page (Michael M)
  12. in progress: investigate re-using Win32 binary signing for Mac (Thorsten)
  13. on-line help for impress-remote would be useful, help appreciated
  14. add off-line help and it'll appear on-line (kendy)
  15. minimal triage for good mentors for proposed easy hacks (Bjoern)
  16. disable Rhino / Beanshell unless in experimental mode (Michael M)
  17. tweak the configure defaults, no submodules by default, no gnome-vfs (Kendy)
  18. clarify at Canonical (Bjoern)
  19. Thorsten looking into the MySQL stuff
  20. all member: do your duty and vote!
  21. update your GSoC stuff


Action items, by person

  1. caolan
    1. in progress: completing generic / Linux builds -> RedHat (Caolan)
    2. full-word selection / editing ergonomics cf. UX-advise https://bugs.freedesktop.org/show_bug.cgi?id=46517 pending input from Caolan / Cedric / Michael S
  2. Fridrich
    1. STLPort removal - release-note: Document dropping the DLL and the VS run-time on the system in the release-notes (Fridrich)
  3. thorsten
    1. find person who can write and add off-line help for impress-remote (Thorsten)
    2. in progress: investigate re-using Win32 binary signing for Mac (Thorsten)
    3. Thorsten looking into the MySQL stuff
  4. UNASSIGNED
    1. create/request mail alias for certification (Bjoern)
    2. inprogress: Bugzilla attachments not set to autodetect (Bjoern)
    3. Update gsoc ideas page before FOSDEM
    4. in progress: Investigate native build/env scripts for SDK (Bjoern)
    5. regression catching on tinderbox, Figure out time-out issues (Markus)
    6. Presenter console patches 4-0 backport (Michael M)
    7. create a new AmbitiousHacks wiki page, based on GSOC page (Michael M)
    8. on-line help for impress-remote would be useful, help appreciated
    9. add off-line help and it'll appear on-line (kendy)
    10. minimal triage for good mentors for proposed easy hacks (Bjoern)
    11. disable Rhino / Beanshell unless in experimental mode (Michael M)
    12. tweak the configure defaults, no submodules by default, no gnome-vfs (Kendy)
    13. clarify at Canonical (Bjoern)
    14. all member: do your duty and vote!
    15. update your GSoC stuff


People present (lines said)

  1. Sweetshark (96)
  2. _rene_ (29)
  3. jmadero (28)
  4. jorendc (18)
  5. thorsten (14)
  6. caolan (11)
  7. IZBot (9)
  8. schoinobates (5)
  9. floeff (4)
  10. shm_get (3)
  11. cbosdonnat (3)
  12. kohei_ (3)
  13. moggi (3)
  14. vmiklos (3)
  15. loirkerbot (3)
  16. sknorr (2)
  17. bubli (2)
  18. erAck (1)
  19. matus (1)
  20. pmladek (1)
  21. sberg (1)
  22. timar (1)
  23. jcorrius (1)
  24. tibbylickle (1)
  25. Fridrich (1)
  26. mst__ (1)
  27. astron (0)


Generated by MeetBot 0.1.4.