15:12:52 <Sweetshark> #startmeeting
15:12:52 <IZBot> Meeting started Thu Jan 24 15:12:52 2013 UTC.  The chair is Sweetshark. Plugin info at http://wiki.debian.org/MeetBot.
15:12:52 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:12:52 <Sweetshark> #meetingtopic ESC call 2013-01-24
15:12:52 <Sweetshark> if you are in the ESC call please mark yourself like this:
15:12:52 <Sweetshark> #nick Sweetshark
15:12:52 <jmadero> attacking character is not okay here
15:13:06 <jorendc> _rene_: and if I don't know what's doxygen is ?
15:13:12 <_rene_> does it matter?
15:13:13 <schoinobates> #nick schoinobates
15:13:17 <jmadero> #nick jmadero
15:13:18 <_rene_> no, it doesn't.
15:13:19 <thorsten> #nick thorsten
15:13:20 <shm_get> #nick shm_get
15:13:21 <moggi> #nick moggi
15:13:24 <sberg> #nick sberg
15:13:35 <jorendc> _rene_: if that'll result in a bad bibisect !I! am wasting my time
15:13:37 <bubli> kohei_: true
15:13:53 <_rene_> jorendc: you want a *build*. yopu need to build it. in whatever way.
15:14:00 <Sweetshark> #topic Last-time Action Items
15:14:02 <timar> #nick timar
15:14:07 <_rene_> jorendc: and hell, if you don't know what doxygen is there's aunt google
15:14:19 <jorendc> _rene_: I need a good build, not a build I guess is good
15:14:23 <mst__> #nick mst__
15:14:41 <jorendc> _rene_: yes, and I know that'll affect my bibisect?
15:14:46 <_rene_> and how does *documentation* matter in there?
15:14:47 <jmadero> _rene_: again, why can't you just answer civilly, volunteers, new developers, etc....you just push people away when you speak this way
15:14:48 <Sweetshark> #action find person who can write and add off-line help for impress-remote (Thorsten)
15:15:04 <sknorr> #nick astron
15:15:19 <kohei_> #nick kohei_
15:15:25 <_rene_> jmadero: because if you are calm to them (and I was in the past) they will stay clueless and not use their brain and ask the complete shit everytime
15:15:27 <jorendc> _rene_: I'm happy for you you know everything and everything you know, others know... if not they are dumb. Ok, have a pretty live than ... but I don't like that attitude. Good for you
15:15:33 <Sweetshark> #info in progress: get tshirts / hoodies printed (kendy)
15:15:46 <jmadero> jorendc: best to just ignore his responses
15:15:51 <Sweetshark> #action create/request mail alias for certification (Bjoern)
15:15:58 <jorendc> jmadero: I will, NOW I'm wasting my time
15:16:00 <_rene_> jorendc: I don't like the "I try a build but I don't read and know what X is and I don't even think or ask google" attitude
15:16:02 <Sweetshark> #action inprogress: Bugzilla attachments not set to autodetect (Bjoern)
15:16:29 <Sweetshark> #action Update gsoc ideas page before FOSDEM
15:16:51 <Sweetshark> #link https://wiki.documentfoundation.org/Development/Gsoc/Ideas (all)
15:16:56 <jmadero> caolan: if I change a symbol in a help file, it should link to something new yes?
15:17:21 <thorsten> Sweetshark: prolly nice to repeat the 'register your nick' a few times for the late-comers
15:17:22 <Sweetshark> #action in progress: Investigate native build/env scripts for SDK (Bjoern)
15:17:44 <tibbylickle> #nick tibbylickle
15:18:03 <_rene_> jorendc: it just creates noise
15:18:11 <_rene_> jorendc: and will repeat everytime
15:18:19 <vmiklos> sberg: true, i forgot that in this case no gdb will be necessary, which would want the real binary
15:18:28 <caolan> jmadero: i think seeing your patch might help see what you mean
15:18:55 <_rene_> jorendc: or are you also going to drive a car without knowing how to use it?
15:19:09 <vmiklos> jorendc: feel free to disable doxygen, it just affe ts documentation
15:19:18 <jorendc> vmiklos: thanks :)
15:19:23 <Sweetshark> #info sberg and Sweetshark will look at SDK together
15:19:26 <caolan> #nick caolan
15:19:27 * cbosdonnat is in the call
15:19:30 <erAck> #nick erAck
15:19:35 <cbosdonnat> #nick cbosdonnat
15:19:45 <pmladek> #nick pmladek
15:20:06 <_rene_> on a related note, if we use the bot here anyway, can't we make the ESC purely IRC?
15:20:18 <Sweetshark> #action in progress: completing generic / Linux builds -> RedHat (Caolan)
15:20:25 <Sweetshark> #topic Pending Action Items
15:20:30 <bubli> kohei_: http://www.shirky.com/weblog/2013/01/remembering-aaron-by-taking-care-of-each-other/ <= I guess you read that already ?
15:20:33 <jmadero> caolan: I just added a help button here http://opengrok.libreoffice.org/xref/core/sd/source/ui/dlg/animobjs.src, and the help file is http://opengrok.libreoffice.org/xref/help/source/text/simpress/01/06050000.xhp
15:20:34 <_rene_> that would cause people at work be able to attend without going somewhere to phone...
15:20:36 <thorsten> _rene_: some (including me) still prefer the extra voice line I guess
15:21:03 <_rene_> but just because you are at work and that probably counts for work
15:21:08 <jmadero> caolan: now it's just linking the button in the src to the help file......I don't get why the help stuff has to be so convoluted
15:21:16 <_rene_> I can live with phone line, too, as long as it's not during work hours ;)=
15:21:24 <schoinobates> _rene_: +1, "but" sometimes we want things not logged / not written
15:21:32 <_rene_> vi? ;)
15:22:09 <kohei_> bubli, just read that this morning, hence my earlier comment.
15:22:58 <Sweetshark> #info completed: decision on whether to switch back to old floppy save (Astron)
15:22:59 <_rene_> and I'd bet that meetbot has a option to disable logging and reenable it
15:23:20 <_rene_> (and be it disable/enable it ;))
15:23:31 <Sweetshark> #action regression catching on tinderbox, Figure out time-out issues (Markus)
15:23:48 <Sweetshark> #info completed: FOSDEM: misc. new interop. feature and their development, Markus will write to Italo to add Eilidh's talk (Markus)
15:23:56 <thorsten> _rene_: so having mixed irc / phone is at least better for you than phone-only?
15:23:59 <moggi> https://fosdem.org/2013/schedule/track/libreoffice/
15:24:15 <_rene_> thorsten: only if everything spoken is copied here, otherwise it gets messy.
15:24:21 <Sweetshark> #action Presenter console patches 4-0 backport (Michael M)
15:24:24 <_rene_> thorsten: at which time you could just go to irc directly only
15:24:24 <caolan> jmadero: if you just add a HelpButton with no HelpId then the helpbutton should go up the tree on its own and ask for CMD_SID_ANIMATION_OBJECTS which is ".uno:AnimationObjects" , hmph should "just work"
15:24:32 <caolan> jmadero: where do I find the dialog in the UI ?
15:25:05 <thorsten> shm_get: or is it? ;)
15:25:12 <jmadero> caolan: what dialog?
15:25:13 <Sweetshark> #info completed: come up with / improve the existing concrete funding request for build hardware => board budget (Thorsten)
15:25:32 <Sweetshark> #action STLPort removal - release-note: Document dropping the DLL and the VS run-time on the system in the release-notes (Fridrich)
15:25:56 <schoinobates> how do I see if a specific module is gbuild or "old build system"?
15:26:06 <caolan> jmadero: where's the "thing" that you added the helpbutton to ?
15:26:08 <Sweetshark> #action full-word selection / editing ergonomics cf. UX-advise https://bugs.freedesktop.org/show_bug.cgi?id=46517 pending input from Caolan / Cedric / Michael S
15:26:11 <IZBot> bug 46517: LibreOffice-Libreoffice normal/medium REOPENED Subscript/superscript shortcuts apply style to whole word instead of only characters written after use of shortcut
15:26:12 <shm_get> thorsten ???
15:26:20 <Sweetshark> #action create a new AmbitiousHacks wiki page, based on GSOC page (Michael M)
15:26:25 <thorsten> shm_get: funding whishlist request for hw
15:26:30 <Fridrich> Sweetshark: itis part of releasae notes
15:26:48 <jmadero> caolan: insert-animation in Presentation
15:26:55 <jmadero> caolan: insert - animated image
15:27:00 <thorsten> schoinobates: <module>/prj/build.lst will look markedly different
15:27:28 <shm_get> thorsten well, what we discussed is good enough for now I recon...
15:27:30 <_rene_> Fridrich: maybe link to the past posts (espeially yours 1 year ago) to show more explicitely that they had 1 year to adapt and they don't need to cpmplain?
15:27:35 <Sweetshark> #action in progress: investigate re-using Win32 binary signing for Mac (Thorsten)
15:27:38 <matus> schoinobates, gbuild one has <module>Module_<module>.mk
15:28:22 <thorsten> shm_get: ok, will mail it out then
15:28:26 <_rene_> and that said, are we also mentioning the "merged-into-core" extensions in the release notes?
15:28:34 <jmadero> #https://bugs.freedesktop.org/show_bug.cgi?id=58699
15:28:37 <IZBot> bug 58699: LibreOffice-Presentation critical/high NEW Impress remote doesn't close
15:28:41 <Sweetshark> #action on-line help for impress-remote would be useful, help appreciated
15:28:44 <schoinobates> matus: OK, so mysqlc is still "old build system". Thanks
15:28:53 <Sweetshark> #link https://bugs.freedesktop.org/show_bug.cgi?id=58699
15:28:54 <_rene_> I think pdfimport stayed an own package, but I think presenter-console "disappeared"
15:28:55 <IZBot> bug 58699: LibreOffice-Presentation critical/high NEW Impress remote doesn't close
15:29:59 <Sweetshark> #action add off-line help and it'll appear on-line (kendy)
15:29:59 <Sweetshark> #info might be better next week with new stuff by floeff
15:30:03 <Sweetshark> #action minimal triage for good mentors for proposed easy hacks (Bjoern)
15:30:06 <Sweetshark> #action disable Rhino / Beanshell unless in experimental mode (Michael M)
15:30:13 <Sweetshark> #action tweak the configure defaults, no submodules by default, no gnome-vfs (Kendy)
15:30:22 <Sweetshark> #topic Release Engineering update (Petr)
15:33:05 <Sweetshark> #info 4.0.0 rc ready and pushed to mirror
15:33:06 <Sweetshark> #info Jan 28 rc3 date, triple review, lets be careful
15:33:06 <Sweetshark> #info any known issues?
15:33:06 <Sweetshark> #info android remote to 4.0.0 or 4.0 branch (Thorsten)
15:33:23 <floeff> Sweetshark: what new stuff? ;)
15:33:38 <Sweetshark> floeff: shhh, ESC call
15:33:42 <Sweetshark> ;)
15:33:48 <floeff> sorry, i'm a noob :)
15:34:38 <jmadero> floeff: if you're a noob, I'm not sure what I am....
15:34:41 <loirkerbot> LibreOffice (core) [libreoffice-4-0-0] markus.mohrhard * sc/source/ui/docshell/docsh.cxx: reset automatic row height flag after import, fdo#59193
15:34:43 <Sweetshark> #agreed android to 4.0 branch, not 4.0.0 -- more relaxed reviews
15:34:45 <IZBot> LibreOffice-Spreadsheet normal/medium ASSIGNED automatic row height does not work after import https://bugs.freedesktop.org/show_bug.cgi?id=59193
15:34:53 <floeff> jmadero: :)
15:35:00 <floeff> well, surely i'm no dev
15:35:27 <jmadero> floeff: I just pretend to know anything, even my pretending makes it clear I don't ;)
15:36:01 <Sweetshark> #info template manager remote repos moved to experimental features ( schoinobates )
15:36:12 <jmadero> by the way thanks for getting php working correctly, we're excited to get the French BSA test up and running
15:36:15 <kohei_> in my heart this is a blocker: https://gerrit.libreoffice.org/1846
15:36:43 <schoinobates> Sweetshark: what does "template manager" repos" have to do with me?
15:36:46 <jmadero> kohei_: I agree
15:37:06 <Sweetshark> #info 3.6.5 rc2 will go final next week if there are no issues. if you know about regressions speak up now
15:37:31 <Sweetshark> #topic UX Update (Astron)
15:37:39 <Sweetshark> #info template manager progress
15:38:10 <jmadero> thorsten: shot you an email, BSA won't update for me
15:38:17 <thorsten> eh
15:38:33 <Sweetshark> #info restore menu entries? no, we shouldnt at all (Astron)
15:39:03 <Sweetshark> #link https://gerrit.libreoffice.org/1787
15:40:02 <caolan> jmadero: hmm, pressing F1 there doesn't work (which it should) seems like the toplevel window is missing the helpid that it clearly there in the .src
15:40:41 <Sweetshark> #info (Thorsten) has string changes, might cause trouble/extra work
15:41:15 <Sweetshark> #info Andras: also not happty about string changes
15:41:49 <loirkerbot> LibreOffice (core) serval2412 * drawinglayer/source/primitive2d/metafileprimitive2d.cxx: Resolves: fdo#49784 CRASH when FILEOPEN particular doc containing .svm
15:41:52 <IZBot> LibreOffice-Libreoffice major/medium NEW CRASH when FILEOPEN particular document containing .svm pictures https://bugs.freedesktop.org/show_bug.cgi?id=49784
15:42:19 <jmadero> caolan: hm, I'm looking for the test case that I was modeling my patch after, I didn't see that it was looking at helpid from above, it was pulling from below which was strange
15:42:22 <jmadero> looking
15:42:49 <Sweetshark> #accept reject patch for now/postpone the patch
15:43:46 <Sweetshark> #info personas punted, kendy not in the call -- some issue need to be disccussed
15:44:30 <jmadero> caolan: http://opengrok.libreoffice.org/xref/core/sd/source/ui/dlg/present.src, http://opengrok.libreoffice.org/xref/help/source/text/simpress/01/06100000.xhp
15:44:56 <jmadero> caolan: that is for presentation, "Slide Show - Custom Slide Show..."
15:45:33 <jmadero> caolan: when you click the help you see that it's using sd:ListBox:DLG_CUSTOMSHOW:LB_CUSTOMSHOWS, but that comes below the button code in the src
15:45:57 <Sweetshark> #info Ubuntu font excluded so far on licensing ground, forbid renaming is a blocker/problem
15:46:01 <sknorr> # http://font.ubuntu.com/ufl/
15:46:17 <caolan> hmm, something unsets the helpid on the toplevel dialog, let me debug that
15:46:18 <Sweetshark> #action clarify at Canonical (Bjoern)
15:47:28 <jorendc> vmiklos: sorry to disturb you again; but my 'make dev-install' keeps failing on /home/joren/core/Module_tail_build.mk:27: /home/joren/core//dictionaries/Module_dictionaries.mk: No such file or directory
15:47:29 <_rene_> why on earth should we include the font?
15:47:30 <Sweetshark> #info not available on most distros because of legal review
15:47:34 <jmadero> caolan: appreciate it, frustrating that everything is there and just a link isn't working
15:47:53 <jorendc> vmiklos: I found http://www.mail-archive.com/libreoffice@lists.freedesktop.org/msg43715.html ... mailinglist with same error description
15:47:54 <_rene_> are we going to include any random font of a random (unfortunately popular) distro?
15:48:22 <Sweetshark> #topic FOSDEM Update (Markus)
15:48:33 <moggi> #link https://wiki.documentfoundation.org/Marketing/Events/Fosdem2013Stand
15:48:45 * _rene_ is not going to ship it either way. and that would be bad, as that also would mean that would need to opoerate templates using it out
15:48:49 <jorendc> vmiklos: I already git bisect skip 10 times or so :p (and make tail_build.clean), but didn't help
15:49:49 <Sweetshark> #info bring hardware to FOSDEM!
15:50:13 <caolan> sfx2/source/dialog/dockwin.cxx:919 hmm, SetHelpId("")
15:50:20 <_rene_> Monday?!
15:50:34 <Sweetshark> #info poke Thorsten for that.
15:50:47 <Sweetshark> #topic Features
15:50:51 <Sweetshark> #info please update: http://wiki.documentfoundation.org/ReleaseNotes/4.0
15:51:01 <Sweetshark> missing Mac / full-screen bits (Tor)
15:51:23 <_rene_> thorsten: as we see, doing irc/phone doesn't really work well :(
15:51:24 <thorsten> WindowsUser: ^^ - was there any update?
15:51:35 <Sweetshark> #topic 4.0 pending tasks
15:51:39 <Sweetshark> #info MySQL connector compat issues
15:52:18 <thorsten> _rene_: hmm, monday? missing context :)
15:52:38 <Sweetshark> #info comments on the bugs: recompile against 4.0 for stlport drop
15:52:40 <_rene_> thorsten: wiki has a column "Monday" :-)
15:53:13 <thorsten> _rene_: ah. well, that's people leaving monday instead of sunday, so we can crash into a bar sunday night ;)
15:53:49 <jmadero> caolan: so, it looks to me like it's something missing in the Insert Animated Image...help file, when you compare that to the Custom Slide Show ...it looks like there is a lot going on
15:54:24 <vmiklos> jorendc: i build with --without-myspell-dicts and --without-help when bisecting
15:54:24 <jmadero> caolan: so for my test I changed the Custom Slide Show help file, I chnaged sd:ListBox:DLG_CUSTOMSHOW:LB_CUSTOMSHOWS to another help file, did a make and a make dev-install
15:54:38 <jmadero> but nothing changed, it still linked to sd:ListBox:DLG_CUSTOMSHOW:LB_CUSTOMSHOWS
15:54:57 <Sweetshark> #info who releases, publishes that? TDF would host. if someone would build? Thorsten: maybe not even then, needs further resaerch.
15:55:46 <Sweetshark> #info FLOSS license exception from MySQL homepage (mst)
15:56:53 <Sweetshark> #action Thorsten looking into the MySQL stuff
15:57:03 <Sweetshark> #info binfilter: warn on legacy file-types with helpful dialog (no owner)
15:57:55 <Sweetshark> #info drop Mozilla mess in the tree: lots of cleanup in configure
15:57:55 <Sweetshark> #link https://bugs.freedesktop.org/show_bug.cgi?id=56902
15:57:57 <IZBot> bug 56902: LibreOffice-Database enhancement/medium NEW Kill off in-tree (ancient) mozilla copy
15:59:15 <Sweetshark> #info we need Outlook/O Express drivers for windows to completely drop it.
15:59:23 <Sweetshark> #info Unix / LDAP addressbook support disappeared, close that wontfix & release-note it ?
15:59:26 <Sweetshark> #link https://bugs.freedesktop.org/show_bug.cgi?id=57417
15:59:28 <IZBot> bug 57417: LibreOffice-Database major/medium NEW LDAP address book support disappeared
16:00:15 <jorendc> thorsten: I add a 'close' button to the 'findbar', and placed the button in icon-theme folder 'galaxy' because every other theme will just cover the galaxy-theme... that worked perfect at linux, but now I have latest master installed on mac osx ... no button but only the text 'exit search'
16:01:01 <jorendc> thorsten: any thought's why it doesn't accept the icon in the galaxy theme? (or is that galaxy-thing Linux-only?)
16:01:07 <Sweetshark> #info no major distro uses that
16:01:57 <jcorrius> for all the ones here who write Micro$oft: https://lh4.googleusercontent.com/-zfFuqyAzxO8/UP9E8-ZPt6I/AAAAAAACUMo/2ABfeM9h8_0/s604/downgradetowindows7.jpg
16:01:58 <Sweetshark> #info evolution2 enabled in the upstream TDF build
16:02:09 <thorsten> jorendc: no immediate clue, sorry
16:02:12 <Sweetshark> #info OSX state unknown
16:02:22 <jorendc> thorsten: ok, no problem :-) thanks
16:02:44 <Sweetshark> #topic Proposed easy-hacks -> Easy Hacks (Joel)
16:02:45 <Sweetshark> #info devs to to build code-pointers or clear proposed easy-hack for these:
16:02:48 <Sweetshark> #link https://bugs.freedesktop.org/buglist.cgi?list_id=147895&status_whiteboard_type=anywordssubstr&query_format=advanced&status_whiteboard=ProposedEasyHack&bug_status=NEW&bug_status=REOPENED&product=LibreOffice
16:03:38 <Sweetshark> #info make them real EAsyHacks or unpropose them
16:03:49 <Sweetshark> #topic HardHacks (Joel)
16:03:49 <Sweetshark> #link http://wiki.documentfoundation.org/HardHacks
16:03:49 <Sweetshark> #info mostly suspended until post 4.0 release.
16:04:09 <Sweetshark> #info on hold
16:04:16 <Sweetshark> #topic google play account created
16:04:16 <Sweetshark> #info who wants access?
16:05:04 <thorsten> #info thorsten raises hand for impress remote
16:05:28 <Sweetshark> #topic QA update (Joel)
16:05:28 <Sweetshark> #info REOPENED vs. UNCONFIRMED discussion
16:07:02 <Sweetshark> #info discussion needs to be reopened
16:07:15 <jmadero> https://bugs.freedesktop.org/buglist.cgi?list_id=205374&query_format=advanced&bug_status=UNCONFIRMED&bug_status=REOPENED&version=4.0.0.0.alpha0%2B%20Master&version=4.0.0.0.alpha1&version=4.0.0.0.beta1&version=4.1.0.0.alpha0%2B%20Master&version=4.0.0.0.beta2&version=4.0.0.1%20rc&produc
16:07:16 <Sweetshark> #info current consensus doesnt work too well
16:07:40 <Sweetshark> #info please look at these:
16:07:49 <Sweetshark> #link  https://bugs.freedesktop.org/buglist.cgi?list_id=205374&query_format=advanced&bug_status=UNCONFIRMED&bug_status=REOPENED&version=4.0.0.0.alpha0%2B%20Master&version=4.0.0.0.alpha1&version=4.0.0.0.beta1&version=4.1.0.0.alpha0%2B%20Master&version=4.0.0.0.beta2&version=4.0.0.1%20rc&produc
16:07:56 <caolan> jmadero: gimme a little while to build my potential fix
16:08:03 <jorendc> vmiklos: I think I just can't do a bibisect for that :s. It keeps giving dictionaries.mk errors :p
16:08:23 <jorendc> I saw I'm not the only one http://pastebin.com/SM5GraWe
16:08:36 <Sweetshark> #info we can now "ban" abusive users on fdo
16:08:43 <Sweetshark> #info hope we never need it
16:08:45 <jmadero> https://wiki.documentfoundation.org/FreeDesktop_Rules_Procedures
16:08:45 <jorendc> exactly the same, without help, without myspell stuff and without doxygen
16:09:58 <loirkerbot> LibreOffice (core) p.weissenbacher * sc/source/core/data/ (cell.cxx cell2.cxx): Translate German comments, fix some ws
16:10:10 <caolan> jorendc: disable building the dictionaries ? --without-myspell-dicts
16:10:19 <cbosdonnat> enabling remote repos in template manager only in experimental mode is in gerrit for review: https://gerrit.libreoffice.org/#/c/1847/
16:10:37 <jorendc> caolan: ./autogen.sh --without-myspell-dics --without-help --without-doxygen
16:10:47 <jorendc> caolan: so yes I did
16:11:22 <caolan> hmph
16:12:13 <Sweetshark> #topic poll for libreoffice conference
16:12:32 <Sweetshark> #action all member: do your duty and vote!
16:12:56 <_rene_> did the Montreal guys answer (I don't know who asked it) about a BIG budget for travel sponsorhip?
16:13:37 <Sweetshark> #topic GSOC updates
16:13:49 <jmadero> Your LibreOffice 2013 Conference Location Poll Voting Token
16:13:52 <Sweetshark> #action update your GSoC stuff
16:14:08 <Sweetshark> #endmeeting