15:00:30 <x1sc0> #startmeeting
15:00:31 <IZBot> Meeting started Tue Apr 30 15:00:30 2019 UTC.  The chair is x1sc0. Plugin info at http://wiki.debian.org/MeetBot.
15:00:32 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:48 <x1sc0> so let's get started
15:00:54 <x1sc0> who is around for the QA meeting ?
15:02:57 <x1sc0> buovjaga, bearon ?
15:03:19 <buovjaga> I am around, but intermittently. Don't wait for me
15:03:19 * bearon is here
15:03:51 <x1sc0> hello there
15:04:03 <x1sc0> ok, let's do it quick then
15:04:18 <x1sc0> #topic regular tasks
15:04:37 <x1sc0> any proposal for the BZ contributors group ?
15:05:13 <lo-qa-tg1> <K​ompilainenn> don't have
15:05:26 <bearon> not from me
15:05:28 <x1sc0> hello kompilainenn
15:05:37 <lo-qa-tg1> <K​ompilainenn> Hello
15:05:39 <x1sc0> nice interview from yesterday
15:05:50 <buovjaga> I think I will add Tasanim Mulla to the contributors
15:06:04 <x1sc0> yep, I agree
15:06:09 <bearon> yep, nice interview Kompi :)
15:06:17 <x1sc0> he has been really active recently
15:06:32 <CorNouws> x1sc0: I'm here too - but handling multiple threads, and since I'm !♀, it's complicated
15:06:35 <lo-qa-tg1> <K​ompilainenn> thanks, people
15:06:54 <x1sc0> CorNouws, I understand you well :D
15:07:06 <x1sc0> nice to have you here too
15:07:15 <CorNouws> @Kompilainenn Nice indeed
15:07:22 <CorNouws> x1sc0: thnx
15:08:41 <x1sc0> ok, regarding the wiki updates, bearon proposed a few months ago to create a wiki page where we can evaluate the different screencast apps
15:08:57 <x1sc0> for different OS
15:09:17 <x1sc0> it has been on my todo list for a while and I plan to do it
15:09:22 <Telesto> seems a good idea
15:09:32 <x1sc0> just wanted to mention it here in casen anyone wants to start with it
15:09:38 <x1sc0> eih Telesto
15:10:03 <bearon> i can try some apps
15:10:39 <x1sc0> so we can forward users to this page
15:11:13 <x1sc0> i think for now what we can do is everyone to add the app their use
15:11:16 <bearon> i tried to set up AMD ReLive for an OpenGL bug, but it wasn't good for that particular issue (not related to its usability in general, i think the software might still be good)
15:11:57 <CorNouws> have a bit experience with SimpleScreenRecorder on Ubuntu/Linux - stumbled over some oddities
15:11:58 <x1sc0> I've only used SimpleScreenRecorder
15:11:59 <Telesto> Ocam works nicely for me (Win)
15:12:11 <CorNouws> x1sc0: ;)
15:13:01 <x1sc0> so let's do it like this: I create a first draft about SimpleScreenRecorder
15:13:09 <CorNouws> will an update be shared via the QA-list? So that I can look if I've something to add?
15:13:13 <x1sc0> and then people add on top their experience
15:13:53 <x1sc0> yep, I can send an email to the qa-list
15:14:28 <x1sc0> #todo x1sc0 create draft and others add on top
15:14:37 <x1sc0> #todo x1sc0 send email to the mailing list
15:15:30 <x1sc0> #action x1sc0 create draft ( and send email to the mailing list ) and others add on top
15:15:38 <x1sc0> used the wrong command ...
15:16:18 <x1sc0> ok, great
15:17:01 <x1sc0> #topic BHS for Libo 6.3 alpha1
15:17:15 <x1sc0> so next topic is about the next BHS
15:17:19 <lo-qa-tg1> <K​ompilainenn> oh
15:17:28 <x1sc0> alpha1 release is planned for next week
15:17:49 <x1sc0> any opinion on whether it should be on Friday or Monday ?
15:18:22 <lo-qa-tg1> <K​ompilainenn> doesn't matter for me
15:19:36 <x1sc0> the one for Libo 6.2 alpha1 was on monday
15:20:02 <x1sc0> good thing about having it on monday is we ensure we have the builds
15:20:28 <x1sc0> otherwise at this point, they don't differ much from a daily build
15:21:50 <x1sc0> any other opinion?
15:22:08 <x1sc0> considering the one for 6.2 was on Monday, I would do the same
15:22:14 <CorNouws> Monday is fine, Then BHS on Friday I assume?
15:22:17 <x1sc0> unless anyone is against it
15:22:38 <CorNouws> does it attrac many people nowadays?
15:23:06 <lo-qa-tg1> <K​ompilainenn> i think no
15:23:11 <x1sc0> a few people in IRC
15:23:33 <x1sc0> but it's good for letting people know a pre-release is available for testing
15:23:54 <x1sc0> for announcing a new pre-release is available for testing
15:25:03 <x1sc0> CorNouws, my question is whether we have the BHS on Friday or Monday
15:26:05 <CorNouws> x1sc0: ah :) - I've no preference, so if you think Monday is fine: +1
15:26:49 <x1sc0> ok, let do it Monday then
15:27:33 <x1sc0> I'll create the wiki page. Everyone is invited to join as participant/entor
15:27:36 <x1sc0> *mentor
15:28:05 <buovjaga> I have a couple of topics btw.
15:28:31 <x1sc0> sure, let's move on then
15:28:35 <x1sc0> I also have another one
15:28:40 <x1sc0> but go ahead
15:29:01 <buovjaga> #topic UIforETW
15:29:15 <buovjaga> IZBot does not respect me
15:29:38 <buovjaga> Anyway: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_how_to_get_an_ETW_performance_trace
15:30:15 <x1sc0> #link https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_how_to_get_an_ETW_performance_trace
15:30:18 <lo-qa-tg1> <K​ompilainenn> bad link
15:30:28 <buovjaga> Last year I tried to get UIforETW to work, but was discouraged for some reason (maybe just confused). Recently, Telesto sent me instructions on how to set it up and now I massaged them into the wiki.
15:31:00 <buovjaga> I encourage people to try it out
15:31:17 <x1sc0> buovjaga, is this the tool you're using for perf issues ?
15:32:14 <lo-qa-tg1> <K​ompilainenn> I'll try it if I'll be to have good manual
15:32:20 <buovjaga> If someone has too much time in their hands and wants to fiddle with Python, there is an abandoned script to create flame graphs. The UIforETW dev does not work on it anymore (it is in Python 2) because he thinks the flame graph display in WPA is enough. However, this means one has to use Windows to see them
15:32:25 <buovjaga> x1sc0: no, it is not
15:32:55 <buovjaga> @Kompilainenn now you have a good manual :)  or do you think it is a bad one?
15:33:18 <lo-qa-tg1> <K​ompilainenn> I see empty site without info
15:33:42 <lo-qa-tg1> <K​ompilainenn> check your link yourself
15:34:05 <x1sc0> it works for me
15:34:42 <lo-qa-tg1> <K​ompilainenn> may be telegram broked it
15:34:50 <x1sc0> buovjaga, out of curiosity, which one did you use for the perf issues ?
15:34:53 <buovjaga> The special thing about ETW is that, if there is no privacy concern, you can record everything. This can help with weird bugs that are hard to repro
15:35:06 <buovjaga> x1sc0: for perf, I use perf (trolololo)
15:35:18 <buovjaga> x1sc0: https://wiki.documentfoundation.org/Development/How_to_debug#Performance_debugging_.28perf.29
15:36:10 <lo-qa-tg1> <K​ompilainenn> yep, telegram makes link wrong
15:37:17 <x1sc0> buovjaga, so did you already use UIForETW with any bug ?
15:37:31 <buovjaga> x1sc0: too early, but for sure I can use it for Win-only issues
15:37:35 <lo-qa-tg1> <K​ompilainenn> ah, it deleted "_" sign
15:38:03 <IZBot> News from tdfnew: [Bug 125048] Saved file has wrong group if calc file contains a chart. (Truly bizarre ...) <https://bugs.documentfoundation.org/show_bug.cgi?id=125048>
15:38:05 <buovjaga> x1sc0: one problem is that we don't have a daily build with --enable-symbols
15:38:22 <buovjaga> x1sc0: do you know, if one can install Visual Studio on an unactivated Windows?
15:39:44 <x1sc0> no idea
15:40:05 <buovjaga> I guess I should try it out some day, even if I would not start doing builds for now
15:40:23 <buovjaga> any other comments or shall we move to the next topic?
15:40:33 <x1sc0> not from me
15:40:46 <lo-qa-tg1> <K​ompilainenn> I see instruction, I'll try it later
15:40:57 <buovjaga> #topic Script for checking fileopen/filesave regressions
15:41:22 <buovjaga> I wrote this script: https://gerrit.libreoffice.org/#/c/71069/ Please test it for all fileopen and filesave issues.
15:41:23 <IZBot> gerrit: »Script for checking fileopen/filesave regressions« by Ilmari Lauhakangas for master [NEW]
15:41:35 <lo-qa-tg1> <K​ompilainenn> Automatic testing, omnomnom
15:41:48 <x1sc0> yep, I haven't checked it yet
15:41:58 <x1sc0> plan to do it this week
15:42:22 <buovjaga> An idea in the past was that perhaps this script or some future incarnation could be used in Bugzilla. We could click a button and PDFs would appear in BZ.
15:42:55 <x1sc0> yep, that would be great
15:43:00 <buovjaga> So we would not even need to download the example document in order to regression test it
15:44:24 <buovjaga> x1sc0: if no other comments, we can move to your topic
15:44:57 <x1sc0> for now, what we could do it to write a blogpost about it
15:45:00 <x1sc0> once it's ready
15:45:08 <x1sc0> so people are aware and can use it
15:45:32 <buovjaga> yeah, same for UIforETW, once we get some experience
15:45:53 <x1sc0> cool
15:46:35 <x1sc0> sorry I didn't review it before but I've been busy with the mass-uitesting
15:46:56 <x1sc0> will test it on linux only though
15:48:12 <x1sc0> #topic triage week
15:49:25 <x1sc0> so, I'm a bit worried about unconfirmed bugs count being above 500
15:49:55 <x1sc0> because it has been like this for some weeks now
15:50:11 <x1sc0> and I found this page
15:50:21 <x1sc0> #link https://wiki.mozilla.org/SeaMonkey:Triage_Week
15:51:00 <x1sc0> and I've been thinking if this could help us the put the count down
15:51:29 <x1sc0> doing proper triage, of course ;-)
15:51:42 <az> What is BHS?
15:51:50 <bearon> bug hunting session
15:52:17 <az> thank you
15:53:01 <az> May I get the link for daily build used to test bugs? it was in the page in the topic
15:53:31 <x1sc0> az -> https://wiki.documentfoundation.org/QA/GetInvolved#Test_Daily_Builds
15:53:40 <x1sc0> deb builds are broken at the moment
15:55:23 <CorNouws> and installing RPM with cpio as cloph suggested didn't result in a full installation too for me - but that may be me
15:56:39 <x1sc0> any opinion on the topic? otherwise I'll give it a thought, just wanted to share the idea with you
15:57:07 <az> is this one working? http://libreoffice.soluzioniopen.com/index.php/daily-version/
15:57:37 <buovjaga> az: the appimages are done from the daily builds, so ... I don't know, you can try
15:57:39 <az> maybe you should donate some BCH to volunteers :)
15:58:11 <buovjaga> x1sc0: yes, please pay us in cryptocurrency so we will triage more
15:59:45 <x1sc0> buovjaga, is it fine if I pay in petros ?
15:59:56 <buovjaga> x1sc0: what do you think will be the impact of the triage week?
16:00:47 <buovjaga> marketing impact like BHS?
16:01:20 <x1sc0> buovjaga, don't know to be honest, just scratching my head about how to improve the situation
16:02:18 <x1sc0> maybe it encourages people to participate
16:02:29 <az> x1sc0, I can get donation from someone if there is a system where volunteer could be paid for triaging, you can create a kickstart or something similar and give the people and it will be in the news
16:02:29 <x1sc0> like, triage 5 bugs a day
16:02:32 <x1sc0> or something like that
16:02:48 <az> around 50 Eur
16:03:29 <buovjaga> but then it's not volunteering anymore
16:03:32 <bearon> triage 5 bugs a day sounds like a good initiative
16:04:27 <x1sc0> az, we can't do that, at least not me
16:04:56 <x1sc0> #idea triage 5 bugs a day
16:05:17 <az> buovjaga, well I've seen many projects that pay volunteer just like a small gift
16:05:26 <az> in real life
16:05:32 <lo-qa-tg1> <m​uhammetk> Might easily end up causing overwhelming spam in our bugzilla.
16:05:37 <x1sc0> if we could get 5 people interested it would mean 175 bugs triaged
16:06:15 <az> lo-qa-tg1, muhammetk if you put good guide then you can prevent this spam
16:06:27 <az> guidelines
16:06:51 <buovjaga> az: conference trips can be good gifts ;)
16:07:21 <buovjaga> if you are fascinated about the thought of being bombarded with LibreOffice information for several days
16:07:23 <az> people may not like to travel :)
16:07:23 <x1sc0> well, a gift would be nice, but not money
16:08:09 <IZBot> News from tdfnew: [Bug 125049] Request more standard (and useful) way to select anchor point for object align <https://bugs.documentfoundation.org/show_bug.cgi?id=125049>
16:08:23 <x1sc0> I'll try to have something for next meeting so we can discuss on that
16:08:50 <x1sc0> I'm going to close the meeting
16:09:00 <x1sc0> thank you very much for attending it
16:09:17 <x1sc0> #endmeeting