16:01:31 <x1sc0> #startmeeting
16:01:31 <IZBot> Meeting started Tue Oct 31 16:01:31 2017 UTC.  The chair is x1sc0. Plugin info at http://wiki.debian.org/MeetBot.
16:01:31 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:52 <x1sc0> #topic rollcall
16:02:12 <x1sc0> Porkepix, how many do they get?
16:02:32 <x1sc0> Porkepix, btw, we're starting the monthly meeting now
16:02:44 <buovjaga> x1sc0: some triaging-related stats https://emceeaich.dreamwidth.org/206684.html
16:02:54 <x1sc0> everybody is welcomed to join
16:04:39 <Porkepix> I wouldn't know what to tell to help in it, and wouldn't be of much use, you know it's been years since I used LibreOffice for myself :d
16:05:37 <x1sc0> Porkepix, no problem, but you can stay anyway, it seems today's meeting is going to be quick, specially being right after the Libo Conference
16:05:42 <Porkepix> bearon: Oh and btw, no caelan on #libreoffice-dev
16:06:03 <Porkepix> caolan*
16:06:17 <x1sc0> Porkepix, yep, he's not right now, but he's normally
16:06:45 <x1sc0> buovjaga, any topic you would like to talk about during the meeting? I have a couple of things I would like to share with you
16:07:09 <buovjaga> x1sc0: hmm, did you read Telesto's emails?
16:07:22 <x1sc0> buovjaga, not yet
16:07:53 <buovjaga> ok.. was thinking that we should maybe just encourage to report those as bugs
16:07:57 * x1sc0 reading
16:11:22 <x1sc0> buovjaga, well, it's hard to tell, on the on hand, they might be a bug, but is it really a problem that the memory increases for some seconds?
16:11:59 <buovjaga> yeah for the first..
16:12:09 <x1sc0> sometimes I have difficulties to triage telesto's bugs, I have different behaviour in my computer
16:12:25 <buovjaga> what about the second one: Memory usage will be sky high (2 GB or so) and drop a bit, but it still uses 878 MB with a empty sheet.
16:13:34 <x1sc0> *with zero undo steps
16:14:25 <x1sc0> it's great we test all scenarios available, but is any end-user going to face it?
16:14:57 <x1sc0> I mean, who sets the undo steps to zero?
16:15:07 <x1sc0> maybe there's a case I'm missing
16:15:11 <buovjaga> it's true that that is a bit pedantic :)
16:15:50 <buovjaga> so, should we just say "don't worry, be happy"? :)
16:16:01 <x1sc0> in an ideal world, that should be fixed too, but we have limited resources :)
16:16:39 <x1sc0> it's like, this document take 2 more seconds to open than in LibreOffice 4
16:17:18 <x1sc0> I've seen some of those, and it's hard to triage that
16:17:25 <buovjaga> we should make a flowchart "relative importance of bugs" :)
16:18:07 <buovjaga> I mean for considering whether to even report
16:18:30 <x1sc0> yep
16:18:54 <buovjaga> so action is to tell Telesto to skip reporting those?
16:19:41 <x1sc0> even if it took 2 seconds in the past and now it takes 4 seconds, it's the double, but is it really that much? another thing would be 30 seconds instead
16:19:51 <x1sc0> buovjaga, I'd say, go for the first one
16:20:03 <x1sc0> but not for the second one ( the zero steps )
16:20:16 <buovjaga> ok, I will reply
16:20:20 <x1sc0> buovjaga, as he said, first one might be an OOM
16:21:24 <x1sc0> so a couple of thing from my side
16:21:56 <x1sc0> #topic adding a banner in Bugzilla for pre-releases
16:22:25 <x1sc0> after the BHS, I got some complains about the banner in Bugzilla, as the BHS was last week
16:22:43 <x1sc0> however, I think it's a good idea to let people know a new pre-release is available
16:23:17 <buovjaga> so they complained "remove the obsolete banner"?
16:23:37 <x1sc0> so I was thinking we could change the banner after each BHS to something like: LibreOffice 6.0 alpha1 is out. Help us test it! or something
16:24:00 <buovjaga> yeah, why not :)
16:24:52 <x1sc0> buovjaga, ok, so I think we are majority here xDD
16:25:20 <bearon> preferably for a strict time period
16:25:36 <x1sc0> #idea After BHS, change the banner to something lie: LibreOffice 6.0 alpha1 is out. Help us test it!
16:25:54 <bearon> and remove it when that period passes, not at random times
16:26:17 <bearon> also, what counts as pre-release? i assume pre-release of updates don't count
16:26:17 <x1sc0> #link https://wiki.documentfoundation.org/ReleasePlan/6.0#6.0.0_release
16:26:32 <bearon> so, only alpha1, beta1, beta2?
16:26:34 <x1sc0> ^^^^ this is the release plan
16:26:57 <x1sc0> yep, probably rc1 is too late to ask for help
16:27:38 <buovjaga> at rc1: sorry, you deserve all the bugs you got!
16:28:01 <bearon> so in that case the period the banner is up is until the next pre-release is out? (and then it's changed/removed)
16:28:21 <x1sc0> yep, that could be an option
16:28:47 <x1sc0> or, alpha1, beta1, rc1 for a period of 2 weeks after release
16:29:03 <bearon> ok, sounds good to me
16:29:24 <x1sc0> yep, it sounds good to me too
16:29:58 <x1sc0> #idea alpha1, beta1, rc1 for a period of 2 weeks after releas
16:30:22 <x1sc0> probably I'll do it smaller
16:30:35 <x1sc0> to avoid people's complains
16:30:51 <bearon> yeah, that never hurts :)
16:31:08 <x1sc0> ok, greal
16:31:28 <x1sc0> #agreed
16:31:30 <bearon> where will the banner link?
16:31:54 <x1sc0> to the download page? or to the release notes?
16:32:28 <bearon> can we adjust the download via parameters? eg. to bring up the particular pre-release right away
16:32:55 <x1sc0> bearon, you mean depending on the client ?
16:33:15 <bearon> no, not the OS, just the version
16:34:56 <LibO_welcome> Welcome plino! I thought I'd say hello, and ping some people so they know you're here (like bearon, buovjaga, and x1sc0). I'm a bot! If no one responds for a while, relax and stay in the channel. Channels are most active during weekdays, EU office hours. Please look at the channel topic for helpful advice.
16:35:07 <x1sc0> bearon, yep, maybe it can be done, but I dunno right now
16:35:20 <x1sc0> #idea bearon> can we adjust the download via parameters? eg. to bring up the particular pre-release right away
16:36:50 <x1sc0> ok, let's move on
16:36:55 <bearon> ok, i tested this, it should be something like this: http://www.libreoffice.org/download/download/?version=5.4.3
16:37:22 <bearon> this brings up the 5.4.3 pre-release for your OS and language
16:38:01 <buovjaga> http://dev-builds.libreoffice.org/pre-releases/win/x86_64/ is a different story
16:38:25 <x1sc0> bearon, http://www.libreoffice.org/download/download/?type=deb-x86_64&version=5.3.7&lang=ca
16:38:28 <buovjaga> but sure, generating the file names should not be a problem
16:38:54 <bearon> x1sc0: yeah, but you can omit the parameters you don't want there
16:39:00 <bearon> anyway, we can move on
16:39:11 <x1sc0> yep, I'll look into that
16:39:28 <x1sc0> #topic next BHS
16:39:35 <x1sc0> so, speaking of BHS
16:39:49 <x1sc0> when you you prefer to have the next BHS?
16:40:10 <x1sc0> for beta1, beta2(optional) or rc1?
16:40:49 * bearon votes for Friday :D
16:40:51 <buovjaga> beta2 is optional, so we cannot rely on it :)
16:41:07 <x1sc0> yep, that's true
16:41:16 <buovjaga> but is it wise to tie the BHS so closely with the "expected" release of a pre-rel?
16:41:16 <x1sc0> beta1 ->Week 47 , Nov 20, 2017 - Nov 26, 2017
16:41:25 <buovjaga> why not give it a couple of days
16:41:31 <x1sc0> RC1 -> Week 51 , Dec 18, 2017 - Dec 24, 2017
16:41:45 <buovjaga> then we don't have to explain, if there is some last minute problem with release
16:41:49 <x1sc0> buovjaga, so, you would prefer, the week after?
16:42:01 <bearon> hm, not sure how many people will be available after Christmas, when RC1 is out
16:42:54 <buovjaga> x1sc0: yeah like 27 Nov or something
16:43:20 <x1sc0> #idea <buovjaga> but is it wise to tie the BHS so closely with the "expected" release of a pre-rel
16:43:27 <x1sc0> yep, I like it too
16:43:43 <x1sc0> actually, we do it the same week because we have always done it like this
16:43:46 <buovjaga> the advantage is that most devs are working and can be pinged in case of an emergency
16:43:51 <x1sc0> but there's no real reason behind it
16:44:39 <x1sc0> yep, I think it's better to have it before christmas too
16:45:27 <x1sc0> buovjaga, so you would prefer monday?
16:45:45 <buovjaga> we will not die, if we try it once :)
16:46:03 <x1sc0> sure thing
16:46:05 <x1sc0> yep, let's try
16:46:54 <x1sc0> bearon any objection ?
16:48:30 <x1sc0> well, let's do it then
16:49:13 <x1sc0> #agreed next BHS -> MONDAY 27 nov
16:49:40 <x1sc0> ok, so that's all from my side
16:49:49 <x1sc0> anything else before closing the meeting ?
16:50:32 <bearon> i'm fine
16:50:53 <bearon> with the Monday
16:51:50 <x1sc0> great!
16:51:56 <x1sc0> let's close the meeting then
16:52:10 <x1sc0> thanks your guys
16:52:15 <x1sc0> #endmeeting