15:45:24 <x1sc0> #startmeeting
15:45:24 <IZBot> Meeting started Tue Apr 25 15:45:24 2017 UTC.  The chair is x1sc0. Plugin info at http://wiki.debian.org/MeetBot.
15:45:24 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:45:53 <x1sc0> #topic Documentation as a Keyword
15:46:09 <x1sc0> so this is from last esc minutes
15:46:25 <x1sc0> * should we have keywords not components in bugzilla (Heiko)
15:46:25 <x1sc0> + would need to move things from writer → documentation etc.
15:46:25 <x1sc0> + what’s wrong with a component ? (Xisco)
15:46:25 <x1sc0> + don’t see the problem.
15:46:25 <x1sc0> + some bugs have multiple facets: l10n, UI, documentation (Heiko)
15:46:27 <x1sc0> AI:     + come up with a proposal (Xisco, Heiko, Olivier)
15:46:46 <x1sc0> so, I think we have 3 options here
15:46:53 <x1sc0> 1. leave it as it's right now
15:47:07 <x1sc0> 2. to have the component and the keyword
15:47:18 <x1sc0> 3. remove the component and only use the keyword
15:47:55 <x1sc0> I was a bit concert about removing the component, specially for the bugs which use it
15:48:12 <x1sc0> but I think they can just be moved to 'LibreOffice'
15:48:46 <x1sc0> the thing is: which are the pros and cons of doing it
15:48:51 <ohallot> x1sc0: I like the documentation  as a Keyword., sub keywords as Help, Guide, Wiki, Multimedia
15:49:53 <x1sc0> ohallot, then, we can just use Help, Guide, Wiki or Multimedia without using Documentation keyword
15:49:56 <x1sc0> the less the better
15:50:12 <x1sc0> are there more subsections ?
15:50:30 <cloph> i'd not have both.
15:50:52 <cloph> So if keyword is preferred way, ninja-edit existing ones to use the keyword instead of component and then get rid of the component.
15:50:59 <ohallot> Is this going to confuse reporters? e.g. a long dropdown list?
15:51:01 <cloph> other than that I don't have personal pref.
15:51:23 <DennisRoczek> it won't be intuetive for users who want to report errors in the help
15:51:40 <x1sc0> cloph, yes, I don't really like having both neither
15:51:42 <DennisRoczek> (i even find documentation not intuitive for that)
15:51:54 <cloph> DennisRoczek: wouldn't care so much about that, since you could tweak the simple bug form to make that easier.
15:53:18 <x1sc0> another thing: if we have different subkeywords, moving from 'Documentation' component to the keywords isn't going to be straightforward
15:53:53 <ohallot> guys.... my mistake. above please read Component instead of keyword
15:54:35 <cloph> kinda sucks to not have Heiko around though
15:54:44 <DennisRoczek> heh
15:55:07 <x1sc0> ohallot, -> I like the documentation as a "Components"., sub keywords as Help, Guide, Wiki, Multimedia ?
15:55:11 <sophi> ohallot: so you'd prefer component+subcomponent?
15:55:23 <ohallot> sophi: yes
15:55:26 <cloph> #info cloph doesn't mind which way to go, but doesn't want to have *both* component and keyword
15:55:44 <sophi> cloph: +1
15:55:49 <iplaw67> me neither
15:55:54 <x1sc0> #info ohallot I like the documentation as a "Components"., sub keywords as Help, Guide, Wiki, Multimedia
15:55:56 <iplaw67> cloph: +1
15:56:25 <x1sc0> #info iplaw67 and x1sc0 agree with cloph
15:57:08 <ohallot> x1sc0: +1
15:57:08 <bearon> cloph: so how do you track functionality changes that also require changes to documentation?
15:57:23 <cloph> "clone this bug"
15:57:52 <x1sc0> ohallot, do you think having the component + subkeyword would improve current situation a lot ?
15:58:14 <IZBot> News from tdfnew: [Bug 107414] Close sidebar deck button doesnt respond after redocking <https://bugs.documentfoundation.org/show_bug.cgi?id=107414>
15:58:56 <bearon> x1sc0: for clarification, that's subcomponent, not subkeyword
15:59:01 <bearon> i assume
15:59:03 <ohallot> x1sc0: it will improve, although I can't say "a lot"
15:59:25 <cloph> there's Product and Component, not sure what you mean with subcomponent
16:00:25 <x1sc0> I don't think there's suck a subcomponent option
16:00:26 <bearon> ok, my mistake, i'm tired, too :)
16:01:20 <x1sc0> ohallot, and if you had to decide between, having only the component or only keyword, which one would you choose ?
16:01:35 <ohallot> x1sc0: one component
16:01:36 <buovjaga> https://wiki.documentfoundation.org/QA/Bugzilla/Components#How_to_use_subcomponents
16:02:51 <x1sc0> buovjaga, ahh ok, so adding the subcomponent in the summary
16:03:00 <x1sc0> like FILEOPEN/FILESAVE
16:03:00 <cloph> while I suggested "clone the bug", I see we don't have a "clone the bug" on our instance (yet :-))
16:03:37 <buovjaga> x1sc0: just trivia regarding what we have referred to as subc. historically
16:03:51 <x1sc0> ohallot, what about using GUIDE: WIKI: HELP: and MULTIMEDIA: at the beginning of the summary ?
16:04:07 <buovjaga> many ways to skin a cat :)
16:04:08 <ohallot> x1sc0: Excellent!
16:04:12 <x1sc0> if it's not used yet, I don't know though
16:04:49 <ohallot> I use to report "[LOCALHELP] Add page on feature xyz"
16:04:55 <x1sc0> I think it can work without changing thousand of bugs in bugzilla
16:05:42 <DennisRoczek> cloph: so fix it :-D
16:06:01 <cloph> DennisRoczek: me is stupid, it is available/enabled, just "hidden" at the bottom
16:06:03 <x1sc0> #info use 'Documentation' component + GUIDE: WIKI: HELP: or MULTIMEDIA: at the beginning of the summary
16:06:05 <DennisRoczek> x1sc0: LOCALHELP and HELPWIKI please; as it is now ^^
16:06:19 <cloph> (next to "Format for Printing" and xml export)
16:06:28 <x1sc0> DennisRoczek, absolutely, up to you
16:06:57 <cloph> so fix would be to make that a more prominent link / put that next to comment window/bug resolutin thing
16:07:07 <buovjaga> hmm never used that clone tool, might be interesting
16:07:52 <buovjaga> it adds "This bug was initially created as a clone of Bug.."
16:07:54 <x1sc0> ohallot, I think you should discuss it in the Doc team, and come up with some subcomponents that fit your needs
16:07:56 <buovjaga> to the desc
16:07:59 <cloph> need to tweak that though, that right now also goes via the simpleform and kinda defeats the purpose
16:08:21 <x1sc0> ohallot, and then you just need to document it in the doc wiki
16:08:47 * cloph outs itself as a fool again, as whether or not simple wizard is used does not depend on the clone link, but rather what link you choose in the project/component selection :-)
16:08:58 <marcoagpinto> cloph: well, bugzilla is kind of hard to use right now
16:09:06 <cloph> buovjaga: and more importantly it auto-adds the info of depends-on
16:09:23 <cloph> nah, it is too easy to use :-)
16:09:31 <marcoagpinto> what? :)
16:10:03 <DennisRoczek> marcoagpinto: what is hard? (if you do not tell us, we cannot change it for improving the usability for everybody)
16:10:07 <cloph> to use the clone function properly, you should use the "expert" entry mask, not the simple step-by-step dialog.
16:10:08 <ohallot> x1sc0: no need for such roundtrip. Let's do it and announce. Doc team not used to BZ, it will take time to place BZ in the mainstream
16:10:34 <ohallot> x1sc0: I'll think into a blog past on that
16:10:39 <ohallot> post
16:10:48 <cloph> and on the project selection we have the two huge entries for LibreOffice and Impress Remote that always go via the simple ones, whereas the smaller-print list of projects use the traditional form, and that is what you want if you clone a bug
16:10:48 <x1sc0> ohallot, ok, great
16:11:02 <marcoagpinto> DennisRoczek: because when I want to report a bug, I can't find the right component or whatever to choose
16:11:55 <cloph> marcoagpinto: that's a different topic though, mabye discuss this later (i.e. another topic on how to improve the simple bug form)
16:11:56 <ohallot> I think marcoagpinto has a point, from user POV.
16:12:05 <x1sc0> #agreed 'Documentation' component remains and some subcomponents will be used at the beginning of the summary
16:12:16 <ohallot> x1sc0: +1
16:12:17 <x1sc0> #todo ohallot to blog about it
16:12:23 <cloph> #info "clone bug" is kinda hidden at bottom of the page
16:12:35 <DennisRoczek> marcoagpinto: please do not talk about your project open thesauri... that's somewhat out of scope for the bug tracker itself
16:12:42 <x1sc0> ohallot, thanks for attending the meeting
16:12:44 <cloph> #info make sure to not use the simple form links (large print), but the smaller-print project list when creating the clone
16:12:48 <x1sc0> it's getting a bit caotic xDD
16:12:57 <bearon> seems like i was accidentally right about subcomponents :)
16:12:57 <x1sc0> #topic clone link
16:13:03 * ohallot likes irc meetings
16:13:08 <cloph> that's why using info keyword help, only info lines will show up in the shortened excerpt/minutes :-)
16:13:09 <x1sc0> bearon, yes, you were. thanks
16:13:15 <marcoagpinto> DennisRoczek: the project will be external
16:13:46 <x1sc0> so cloph, what is it with the clone link ?
16:13:56 <x1sc0> is it implemented ?
16:13:58 * ohallot waives "bon apétit" to team and quit
16:14:14 <marcoagpinto> what I am tring to say is that last night I found another bug in .docx import and there isn't an option for it
16:14:15 <marcoagpinto> :)
16:14:19 <cloph> yes, it is alredy there, it just is at the bottom of a bug, and not where you'd expect edit actions
16:14:46 <x1sc0> cloph, oh yes, I've just seen it too
16:14:58 <x1sc0> #info link at the bottom of the page
16:14:59 <cloph> so cloning a bug was my answer to "so how do you track functionality changes that also require changes to documentation"
16:15:42 <x1sc0> ah ok
16:15:51 <cloph> don't try to have it all in one issue. Mutating issues are bad, so have a separate one that can be easily created without having to enter the data manually is a rather convenient way to have it appear in another/dedicated component
16:15:52 <x1sc0> #info it clones the summary and the description
16:16:08 <cloph> → and sets depends-on
16:17:00 <x1sc0> cloph, yes, I like the feature. I've copied quite some bugs in the past
16:17:16 <DennisRoczek> marcoagpinto: let us discuss this later
16:17:38 <x1sc0> ok, so let's move to the next topic
16:17:48 <x1sc0> #topic QA telegram group
16:18:12 <DennisRoczek> is there already one?
16:18:17 <x1sc0> the other day, I was told that the design team created a new telegram group for them
16:18:23 <x1sc0> so I wanted to ask you
16:18:29 <x1sc0> if you use Telegram
16:18:36 <x1sc0> and if you would like to have a group
16:18:39 <buovjaga> is the only reason for design telegram group the ability to post images?
16:18:40 <x1sc0> personally I like the idea
16:18:45 <x1sc0> but I would like to hear from you
16:18:45 <DennisRoczek> I use it (only  deskop; no mobile here)
16:18:48 <buovjaga> personally I hate it of course
16:19:00 * cloph uses telegram, but not interested in a QA group, don't think it would be useful without actually being at PC, and thus could just use IRC
16:19:04 <x1sc0> DennisRoczek, I don't think there's one
16:19:09 <sophi> x1sc0: I like it too
16:19:29 <DennisRoczek> no opinion of having yet another group
16:19:43 <buovjaga> design team should look into harmonising their IRC clients to ones that support inline images, so they don't need another tool
16:19:45 <cloph> put it another way: what kind of conversations would be held in that telegram group/why not use an exising group?
16:19:47 <x1sc0> as prefer IRC to discuss thing, but maybe it can work for newcomers
16:20:14 <x1sc0> s/as/I
16:20:15 <sophi> cloph: which one would you use?
16:20:42 <DennisRoczek> what's different to just add another bot which puts stuff from irc to telegram (but not to join the group chat itself?)
16:20:43 <cloph> again: no idea what would be the purpose of the QA telegram group, so depends.
16:20:55 <DennisRoczek> so for newcomers
16:20:57 <x1sc0> I see that sometimes newcomers come to IRC, leave a message, no one answers, and they leave, that wouldn't happen in the qa team
16:21:05 <x1sc0> qa telegram group
16:21:14 <buovjaga> x1sc0: you don't remember the welcome bot?
16:21:17 <cloph> just bridging without having dedicated use also isn't that helpful from my POV
16:21:42 <x1sc0> buovjaga, I do, but if no one is available, it's worthless
16:21:49 <cloph> but qa-telegram then likely will become user-support channel?
16:21:59 <buovjaga> it's not worthless.. it tells them to stay in the channel
16:22:06 * bearon casts his vote on forums/discussion boards
16:22:11 <buovjaga> it's not like this is some deserted channel
16:22:24 <bearon> or rather, _a_ forum/discussion board
16:22:34 <buovjaga> yeah forums are better for asynch discussion
16:22:54 <buovjaga> better index, search etc.
16:23:03 <x1sc0> #info buovjaga> yeah forums are better for asynch discussion
16:23:37 <cloph> forums are a plague..
16:23:59 <buovjaga> proprietary systems like Telegram and running after them is a plague
16:24:17 * cloph very rarely finds helpful info in forum threads. Often enough unanswered questions of "solved" without stating how,...
16:24:22 <DennisRoczek> cloph: depend on the stuff. i do like them
16:24:30 <DennisRoczek> (depend always on the purpose)
16:25:05 <cloph> yeah, and people using signatures that have the important keywords in them, making it impossible to find info on that specific topic (as ~ every post matches)...
16:25:27 <cloph> I uses very specific forums, but only because there is no alternative :-)
16:25:56 <DennisRoczek> cloph: that's a different matter. if forums are used for wrong purpose and marketing, well hence every tool can be misused
16:25:57 <cloph> tldr; I'm not very active in QA anyway, so don't put too much weight into my view
16:26:46 <DennisRoczek> x1sc0: why not create a telegram group for newcomers and ropute the traffic through a bot to this channel (and not really joining the telegram channel)
16:27:00 <x1sc0> the problem I see with a forum is that it's quite possible it will look desert
16:27:43 <sophi> x1sc0: and it's much more work to manage a forum than a channel
16:27:54 <x1sc0> sophi, that's true
16:28:22 <IZBot> News from tdfnew: [Bug 107423] Contextual groups variant of the Notebookbar is supposed to work with main menu and sidebar <https://bugs.documentfoundation.org/show_bug.cgi?id=107423> || [Bug 107424] Non-split button of Format as Currency doesn't work of Notebookbar <https://bugs.documentfoundation.org/show_bug.cgi?id=107424>
16:28:52 <x1sc0> DennisRoczek, what do you mean by not really joining the telegram channel ?
16:29:17 <sophi> looks like a channel but is in fact irc ;-)
16:29:20 <DennisRoczek> only owner of channel; and telegram-irc-bridge-bot + newcomers
16:29:36 <DennisRoczek> stuff is simply bridged by bot to both sides
16:29:51 <buovjaga> let's just host a web based IRC with persistent logs and call it Telegram
16:29:53 <DennisRoczek> so the "pros" are still here;
16:29:57 <DennisRoczek> yeah
16:30:10 <DennisRoczek> or like the #libreoffice-telegramm channel
16:30:11 <x1sc0> then we will have too much noise in the telegram channel, aren't we ?
16:30:17 <DennisRoczek> which is used only by buovjaga ^^
16:30:31 <DennisRoczek> only what we write
16:30:35 <buovjaga> like this incomplete one https://github.com/waartaa/waartaa It is aimed towards being an intuitive, collaborative IRC client across multiple devices of the user along with centralized logging.
16:30:41 <x1sc0> so everything we would write here would be displayed there?
16:30:56 <cloph> still miss the point for having telegram group though.
16:31:10 <cloph> I don't think it is "newcomery" enough.
16:31:24 <cloph> i.e. it is not as widespread as e.g. twitter of facebook would be.
16:31:55 <cloph> and whether one uses a telegram client or IRC is more or less a technical detail - both require action by the user.
16:32:09 <buovjaga> steve-_-[m] would recommend Riot, naturally
16:32:22 <buovjaga> as you can use IRC through it
16:32:24 <cloph> It will solve the "having local history" for those impatient folks, but again I don't see the big impact on newcomers.
16:33:26 <DennisRoczek> jep. moreover qa is boring for most users / newcomers :-D
16:33:27 <cloph> But I still don't really know what kind of conversations you have in mind re the channel, so cannot really tell whether twitter would be better way.
16:34:01 <cloph> (but then again even more a problem of being "abused" as user-support channel I guess)
16:34:28 <cloph> for design it solves a problem (re images) - for QA? not sure..
16:35:21 <x1sc0> cloph, yep, good point, I didn't it that way before
16:36:01 <cloph> so maybe otherwise put: Using telegram *instead* of IRC as main channel (and having the irc channel just as "mirror") would be other issue, but for that I think QA channel has too much traffic/would be too noisy and even easier to loose track in telegram than in irc window.
16:36:49 <x1sc0> cloph, no ,I wouldn't like to use telegram as the main communication channel
16:37:32 <buovjaga> these slacks and telegrams with their persistent chat histories come up again and again in articles describing how communication devolves into complete chaos because of having to keep track of all the histories and different conversations happening between each other..
16:37:42 <sophi> I see x1sc0 point as users on telegram as not the same population as users on irc, it could be a way to attract them
16:38:20 <x1sc0> the only thing why I was thinking it could be good for newcomers is that we have 300 people in LibreOffice telegram group so using the qa group could attack some new ones
16:38:25 <x1sc0> sophi, yep, exactly
16:38:43 <cloph> #info cloph is sceptical, doesn't think telegram would be newcomer-friendly (not as widespread like e.g. twitter/facebook), and also cannot see what kind of conversations it would be good for
16:38:54 <x1sc0> s/attack/attract
16:39:50 <buovjaga> we don't take bug reports through Facebook, so why deal with QA in Telegram?
16:40:18 <cloph> don't agree with telegram's history being chaotic, at least not more chaotic than irc backlog, just using on phone with smaller screen will make it more cumbersome to follow a high-activity channel like qa
16:40:22 <buovjaga> I was once in a translators group in Skype. Pretty funny.
16:40:56 <sophi> buovjaga: there is a translator group on facebook, dealing only with strings :)
16:41:48 <buovjaga> example of the articles about chaos https://medium.com/@chrisjbatts/actually-slack-really-sucks-625802f1420a
16:41:56 <buovjaga> https://m.signalvnoise.com/is-group-chat-making-you-sweat-744659addf7d
16:42:14 <x1sc0> there might be some people using Telegram who have never used IRC, so they could find QA-telegram useful, but i'm just saying
16:43:21 <buovjaga> x1sc0: well if you have the time or are paid for it, then you can do it
16:43:28 <sophi> we had the same discussion at the beginning of the LO channel and now there are 300 people on it, maybe just give it a try and close it if it's not usefull
16:43:58 <buovjaga> I think it really needs some sort of paid dedicated social media & marketing pro to keep up with every single proprietary platform that people could be blabbing in
16:44:42 <x1sc0> yes, I think I will try it and see how it goes
16:45:03 <x1sc0> nothing much to loose here
16:45:20 <x1sc0> I just wanted to hear your opinion
16:45:22 <sophi> x1sc0: could be something for the BHS too?
16:45:26 <cloph> re chaos links: nothing different from irc then. If you try to use irc as your todo list and don't separate in dedicated channels/groups, then you're doomed either way :)
16:46:21 <x1sc0> sophi, yes, I'll create it before friday
16:46:59 <sophi> x1sc0: ok
16:47:10 <x1sc0> ok, time is over
16:47:26 <x1sc0> thank you all for attending the meeting
16:47:42 <x1sc0> #endmeeting