17:30:20 <x1sc0> #startmeeting
17:30:20 <IZBot> Meeting started Wed Oct 26 17:30:20 2016 UTC.  The chair is x1sc0. Plugin info at http://wiki.debian.org/MeetBot.
17:30:20 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:30:31 <x1sc0> hello *
17:30:40 <x1sc0> so let's start with the QA meeting
17:30:53 <x1sc0> which is meant to last for an hour
17:31:00 <x1sc0> anybody around?
17:31:14 <bearon> yup
17:31:33 <x1sc0> great
17:31:44 <x1sc0> let's wait a couple a minutes
17:31:47 <buovjaga> yeah
17:32:10 <cloph> #topic rollcall
17:32:24 * cloph is no chair, so the bot ignores me :-)
17:33:05 <x1sc0> #topic rollcall
17:33:46 <buovjaga> rollin'
17:33:49 <x1sc0> looks like sophi isn't around
17:34:06 <x1sc0> she was in the last two though
17:35:06 <bearon> i assume this one is too late for her
17:35:07 <x1sc0> ok, let's start
17:35:22 <x1sc0> #topic how to handle bugs that might belong to an external library
17:35:36 <x1sc0> bearon, let's start with the topic you mentioned before
17:35:42 <bearon> ok, great
17:36:08 <x1sc0> do you have an example to illustrate it?
17:36:16 <x1sc0> a bug
17:36:50 <bearon> hm, i don't have the bug number, not so long ago there was a PDF bug with password
17:37:32 <buovjaga> bearon: this? tdf#101270
17:37:33 <bearon> or there was no password, can't remember... anyway, the text after opening referred to password problems
17:37:34 <IZBot> LibreOffice-filters and storage normal/medium NEW Error opening a password encrypted PDF https://bugs.documentfoundation.org/show_bug.cgi?id=101270
17:38:15 <x1sc0> CorNouws, welcome to the QA meeting ;-)
17:38:25 <bearon> yeah, i think so
17:38:53 <buovjaga> bearon: vort can analyze PDF issues like that (which is Poppler, which is us)
17:39:07 <buovjaga> it might be worth a shot to CC him
17:39:13 <CorNouws> x1sc0: eh.. preparing for MC meeting, sorry
17:39:36 <x1sc0> CorNouws, no problem, enjoy
17:39:52 <x1sc0> buovjaga, but bearon means in general I think
17:40:00 <bearon> buovjaga: who's vort, and how come poppler is us?
17:40:09 <x1sc0> not only poppler
17:40:24 <bearon> buovjaga: oh you meant which of the two cases
17:40:48 <buovjaga> bearon: yes.. and vort is vort :) I have been known to give him money to fix PDF import issues
17:41:04 <buovjaga> type vort into the appropriate Bugzilla field and see
17:41:28 <bearon> x1sc0: yeah, it would be nice to have an established route to follow
17:41:41 <bearon> buovjaga: do we have to feed vort to have issues analyzed? :P
17:41:47 <x1sc0> bearon, anyway, at the time you encountered that bug, what did you do?
17:41:53 <buovjaga> I don't know, if QA can analyze such issues (regarding external libs) without code-reading skillz
17:42:01 <buovjaga> bearon: not necessarily
17:42:04 <bearon> x1sc0: basic triage, nothing else
17:42:25 <buovjaga> not long ago he gave me a Calc file analyzing PDF import bugs in our BZ
17:42:46 <x1sc0> bearon, buovjaga yes, I agree that from QA's point of view, it can be tough to know whether the problem is coming from an external library or libreoffice
17:43:45 <x1sc0> I would treat it as any other bug
17:44:02 <bearon> i'd like to ensure such bugs find their place as soon as possible, instead of sitting around until a dev takes a look
17:44:26 <bearon> well, technically a dev needs to take a look anyway
17:44:29 <x1sc0> and if you're sure the problem is in the external library, then open it in their bug tracker and put a link in ours
17:44:45 <bearon> but i mean, it's somewhat like needsDevAdvice
17:45:58 <x1sc0> bearon, then, all PDF related bugs should contain the keyword needsDevAdvice? I don't like it
17:46:10 <bearon> i didn't say that
17:46:37 <x1sc0> yes I know but how can we know it's ours or not?
17:46:42 <bearon> i said bugs should be passed to the place where they can be processed as soon as possible
17:46:55 <bearon> instead of sitting around
17:47:09 <bearon> yeah, well that's what we should think about
17:47:36 <bearon> like, get guidelines from devs who know these stuff
17:47:52 <buovjaga> bearon: we can always ping the suspected library devs :)
17:47:59 <bearon> eg. put a breakpoint here, see what goes in, what comes out, if it's X or Y then it's likely ours, otherwise not
17:48:47 <bearon> or what are the symptoms that raise the likelyhood the issue belongs to an external lib
17:49:23 <x1sc0> putting breakpoints here or there might be too much for a normal QA contributor
17:49:47 <bearon> it doesn't have to be for a regular QA contributor
17:50:02 <bearon> if some people in the QA team can do it, that's already fine
17:50:03 <bearon> i can do it
17:50:22 <x1sc0> problably I could do it as well
17:50:30 <buovjaga> supernatural QA contributor required :)
17:51:00 <x1sc0> but as this is the QA meeting, we need to think in general
17:51:16 <x1sc0> not about a guideline 2 or 3 might follow
17:51:20 <x1sc0> just my 2 cents
17:51:30 <buovjaga> can we think of a general solution, I think it would be quite case-by-case..
17:51:44 <buovjaga> debugging various different libs etc.
17:52:25 <x1sc0> besides, which might be the number of bugs that fall into this category?
17:52:42 <bearon> yes, somewhat case-by-case
17:53:30 <bearon> x1sc0: what do you mean?
17:54:19 <x1sc0> bearon, how many bugs might be caused by external libs?
17:54:26 <bearon> i have no idea
17:54:37 <x1sc0> yes, me neither
17:54:39 <bearon> i don't even know which libraries this is worth it for, PDF handling seems to be a good candidate
17:55:14 <bearon> anyway, we can move on now, i just wanted to mention this question
17:55:30 <bearon> maybe i'll try to get more info on PDF stuff
17:55:39 <bearon> and we don't need a general plan
17:56:03 <x1sc0> but my point is, is it worth to create a guideline for this kind of bugs to be used by QA stuff? My answer would be not. Another thing is that you do it because of your personal interest, which is great and I encourage you to do
17:56:51 <x1sc0> yes, probably if we have a better overview of the libs and bugs we can discuss it more in detail
17:57:25 <bearon> i think if bugs sit in our BZ instead of their respective place , it's a waste of time
17:57:54 <bearon> and if something can be identified easily, it's worth to pursue
17:58:11 <bearon> but as i said, i don't know any particular details myself
17:58:28 <x1sc0> the point is, is it easy to point breakpoints here and there and understand what's going in on and so?
17:59:08 <x1sc0> I add an action, and if you feel like doing it, you can get more info
17:59:17 <bearon> ok, cool
17:59:27 <x1sc0> #action bearon might try to get more info
17:59:41 <x1sc0> ok, so let's move on
17:59:51 <x1sc0> I have one topic I'd like to discuss too
18:00:09 <x1sc0> #topic old unconfirmed bugs
18:00:35 <x1sc0> I was checking the list of unconfirmed bug and the oldest one is from 2015-02-27
18:00:54 <x1sc0> #link https://bugs.documentfoundation.org/show_bug.cgi?id=89491
18:00:57 <IZBot> bug 89491: LibreOffice-Writer normal/medium UNCONFIRMED Font adornments ("style") get lost when saving as Word DOC
18:01:38 <x1sc0> should we, at some point, move it to another status or they should remain unconfirmed eternally ?
18:02:00 <buovjaga> that one is about a commercial font
18:02:09 <buovjaga> I think eternal unconfirmed is fine
18:02:18 <buovjaga> 2015 is not very eternal yet
18:02:56 <buovjaga> however, needsDevAdvice might be good at least
18:03:00 <x1sc0> 83 untouched for a year
18:03:14 <x1sc0> #link https://bugs.documentfoundation.org/buglist.cgi?bug_status=UNCONFIRMED&f1=days_elapsed&list_id=644307&o1=greaterthaneq&query_format=advanced&v1=365
18:04:11 <x1sc0> I wouldn't rely too much on needsDevAdvice though
18:04:23 <buovjaga> that is the next problem :P
18:04:30 <x1sc0> yup
18:04:38 <buovjaga> how to force devs to give advice
18:05:28 <x1sc0> the eternal unanswered question
18:06:19 <buovjaga> x1sc0: if we focus on lowering the number of unconfirmeds, then we will at some point have more time to think about the tough ones
18:06:32 <buovjaga> so I don't think we need to hurry
18:06:51 <buovjaga> the situation is under control
18:06:59 <x1sc0> buovjaga, I'm not really thinking about lowering it
18:07:16 <x1sc0> just thinking if it would be worth it to ping those bugs
18:07:24 <x1sc0> let's say, older than a year for instance
18:07:42 <x1sc0> and ask the reporter to check again with a newer version
18:07:59 <x1sc0> maybe, the bug is magically gone
18:08:12 <buovjaga> might be better to do case-by-case and not automatically.. otherwise some might get pissed off
18:09:13 <x1sc0> the reporter shouldn't be the same in most of them
18:09:34 <x1sc0> and if he/she is, then it's something to worry about :D
18:10:29 <buovjaga> x1sc0: I mean, it might be a Base bug, for example
18:10:43 <buovjaga> and there is so little movement that we can be quite sure the bug didn't get magically fixed
18:11:21 <x1sc0> personally I'd go for an automatic ping to older than a year as we do with untouched bug, the annoyance is the same
18:11:55 <x1sc0> buovjaga, ok, we can exclude those for instance
18:11:59 <bearon> can we think about asking questions in those bugs, then they can legitimately go to NEEDINFO?
18:12:19 <buovjaga> x1sc0: yeah there was talk about excluding Base as Alex got upset once
18:12:49 <x1sc0> #idea send automatic ping to unconfirmed bugs older than a year
18:12:57 <x1sc0> #idea <bearon> can we think about asking questions in those bugs, then they can legitimately go to NEEDINFO?
18:13:11 <buovjaga> bearon: sure :) that was kind of what I was chasing with my thought about lowering unconfirmed count until we have time to think more deeply about the hard ones
18:13:47 <buovjaga> I will set needsDevAdvice to 89491 in any case
18:14:20 <x1sc0> bearon, so which kind of question should we ask?
18:14:40 <bearon> what we usually do? :)
18:14:49 <bearon> it entirely depends on the bug report...
18:15:50 <x1sc0> ok, but we mostly do that with the new ones
18:16:03 <x1sc0> I wouldn't like to do that with the old ones
18:16:28 <x1sc0> it's like, my bug has been unconfirmed for a year, now you ask me something and put it in NEEDINFO
18:16:29 <bearon> buovjaga: i wonder if unified font rendering helps with that issue
18:16:39 <buovjaga> bearon: ah, good point :)
18:16:40 <x1sc0> I don't know, I don't see it completely right
18:17:01 <bearon> x1sc0: the question should be meaningful of course
18:17:03 <buovjaga> bearon: but it's about .DOC
18:17:44 <buovjaga> x1sc0: well, we do it with oldies, if there is a legitimate question.. and yes, even "plz test with newer version" sometimes
18:17:55 <bearon> x1sc0: and i don't see how an automatic ping would be better
18:18:20 <bearon> like: you don't do anything about it, but want me to check it again to see if the bug is magically gone?
18:18:36 <x1sc0> bearon, yep, you're right
18:19:37 <bearon> i think if we actually give the issue a bit of thought, and give a reasonable explanation on the action, people don't mind
18:19:47 <jphilipz> x1sc0: so with buovjaga comments fixed, is he first or second now?
18:20:04 <x1sc0> there might be some where the bug is gone, installing a new version cleans the profile or so, but maybe it isn't worth it to ping all of them
18:20:05 <jphilipz> dave_largo: pong
18:21:48 <x1sc0> so conclusion is we keep doing things as we have done so far
18:22:31 <bearon> buovjaga: btw, i wonder if we could get special free licenses for commercial fonts from their respective distributors for testing/bugfixing purposes
18:22:57 <x1sc0> #action no action
18:23:15 <x1sc0> so anything else do you want to talk about?
18:23:24 <x1sc0> we still have 7 minutes
18:23:31 <x1sc0> otherwise, we can end the meeting
18:23:32 <bearon> x1sc0: we could give more attention to old bugs
18:23:49 <bearon> *old unconfirmed bugs
18:23:57 <buovjaga> bearon: anything is possible, but I doubt it.. maybe other orgs have experience
18:24:03 <bearon> have a query available
18:24:11 <bearon> follow the numbers
18:24:11 <x1sc0> #action give more love to old unconfirmed bugs
18:24:46 <bearon> buovjaga: i'm kind of curious, it's in their interest as well
18:24:52 <x1sc0> ok guys, so thank you for attending the meeting
18:24:57 <x1sc0> #endmeeting