16:00:59 <x1sc0> #startmeeting
16:00:59 <IZBot> Meeting started Tue Oct 11 16:00:59 2016 UTC.  The chair is x1sc0. Plugin info at http://wiki.debian.org/MeetBot.
16:00:59 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:29 <x1sc0> hi everyone, so let's start the meeting
16:01:54 <bearon> hey
16:02:20 <x1sc0> first thing I wanted to say is thank you to everyone confirming bugs this week
16:02:38 <buovjaga> no problem, man
16:03:21 <x1sc0> #info unconfirmed bugs have gone down from 702 ( Thursday 6th ) to 620 ( today ). So big thank you to everyone
16:04:23 <x1sc0> then, there's a couple of list I would like to share in case anybody wants to take a look at them
16:04:43 <x1sc0> but first, I would like to ask if anybody has any topic to discuss about
16:04:57 <x1sc0> later on, I'd like to talk about the bug hunting session too
16:05:40 <sophi> x1sc0: ok
16:06:23 <x1sc0> any other topic you would like to discuss later on?
16:06:37 <x1sc0> I can write it down and we can discuss it later
16:07:08 <bearon> i'd like to bring up QA responsibility over non-LO components
16:07:24 <bearon> just so we're on the same page
16:07:33 <x1sc0> ok
16:07:47 <x1sc0> #info Bearon: i'd like to bring up QA responsibility over non-LO components
16:08:03 <x1sc0> anything else?
16:09:06 <x1sc0> well, so let's cover the bug hunting session
16:09:16 <x1sc0> #topic Bug Hunting Session
16:09:46 <x1sc0> #link https://wiki.documentfoundation.org/QA/BugHuntingSession/5.3.0Alpha
16:10:27 <x1sc0> #info: on Friday October 21th
16:10:58 <x1sc0> sophi, should we put a banner in the main bugzilla page?
16:11:31 <sophi> x1sc0: yes, we usually do it
16:11:39 <x1sc0> anybody has done that before? I don't know how to it?
16:11:59 <buovjaga> yep, tagezi was asking about the banner
16:12:41 <x1sc0> I can do it, but I'd like to know if someone has done it before
16:12:55 <x1sc0> or changing anything in the main page
16:13:04 <sophi> x1sc0: not me
16:13:17 <x1sc0> who did it in the past?
16:13:19 <x1sc0> robinson?
16:13:23 <sophi> x1sc0: yes
16:13:30 <x1sc0> ok
16:13:57 <x1sc0> #action ask Robinson how to put the banner in the main page and do it
16:14:44 <cloph> #info there's announcehtml field in general settings
16:15:26 <x1sc0> #action talk with Michael to stick it on the top in reddit until it's over
16:16:13 <x1sc0> cloph, then it's put in the main page?
16:16:37 <cloph> all bugzilla pages
16:16:52 <x1sc0> ok, much better then
16:17:35 <x1sc0> sophi, do you normally announce it somewhere else?
16:17:58 <sophi> x1sc0: on the blog, relayed on twitter, facebook, G+
16:18:30 <sophi> x1sc0: and a banner on the site if you give a logo with the right size to cloph ;)
16:18:32 <buovjaga> in the hallway of your apartment building .. :P
16:19:03 <sophi> buovjaga: good idea :)
16:19:16 <x1sc0> hehehe
16:19:29 <buovjaga> but then residents could panic about cockroaches
16:19:36 <x1sc0> it's already on twitter
16:19:46 <x1sc0> #link https://twitter.com/libreoffice/status/784334147120529412?lang=es
16:20:00 <sophi> x1sc0: yes, I think Italo has published the news already
16:20:09 <cloph> right size (can also be multiple, but if different dimensions than the current one, I'd like to have the dimensions at least two days in advance :-)
16:20:56 <cloph> #info banner dimensions for birthday one were 800x200 and 400x100
16:21:29 <x1sc0> ok
16:21:37 <x1sc0> #action provide the banners to clop
16:22:27 <x1sc0> sophi, anything else you would like to mention wrt the BHS?
16:22:46 <x1sc0> #info so far we're 3 mentors
16:23:14 <sophi> x1sc0: no, nothing for the moment
16:23:23 <cloph> #info oldbanner was 378x133 http://www.libreoffice.org/themes/libreofficenew/img/bughunt4301.png
16:23:51 <sophi> cloph: it was mine with the wrong dimension
16:23:54 <cloph> (or at least somthing like that -that one is an old one for sure, maybe the 5.x one were different
16:24:15 <x1sc0> sophi, what's the difference between a dedicated session an the rest of the day?
16:24:53 <x1sc0> does it follow any schedule?
16:25:00 <sophi> x1sc0: a session where we focus on one module or one functionality, etc.
16:25:30 <sophi> x1sc0: it should but we have quite never run them
16:25:31 <cloph> have a specific goal instead of "just look at issues"
16:25:49 <x1sc0> so we focus for 2 hours on that, or we change between modules?
16:25:52 <cloph> ideally something that can be measured in one way of the other.
16:26:03 <sophi> x1sc0: also cloph has a script to call random bugs, that we run in the past
16:26:09 <x1sc0> let's say, writer, or is it to general?
16:26:23 <x1sc0> nice
16:26:25 <sophi> x1sc0: I think it's too general, functionalities are more fun
16:26:34 <x1sc0> #info  cloph has a script to call random bugs, that we run in the past
16:27:06 <cloph> !loadsession
16:27:06 <IZBot> loaded list with a total number of 600 issues
16:27:06 <cloph> (gets list of unconfirmed issues and puts it into IZBot's memory)
16:27:14 <cloph> !gr
16:27:14 <IZBot> LibreOffice-Writer normal/medium UNCONFIRMED PRINTING: problem with printing on sheets of other than A4 format https://bugs.documentfoundation.org/show_bug.cgi?id=81642
16:27:24 <cloph> → get a random one from that list.
16:27:57 <x1sc0> sophi, and eventually, are we going to use moztrap?
16:28:04 <cloph> #info use IZBot's "loadsession" command to init the list, and "gr" to get a random one
16:28:20 <x1sc0> cloph, thanks
16:28:30 <cloph> if you want a specific query, you need to let me know, then I can change it
16:28:45 <sophi> x1sc0: I'll set a run, not sure if somebody will use it, but let see
16:28:53 <x1sc0> ok
16:28:57 <IZBot> News from tdfnew: [Bug 103126] 100% usage when creating new document after sleep <https://bugs.documentfoundation.org/show_bug.cgi?id=103126> || [Bug 103127] Drag and Drop no longer works <https://bugs.documentfoundation.org/show_bug.cgi?id=103127>
16:29:11 <x1sc0> #action sophi: set up a moztrap run
16:30:22 <x1sc0> sophi, I remember reading a redmine ticket talking about how to improve BHSs' involvement
16:30:36 <sophi> x1sc0: I think we should revisit the manual test tool if we want to go on with manual tests, this session of MozTrap is really oudated, but let discuss this another day
16:30:55 <sophi> x1sc0: yes, there are several ideas on it
16:31:18 <x1sc0> sophi, ok, let's discuss it another day
16:31:28 <buovjaga> btw. Mozilla is dropping the use of MozTrap and could transfer the repo to TDF, if it is interested
16:31:29 <x1sc0> sophi, any idea we could apply this time?
16:32:04 <sophi> buovjaga: yes, but I don't have the answer yet
16:32:30 <sophi> x1sc0: the dedicated session is one of them
16:33:15 <sophi> x1sc0: Cloph's bot is another
16:33:18 <buovjaga> Mozilla now uses this commercial service http://www.gurock.com/testrail/pricing/
16:33:25 <x1sc0> #link https://redmine.documentfoundation.org/issues/1761
16:33:26 <IZBot> redmine: »improve Bug Hunting Sessions« in Release Engineering (Task for Sophie Gautier) [In Progress]
16:34:25 <x1sc0> Ok, I see that most of them are already in use
16:35:13 <sophi> x1sc0: yes, attracting more people is not easy...
16:36:03 <x1sc0> sophi, in the past, when you did it over the weekend
16:36:17 <x1sc0> which was the time with more people participating?
16:36:21 <x1sc0> or the day ?
16:36:35 <bearon> introducing some of the new features beforehand could be useful
16:36:52 <sophi> I'd say Friday, cloph do you agree?
16:37:12 <x1sc0> #idea <bearon> introducing some of the new features beforehand could be useful
16:37:20 <cloph> yes, Friday was best
16:37:28 <sophi> bearon: how do you see that?
16:38:16 <sophi> bearon: shall we do a short intro just before the session?
16:38:38 <bearon> maybe have a blog post up a week or so earlier
16:38:48 <bearon> to get people interested
16:40:29 <sophi> bearon: yes, good idea, something to try, we should discuss it with Mike when he is back from vacation
16:41:36 <x1sc0> normally that's something he does one the the final version is released
16:41:56 <x1sc0> in videos
16:42:04 <x1sc0> maybe he can write a short post for the BHS too
16:42:33 <x1sc0> well, we have 20 minutes left
16:42:41 <x1sc0> so I'd suggest to move to the next topic
16:42:47 <bearon> if i were a regular user, but generally curious about the software, seeing upcoming stuff might make me interested in trying them out
16:43:18 <bearon> even if i wouldn't come to test random bugs
16:44:00 <x1sc0> yeah, I think it's always better to tell them what to do rather than offering them random bugs
16:44:11 <x1sc0> something they can focus on
16:44:21 <sophi> yes
16:45:10 <x1sc0> #idea we can tell them to verify bug fixed in master ?
16:46:16 <x1sc0> well, let's move on
16:46:22 <x1sc0> #topic QA responsibility over non-LO components
16:46:48 <x1sc0> bearon, anything you want to say wrt this topic?
16:47:24 <bearon> yup
16:47:59 <bearon> so, there are the DLP projects that are part of LO as import/export filters
16:48:20 <bearon> but are also used in other programs, like Scribus
16:48:30 <x1sc0> yes
16:48:37 <bearon> i'd assume we're responsible for those
16:49:00 <x1sc0> well, they're under tdf umbrella
16:49:21 <buovjaga> usually the advice has been to leave them to the devs
16:49:47 <bearon> do devs know about that?
16:50:31 <x1sc0> I want to say that there're only 19 bugs in bugzilla
16:50:35 <x1sc0> #link https://bugs.documentfoundation.org/buglist.cgi?list_id=640587&product=Document%20Liberation%20Project&query_format=advanced
16:50:42 <sophi> bearon: I think dtarton check them no?
16:50:47 <x1sc0> under DLP
16:50:58 <sophi> s/dtarton/dtardon/
16:51:06 <x1sc0> should be really care about them?
16:51:31 <bearon> sophi: i saw UNCONFIRMED bugs untouched for a year
16:51:39 <bearon> there are really few bugs there indeed
16:51:56 <bearon> btw, x1sc0, that isn't the only project
16:52:43 <x1sc0> bearon, yes you're right
16:52:46 <bearon> most projects in the list are DLP ones
16:53:37 <bearon> anyway, it's not a workload, really, but i think we should regularly check them, especially since some of those were mistakenly categorized
16:54:10 <bearon> like, it was on DLP, but should've been on LibreOffice / Documentation
16:54:20 <x1sc0> ok
16:54:22 <x1sc0> good idea
16:54:25 <bearon> what's more relevant is Impress Remote
16:55:18 <bearon> are those checked regularly?
16:56:12 <x1sc0> no idea
16:56:43 <x1sc0> #action Check non-LO components -> https://bugs.documentfoundation.org/buglist.cgi?list_id=640587&product=Document%20Liberation%20Project&query_format=advanced
16:57:20 <x1sc0> well, we still have 3 minutes left
16:58:07 <x1sc0> I'd like to propose 3 lists in case someone wants to take a look
16:58:30 <x1sc0> #topic List of bugs
16:59:01 <x1sc0> #action Check bugs tagged with keyword 'possibleRegression' -> https://bugs.documentfoundation.org/buglist.cgi?keywords=possibleRegression%2C%20&keywords_type=allwords&list_id=640538&query_format=advanced&resolution=---
17:00:03 <x1sc0> #action Check reopened bugs and if the issue is still reproducible, move it to NEW, otherwise, create a follow-up bug -> https://bugs.documentfoundation.org/buglist.cgi?keywords=needUITest%2C%20&keywords_type=allwords&list_id=640539&query_format=advanced&resolution=---
17:00:47 <x1sc0> #action Check possible fixed bugs, and if they're really fix, close them -> https://bugs.documentfoundation.org/buglist.cgi?chfieldto=2016-09-16&f1=days_elapsed&list_id=640552&longdesc=If%20so%2C%20could%20you%20please%20close%20it%20as%20RESOLVED%20FIXED%3F&longdesc_type=casesubstring&o1=greaterthan&query_format=advanced&resolution=---
17:01:18 <x1sc0> well, so thank you for attending the QA meeting
17:01:35 <x1sc0> I guess this one went much better that the previous one :D
17:01:57 <x1sc0> I'll send the meeting minutes to the mailling list
17:02:00 <sophi> x1sc0: yes, great meetin, thanks :)
17:02:09 <x1sc0> #endmeeting