13:14:47 <colonelqubit> #startmeeting
13:14:47 <IZBot> Meeting started Wed Jan 27 13:14:47 2016 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
13:14:47 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:14:55 <colonelqubit> Hello, hello
13:15:07 <colonelqubit> UNCONFIRMED bugs are down to 606
13:16:11 <colonelqubit> I've heard from just a couple of people re: bugs that should be escalated to the ESC
13:16:52 <colonelqubit> And I got some good feedback and made some nice contacts (especially in education) at the SCALE conference in California this past week
13:17:46 <sophi> colonelqubit: great for your contacts :) I'm not sure there is an ESC tomorrow, as everybody will be at the hackfest
13:17:59 <colonelqubit> sophi: ah yes, that makes sense
13:18:35 <colonelqubit> sophi: if not, that's fine -- we can punt those bugs until next week
13:19:18 <sophi> ok
13:20:06 <colonelqubit> sophi: I've noted a number of persisting mail merge bugs. I don't use that particular feature extensively, but are you seeing any issues in our latest builds?
13:21:46 <sophi> colonelqubit: didn't followed that topic, sorry, but I've not seen much feedback on the lists about it
13:22:12 <DennisRoczek> beluga_away: mentioned a bug yesterday (actually a duplicate of one of jmux reported bugs)
13:22:27 <colonelqubit> DennisRoczek: something particularly bad?
13:23:01 <IZBot> News from tdfnew: [Bug 97393] English Dictionaries update - 2016 <https://bugs.documentfoundation.org/show_bug.cgi?id=97393>
13:23:52 <colonelqubit> sophi: Here's the link: http://bit.ly/1POJrmp
13:24:09 <colonelqubit> 7 open (6 in NEW) mail merge regressions
13:24:18 <DennisRoczek> a crash, lemme check my logs
13:24:25 * colonelqubit nods
13:25:09 <DennisRoczek> #97287 and tdf#90185
13:25:11 <IZBot> LibreOffice-Writer major/high NEW Writer crashes just as Mailmerge begins to send the first email. https://bugs.documentfoundation.org/show_bug.cgi?id=90185
13:26:22 <colonelqubit> DennisRoczek: 90185 is on that list; 97287 is not
13:27:48 <DennisRoczek> you're welcome
13:27:53 <colonelqubit> :-)
13:28:31 <sophi> colonelqubit: the jmux one should be the last of your list #96914
13:28:33 <IZBot> LibreOffice-Writer normal/medium UNCONFIRMED MAILMERGE crash on first run after DB registration https://bugs.documentfoundation.org/show_bug.cgi?id=96914
13:28:55 <colonelqubit> DennisRoczek: looks like beluga has at least mentioned 97287 on 90185; if it's confirmed and not a dupe, I'll make sure to bring it up to ESC
13:29:51 * colonelqubit really wishes we could avoid more regressions through unit tests
13:30:31 <colonelqubit> let's take a look at the pending items
13:30:34 <colonelqubit> #topic Pending Items
13:30:34 <DennisRoczek> colonelqubit: write more unit tests :-D
13:30:40 <DennisRoczek> oh some for you ^^
13:31:47 <colonelqubit> DennisRoczek: (re: Unit Tests) -- yeah, at some point it probably makes a lot of sense to try to stop the bleeding from starting (via tests) than to just sop up the lost blood (by triaging bugs)
13:32:04 <DennisRoczek> \offtopic /me is doing a great comparison on Calc/Apple's iWork Numbers function names (see https://wiki.documentfoundation.org/Functions_comparison_of_LibreOffice_Calc_and_Numbers )
13:33:12 <DennisRoczek> colonelqubit: well as some devs say: every bug / regression fix should include a tests for not introducing yet another the same test
13:33:13 <colonelqubit> DennisRoczek: is that related to your work comparing ODF software?
13:33:18 <jmux> sophi, DennisRoczek: my bug is not directly mail merge related. There is already a fix for it in private/jmux/mm-cleanup
13:33:27 <DennisRoczek> and depending on our frameworks, it shouldn't be so hard to get more tests in
13:33:41 <DennisRoczek> (btw: do we take part of google code-in?)
13:33:42 <sophi> jmux: ok, thanks
13:33:57 <colonelqubit> jmux: great to hear!
13:34:10 <DennisRoczek> colonelqubit: totally unrelated. but I need to check iWorks if it finally is able to export/import ODF stuff
13:34:38 <colonelqubit> DennisRoczek: I'd be very interested to hear your results
13:35:04 <colonelqubit> obviously understanding what's out there in the ODF ecosystem is important
13:35:06 <DennisRoczek> but it was fun (and will be fun for the rest) to check which spreadsheet software is isuperior in which area
13:35:09 <jmux> And while testing stuff, I even found more bugs. I actually stopped opening new reports and just continued fixing the stuff I found. The patchset is already 25 patches long
13:35:09 <DennisRoczek> we won :-p
13:35:38 <colonelqubit> if iWorks is struggling (or disagreeing) about how to handle ODF, then that's something that we should perhaps investigate
13:36:15 <DennisRoczek> colonelqubit: scroll to the bottom of the link i gave: simple calculation + bug ticket in the introduction for dtardon ^^
13:36:28 <DennisRoczek> colonelqubit: well apple is crap
13:36:32 <DennisRoczek> no odf :-(
13:37:32 <DennisRoczek> well at least in iWork. in textedit and finder there is odf support -.-
13:38:03 <colonelqubit> DennisRoczek: a few years back when I asked people on the Apple forums whether Pages supported ODF and open standards, I got rather bellicose "The file format is XML! It's open -- just read it yourself" responses
13:38:24 <DennisRoczek> colonelqubit: that WAS true. now it is binary
13:38:46 <colonelqubit> DennisRoczek: the fact that the "premier"/most office-suite-like stuff is the one that *doesn't* support ODF is absolutely hilarious
13:39:15 <colonelqubit> I will definitely make sure to let everyone know about that the next time I give a talk
13:40:03 <colonelqubit> DennisRoczek: we should wrap up the digression (although we are riffing on one of your pending items ;-), but is the binary format documented, or just some internal, proprietary thing?
13:41:15 <DennisRoczek> colonelqubit: give me until tomorrow night. I do want to do some further tests regarding OS X
13:41:21 <DennisRoczek> then I give you material to fire
13:41:30 * colonelqubit nods
13:42:15 <colonelqubit> thanks!
13:42:52 <colonelqubit> DennisRoczek: so to the topic at hand: Do you think that 'Comparison of ODF Software' should live under ODF/ somewhere?
13:43:54 <DennisRoczek> well we have multiple comparison pages. no. i do not think so. moreover we have [[Category:ODF]] and it is linked on ODF under see also, too
13:43:55 <sophi> colonelqubit: it's more 'coverage of ODF implementation' no?
13:44:03 <DennisRoczek> sophi: not at this stage
13:44:23 <DennisRoczek> for that you best talk to the devs of the ODF test suites
13:44:35 <DennisRoczek> (the Netherland guys, I always miss the name(s))
13:44:42 <DennisRoczek> or was it dutch?
13:45:01 <sophi> DennisRoczek: Jos
13:45:39 <colonelqubit> DennisRoczek: sure, and for the comparison pages, maybe they could all live under some hierarchy?  (if they fit together at all...)
13:46:38 <DennisRoczek> thx
13:46:54 <colonelqubit> It's like with the BugHunting Sessions -- I was thinking that instead of having each one be a top-level page (BugHunting_Session_5.1.0.0), we could have (BugHunting_Sessions/5.1.0.0)
13:47:17 <DennisRoczek> colonelqubit: how do you want to map them together? Comparison/LibreOffice_vs.MSO?
13:47:30 <DennisRoczek> colonelqubit: how do you want to map them together? Comparison/ODF_software?
13:47:37 <sophi> colonelqubit: yes, you're right, that's more logical and easier to find
13:48:00 <DennisRoczek> Marketing/comparison/OPC_software ?
13:48:04 <DennisRoczek> *ODF
13:48:45 <colonelqubit> DennisRoczek: hmm...they seem somewhat disparate
13:49:11 <colonelqubit> DennisRoczek: if some hierarchy doesn't lend itself well, perhaps a sidebar or horizontal bar, like Wikipedia uses for a number of articles in a category?
13:50:03 <colonelqubit> DennisRoczek: Most of these comparison pages are pretty accessible by the userbase, I believe?
13:50:04 <DennisRoczek> it's all possible. simply say (at best with an en.wikipedia example) what you want
13:50:18 <DennisRoczek> hopefully they are
13:51:01 <colonelqubit> DennisRoczek: My biggest concern is that we'll have pages with good content that don't get used or viewed much, because there's no strong path to find them
13:51:31 * DennisRoczek hopes on google :-p
13:52:18 <colonelqubit> Let's see -- I haven't had a chance to look at that BHS stuff yet. Thanks for that, Dennis!
13:52:31 <DennisRoczek> colonelqubit: well my function comparison was mostly because I do will implement the Numbers function mapping the week after the next as it seems (just got the framework from dtardon http://cgit.freedesktop.org/libreoffice/libetonyek/commit/src?id=e54e5817f7d56a5fac0e0dac2f1cfd1255355e44
13:52:32 <IZBot> libetonyek - allow to map function names
13:52:33 <DennisRoczek> ^^
13:53:01 <DennisRoczek> brb
13:53:04 <IZBot> News from tdfnew: [Bug 97394] Format a sheet section CLEAR Function <https://bugs.documentfoundation.org/show_bug.cgi?id=97394>
13:56:42 <colonelqubit> DennisRoczek: I'm taking at look at the EasyHacks page as well --> you mentioned having trouble there previously?
13:59:48 <colonelqubit> DennisRoczek: yeah, looks like the Keywords piece is what's not working. IIRC I also ran into some caching issues with that plugin previously
14:00:41 <colonelqubit> #topic New Items
14:00:59 <colonelqubit> sophi: You mentioned investigating a new time for the QA meeting
14:01:38 <colonelqubit> (it's a perennial problem)
14:01:46 <sophi> colonelqubit: yes, I think it's too early and maybe we should find a later time in the day to gather more team members
14:01:54 * colonelqubit nods
14:02:48 <colonelqubit> I'll send out an email with a link to one of those meeting-time-pickers
14:02:55 <colonelqubit> sophi: How late is too late for Europe?
14:04:24 <sophi> I think it would be past 9 PM UTC
14:04:31 * colonelqubit nods
14:05:35 <DennisRoczek> re, colonelqubit: well I have no clue how the plugin needs the keywords provided (in contrast to the whiteboads keywords)
14:05:54 <colonelqubit> I'd suggest that we keep it to a weekday, as well
14:05:56 <DennisRoczek> dunno about the caching. it simply doesn't work
14:06:22 <colonelqubit> DennisRoczek: I'll dig into the code
14:06:25 <DennisRoczek> colonelqubit: weekday is bad for me.
14:06:35 <sophi> colonelqubit: yes I agree
14:06:41 <DennisRoczek> 19 utc+1 infra call and de-call sometimes
14:06:55 <DennisRoczek> at 20:00utc+1 I'm away (always)
14:06:57 <colonelqubit> DennisRoczek: did you say you have a test VM for that wiki?
14:07:33 <DennisRoczek> we have a testwiki, but not configured. no db etc. alex is doing it at fosdem so i can finally test the upgrade (this is important)
14:08:06 <colonelqubit> DennisRoczek: ah ok, that might make it faster to identify and fix
14:08:59 <colonelqubit> DennisRoczek: if we don't do weekend, what day(s) of the week would work well for you?
14:09:30 <DennisRoczek> well for what?
14:09:38 <DennisRoczek> oh i see
14:09:52 <DennisRoczek> friday is bad. all other days should work mostly
14:10:10 <DennisRoczek> (so mo, th, tu,)
14:10:11 <sophi> colonelqubit: but it's important that the time fits for you too
14:10:21 <colonelqubit> sophi: oh, definitely
14:11:07 <colonelqubit> :-)
14:12:44 <colonelqubit> Okay, I've got some good rough parameters for meeting times. We'll look Mon-Thu from say 14:00 UTC - 20:00 UTC
14:13:14 <colonelqubit> And I'll block-off TDF and ESC call times
14:13:44 <colonelqubit> #action Set up doodle for new QA Meeting time
14:13:51 <sophi> colonelqubit: I've no meetings on Tuesday, it's the only day of the week, and Wednesday is impossible
14:14:20 <DennisRoczek> colonelqubit: how about the pending actions regarding BHS? have you all information you need?
14:14:21 <colonelqubit> sophi: so you'd prefer Tues, or would like to keep it clear?
14:14:45 <sophi> colonelqubit: Tues is ok, no problem, it's fully available :)
14:14:54 * colonelqubit nods
14:15:05 <colonelqubit> DennisRoczek: I think I have info -- I'll email you if I have additional q's
14:16:51 <colonelqubit> Looks like our time is about up.
14:17:00 <colonelqubit> Any other New Items?
14:18:47 <colonelqubit> Okay, that wraps it up!
14:20:04 <colonelqubit> Thanks for attending. Our next meeting will be tentatively... February 10th, unless we change it based on that Doodle
14:20:29 <colonelqubit> hopefully we get a good number of responses!
14:20:31 <colonelqubit> #endmeeting