13:08:29 <colonelqubit> #startmeeting
13:08:29 <IZBot> Meeting started Wed Dec  9 13:08:29 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
13:08:29 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:08:38 <colonelqubit> Ok, who's here?
13:09:02 <colonelqubit> beluga_, ahoneybun: poke
13:09:16 <colonelqubit> ertai_NL: hey! you around?
13:09:53 * colonelqubit wonders if mjayfrancis is here as well...
13:10:17 * ahoneybun is about to leave in 5 mins or so
13:10:22 <colonelqubit> UNCONFIRMED count is at 551
13:10:46 * mjayfrancis makes zombie noises, waves arms in an undead manner
13:10:56 <colonelqubit> ahoneybun: Before you leave, any bugs or notes for the ESC?
13:11:36 <ahoneybun> ESC?
13:11:52 <beluga_> engineering steering comittee
13:12:46 <ahoneybun> I've have not gotten around to test the 5.1 beta
13:13:05 * ahoneybun needs to start leaving note
13:13:08 <ahoneybun> *s
13:15:32 <colonelqubit> mjayfrancis: good to hear that there's some movement...
13:15:32 <colonelqubit> Hmmm, it's a tough crowd out there this morning ;-)
13:15:33 <colonelqubit> #topic Completed Items
13:15:34 <colonelqubit> I don't see any completed items from this week
13:15:42 * colonelqubit nudges IZBot
13:16:30 <colonelqubit> Looks like IZbot is also quiet this morning :P
13:16:40 <colonelqubit> #topic Pending Items
13:17:13 <colonelqubit> ahoneybun: Sorry about that, my client appears to be lagging here
13:17:23 <beluga_> colonelqubit: was the mime type thing pending? well, let's make a note that the cause seems to be clear now https://bugzilla-test.documentfoundation.org/show_bug.cgi?id=89096
13:17:49 <colonelqubit> ahoneybun: If you do get a chance to test 5.1 builds, that's always helpful
13:18:04 <colonelqubit> beluga_: I think the MIME type was still pending, and thank you for testing
13:18:42 <colonelqubit> beluga_: For the record here, want to give a quick recap?
13:19:41 <beluga_> yeah so I use Firefox and noticed that my pdf uploads to BZ got detected wrong. it turns out there is a known bug for that (upload mime types in general being mixed up) https://bugzilla.mozilla.org/show_bug.cgi?id=373621
13:20:01 <colonelqubit> beluga_: and no fix currently planned for FF, right?
13:20:39 <beluga_> unfortunately no
13:20:55 <colonelqubit> yeah, not the best situation
13:21:18 <colonelqubit> I looked at the upstream issue, and the work-arounds are pretty hackish
13:22:03 <colonelqubit> beluga_: perhaps we should just make a note on the TDF wiki about the MIME-type issues and then consider this ACTION item done?
13:22:12 <beluga_> colonelqubit: yes
13:22:22 <DennisRoczek|afk> oh meeting without any ping?
13:22:56 <colonelqubit> DennisRoczek: heya, sorry -- either my IRC client or the server is acting a bit laggy for me
13:23:09 * colonelqubit has been fighting with it since this morning
13:23:22 <colonelqubit> DennisRoczek: glad to see you're here :-)
13:23:25 <DennisRoczek> no completed AI on my side. rather busy in rl work
13:23:39 <colonelqubit> beluga_: https://wiki.documentfoundation.org/index.php?title=MIME-Type&redirect=no  that redirects to perhaps the right place
13:23:40 <DennisRoczek> except the redmine ticket you get in CC
13:24:27 <colonelqubit> DennisRoczek: okay, thanks!
13:24:59 <colonelqubit> beluga_: Could you update this wiki page with the latest info about FF? https://wiki.documentfoundation.org/QA/Bugzilla/Attachments
13:25:14 <beluga_> yeah
13:25:25 <beluga_> I'll do it live
13:25:35 * colonelqubit laughs
13:26:11 <colonelqubit> Okay, let's mark the sub-ACTION items related to this task SUPERSEDED
13:26:30 <colonelqubit> If you get the update to the wiki done by the end of the meeting, then we can mark the main task DONE as well
13:26:48 * colonelqubit looks at other pending items
13:27:11 <colonelqubit> mjayfrancis: how's zombiefrancis doing?
13:27:13 <iplaw67> Afternoon all
13:27:23 <iplaw67> for once, I actually managed to make it ;-)
13:27:32 <colonelqubit> iplaw67: heya!
13:27:58 <colonelqubit> iplaw67: apologies in advance, my client or connection is sometimes lagging for a bit
13:28:48 <iplaw67> colonelqubit: no worries, I might have to leave in a hurry anyway, expecting incoming work order any time now from a colleague
13:28:59 <colonelqubit> I don't see jphilipz, so no updates on that front
13:29:17 <colonelqubit> beluga_: any update from medfly about BSDs?
13:29:35 <colonelqubit> (or other contribs)
13:29:46 <mjayfrancis> colonelqubit: Working on a new and exciting plan for re-entry into Cambridge
13:29:57 <colonelqubit> mjayfrancis: from..outer space?
13:30:13 <mjayfrancis> Looking out my window, I could well believe so
13:30:19 * colonelqubit chuckles
13:30:23 <beluga_> colonelqubit: yes, I got a reply from the NetBSD packager Ryo Onodera
13:30:29 <beluga_> bapt: still working?
13:31:00 <colonelqubit> mjayfrancis: I still have an item here from our discussions about diff'ing user profiles
13:31:14 <colonelqubit> mjayfrancis: did you ever file an enhancement bug about the topic?
13:31:50 <bapt> beluga_: I'm here but I have meeting in 10minutes
13:31:52 <iplaw67> fyi, I'm just installing Office 2016 for Mac on my Macbook, so will be able to test compatibility bugs, at least the ones involving round tripping via doc/docx etc - no ODF support on Mac tho
13:32:03 <bapt> beluga_: being in .fr this is the middle of the work day :)
13:32:23 <colonelqubit> iplaw67: in Office 2016? No ODF support?
13:32:46 <IZBot> News from tdfnew: [Bug 96357] Switching icon theme doesnt update toolbar or statusbar <https://bugs.documentfoundation.org/show_bug.cgi?id=96357>
13:33:00 <beluga_> ok, well bapt is from FreeBSD land and has worked on LibO packaging before.. now he is in contact with the current packager with the hope of upstreaming all build-related patches
13:33:15 <colonelqubit> cool
13:33:27 <bapt> I have a gerrit account
13:33:36 <bapt> ok I have to run I will backlog
13:33:42 <beluga_> colonelqubit: I added the note to the red text https://wiki.documentfoundation.org/QA/Bugzilla/Attachments#MIME_Type_Problems
13:33:47 <bapt> btw I already sent the needed stuff for licenses :)
13:33:49 <colonelqubit> So I have an ACTION item that was at least marked for medfly about getting docs for building on BSD
13:34:16 <colonelqubit> bapt, beluga_: How are our docs for building on BSD now? Improved, much?
13:34:35 <iplaw67> colonelqubit: not on Mac
13:34:57 <beluga_> colonelqubit: would want to focus on upstreaming patches in this first phase
13:35:07 <colonelqubit> iplaw67: ah, are we documenting the two together?
13:35:16 <colonelqubit> beluga_: yep, that's fair enough
13:35:16 <iplaw67> bapt: the last time I tried building OOo on my then FreeBSD installation, I filled the disk up and hosed it all :-)
13:35:29 <iplaw67> and that was the end of my FreeBSD adventure
13:35:31 <colonelqubit> beluga_: okay, I'll just leave that ACTION item in place for now, then
13:35:54 <beluga_> colonelqubit: Francois Tigeot added minimal instructions https://wiki.documentfoundation.org/index.php?title=Development%2FBuildingOnLinux&diff=119077&oldid=117492
13:36:11 <beluga_> I contacted him on Dragonfly BSD's IRC channel on EFNet
13:36:12 <iplaw67> colonelqubit: dunno, but I've seen the question come up at least twice on the French m-l
13:37:06 <colonelqubit> beluga_: Okay, so do we think the current BSD docs are sufficient, or should we punt for a week or two and see if/how much the docs improve?
13:37:22 <colonelqubit> iplaw67: ^^ (same q to you, too)
13:37:46 <beluga_> colonelqubit: medfly is not able to update the docs.. Ryo O. and other more experienced folks can do it
13:37:56 <beluga_> so let's cancel the item for now
13:38:00 <colonelqubit> beluga_: thanks for the update re: MIME types wiki page. I'll consider that family of ACTION items DONE for now
13:38:34 <colonelqubit> Okay, I'll mark the BSD docs stuff as 'Set Aside' for now and take it off the agenda
13:38:53 <iplaw67> colonelqubit: really couldn't answer the BSD question, been at least 6 years since I tried building anything that big on any flavour of BSD
13:38:54 <beluga_> yeah we need someone to assign to the item :)
13:39:17 <beluga_> iplaw67: don't worry, it is being taken care of :)
13:39:38 <beluga_> the BSD QA revolution is around the corner
13:40:32 * colonelqubit smiles
13:40:59 <iplaw67> beluga_: excellent :-)
13:41:00 <colonelqubit> Let's see...I talked with Italo about some recruiting ideas and notes for the BHS and future events. That's a bit longer-term strategy, though, so nothing beyond the BHS to report
13:41:23 <colonelqubit> Speaking of which, how many people here participated in the BugHunting Session?
13:41:57 <colonelqubit> beluga_: I know that you were around a bit
13:42:23 <iplaw67> not me, I was busy hunting bugs in my new house ;-)
13:42:25 <beluga_> several of the Turkish team were on IRC during BHS
13:42:41 <beluga_> compared to the last BHS, it was much livelier on IRC
13:42:58 <colonelqubit> I had a number of people from the US who expressed interest in participating on Sat or Sun, but I wasn't around to see if they actually showed up in the IRC channel
13:43:12 <beluga_> I did see new people, also on Monday
13:43:22 <colonelqubit> Ah, good!
13:43:28 <beluga_> and gave intro
13:43:43 <sophi> colonelqubit: do you have names? didn't see much more people than usual
13:44:01 <colonelqubit> sophi: did you see more people on Sat or on Sun?
13:44:19 <beluga_> jayad was here during the weekend.. JohnnyComeL8ly was on Mon
13:44:25 <sophi> colonelqubit: not so much, no
13:46:09 <colonelqubit> sophi: I'm not sure what nicks they might have on IRC. There were two people from the Portland, OR area. One's a programmer and one's a professor at the University here (he might be retired)
13:46:18 <sophi> colonelqubit: MozTrap tests has been completed at 3% :(
13:46:56 <colonelqubit> Names are Mike and Bart/Bartholomew
13:47:35 <beluga_> sophi: medfly has a group of local people who are interested in testing with MozTrap
13:47:42 <colonelqubit> sophi: yeah, 3% is a lot lower than I'd like to see after a BHS
13:48:13 <beluga_> I think the group will have a meeting today about improving Hebrew support in LibO and other software projects
13:48:47 <colonelqubit> So here's a question for everyone: Do you think that people are more likely/able to show up on a Weekend or a Weekday?
13:49:13 <DennisRoczek> colonelqubit: in my case it's always a matter of real life events
13:49:21 <colonelqubit> ah, fair enough
13:49:46 <colonelqubit> DennisRoczek: do you think that things are too open-ended for a BHS?
13:50:06 <sophi> that's why we do it between a week day and week end
13:50:48 <colonelqubit> sophi: oh, definitely -- I was just wondering if there was a period of time that was much preferred
13:51:13 <colonelqubit> DennisRoczek: maybe if we asked people to come help out for a more set period of time (e.g. 1hr or 2hr), then they'd feel more motivated to schedule-in the time?
13:51:14 <iplaw67> colonelqubit: same as DennisRoczek
13:51:28 <iplaw67> Wed is nearly always impossible for me
13:51:40 <iplaw67> and the weekend is always full of other things
13:51:41 <colonelqubit> iplaw67: for meetings or for BHS?
13:51:48 <iplaw67> colonelqubit: for meetings
13:51:52 * colonelqubit nods
13:52:06 <iplaw67> for BHS, I just do it as and when I've got a free moment in the day, any day ;-)
13:52:07 <colonelqubit> iplaw67: So when's the best time for you to have meetings or other events?
13:52:34 <sophi> colonelqubit: for the January BH, I'll propose dedicated sessions per component, for example Saturday 14:00 to 15:00 Writer testing
13:52:51 <iplaw67> colonelqubit: weekdays after lunch except Wed for meetings
13:52:59 <sophi> and so on with 2 sessions per component over the week end
13:53:11 <iplaw67> evenings not so good, as I'm generally either on phone to clients, or in the car
13:53:31 <sophi> maybe that will motivate more people to come on a dedicated period of time
13:53:33 <colonelqubit> sophi: I think it'd be interesting to try a bit more structure like that
13:53:52 <colonelqubit> sophi: Another idea I had was to get people to buddy-up or bring a friend
13:54:19 <colonelqubit> So if we ask someone in QA to just show up, then they might or might not be motivated
13:55:13 <colonelqubit> but if we talk to them in advance, and encourage them to bring a friend with them for a couple of hours, then perhaps that structure will result in more consistent participation
13:55:22 <colonelqubit> ahoneybun: are you gone?
13:55:41 <colonelqubit> So ahoneybun and I have talked a bit about events in Florida
13:56:38 <colonelqubit> Because the QA Team is spread out over so many time zones, perhaps it would be helpful for us to find people to help organize/recruit volunteers in their own time zone
13:57:18 <colonelqubit> That might be a better way to get a chunk of people to join the BHS together
13:57:20 <sophi> colonelqubit: this happen on the NLP QA mailing lists/channels
13:57:56 <colonelqubit> sophi: great!  has that worked out well so far?
13:57:57 <sophi> colonelqubit: they don't come here but are testing however
13:58:37 <colonelqubit> sophi: so perhaps for the next BHS, we could ask a representative from the local group to check-in with us, or at least leave a note on the wiki page?
13:59:02 <colonelqubit> It'd be helpful for us to know (in rough numbers) who is participating and when
13:59:14 <beluga_> sophi: why don't they come here, though? :)
13:59:36 <sophi> beluga_: language barrier mostly
14:02:08 <colonelqubit> Another thing we could do for the next BHS is to post periodic updates during each day
14:02:46 <sophi> colonelqubit: what do you mean by updates?
14:02:55 <colonelqubit> So... X bugs filed against the latest build, Y% of MozTrap tests completed, etc..
14:03:16 <sophi> colonelqubit: ah ok :)
14:03:31 <beluga_> would twitter be enough?
14:03:48 <colonelqubit> basically, giving people in the channel (and on the QA Mailing List) an indication of how much work we've done so far (and what we'd still like to accomplish)
14:04:04 <sophi> beluga_: I think here too, to show more activity on the channel
14:04:04 <colonelqubit> beluga_: twitter could be a good part of that process
14:04:18 <colonelqubit> beluga_: what would you suggest we share over twitter?
14:04:41 <beluga_> colonelqubit: well those type of stats you mentioned, bugs filed, moztrap tests
14:04:41 <colonelqubit> Periodic updates, or more of a live-updates, frequent-posting thing?
14:04:46 * colonelqubit nods
14:04:52 <beluga_> live-tweet the whole thing :D IRC feed
14:05:37 <colonelqubit> Perhaps having some kind of stats/visual graphics that show how much we've accomplished vs. what we'd like to accomplish by the end of the weekend would be a good motivator?
14:06:21 <beluga_> colonelqubit: that would be novel and cool
14:06:42 <beluga_> we can use it for an excuse for endless tweets etc.
14:06:50 <beluga_> plz help us get to 100%!!
14:07:27 <colonelqubit> beluga_: okay, so who's going to work on graphics and bits for that? Should we recruit someone from the Design Team?
14:07:45 <beluga_> colonelqubit: I can do it
14:08:01 <colonelqubit> awesome
14:08:19 <sophi> beluga_: great, thanks!
14:08:54 <colonelqubit> #action Work on some graphics, visual stats, etc for us to use at the next BHS in conjunction with live updates on IRC & twitter (beluga)
14:09:33 <colonelqubit> beluga_: make sure to include MozTrap in there :-)
14:10:06 <colonelqubit> Great -- sounds like we have some good improvements in the pipeline for the next BHS
14:10:20 <colonelqubit> Any other Pending Items that we should discuss today?
14:11:48 <sophi> colonelqubit: not on my side, I need to leave the meeting anyway
14:11:53 * colonelqubit nods
14:12:18 <colonelqubit> #topic New Items
14:12:27 <colonelqubit> Anything new that people want to discuss?
14:13:26 <colonelqubit> Any particular bugs that I should bring to the ESC tomorrow?
14:13:38 * colonelqubit already got a couple of bugs that Pedro mentioned
14:14:05 <colonelqubit> "Bugs #96118 and #96119 need absolute priority. I know that there is a workaround using the cursor keys and enter but most users don't even know they can use a keyboard for that effect."
14:14:07 <IZBot> LibreOffice-graphics stack critical/highest NEW Cannot select list item with mouse in any combobox https://bugs.documentfoundation.org/show_bug.cgi?id=96119
14:14:58 * colonelqubit hears nothing but crickets
14:15:03 <colonelqubit> #topic End Meeting
14:15:18 <colonelqubit> Okay, sounds like we've arrived at the end
14:16:02 <colonelqubit> Big thanks to all of you for attending today, especially those we haven't heard from in a while such as mjayfrancis and iplaw67 :-)
14:16:43 <colonelqubit> It sounds like we have a number of good ideas for the next BHS, and I'm looking forward to seeing those improvements in place!
14:16:59 <colonelqubit> Our next meeting is in 1 week on Dec 16th.
14:17:33 <colonelqubit> Adios!
14:17:38 <colonelqubit> #endmeeting