13:14:42 <colonelqubit> #startmeeting
13:14:42 <IZBot> Meeting started Wed Dec  2 13:14:42 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
13:14:42 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:15:11 <DennisRoczek> medfly: welcome to the qa minutes meeting. weekly meeting :-)
13:15:26 <DennisRoczek> medfly: don't be shy. fresh blood is always good ;-)
13:15:42 <DennisRoczek> steve-_-: QA meeting :_P
13:16:09 <colonelqubit> UNCONFIRMED bugs are at 528
13:16:50 <colonelqubit> BugHunting Session is this weekend (Fri, Sat, Sun); we'll talk more about that later
13:17:36 <beluga> BSD QA revolution about to happen
13:18:22 <colonelqubit> People are often very busy during December, but hopefully we'll be able to chew off a bunch of work this month and get bugs triaged, regressions bibisected, etc.
13:18:30 <steve-_-> meeting OT cloph: well since the URL exists why not direct it to the correct location? I don't really see why a deprecated URL should be filled with content (even if the content explains BSA no longer exists please move on)
13:18:51 <colonelqubit> beluga: oh, I'm looking forward to it ;-)
13:19:10 <colonelqubit> steve-_-: feel free to bring up that issue w/cloph on #tdf-infra :-)
13:19:30 <colonelqubit> #topic Completed Items
13:19:55 <colonelqubit> I chatted w/Italo on Monday, and we came up with some ideas for this BHS as well as for the future
13:20:33 <colonelqubit> If/when you recruit people to join us, please encourage them to sign up on the Wiki page
13:20:42 <colonelqubit> https://wiki.documentfoundation.org/BugHunting_Session_5.1.0_Beta
13:20:55 <colonelqubit> https://wiki.documentfoundation.org/BugHunting_Session_5.1.0_Beta#Participants
13:21:26 <colonelqubit> (People don't have to sign up for a particular day, although if they're working on (e.g.) Saturday, feel free to have them put their name there)
13:21:42 <colonelqubit> This helps us in two ways:
13:22:01 <colonelqubit> 1) Helps us to keep track of # of participants
13:22:21 <colonelqubit> (and a little more about what they're working on or are interested in)
13:22:36 <colonelqubit> 2) Gets a little more buy-in, if we can get people to sign up for an account
13:23:32 <colonelqubit> DennisRoczek: I assume that we could work back from a list of editors to a page to get a list of email addresses to ping when the next BHS happens?
13:23:45 <colonelqubit> (hopefully)
13:24:51 <colonelqubit> DennisRoczek: you still with us?
13:25:07 <DennisRoczek> colonelqubit: yes. /me at work... :-(
13:25:20 <DennisRoczek> colonelqubit: nothing public completed
13:25:24 <sophi_> colonelqubit:maybe we should ping them before, next BHS is quite far
13:25:40 <colonelqubit> DennisRoczek: no wories
13:25:51 <DennisRoczek> colonelqubit: might not be available at weekend (at parents home, maybe drunken)
13:26:27 <colonelqubit> sophi_: oh, we definitely could ping them earlier. I was just thinking about getting "repeat customers" for the BugHunting Sessions at least
13:26:50 <DennisRoczek> colonelqubit: so do you want to have a list of mailing addresses of people who had edited the bhs pages?
13:27:17 <colonelqubit> DennisRoczek: yeah, that'd be one way for us to filter-out people who are interested/involved
13:29:02 <DennisRoczek> i guess i can do that.
13:29:11 <colonelqubit> DennisRoczek: I'll make a note that you'll (hopefully) be around
13:31:11 * colonelqubit wishes that people could just use their Bugzilla account to sign-up for BHS, but that'll have to wait for future improvements
13:31:37 <colonelqubit> #topic Pending Items
13:31:45 <colonelqubit> mjayfrancis: you happen to be in ?
13:32:49 <colonelqubit> Let's see... no jphilipz
13:33:02 <DennisRoczek> colonelqubit: yeah, create a redmien ticket for (otherwise i might forget it)
13:33:22 <colonelqubit> DennisRoczek: will do
13:34:27 <colonelqubit> #action Investigate creating email list from editors of BHS wiki page (to announce future events) ( DennisRoczek )
13:35:00 <colonelqubit> beluga: What's the status of Bugzilla PDF attachments?
13:35:30 <DennisRoczek> colonelqubit: yeah, get the single-sign-on-stuff working and everybody would be happy :-p
13:35:50 <beluga> colonelqubit: well compiling that statistic is pretty low on my todo list as it is of dubious usefulness
13:36:31 <colonelqubit> beluga: I'm mostly curious if the #s are increasing, or holding steady
13:37:04 <beluga> I would do it for all sorts of mime types.. to identify the users whose uploads get detected wrong
13:37:10 * colonelqubit nods
13:37:24 <beluga> numbers are very suspicious indeed as they are corrected all the time
13:37:32 <beluga> mst does it when he is bored in ESC meetings
13:37:52 <beluga> and I do it when I run into some and happen to notice
13:38:07 <colonelqubit> When we migrated from FDO, I believe that the auto-detection got much better
13:38:23 <beluga> it might be tied to browser and OS
13:38:27 <beluga> the fails
13:38:38 * colonelqubit hmms
13:39:15 <beluga> Firefox is always having its own opinions when downloading stuff, so why not when uploading?
13:39:29 <beluga> we should upload some stuff to the test vm
13:39:34 <beluga> with different browsers
13:39:38 <colonelqubit> beluga: Could you run a few quick tests and then report back in a week?
13:39:45 <beluga> ok
13:40:25 * steve-_- confirming auto detection has improved a lot. I recall it was close to unusable when making my first qa steps
13:41:24 <colonelqubit> #action Test attachment upload (to Bz test VM) with different browsers/OSes/filetypes (beluga)
13:41:42 <colonelqubit> steve-_-: good to hear
13:42:44 <colonelqubit> steve-_-: perhaps you can help beluga run some upload tests from OSX ?
13:43:15 <steve-_-> I know that jpg png and txt is working fine from filing bugs in firefox.
13:43:30 <beluga> steve-_-: yeah try to upload some PDFs (exported from LibO), docx here https://bugzilla-test.documentfoundation.org/
13:44:38 <colonelqubit> sounds like you two are off to the races
13:44:50 <colonelqubit> okay, that's all I have for pending items
13:44:57 <colonelqubit> Anything else from Pending?
13:45:18 <colonelqubit> #topic New Items
13:45:38 <colonelqubit> Okay, New Items. Whatcha got?
13:46:32 <beluga> colonelqubit: about the discussion between Pedro and Joel about BZ design
13:47:10 <beluga> there should be no drafts, tenders or such before P and J have looked at BzDeck in depth: https://github.com/bzdeck/bzdeck
13:47:33 <beluga> the discussion is connected to the version field debacle
13:47:59 <beluga> I proposed a solution to it several months ago, but there was no drop-in solution
13:48:10 <colonelqubit> Yeah, I wish that we had a better solution for the version field
13:48:17 <beluga> the version list must be turned into a collapsed tree view
13:48:24 <colonelqubit> sure, that'd be nice
13:48:30 <beluga> every major version opens up to reveal the minor ones
13:48:33 <beluga> like this http://www.jqueryscript.net/form/jQuery-Plugin-For-Multi-Selectable-Tree-Structure-Tree-Multiselect.html
13:48:51 <colonelqubit> It really is a *tree*, and not just an ordered list, because we do create builds on release series branches
13:49:12 <beluga> yet, we would need to do some hacking with BZ first, to have the major versions be <optgroup> html elements
13:49:32 <beluga> and there is already a thing for that https://github.com/rojanu/bugzilla-field-groups
13:49:45 <colonelqubit> well, and then we're getting into some deeper surgery, and then that can become another maintenance burden moving forward
13:50:08 <beluga> so if there is going to be some tender or money-spending, it doesn't have to be a big sum
13:50:28 <colonelqubit> hmm
13:50:34 <beluga> and definitely only for the tree view thing.. not anything bzdeck is going to cover with all the huge improvements in UX
13:50:36 <sophi_> beluga: BzDeck seems very interesting
13:50:39 <colonelqubit> beluga: I don't see a lot on that github page
13:50:52 <beluga> sophi_: yeah it is an old project resurrected by Mozilla :)
13:51:11 <beluga> https://twitter.com/BzDeck/with_replies
13:51:19 * colonelqubit meant on the bz-field-group page.
13:51:25 <beluga> ah ok
13:51:54 <steve-_-> should bz be able to eat more than one attacahment when filing a bug?
13:52:01 <steve-_-> auto detect looking good https://bugzilla-test.documentfoundation.org/show_bug.cgi?id=89095
13:52:15 <sophi_> beluga: it could resolve the issue we face with the different level of needs between dev, QA and users
13:52:17 <beluga> colonelqubit: well the optgroup thing should be looked into.. but version 5 has optgroups for product field for example.. another improvement
13:52:18 <steve-_-> ah pdf not detected?
13:52:28 <beluga> then we could collapse all the lib* stuff
13:52:45 <beluga> steve-_-: yep noticed it with my own uploads
13:52:57 <beluga> steve-_-: multi upload is in v. 5
13:53:05 <steve-_-> … can't wait (:
13:53:11 <beluga> or actually, is it in BzDeck hehe :)
13:53:32 <beluga> yeah it was actually BzDeck: Easy comments & uploads: Post a comment to a bug without page refresh. Attach multiple files by selecting them or dragging & dropping a folder, files, text or link.
13:53:41 <beluga> https://github.com/bzdeck/bzdeck/wiki
13:53:52 <colonelqubit> beluga: ah, okay, I was trying to recall that!
13:54:06 <steve-_-> isn't kohei developing jenkins?
13:54:23 <beluga> back when I researched it, I created a test account on BZ landfill and confirmed the product field has optgroups
13:54:53 * colonelqubit nods
13:55:16 <beluga> this could also be an easy solution, if implemented https://github.com/select2/select2/issues/3269 for the tree view .. and this even has it already https://github.com/SE7ENSKY/jquery-select7
13:55:33 <colonelqubit> Assuming that I'm not inundated with requests for help on Friday, I'll switch the db on the bz test VM over to 5.0 at that point
13:56:01 <colonelqubit> beluga, steve-_-: Feel free to test attachment uploads again at that point, to see if v5 has any better results for you
13:56:07 <beluga> ok, good point
13:56:19 <steve-_-> colonelqubit: feel free to ping when ready
13:57:38 <colonelqubit> I may periodically need to change the db & install back to 4.4 so we can test changes before making them live, but I'll try to keep the VM running v5 as long as we have people testing it out
13:58:23 <beluga> then we have the BSD thing.. I have emailed both the NetBSD and OpenBSD official LibreOffice build gurus.. we need build instructions on the wiki. And then there is the issue of getting their patches upstream.. what has blocked that from happening? I am interested to know
13:58:55 <colonelqubit> #action Ping steve-_-, beluga to test attachment upload once Bz VM is running v5 (Robinson)
13:59:39 <beluga> and just to record this nice gesture from NetBSD to the meeting minutes: https://twitter.com/netbsd/status/671723593693306884 "LibreOffice QA team is looking for BSD users for an upcoming bug hunt… If you can build from source, you might help"
13:59:55 <colonelqubit> beluga: yep, big thanks to them for giving us a shout-out
14:00:21 <colonelqubit> beluga: so let's see... build instructions on the wiki. What do we have currently?
14:00:31 <beluga> colonelqubit: we don't have anything for BSDs
14:00:48 <beluga> both net and open need custom patches applied
14:01:15 <beluga> if patches would be upstreamed, imagine how easy the instructions would be :)
14:01:27 <medfly> beluga: they are simple anyway, we put it all on a package manager
14:01:29 <colonelqubit> you're right -- I thought that I might have stubbed-in https://wiki.documentfoundation.org/BSD but even that page hasn't been created
14:01:34 <medfly> but it is a hassle for package people to upgrade versions
14:01:36 <medfly> because the patches break
14:02:04 <beluga> medfly: do you have time at some point to stub out some stuff on the wiki?
14:05:02 <medfly> I don't know what that means
14:05:04 <colonelqubit> beluga: found it
14:05:08 <medfly> I'm not an expert in any way
14:05:48 <beluga> medfly: I mean just write notes about how you managed to build LibreOffice for NetBSD
14:05:58 <medfly> the same way every package is built
14:05:58 <beluga> (in case you did manage :))
14:06:07 <colonelqubit> https://wiki.documentfoundation.org/BSD
14:06:37 <steve-_-> medfly: it would be great if you could point out the process on that wiki page. you seem to know your stuff when it comes to compiling on netbsd
14:06:53 <medfly> it's the equivalent of writing apt-get install libreoffice
14:07:30 <colonelqubit> Our naming scheme of wiki pages isn't universally consistent, but here's how the Build on XYZ pages look: https://wiki.documentfoundation.org/Category:Build
14:08:48 <colonelqubit> medfly: can you build from master that way? or just a release branch?
14:09:05 <beluga> hmm.. yeah I recall some problems last night
14:09:15 <IZBot> News from tdfnew: [Bug 96205] impress : problem viewing a pptx after a save with LibreOffice <https://bugs.documentfoundation.org/show_bug.cgi?id=96205>
14:09:32 <beluga> I got the impression that there were some dark corners
14:09:53 <medfly> well right now you can't, I'm working on it
14:10:02 <medfly> have to upgrade libraries too
14:10:09 <colonelqubit> Ah, fair enough
14:10:35 <medfly> I could write about it, OK
14:11:46 <colonelqubit> medfly: thanks!
14:12:50 <colonelqubit> #action Document building LibreOffice on BSD (medfly)
14:13:01 <colonelqubit> medfly: is that NetBSD you're working on, or?
14:13:59 <medfly> yes
14:14:20 <medfly> well, theoretically it may work for other systems
14:14:34 <beluga> OpenBSD has 80 patches it was said
14:15:10 <colonelqubit> if possible, it'd be great to get things merged-in upstream
14:15:24 <beluga> I hope I will get a reply from the maintainer.. if nothing arrives in some days, I will ask Miklos, if he knows the guy :) both are from Hungary
14:15:25 <colonelqubit> and (as we've noted before) to have buildbots running
14:16:40 * colonelqubit was just reading about the martians..
14:16:43 <colonelqubit> https://en.wikipedia.org/wiki/The_Martians_%28group%29
14:17:21 <medfly> ryoshu has a builtbot thing for llvm
14:17:27 <medfly> pretty neat
14:17:30 <colonelqubit> cool
14:18:31 <colonelqubit> medfly: it'd be great to see a column for NetBSD (and other BSDs) here: http://tinderbox.libreoffice.org/MASTER/status.html
14:18:59 <medfly> but I've only just started making packages, I don't know if I'll succeed in upgrading libreoffice at all :)
14:19:16 <colonelqubit> packaging, smackaging
14:19:28 <beluga> hackaging
14:19:36 <colonelqubit> getting master to consistently build is where it's at!
14:20:27 <colonelqubit> Once we've got that all running smoothly, then we can talk about BSD bibisect repos :P
14:21:11 <colonelqubit> Okay, we're starting to creep over the hour mark
14:21:21 <colonelqubit> Any other New Topics for us to discuss?
14:21:44 <colonelqubit> Any pressing bugs that I should take to the ESC?
14:22:04 <steve-_-> colonelqubit: os x highest critical major annoyances as usual
14:22:04 <steve-_-> https://bugs.documentfoundation.org/show_bug.cgi?id=49853
14:22:04 <steve-_-> https://bugs.documentfoundation.org/show_bug.cgi?id=90913
14:22:06 <IZBot> bug 49853: LibreOffice-UI critical/highest NEW EDITING: Attempting paste/select all into find bar with Cmd-V or Cmd-A on OS X pastes into document not into search bar
14:22:07 <IZBot> bug 90913: LibreOffice-LibreOffice critical/highest NEW OSX - very poor performance when first opening Finder dialog
14:22:39 <colonelqubit> steve-_-: yeah, I wish I had a fix for you on that one
14:23:00 <steve-_-> just keep devs aware that there are rather serious problems
14:23:26 * colonelqubit takes a peek at the 9xxxx one
14:24:39 <steve-_-> those are no crashes but actions used very often and the current behavior is more than akward. since both are actions performed very often I think it could quickly lead to a level of frustration where people just will buy MS office…
14:24:58 <colonelqubit> steve-_-: it's been 6 months (exactly) since Alex's last comment on 90913. Can you repro the slow-down with 5.1 beta1 and/or daily build of master?
14:25:04 <steve-_-> y
14:25:15 <steve-_-> has been very consistent that one
14:25:35 <colonelqubit> steve-_-: oh, and that should have 'perf' in the Whiteboard
14:25:47 <steve-_-> it happens whenever a user saves a file after first opening LO. and after closing and opening again
14:27:15 <colonelqubit> steve-_-: and 4.4 branch is ok?  (how about latest 4.4.7 rc2?)
14:27:33 <colonelqubit> We'll continue this after the meeting
14:27:40 <colonelqubit> Anything else, folks?
14:29:14 <colonelqubit> Okay, thanks for joining in today!
14:29:25 <colonelqubit> Remember: Bug Hunting Session starts on Friday and goes through Sunday
14:29:48 <colonelqubit> Please invite people to join us, and ask them to sign up on the wiki page
14:30:14 <colonelqubit> (if they're reticent to create an account, feel free to just list their name and areas of interest, so we can at least count noses)
14:31:27 <colonelqubit> I'll see you next week!
14:31:34 <colonelqubit> #endmeeting