13:11:26 <colonelqubit> #startmeeting
13:11:26 <IZBot> Meeting started Wed Nov 18 13:11:26 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
13:11:26 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:12:07 <colonelqubit> So... 510 UNCONFIRMED bugs right now
13:12:29 <colonelqubit> Including "New AutoCorrect rules for Ruble sign and Hammer and Sickle"
13:12:39 <colonelqubit> I'll have to look into that one :-)
13:14:10 <colonelqubit> Quick reminder: Our next BugHunting Session will be the first week in December
13:14:42 <colonelqubit> https://wiki.documentfoundation.org/BugHunting_Session_5.1.0_Beta
13:14:58 <colonelqubit> I added some quick Prev/Next links to the BHS pages to make it easier to navigate
13:16:00 <colonelqubit> #topic Pending Items
13:16:22 <DennisRoczek|afk> colonelqubit: what is that ticket id please?
13:16:28 <colonelqubit> mjayfrancis1: you around?
13:16:33 <colonelqubit> DennisRoczek: which ticket?
13:16:42 <DennisRoczek> the hammer and sickle one
13:17:04 <colonelqubit> ah yes: https://bugs.documentfoundation.org/show_bug.cgi?id=95905
13:17:06 <IZBot> bug 95905: LibreOffice-Writer normal/medium UNCONFIRMED New AutoCorrect rules for Ruble sign and Hammer and Sickle
13:17:29 <colonelqubit> it was reported by "General Kutuzov"
13:17:39 <beluga_> colonelqubit: I completed my action item https://redmine.documentfoundation.org/issues/1602
13:17:40 <IZBot> redmine: »More descriptive categories« in Infrastructure (Task for unassigned) [New]
13:17:57 <colonelqubit> beluga_: thanks!
13:18:55 <colonelqubit> beluga_: I think that we could even split up the plone things
13:19:21 <colonelqubit> I believe that cloph was supportive of that change
13:19:35 <beluga_> sure
13:19:46 <beluga_> was actually Dennis' suggestion I just pasted
13:19:57 * colonelqubit nods
13:22:15 * DennisRoczek has also created two tickets --> closed two AI.
13:22:24 <colonelqubit> DennisRoczek: yep, thanks!
13:22:31 <DennisRoczek> I was so free (as you saw) to strike the ones in the qa meeting minutes
13:22:44 <DennisRoczek> for not forgetting it
13:22:51 <DennisRoczek> or for the case i'm not available ;-)
13:23:04 <colonelqubit> DennisRoczek: yes, I just normalized the language and then moved them to the "Completed Items" section
13:24:46 <beluga_> blowfist: welcome to the weekly QA meeting :)
13:25:01 <colonelqubit> blowfist: hiya
13:25:28 <beluga_> I gave blowfist a fairly lengthy introduction earlier today
13:25:31 <blowfist> hello :)
13:25:32 <colonelqubit> awesome
13:25:58 <colonelqubit> I've got an Action item re: recruiting/retaining, and I'll be spreading the good word this week at Fossetcon
13:26:21 <colonelqubit> blowfist: beluga_ is a smart cookie. He should be able to answer *all* of your questions
13:26:37 <beluga_> I am a specialist in most fields of science
13:26:44 <colonelqubit> animal and mineral?
13:26:49 <beluga_> for sure
13:27:16 <DennisRoczek> radioactive?
13:27:35 <beluga_> let's just say I know what mushrooms to eat and what to leave on the ground
13:27:53 <colonelqubit> https://www.youtube.com/watch?v=zSGWoXDFM64
13:27:54 <IZBot> YouTube - I Am the Very Model of a Modern Major-General by: ThePenzancePirate
13:28:42 <colonelqubit> jphilipz: you've got an item about Simple things for new QA folks
13:29:08 <colonelqubit> any update? I know you were drafting
13:29:39 * colonelqubit clarifies: "ACTION: Make a simple page of things new QA should be aware of (jphilipz) "
13:29:45 <jphilipz> colonelqubit: i shared the google doc in a previous meeting and i've been working on the status part.
13:30:04 <blowfist> colonelqubit: beluga_ has been extremely nice to brief me how to do the triage job, hopefully I can do him honor :)
13:30:13 <colonelqubit> jphilipz: great -- I'll take another look after the meeting
13:30:30 <colonelqubit> blowfist: beluga_ is a good instructor
13:30:59 <colonelqubit> blowfist: I like to ask new contributors for their input, as they have a unique perspective on things
13:31:34 <colonelqubit> blowfist: We've got a BugHunting Session coming up in a couple of weeks, and we're always interested in recruiting new people to help us do some testing
13:32:42 <colonelqubit> what brought you here to QA, and how might we best recruit others to join in?
13:33:06 <blowfist> I won't be able to be an active part of the meeting, I have some other things to attend to, but I will make sure to read the back log when I come back
13:33:14 * colonelqubit nods
13:33:59 <blowfist> see you later :)
13:34:02 * colonelqubit waves
13:34:32 <colonelqubit> Let's see.. what other open Items do we have
13:34:59 <colonelqubit> [DONE] ACTION: File bug re: improved categories for Infra project in redmine (beluga)
13:35:15 * colonelqubit Work on wiki page for ODF formats/comparison (DennisRoczek)
13:35:27 <colonelqubit> DennisRoczek: what's the url for that one?
13:36:51 <colonelqubit> hmm..perhaps afk
13:37:11 <colonelqubit> " ACTION: Check on Bugzilla PDF attachments (mimetype application/pdf vs. x-download) (beluga)"
13:37:15 <DennisRoczek> colonelqubit: not worked on
13:37:19 <colonelqubit> DennisRoczek: thnaks
13:37:38 <colonelqubit> beluga_: any update on PDF MIMEtype weirdness on Bugzilla?
13:37:52 <beluga_> colonelqubit: well, I did send you an email :)
13:38:10 <beluga_> but I've observed the weirdness.. docx being detected as zip etc.
13:38:21 <beluga_> (from other uploaders than me)
13:39:09 <beluga_> email sent Nov 12
13:39:22 <colonelqubit> beluga_: so is it an issue with mimetypes generally?
13:39:30 <beluga_> yes, not only pdf
13:39:41 <colonelqubit> iirc, 'file' seemed to correctly identify a few things tested
13:39:48 <beluga_> BZ allows you to search by mimetype so you can get a picture of the situation
13:40:06 <colonelqubit> beluga_: can you paste a link in the minutes here?
13:40:19 <beluga_> well I will make a general query
13:41:15 <beluga_> this is for application/x-download https://bugs.documentfoundation.org/buglist.cgi?f10=attachments.mimetype&f9=OP&list_id=572457&o10=substring&order=changeddate%2Cpriority%2Cbug_severity&product=LibreOffice&query_based_on=&query_format=advanced&v10=application%2Fx-download
13:41:17 <colonelqubit> As for docx, it is xml in a zip container, so I wonder if there's some aspect of the MIMEtype investigating code that's just stopping too early
13:42:15 <beluga_> well I should have limited by date, sorry
13:43:17 <beluga_> for docx and application/zip hopefully matching https://bugs.documentfoundation.org/buglist.cgi?chfield=[Bug%20creation]&chfieldfrom=2015-01-10&chfieldto=Now&f10=attachments.mimetype&f11=attachments.filename&f9=OP&list_id=572461&o10=substring&o11=substring&product=LibreOffice&query_format=advanced&v10=application%2Fzip&v11=docx
13:43:42 <beluga_> yep, seems to have worked :)
13:44:19 <beluga_> let's have a date-limited version of the pdf query https://bugs.documentfoundation.org/buglist.cgi?chfield=[Bug%20creation]&chfieldfrom=2015-01-10&chfieldto=Now&f10=attachments.mimetype&f9=OP&list_id=572462&o10=substring&product=LibreOffice&query_format=advanced&v10=application%2Fx-download
13:44:22 <colonelqubit> Looks like the mimetypes were displaying this way on FDO: https://bugs.freedesktop.org/attachment.cgi?id=45940&action=edit
13:46:14 <colonelqubit> beluga_: so who else is having issues w/pdfs?
13:46:44 <beluga_> colonelqubit: those other guys in the above link
13:46:46 <colonelqubit> you, user 'orion', ..okay a couple
13:46:54 <beluga_> Ivan
13:47:12 <beluga_> Randolph
13:47:50 <colonelqubit> beluga_: Could you do some analysis of what types of files are breaking and for which users?
13:48:05 <colonelqubit> possibly just a couple of PDF-generating applications?
13:48:26 <beluga_> colonelqubit: yeah, LibreOffice being the PDF-generator in this case :P
13:48:38 <colonelqubit> is it always LO?
13:48:51 <beluga_> no
13:48:59 <beluga_> here it is mso https://bugs.documentfoundation.org/show_bug.cgi?id=90353
13:49:01 <IZBot> bug 90353: LibreOffice-Writer major/medium NEW FILEOPEN DOC: TABLE VIEWING destroyed
13:49:22 <beluga_> or some pdf printer perhaps.. I think mso 2003 did not have pdf export
13:49:33 <colonelqubit> ah, interesting
13:49:56 <colonelqubit> are we using poppler for our PDF export?
13:50:15 <beluga_> poppler is used at least in import, so probably yes
13:50:26 <colonelqubit> beluga_: anyhow, if you have time to do some digging, that'd be great
13:50:28 * beluga_ remembers it from Vort's PDF import work
13:50:39 <colonelqubit> and perhaps file a new bug report?
13:50:50 <jphilipz> beluga_: i believe mso 2003 had a virtual pdf printer
13:51:01 <beluga_> ok I guess I can compile you a spreadsheet of who is who and what is what of failed recognitions
13:51:34 <colonelqubit> beluga_: yeah, some more info might help us identify if there's more in common here
13:51:39 <colonelqubit> danke
13:52:16 <colonelqubit> DennisRoczek: one more item for you: Did you get a chance to re-test the Media Support on Windows?
13:54:27 <colonelqubit> IIRC, we got some unexpected results for things like PDF and ODG, and I just wanted to get that cleared up before we sent out an email to QA/Dev/Projects with an update about the current level of testing (and to mention our results for Android)
13:55:38 <colonelqubit> (we can follow-up later on that as well)
13:55:49 <colonelqubit> okay, any other pending items?
13:56:16 <colonelqubit> #topic New Topics
13:56:19 <DennisRoczek> colonelqubit: maybe at the weekend
13:56:24 <DennisRoczek> put it on my list
13:56:27 <colonelqubit> DennisRoczek: great, thanks
13:57:01 <colonelqubit> #action Re-test image results on Windows for Media_Support wiki pages ( DennisRoczek )
13:57:17 <colonelqubit> Okay, who has a New Topic for us?
13:58:43 <colonelqubit> *crickets*
13:59:08 <colonelqubit> #topic The End
13:59:46 <colonelqubit> I think that covers everything on my list.
14:00:21 <colonelqubit> If you haven't tested/given feedback about the auto-added Whiteboard tags when creating new bugs, please go over to the Test VM, try it out, and give me feedback
14:00:40 <colonelqubit> https://bugzilla-test.documentfoundation.org/enter_bug.cgi
14:02:15 <colonelqubit> Because of the way that Bz upgrading to v5.0 works, I'll be cloning the db on the test VM this week so that we can alternate testing between the 4.4 and 5.0 branches. I'll email out if I break things for very long
14:02:53 <colonelqubit> Anything else?
14:03:17 <IZBot> News from tdfnew: [Bug 95906] VIEWING: Elements anchored as 'To Character' on last page of document appear on first page in Web Layout <https://bugs.documentfoundation.org/show_bug.cgi?id=95906> || [Bug 95907] Unable to end the document with a table without an empty paragraph <https://bugs.documentfoundation.org/show_bug.cgi?id=95907> || [Bug 95881] Graphite autoligature errors in hungarian ducuments <https://bugs.documentfoundation.org/show_bug.cgi?id=95881>
14:03:43 <colonelqubit> Have a great week, folks. We'll talk again next week on Thanksgiving Eve!
14:03:59 <colonelqubit> (well, at least it will be Thanksgiving Eve here in the States...)
14:04:11 <colonelqubit> #endmeeting