13:13:11 <colonelqubit> #startmeeting
13:13:11 <IZBot> Meeting started Wed Nov 11 13:13:11 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
13:13:11 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:14:25 <colonelqubit> #action File bug re: improved categories for Infra project in redmine (beluga)
13:15:24 <colonelqubit> beluga_: I'll follow-up on the suggestion once we've got some ideas mentioned there
13:15:32 <beluga_> colonelqubit: ok
13:15:58 <colonelqubit> UNCONFIRMED bugs..we've got 526 currently
13:16:33 <colonelqubit> jphilipz, beluga_: Looks like we've still got a number that have Component: ux-advise that are in UNCONFIRMED
13:16:48 <colonelqubit> What's our current strategy?
13:17:06 <beluga_> colonelqubit: there's still 31 new uncos that I haven't looked at, but I don't know, if I will do it today :)
13:17:46 <colonelqubit> If they're just enhancements, I'd be inclined to push those into NEW (per our previous discussions)
13:17:49 <beluga_> colonelqubit: strategy for ux-advise is that design team members can set to NEW immediately, but otherwise they act as gatekeepers, deciding whether to close or to set to NEW
13:18:15 * colonelqubit nods
13:18:34 <colonelqubit> I just want to make sure that we don't have bugs sitting in UNCONFIRMED for longer than they need to
13:18:50 <colonelqubit> ideally QA would be able to triage them out of there
13:19:23 <colonelqubit> beluga_: The tests of the auto-added Whiteboard tags went quite well, AFAICT
13:19:40 <colonelqubit> so perhaps we could rely more heavily on those
13:19:54 <colonelqubit> and deploy those to production soon
13:20:13 <edwin42> Well, the Problem exists on Linux _and_win. I' m not shure to understanding right, do you recommend using win for debugging or ist it a joke?
13:20:16 <DennisRoczek> colonelqubit: btw any plans to remove the BSA whiteboard tag?
13:20:42 <colonelqubit> So when we triage a bug and set Component to ux-advise, we consider that bug to be triaged
13:20:50 <beluga_> edwin42: no joke, but I'm not sure, if you would need to do something extra besides the normal debug described in the wiki
13:20:56 <colonelqubit> DennisRoczek: it's only on older bugs, right?
13:21:11 <beluga_> DennisRoczek: leave it for older..
13:21:48 <beluga_> no need to mass-remove it.. just causes spam
13:22:09 <DennisRoczek> colonelqubit: yeah, the bsa is dead and won't come back (well except for guided forms)
13:22:24 * colonelqubit nods
13:22:27 <DennisRoczek> beluga_: i thought we can turn off the email-feature?
13:22:36 <colonelqubit> Any particular reason why we'd want to remove it?
13:22:48 * colonelqubit sees it as providing some useful information about how the bug was filed
13:23:42 <beluga_> save the BSA!
13:23:43 <colonelqubit> Having that information captured in the 1st comment (as the Guided Forms do now) might be a slightly better implementation, but the Whiteboard tag is decent enough..
13:23:49 <DennisRoczek> colonelqubit: dunno. maybe faster responses when filtering on hiteboard tags? (no idea actually)
13:23:55 * beluga_ is in BSA conservation field
13:24:18 <colonelqubit> well here BSA = Boy Scouts of America, so I did have to get used to that at first... :P
13:24:57 * DennisRoczek laughs
13:25:01 <colonelqubit> DennisRoczek: I think that in the grand scheme of things, the BSA tag won't provide any slow downs
13:25:29 <colonelqubit> but we can revisit that in the future, if speed issues are a concern
13:25:46 <beluga_> news from the trenches: several reports added to the OpenGL 5.0+ meta bug
13:26:12 <colonelqubit> ah, good
13:26:37 <colonelqubit> Are things looking better/the same/worse?
13:26:52 <beluga_> colonelqubit: glitchy like always
13:27:05 <beluga_> just added a Vanilla Mac options glitch
13:27:17 <beluga_> #95627
13:27:19 <IZBot> LibreOffice-LibreOffice normal/medium UNCONFIRMED Strange characters in LibreOffice Vanilla menu https://bugs.documentfoundation.org/show_bug.cgi?id=95627
13:27:20 <colonelqubit> hm...
13:27:38 <beluga_> now I have this in my Firefox Clippings: Tools - Options - LibO - View - Use OpenGL for all rendering
13:28:01 <beluga_> got fed up typing it so often
13:28:16 <beluga_> it's the new "plz reset user profile"
13:28:38 <colonelqubit> Speaking of which....
13:28:43 <colonelqubit> #topic Pending Topics
13:28:50 <edwin42> beluga: using the "daily masters" like described is possible but requires large download an using WinDbg is also possible with the normal program installation?
13:29:13 <colonelqubit> No mjayfrancis, I see -- I'm definitely looking forward to some tooling for user profiles
13:29:26 <beluga_> edwin42: yes, windows will download the symbols.. not sure, how huge the download will be though.. it kind of runs in the background
13:30:34 <colonelqubit> For DennisRoczek, I have 'ACTION: Add bug to redmine for "remove unsupported und unbuildable OSes from os picker in bz"'
13:30:44 <colonelqubit> DennisRoczek: did you get a chance to mention that one?
13:30:45 <edwin42> beluga: OK, I will try, may be it will waste some time.
13:31:55 <colonelqubit> DennisRoczek: There was another issue from you...I'm trying to recall
13:32:18 <colonelqubit> Ah yes, something about ODF?
13:32:31 <DennisRoczek> colonelqubit: nope. hadn't any time
13:32:45 <DennisRoczek> neither the other ai
13:32:51 <DennisRoczek> until next meeting ;-)
13:32:59 <DennisRoczek> +the hidden redmine ticket is going on
13:33:11 <colonelqubit> DennisRoczek: ah yes, thanks
13:34:03 <colonelqubit> #action Work on wiki page for ODF formats/comparison (DennisRoczek)
13:34:47 <DennisRoczek> actually looks good. /me is really surprised how good the most of download worked. (still having images to download, grrr)
13:34:57 <colonelqubit> Let's see...I have an ACTION item to chat with marketing this week, and I'll follow up either today or tomorrow
13:35:52 <colonelqubit> #topic New Topics
13:36:27 <DennisRoczek> colonelqubit: you misssed an open AI for me
13:36:28 <DennisRoczek> ^^
13:36:33 <colonelqubit> As I believe I mentioned last week, our next Bug Hunting Session is the first week of December, so we should start thinking about invites soon
13:36:42 <colonelqubit> DennisRoczek: The tracking bugs page?
13:36:56 <colonelqubit> DennisRoczek: I thought that you didn't have a chance to look at it
13:37:20 <DennisRoczek> yes
13:37:33 <DennisRoczek> jupp. no chance. enough ai for me :-p
13:38:12 <colonelqubit> ah, fair enough
13:38:23 * colonelqubit makes a note to assign more action items to Dennis
13:39:34 <colonelqubit> Okay, folks, any New Items from you that we should discuss?
13:40:09 <colonelqubit> There's been some good discussion in the email thread re: new Bugzilla status for 'abandoned' bugs
13:41:29 <colonelqubit> Anyone here who hasn't chimed-in yet?
13:42:29 * DennisRoczek has no opinion on that topic.
13:43:18 <colonelqubit> fair enough
13:43:33 <colonelqubit> Any other topics we should cover?
13:43:50 <colonelqubit> How about any bad bugs that should be brought to the ESC?
13:43:56 * colonelqubit takes a look at https://bugs.documentfoundation.org/show_bug.cgi?id=95183
13:43:59 <IZBot> bug 95183: LibreOffice-Installation major/high NEEDINFO Check for Updates dialog does not show up in x86 Windows XP
13:46:45 <colonelqubit> Two "MABs" from this week
13:46:47 <colonelqubit> https://bugs.documentfoundation.org/show_bug.cgi?id=95670
13:46:50 <IZBot> bug 95670: LibreOffice-Calc critical/highest UNCONFIRMED CALCULATING: some text functions doesn't work inside SUMPRODUCT, they need the function introduced as array.
13:46:52 <colonelqubit> https://bugs.documentfoundation.org/show_bug.cgi?id=95573
13:46:54 <IZBot> bug 95573: LibreOffice-Extensions critical/highest NEW EXTENSION MANAGER - freeze / hang when attempting to install extensions on OSX 10.11, installation confirmation dialog not displayed
13:48:00 <beluga_> colonelqubit: why is BZ recognizing pdfs as x-download #95676
13:48:02 <IZBot> LibreOffice-Writer normal/medium UNCONFIRMED When creating labels in Hebrew -- right to left -- the first letters on right are cut off https://bugs.documentfoundation.org/show_bug.cgi?id=95676
13:48:41 * colonelqubit takes a look
13:50:05 <colonelqubit> beluga_: hmm... looks like a normal PDF according to 'file'
13:50:36 <colonelqubit> beluga_: all PDFs, or just that one?
13:51:09 <beluga_> colonelqubit: well, I remember seeing that in other cases, but usually I don't pay attention to the mime type after upload
13:51:28 <edwin42> beluga: I have lost the content of the chat while looking for save button, seems I had to use the clipboard... Could you send me the link to Linux daily masters once more? Thank you very much.
13:51:53 <beluga_> edwin42: http://dev-builds.libreoffice.org/daily/master/?C=M;O=A
13:52:09 <beluga_> sorted by date for your pleasure
13:52:32 <colonelqubit> beluga_: e.g. I see application/pdf MIMEtype here: https://bugs.documentfoundation.org/show_bug.cgi?id=95461
13:52:34 <IZBot> LibreOffice-Printing and PDF export normal/medium RESOLVED DUPLICATE (of 94428) When printing distorded characters appear on top left corner of page
13:52:36 <IZBot> bug 95461: LibreOffice-Printing and PDF export major/highest RESOLVED FIXED Printing adds garbage (characters) to top edge of page https://bugs.documentfoundation.org/show_bug.cgi?id=94428
13:53:09 <beluga_> colonelqubit: maybe I will check my own uploads later
13:53:18 * colonelqubit nods
13:53:41 * colonelqubit has a vague memory of seeing different behavior that was OS-dependent (??)
13:54:26 <beluga_> I have to leave office, bye
13:54:31 <colonelqubit> If you see something consistent/actionable, please do file a bug in redmine
13:54:55 <colonelqubit> either way, let's check-up on the issue next week
13:54:58 <IZBot> News from tdfnew: [Bug 95737] Fontwork Object incompatible <https://bugs.documentfoundation.org/show_bug.cgi?id=95737>
13:55:46 <colonelqubit> #action Check on Bugzilla PDF attachments (mimetype application/pdf vs. x-download) (beluga)
13:56:01 <colonelqubit> #topic Wrapping Up
13:56:08 <colonelqubit> Okay folks, any other topics that we should cover today?
13:56:15 <colonelqubit> steve-_-: anything from you?
13:56:21 <steve-_-> https://bugs.documentfoundation.org/show_bug.cgi?id=49853
13:56:23 <IZBot> bug 49853: LibreOffice-UI critical/highest NEW EDITING: Attempting paste/select all into find bar with Cmd-V or Cmd-A on OS X pastes into document not into search bar
13:57:00 <colonelqubit> Le Monster bug persists, I see...
13:57:25 <steve-_-> kendy__ dug into it and now a user reported what was requested
13:59:02 <colonelqubit> Ah, good to see Takeshi speaking up on the bug
14:00:45 <colonelqubit> Looks like he *just* provided that information, so we'll probably see kendy chiming back in shortly
14:00:57 <steve-_-> hm ok let's wait more
14:02:00 <colonelqubit> steve-_-: thank you for your work here -- it's heartening to see progress being made on older bugs such as this one
14:02:47 * steve-_- didn't do anything. no need to thank me.  just hoping this one can be brought down
14:03:15 <colonelqubit> steve-_-: well it's helpful for you to bring up these issues so that we can keep eyes on them
14:03:31 <colonelqubit> Sounds like that's all for this week.
14:03:57 <colonelqubit> BIG thanks to everyone for joining-in, and to Beluga and the rest of y'all for chomping down on the UNCONFIRMED bugs
14:04:51 <colonelqubit> Our next meeting will be in 1 week, at which I'm sure we'll have many fun, exciting, interesting, and weird things to discuss!
14:08:20 <colonelqubit> Before we wrap up here, just a short mention that It's Veteran's Day here in the US, so to all of you around the world who are veterans, thank you for your service to your country.
14:08:31 <colonelqubit> Ciao, folks
14:08:34 <colonelqubit> #endmeeting