13:08:40 <colonelqubit> #startmeeting
13:08:40 <IZBot> Meeting started Wed Oct 28 13:08:40 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
13:08:40 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:09:28 <colonelqubit> UNCONFIRMED is up to 517
13:09:59 <colonelqubit> Perhaps we can take a bit off that number this weekend
13:10:30 <sophi> colonelqubit: only if it concerns 5.1
13:11:01 <colonelqubit> sophi: yep, yep -- I figure that we might be able to get some people to re-test with the alpha1
13:11:01 <beluga_> otherwise it is not allowed
13:11:06 * colonelqubit laughs
13:12:51 <colonelqubit> But I do think that it could be a useful strategy (for any bugs that haven't been tested with something modern) to mention to people that we're working hard on 5.1, and we'd really appreciate it if they could test with the alpha1 so we can ensure that the release is clean
13:13:21 <beluga_> colonelqubit: you mean unconfirmed ones or new?
13:13:47 <beluga_> bubli: welcome to meeting
13:13:53 <colonelqubit> beluga_: either one;  Recruiting people for the event is also a powerful motivator ;-)
13:14:42 <bubli> meeting?
13:14:49 <colonelqubit> So that's another good point: If any of you are triaging bugs between now and the weekend, and someone sounds competent in their bug report(s), please do invite them!
13:14:49 <sophi> not sure about New ones, more about Unconfirmed
13:15:01 <colonelqubit> bubli: QA Meeting
13:15:16 <bubli> (I'm here just to stare into void, don't plan to do anything constructive)
13:15:17 <colonelqubit> bubli: we're currently planning for the BugHunting Session for the 5.1 alpha1 this weekend
13:15:45 <colonelqubit> bubli: well, it *is* Halloween on Saturday, so staring into the void is very topical ;-)
13:16:19 <colonelqubit> Okay, let's take a look at what's been completed
13:16:25 <colonelqubit> #topic Completed Items
13:17:10 <colonelqubit> Beluga had two items: wiki Vote for Enhancement page and wiki Tracking Bugs page
13:17:44 <beluga_> except I took the vote to mean that I only create a redmine ticket ;)
13:18:01 <colonelqubit> beluga_: lazy-evaluation
13:18:03 * colonelqubit approves ;-)
13:18:04 <bubli> Hm, does our bugzilla have voting feature?
13:18:16 <beluga_> bubli: it could have it but we don't want it to
13:18:18 <colonelqubit> bubli: we could enable it, but we had some caveats
13:18:46 <colonelqubit> bubli: the current plan is to turn it into something like Launchpad's 'heat' feature
13:19:26 <beluga_> low priority task, for sure
13:19:31 * colonelqubit nods
13:19:44 <colonelqubit> So for anyone out there who's excited to jump in... :-)
13:20:04 <colonelqubit> beluga_: regarding the Tracking Bugs page, can the RSS plugin show #s for each row?
13:20:15 <colonelqubit> (might be a question for DennisRoczek)
13:20:38 <beluga_> yeah Dennis should answer that one
13:21:30 * colonelqubit nods
13:21:57 <colonelqubit> #topic Pending Items
13:22:14 <colonelqubit> Let's see...
13:22:32 <colonelqubit> jphilipz: Any updates on ACTION: Make a simple page of things new QA should be aware of (jphilipz) ?
13:23:22 <jphilipz> colonelqubit: yes i started the google doc, let me go grab it
13:24:06 <colonelqubit> great!
13:26:09 <colonelqubit> If DennisRoczek shows up, he can mention if he filed a bug re: the OS picker in Bugzilla
13:26:44 <colonelqubit> No sign of Liongold or tagezi, so we'll punt on Stats
13:27:47 <colonelqubit> jphilipz: got that link?
13:27:52 <jphilipz> colonelqubit: https://docs.google.com/document/d/1CGhkvqZBg-G_uYJFiNS8-d-P2VjyDE8Z2-rtqM__VG4/edit?usp=sharing
13:28:06 <beluga_> colonelqubit: Liongold suspended the stats project due to the dashboard tender
13:28:09 <jphilipz> just the outline has been done, but will start filling in more shortly
13:28:20 <colonelqubit> jphilipz: great, thanks!
13:28:44 <colonelqubit> Okay, I think that's it for Pending Items
13:29:00 <colonelqubit> #topic New Items
13:29:10 <colonelqubit> Any New Items to discuss?
13:29:34 <colonelqubit> How are regressions looking?
13:30:37 * colonelqubit hmms
13:31:06 <colonelqubit> I see two bugs on the shortlist: http://ur1.ca/nkp0t
13:31:48 <colonelqubit> Those are bugs that have been moved into  highest priority ("MAB" status) in the past week or so
13:32:47 <beluga_> I started wondering, if we perhaps get mostly regressions or duplicates these days :)
13:33:10 <colonelqubit> beluga_: you mean, is the dupe percentage higher?
13:33:24 <beluga_> just my subjective feeling
13:33:36 <beluga_> regarding the volume of reports flowing in
13:33:49 <colonelqubit> beluga_: so dupes of regressions, or of all bugs?
13:34:13 <beluga_> regressions + dupes of all bugs ever
13:34:44 <beluga_> btw. I want to mention that Dennis is working on getting a wikitext syntax highlighter extension working https://phabricator.wikimedia.org/T116829
13:34:57 <sophi> colonelqubit: not a new item but an information, Kader has written several tests for MozTrap, she needs to polish them a little bit, but they are really nicely completing the run :) Once this is done, we'll work together on new tests dedicated to 5.1 new functionalities
13:35:26 <bubli> Hehe, another LibreLady
13:36:01 <sophi> bubli: yeah! :)
13:36:06 <colonelqubit> sophi: great!
13:36:25 <beluga_> btw. any action on LibreLadies movement?
13:36:43 <bubli> Nah
13:36:49 <colonelqubit> Y'all have t-shirts yet? :-)
13:38:14 <bubli> I would want LibreLadies to have some mission, like e.g. be the patrons of mentoring programme -
13:38:15 <colonelqubit> bubli: I continue to hear interest in having hackfests in the US. I had a couple of people suggest that I look at the Grace Hopper conference as a possibility
13:38:59 <bubli> as without any mission, it'll be only some platform for women already in the project to bitch about men in the project & anything one can bitch about
13:39:14 <bubli> it will totally not help to get *more* women into the project
13:39:56 <beluga_> so kadert wants to work on Python stuff and I guess our best bet now is to wait for mjayfrancis
13:40:49 <bubli> colonelqubit: If Grace Hopper con could organize LibO hackfest, I'd be all in
13:41:20 <kadert> Hello. I'm new here . I like to work in the field of testing libreoffice. I started writing manual tests in Moztrap. But i want to write unit test for python. I want  to create automation tests.for LibreOffice
13:42:15 <colonelqubit> bubli: I wish that the Grace Hopper conf had more of a focus on FOSS, but at least it has some: https://opensource.com/life/13/6/grace-hopper-event-2013
13:43:17 <IZBot> News from tdfnew: [Bug 95394] Fill dialog inconsistency when filling with an image <https://bugs.documentfoundation.org/show_bug.cgi?id=95394>
13:43:18 <colonelqubit> kadert: great!
13:44:19 <colonelqubit> beluga_: I assume that mjayfrancis is being occupied by the Junior LibreOffice League right now?
13:44:31 <colonelqubit> (or at least his time is...)
13:44:55 <beluga_> only for a couple of days still
13:44:59 * colonelqubit nods
13:45:03 <bubli> colonelqubit: Have you ever made any contact with those Grace Hopper ladies?
13:45:38 <colonelqubit> bubli: I know a few of the people there....and I'm probably 1 hop away for most of the rest of them
13:46:27 <colonelqubit> bubli: Please send me an email, and let's chat more about planning for Grace Hopper for next year
13:47:15 <colonelqubit> bubli: maybe get a LibreLadies mailing list going as well, so we can share the planning?
13:47:24 <bubli> T-shirts :)
13:47:59 <bubli> Would that be something for ESC tomorrow?
13:48:25 <bubli> it's rather non-technical, so maybe not (doesn't fit the "engineering" category)
13:48:31 * colonelqubit hmms
13:49:01 <colonelqubit> Sure, but it would publicize it a bit. And give it a bit of a stamp of approval
13:49:46 <colonelqubit> bubli: wait, are you talking about a mailing list or t-shirts?
13:50:27 <bubli> colonelqubit: Mailing list
13:50:51 <bubli> and well, the existence of LibreLadies in general
13:51:30 <DennisRoczek> colonelqubit: pong (readng log, very busy atm)
13:51:53 <DennisRoczek> colonelqubit: what o you mean with "can the RSS plugin show #s for each row?"
13:53:12 <colonelqubit> bubli: Let's chat more over email
13:53:12 <colonelqubit> Any more New Items to discuss?
13:53:14 <colonelqubit> #action Follow-up re: LibreLadies, t-shirts, mailing list, and possible Grace Hopper Hackfest (bubli, colonelqubit)
13:53:15 <colonelqubit> #topic BugHunting Session 5.1
13:53:50 * colonelqubit puts the BugHunting Session discussion on hold
13:54:06 <colonelqubit> DennisRoczek: yeah, just two items for you
13:54:18 <colonelqubit> 1) Did you file that Redmine bug re: the OS field in Bugzilla?
13:54:49 <bubli> In the meantime -
13:54:55 <colonelqubit> 2) Re: the plugin used to display Bugzilla data on MediaWiki, can we use it to show bug counts for each row?
13:55:13 <colonelqubit> bubli: yes? :-)
13:56:07 <bubli> someone can try to reproduce tdf#95382 ...
13:56:12 <IZBot> LibreOffice-Chart normal/medium NEEDINFO Application crash when confirming font change with enter key https://bugs.documentfoundation.org/show_bug.cgi?id=95382
13:56:19 <colonelqubit> DennisRoczek: it would be nice to have total count next to these: https://wiki.documentfoundation.org/QA/Tracking_Bugs#Tracking_bugs_for_specific_topics
13:56:23 <DennisRoczek> colonelqubit: the bug report about the os was filed by err somebody else
13:56:23 <bubli> on Linux + gtk[23] vcl plugin and on Windows
13:56:39 <colonelqubit> DennisRoczek: ah, great. Do you have the #?
13:56:50 * colonelqubit 's addled brain didn't see it the first time 'round
13:59:40 <beluga_> bubli: that reporter is in CERN :)
14:00:06 <colonelqubit> beluga_: so they're radioactive?
14:00:14 <colonelqubit> or just underground...
14:01:01 <colonelqubit> DennisRoczek: we can follow-up on details a bit later
14:01:07 <colonelqubit> Let's get back to the BugHunting Session
14:01:12 <colonelqubit> So, This weekend
14:01:16 <beluga_> colonelqubit: they are particular
14:01:27 * colonelqubit laughs
14:01:36 <colonelqubit> beluga_: should we invite them to the BugHunting Session?
14:01:54 <colonelqubit> I'm sure that moggi would like to harness their supercomputers for automated testing...
14:02:07 <beluga_> sure
14:02:09 <colonelqubit> Link for the lazy: https://wiki.documentfoundation.org/BugHunting_Session_5.1.0.0
14:02:37 <colonelqubit> We just have two people listed under 'Mentors' right now
14:02:52 <colonelqubit> I'll be helping most of Friday
14:03:15 <beluga_> I will add myself when I am sure of my schedule
14:03:19 <colonelqubit> beluga_: thanks
14:03:44 <colonelqubit> sophi: can you add the day/time next to your name?
14:04:26 <colonelqubit> Oh, we lost Cor.  Shoot! ;-)
14:04:27 <sophi> colonelqubit: was planed for Saturday and Sunday
14:04:41 <colonelqubit> sophi: great!
14:05:01 <colonelqubit> ahoneybun: what days will you be joining us? :-0
14:05:21 <colonelqubit> dave_largo: and you?
14:05:38 <sophi> with less availability on Sunday afternoon, but Italo will ping me on my phone in case
14:05:46 <colonelqubit> Cool
14:06:49 <bubli> If you guys need mentors, I could perhaps help for some 2 h on Fri
14:09:09 <colonelqubit> I'll try to check on Saturday, but as it's Halloween here, it can get a bit crazy
14:09:09 * colonelqubit just realized that there'll be an ESC call on Thanksgiving...
14:09:09 <colonelqubit> As I mentioned in my email, we've already done some advertising, but reaching more people is great
14:09:10 <colonelqubit> I'm going to push out a blog post today, and see about inviting some people who've joined QA in the past
14:09:47 <colonelqubit> bubli: thanks! Yeah, we're mostly just hoping to have people active in this channel, in case newbies have questions
14:11:42 <colonelqubit> bubli: I'll be keeping an eye on things from the morning my time (13:00 UTC), but it'd be great to have eyes in here earlier than that
14:11:47 <bubli> beluga_: I suspect that CERN chap has gtk plugin, gtk3 even and it simply doesn't crash anywhere else
14:12:27 * bubli builds with --disable-gtk since the beginning of time, so no cookies
14:12:55 <colonelqubit> I think that's about it for the BugHunting Session
14:13:04 <colonelqubit> #topic Wrapping Up
14:13:11 <colonelqubit> Anything else to cover?
14:13:21 <colonelqubit> Something important I should bring to the ESC tomorrow?
14:13:42 <bubli> Eh, I'm sorry guys, I wasn't fully aware of the fact that I'm stepping over your QA meeting
14:13:54 <colonelqubit> bubli: you're always welcome :-)
14:13:57 <bubli> by lookin' for someone to reproduce silly bugs
14:14:22 <DennisRoczek> colonelqubit: regariding bug count: i can add another column with a count (if you o want that) or do you imply want a count of total of the rss query?
14:14:46 <DennisRoczek> see https://wiki.documentfoundation.org/index.php?title=User:Dennisroczek&oldid=117890 <-- "5 Open; 0 Resolved; 5 Total (0% complete)" there is already a count... -.-
14:15:02 <DennisRoczek> err i should read first the log
14:15:15 <DennisRoczek> ah that is easy
14:15:50 <colonelqubit> cool, cool
14:16:28 <DennisRoczek> colonelqubit: reload https://wiki.documentfoundation.org/QA/Tracking_Bugs#Tracking_bugs_for_specific_topics
14:17:05 <DennisRoczek> do you want to have that on page / rss feed basis or simply on all pages?
14:17:11 <DennisRoczek> or better bullet points?
14:17:27 * colonelqubit looks suspiciously at those numbers...
14:17:53 <colonelqubit> DennisRoczek: I was thinking about totals for each tracking bug
14:18:17 <colonelqubit> Like Macro Recording: 4 open out of 25 total
14:18:36 <beluga_> colonelqubit: oh.. you don't ask little, do you? :P
14:19:12 <colonelqubit> beluga_: if it's not easy, that's fine -- we can just open a bug and fix it later
14:19:36 <beluga_> if the RSS data contains dependency info then it could be done.. Dennis can comment
14:20:08 <colonelqubit> I just think it'd be very helpful to be able to view the Tracking Bugs and get an overview of how many bugs are open in those categories
14:20:14 <DennisRoczek> colonelqubit: beluga_: right i need a element in the rss feed or i have to hack the extension - might be both worth..
14:20:31 <DennisRoczek> colonelqubit: or use the bugzilla integration
14:20:35 * colonelqubit nods
14:20:41 <DennisRoczek> like at  https://wiki.documentfoundation.org/index.php?title=User:Dennisroczek&oldid=117890
14:20:55 <DennisRoczek> filter it and then you are even able to sort the stuff ;-)
14:21:08 <DennisRoczek> and even and odd line highlight
14:21:28 <colonelqubit> sure, we can go crazy :P
14:21:48 * sophi has to move to another meeting in 10 mn
14:21:58 <DennisRoczek> why crazy? it is nicer, beatiful, better ux to use (sorting, filtering, etc)
14:22:13 <colonelqubit> #action Investigate/file bug re: Adding Open/Resolved/Total numbers to the Tracking Bugs wiki page (DennisRoczek)
14:22:39 <colonelqubit> DennisRoczek: yeah, I just meant that we could go all-out
14:22:48 <colonelqubit> Okay, looks like we're done here
14:22:53 <colonelqubit> Big thanks to all of you for showing up
14:23:15 <colonelqubit> Thanks to beluga_ and DennisRoczek for working on Action items
14:23:38 <colonelqubit> Show up to the BugHunting Session this weekend, and invite your friends!
14:23:50 <colonelqubit> #endmeeting