18:06:14 <colonelqubit> #startmeeting
18:06:14 <IZBot> Meeting started Wed Oct 21 18:06:14 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
18:06:14 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:06:37 <dougmencken> meeting?
18:06:38 <colonelqubit> UNCONFIRMED bugs: 483
18:06:56 <colonelqubit> dougmencken: :-)
18:06:58 <beluga_> dougmencken: watch the magic unfold
18:07:12 <colonelqubit> beluga_: did I tell you I found a walrus?
18:07:22 <beluga_> colonelqubit: in Texas??
18:07:30 <colonelqubit> beluga_: yes, but he's very little
18:07:35 <colonelqubit> (sitting on my monitor now)
18:07:47 <dougmencken> colonelqubit: by the way if I can confirm that GUÍA isn't correctly parsed, so I am supposed to set its state from UNCONFIRMED to NEW or not?
18:08:05 <colonelqubit> what isn't parsed?
18:08:13 <dougmencken> guía
18:08:34 <dougmencken> name is so funny
18:08:40 <dougmencken> here it is https://bugs.documentfoundation.org/show_bug.cgi?id=95230
18:08:41 <IZBot> bug 95230: LibreOffice-Writer normal/medium UNCONFIRMED Formula displayed by LO is not correct and show red "?" signs in formula text
18:09:06 <beluga_> dougmencken: yes you can set it to NEW
18:09:46 <dougmencken> beluga_: okay did it and what's changed?
18:10:19 <colonelqubit> dougmencken: in general, if LO doesn't render a symbol or equation in a significantly-similar way to MSO, then it's something we should investigate
18:10:40 <colonelqubit> bug looks UNCONFIRMED to me -- make sure to save your changes
18:11:18 <dougmencken> guía is NEW
18:12:11 <dougmencken> also why is component >>Writer<< ; it looks like filter/parser issue
18:12:16 <colonelqubit> ah good; sorry -- my internet connection here is very bad right now :P
18:13:10 <colonelqubit> dougmencken: it's possible that it wasn't triaged into the right Component
18:13:34 <colonelqubit> Let's get through a few items first, then we can return to that bug a bit later
18:13:54 <dougmencken> meanwhile as I thought guía is universal word https://translate.google.com/#auto/en/gu%C3%ADa
18:14:16 <colonelqubit> #topic Pending Items
18:14:19 <dougmencken> timetable, bacon, pilot, ...
18:14:29 <dougmencken> everything is guía
18:15:57 <colonelqubit> actually, make that Completed items
18:15:57 <colonelqubit> #topic Completed Items
18:15:57 * colonelqubit nudges IZBot
18:16:08 <colonelqubit> thank you IZBot
18:16:21 <dougmencken> so informative topic
18:16:27 <colonelqubit> So, the baseline image tests are done for OSX
18:16:57 <colonelqubit> Dennis R. helped out with Windows tests, but I still want to check back about some results before I make an announcement
18:17:38 <colonelqubit> The Summary page (https://wiki.documentfoundation.org/Media_Support/Summary) is a handy place to verify whether certain formats should work on certain platforms
18:18:20 <colonelqubit> Bugzilla: patch to auto-add tags to the Whiteboard is in place
18:18:39 <colonelqubit> please take a look here if you haven't already: http://bugzilla-test.documentfoundation.org/
18:19:06 <colonelqubit> Right now we're just adding a couple of tags, but we can discuss adding more before we roll any changes out to production
18:19:17 <colonelqubit> beluga_: You had some thoughts?
18:19:52 <beluga_> colonelqubit: about the tags? I don't remember having thoughts about them
18:20:13 <colonelqubit> beluga_: even better -- we're done! :-)
18:20:28 <colonelqubit> But yes, if you haven't tried them out, please go play on the test VM
18:20:43 <colonelqubit> The general idea is to remove each tag as soon as that part of triage is done
18:21:06 <colonelqubit> dougmencken: so for example, once you've correctly set the Component, you could remove a tag such as 'triageComponent'
18:22:32 <colonelqubit> One more completed Item: The QA-list moderation queue is finally cleared
18:23:13 <colonelqubit> it had several hundred pieces of SPAM, and (of course) a few good emails buried in there, including some requests to join our merry band
18:23:32 <IZBot> News from tdfnew: [Bug 95228] FILEOPEN DOCX Textboxes overlap <https://bugs.documentfoundation.org/show_bug.cgi?id=95228>
18:23:50 <colonelqubit> So if you're one of our list mods/admins, please chip in whenever you see the list getting long
18:23:57 <beluga_> ah like the SF contact http://lists.freedesktop.org/archives/libreoffice-qa/2015-October/009118.html
18:24:15 * colonelqubit nods
18:24:16 <colonelqubit> yep!
18:24:46 <colonelqubit> #topic Pending Topics
18:25:14 <colonelqubit> As I mentioned above, Image Testing is done, but I need to clarify some results before we broadcast the Summary page again
18:25:58 <colonelqubit> If anyone has suggestions on improvements to those pages, or would like to add 'Android' to our list of tested OSes, please poke me or just jump in and start making some new pages!
18:26:14 <colonelqubit> Pending ACTION items:
18:26:52 <colonelqubit> mjayfrancis is probably busy with the junior QA team
18:27:23 <colonelqubit> jphilipz: any updates on the simple-page of QA info for new people?
18:28:18 <jphilipz> colonelqubit: had brainstormed about it but havent done more than that. :D
18:28:49 <colonelqubit> jphilipz: great!  If you like, perhaps we can partner you up with some newcomers, as they might have some additional inspiration?
18:29:18 <jphilipz> colonelqubit: will create a google doc for my brainstorming to share with the QA team
18:29:22 <colonelqubit> cool
18:29:52 <colonelqubit> We've got an ACTION item regarding the overhaul of MABs. I think most pieces have been updated
18:30:24 <colonelqubit> we've reviewed all the old mab-tracker-bugs. Tommy has overhauled/closed them, I believe
18:30:55 <colonelqubit> wiki docs are updated, etc.., so I think we're pretty much done here
18:30:58 <colonelqubit> Anything else that I'm missing?
18:32:05 <dougmencken> ``I've been using Libre Office and find it as convenient as with Microsoft Office. We appreciate your time and effort on this bug.
18:32:19 <dougmencken> ...why reporters write this?
18:32:34 <colonelqubit> dougmencken: well, it beats them swearing? :P
18:33:09 <colonelqubit> Some people are just being nice, I think. Others are hoping that a little sugar on top will endear us to them, and get the bug fixed faster...
18:34:01 <colonelqubit> [DONE] ACTION: Review MABs, wiki pages and other resources dependent on  them, and determine workload to switch over to using Priority:highest  (Robinson or Other)
18:34:49 <colonelqubit> Last ACTION item regards recruiting, which leads us into the next piece: BugHunting Session 5.1
18:35:04 <colonelqubit> #topic BugHunting Session 5.1
18:35:17 <colonelqubit> https://wiki.documentfoundation.org/BugHunting_Session_5.1.0.0
18:35:46 <colonelqubit> Dates are Oct 30 - Nov 1st
18:36:10 <colonelqubit> So I've nicknamed this our "Halloween BugHunting Session"
18:36:29 <colonelqubit> Is Halloween celebrated much outside of North America?
18:36:43 * colonelqubit saw some decorations in a store in Denmark..
18:37:12 <thorsten> yeah, it's kind of a thing here since ~10-15 years
18:37:39 <colonelqubit> thorsten: holiday == profit?
18:37:55 <thorsten> no holiday, but still profit, yep
18:37:57 <dougmencken> why ony 3 days?
18:38:28 <colonelqubit> dougmencken: a shorter period can concentrate  and liven the work, I think
18:39:06 <colonelqubit> Just a single day is a bit tricky, and it's nice to have time both during the week and the weekend (as some people have one or the other available)
18:39:32 <dougmencken> colonelqubit: well I actually mean why not a week at least
18:39:36 <colonelqubit> ah, okay
18:40:10 <colonelqubit> dougmencken: We do try to have coverage in IRC and keep people energized for that time
18:40:24 <thorsten> dougmencken: I suppose it's pretty exhausting for the mentors/regulars - you'd want to maintain some 24/7 irc presence to direct/mentor/handle people ...
18:40:32 <dougmencken> energized (:
18:40:56 <colonelqubit> in the future, perhaps we could extend an event up to a week, but I think that 3 days is a good span for now :-)
18:41:15 <dougmencken> so it's assumed to be 3-day 24-hour marathon huh?
18:41:24 <colonelqubit> beluga_: has the BH Session been mentioned on Reddit yet?
18:41:32 <beluga_> colonelqubit: not yet
18:42:00 <steve-_-> colonelqubit: is there time to discuss the bugzilla assistant (just ping me when there's space for that)…
18:42:11 <colonelqubit> steve-_-: yes, definitely -- just chugging through here :-)
18:42:39 <thorsten> colonelqubit: syed just in, wants to help with bug verification - want to fill him in? :)
18:42:40 <colonelqubit> beluga_: Could you take care of reddit stuff? And perhaps elsewhere?
18:42:45 <beluga_> yeah
18:42:49 <colonelqubit> syed: welcome!
18:42:55 <syed> thanks
18:43:16 <colonelqubit> syed: we're currently chatting about our upcoming BugHunting Session (Oct 30 - Nov 1st)
18:43:46 <colonelqubit> Will you be available some of that time to help us find bugs in our alpha1 build?
18:43:48 <syed> well, hit me!!
18:43:53 <colonelqubit> :-)
18:44:34 <syed> yeah sure, but i am new at it
18:45:21 <beluga_> syed: you will have time to study it https://wiki.documentfoundation.org/QA/Triage_For_Beginners
18:45:29 <colonelqubit> syed: great! We're going to chug through some more topics for our QA Meeting right now -- feel free to ask q's, and at the end we can chat a bit more about Triaging
18:45:47 <colonelqubit> let's see ... so BugHunting Session.
18:45:48 <syed> ohh , that would be great
18:46:22 <colonelqubit> As thorsten mentioned, we definitely do want to have knowledgeable people in IRC
18:47:04 <colonelqubit> Mentors!  Please add your name and which days/rough times you'll be around here: https://wiki.documentfoundation.org/BugHunting_Session_5.1.0.0#Mentors
18:48:06 <colonelqubit> Soooo, new things
18:48:17 <colonelqubit> #topic New Topics
18:48:52 <steve-_-> time for the wiz question?
18:49:04 <colonelqubit> Dennis had a quick action item: remove unsupported und unbuildable OSes from os picker in bz
18:49:26 <colonelqubit> #action Add bug to redmine for "remove unsupported und unbuildable OSes from os picker in bz" (Dennis)
18:49:26 <colonelqubit> ;-)
18:49:52 <colonelqubit> steve-_-: one sec, joel had something
18:50:43 <colonelqubit> beluga_: anything further re: the OpenGL questions from Joel?
18:51:09 <beluga_> well meeks answered that we should just put them in the meta bug
18:51:18 <beluga_> https://bugs.documentfoundation.org/show_bug.cgi?id=93529
18:51:20 <IZBot> bug 93529: LibreOffice-graphics stack normal/medium NEW Meta: VCL/OpenGL tracker bug for 5.0+
18:51:36 <beluga_> even if unconfirmed
18:51:55 <colonelqubit> yep, I saw that
18:52:12 <colonelqubit> Okay, let's consider the OpenGL question Asked and Answered for now
18:52:52 <colonelqubit> steve-_-: your turn! Tell us about the Wizard
18:54:10 * colonelqubit wonders if it's anything like the Wizard of Oz
18:54:57 <colonelqubit> tagezi: did you have a question about Bugzilla?
18:56:20 <beluga_> colonelqubit: I think Liongold's stats project would answer tagezi's needs
18:57:35 <tagezi> beluga_: This project is crude.
18:57:53 <beluga_> tagezi: no, it is unfinished
18:58:44 * colonelqubit laughs
18:58:57 <colonelqubit> tagezi: the *qa channel* is crude
18:59:04 <tagezi> colonelqubit: I thought to take bugs information and process them
18:59:10 <colonelqubit> yep, sounds good
18:59:54 <tagezi> crude = unfinished )
19:00:57 <colonelqubit> tagezi: so... do you think you two will be working together on that?
19:01:29 <beluga_> we need to get tagezi some assistants first, so he will have time for this new project
19:01:58 * colonelqubit nods
19:02:59 <colonelqubit> like elves?
19:03:03 <tagezi> what is project?
19:03:17 <beluga_> like the cabal of furiously typing elves
19:03:26 <beluga_> tagezi: the project is Liongold's
19:04:03 <beluga_> steve-_-: seems to be afk so let me slip in a suggestion: let's remove this page: https://wiki.documentfoundation.org/Vote_for_Enhancement
19:04:11 <tagezi> beluga_: I said that I have no time for it
19:04:22 <colonelqubit> if that's what I think it is...
19:04:31 <colonelqubit> quickly back to the previous topic
19:04:31 <beluga_> tagezi: and I said you will have time, if we get you assistants to do what you are currently doing
19:04:54 <colonelqubit> Perhaps tagezi and Liongold can chat about the project and what needs to get done?
19:05:00 <colonelqubit> would be great to hear more next week?
19:05:43 <colonelqubit> #action Chat about status of stats project and what's next on the todo list (tagezi, Liongold)
19:06:13 <colonelqubit> beluga_: oh goodness, the voting page
19:06:26 <colonelqubit> It obviously shouldn't be something edited by hand
19:06:43 <tagezi> beluga_: even if you do find 5 assistants, perfectly speak English and Russian, I can do it in about a year.
19:06:57 <tagezi> next year
19:07:07 <colonelqubit> tagezi: can we just find 5 people who speak English, and 5 who speak Russian?
19:07:09 <colonelqubit> :P
19:07:28 <colonelqubit> #mythicalManMonth
19:08:03 <colonelqubit> The short explanation is that we don't want to mislead people into thinking that voting is going to influence our development choices
19:08:55 <colonelqubit> Wow! I had no idea that the page had been maintained so much -- so many edits in october alone!
19:09:40 <colonelqubit> beluga_: If we remove that page, then I think people will want to go elsewhere
19:10:20 <beluga_> colonelqubit: we must stop them
19:10:36 <colonelqubit> I don't like to engender false hope, but I definitely don't want to enable anything on Bugzilla to replace one misguided thing with another
19:10:59 <colonelqubit> The best compromise I've heard so far is the 'heat' metric on Launchpad
19:11:28 <colonelqubit> It's not called a 'vote', it's not tracked as a counting number
19:11:58 <colonelqubit> IIRC, it's just a display of how many people currently care about this particular issue
19:12:22 <colonelqubit> and therefore could be *one* of many variables that devs take into account
19:12:36 <beluga_> colonelqubit: yeah, the page should be replaced with a message that calls for something better that doesn't give the false hope etc.
19:12:50 <colonelqubit> I'm honestly very surprised to see so many edits there
19:13:07 <beluga_> same here..
19:13:16 <colonelqubit> let's document it and move on
19:13:19 <beluga_> wasted manhours :(
19:14:36 <colonelqubit> #action Add redmine issue to (gently) replace Vote_for_Enhancement page on wiki with something more realistic (e.g. Launchpad's 'heat' metric) (beluga)
19:15:11 <colonelqubit> beluga_:  we can discuss particulars in redmine. I don't want to just bulldoze the page, given how much people appear to be invested in it..
19:15:12 <beluga_> one suggestion regarding wiki: we should add a list of META bugs somewhere
19:15:26 <colonelqubit> beluga_: I factored-out tracking bugs from the old MAB page
19:15:52 <colonelqubit> https://wiki.documentfoundation.org/QA/Tracking_Bugs
19:16:10 <colonelqubit> that page could use some love
19:16:17 <beluga_> ah just found it :)
19:16:27 <beluga_> colonelqubit: we should use the RSS extension
19:16:53 <beluga_> I understand it can be used for any BZ query
19:16:54 <colonelqubit> Sure, definitely. Chat with Dennis if you need more goodies available in the wiki. He talked about improving the Bugzilla-Mediawiki extension
19:16:56 <markit> is there a system wide setting where I can disable HW acceleration for all users at once? I've a ltsp server
19:17:11 <beluga_> Dennis already uses the RSS extension, Simplefeed got replaced
19:17:21 <colonelqubit> beluga_: ah, cool
19:17:32 <colonelqubit> #action Update tracking bug page to be more complete (beluga)
19:17:56 <colonelqubit> markit: probably set in userprofile?
19:18:00 <beluga_> https://wiki.documentfoundation.org/WikiAction/edit/Category:Pages_with_RSS_feeds
19:18:11 <colonelqubit> markit: possibly diff it, then propagate change?
19:18:11 <markit> colonelqubit: I've > 300 users on this server
19:18:47 <markit> colonelqubit: and if I create a new user? Should be something global, like KDE let you have (/etc/kde/whateversetting)
19:19:19 <colonelqubit> markit: Hmm... I'd check over in #libreoffice
19:19:42 <colonelqubit> that's the extent of my knowledge about dealing with multiple users :-)
19:20:01 <colonelqubit> Okay folks, I think that's completed the list of completed, old, and new items
19:20:39 <colonelqubit> did steve-_- ever come back?
19:21:15 <colonelqubit> It's been an hour, so let's wrap things up. We can talk more about the Wizard and other fun things next week.
19:21:38 <colonelqubit> Remember: BugHunting Session on Oct 30, 31, and Nov 1st (that's a Friday, Sat, and Sunday)
19:22:10 <colonelqubit> And please go poke at the Test VM and give me feedback on the auto-added whiteboard tags
19:23:54 <colonelqubit> I'll email out about the alpha1 builds for LibreOffice 5.1 shortly. As expected, win64 was petulant and we had to poke it with a stick a few times.
19:24:14 <colonelqubit> Thanks, everyone!
19:24:22 <colonelqubit> #endmeeting