13:21:19 <colonelqubit> #startmeeting
13:21:19 <IZBot> Meeting started Wed Sep  9 13:21:19 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
13:21:19 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:21:28 <colonelqubit> okay, to copy that in
13:21:37 <colonelqubit> UNCONFIRMED count is at 538 (yikes!)
13:21:49 <colonelqubit> After a few hiccups, 5.0.2.1 is pushed out
13:21:58 <colonelqubit> We've got updated patches on bugzilla-test VM for restricting access to the Priority and Severity fields
13:22:05 <colonelqubit> And the conference in Aarhus is coming up soon
13:22:14 <colonelqubit> Who's here?
13:22:56 * sophi is here
13:23:01 * beluga_ is
13:23:04 * mjayfrancis is too
13:23:11 <colonelqubit> ahoneybun: you awake?
13:23:28 <colonelqubit> (we'll see if he joins us)
13:24:16 <colonelqubit> #topic Pending Topics
13:25:05 <colonelqubit> Multimedia testing --> this topic's been on the list for a long time w/no change. Unless someone wants to change/update it, I suggest removing it
13:25:50 <colonelqubit> (I think that we just need to finish some image tests on OS X)
13:26:35 <colonelqubit> Okay, sounds like no objections, so I'll remove it
13:27:28 <colonelqubit> We also have a note about tracking down UserProfile issues. I think this was a suggestion by Joel a while ago. Is there any update?
13:28:26 <sophi> colonelqubit: there has been a tracking done by a FR member, I can sum up the report on the QA list
13:28:36 <colonelqubit> sophi: that'd be great
13:29:20 <beluga_> I was also doing it, but then I went to summer cottage
13:29:46 <beluga_> I have a file with a list that I have to go through
13:29:56 <colonelqubit> sophi: I recall seeing a bug that has suggestions for improving how we deal with UserProfile problems
13:30:22 <colonelqubit> IIRC, it mentions a concept for uploading invalid UserProfiles, etc.
13:30:34 <beluga_> now I have 20 examples, before June 2013
13:30:58 <beluga_> still would have to look at 680 reports
13:31:30 <beluga_> but maybe it is not needed to convice improving the situation?
13:31:39 <sophi> colonelqubit: thread is there http://nabble.documentfoundation.org/Enquete-sur-le-profil-de-LibreOffice-non-lieu-td4143623.html#a4144557 with a report on the study
13:32:31 * colonelqubit puts on his French reading glasses
13:32:47 <sophi> colonelqubit: I'll do a summary for the QA list
13:32:56 <colonelqubit> great
13:33:06 <beluga_> À partir d’une recherche, via l’outil de l’hébergeur de la liste Nabble, au mot « profil », 166 messages dans lesquels le profil avait été soit incriminé soit suggéré comme solution au problème signalé ont été retenus sur l’ensemble des 31 795, soit 5 852 fils de discussions. Sur ces 166 messages, seulement un tiers (52 messages) ont fait apparaître que la réinitialisation du profil ou celle de certains
13:33:29 <colonelqubit> #action Summarize UserProfile study and send to QA list (sophie)
13:33:29 <beluga_> well I've been looking at BZ myself
13:34:09 <colonelqubit> Here's the bug I was talking about:
13:34:09 <colonelqubit> https://bugs.documentfoundation.org/show_bug.cgi?id=53583
13:34:11 <IZBot> bug 53583: LibreOffice-LibreOffice enhancement/medium NEW Helper tool collecting user configuration (User Profile)
13:34:59 <colonelqubit> beluga_: So what's your take on the UserProfile issues? Should we look at specific cases, or perhaps take a broader view?
13:35:30 <beluga_> colonelqubit: the profile should be diffable
13:35:44 <colonelqubit> beluga_: that sounds very reasonable to me
13:35:58 <mjayfrancis> Not even sure what the important parts of a profile are made of, but I presume the main config file(s) are XML
13:36:13 <mjayfrancis> That being the case, at most you would have to xmllint --format them, then diff
13:36:16 <mjayfrancis> Maybe
13:36:27 <mjayfrancis> Unless the order of the content was non-deterministic
13:36:29 <beluga_> so that
13:36:34 <colonelqubit> mjayfrancis: does xmllint --format sort the elements?
13:36:38 <mjayfrancis> Nope
13:36:39 <beluga_> helper tool should contain a diffing tool
13:36:50 <colonelqubit> mjayfrancis: you beat me to the punch line ;-)
13:37:07 <mjayfrancis> That however ought to be a Small Matter of Programming
13:37:26 <colonelqubit> Indeed -- computers are rather good at sorting
13:38:13 <colonelqubit> It sounds like making UserProfile structure and ordering deterministic could be done independently from writing and shipping a tool w/LibreOffice
13:38:24 <colonelqubit> however it would probably make a certain amount of sense to do both things concurrently
13:39:32 <sophi> the study shows that in fact the profile is not faulty and when we say remove your profile, it's about extensions or such that are corrupting things
13:39:46 <colonelqubit> sophi: ah, that's very interesting
13:40:05 <colonelqubit> sophi: so we should make sure that there's an easy way to remove or test extensions?
13:40:10 <sophi> so I'm not sure it's still relevant to follow-up on the profile story
13:40:40 <sophi> colonelqubit: it's already easy :)
13:40:45 <colonelqubit> mjayfrancis: this bug seems relevant: https://bugs.documentfoundation.org/show_bug.cgi?id=88585
13:40:47 <IZBot> bug 88585: LibreOffice-LibreOffice enhancement/low NEEDINFO Feature request: user profile synchronization across multiple LO installs
13:42:04 <colonelqubit> sophi: I thought it could be a bit more straightforward, especially if one has several installed...
13:42:34 <colonelqubit> But let's not get hung up here
13:42:52 <colonelqubit> mjayfrancis: could you write up a new bug/enhancement about making the UserProfile structure be deterministic?
13:44:07 <colonelqubit> beluga_: or perhaps you'd like to take that one?
13:44:29 <beluga_> colonelqubit: I wouldn't know how to write it
13:44:44 * cloph_away doesn't think it is worth making the profile deterministic by default - rather a script that compares two profiles should normalize the xml..
13:45:01 <cloph_away> only changes should be different xml snippets in the main config
13:46:29 <colonelqubit> cloph_away: okay, that sounds fine. I just wanted to make sure that the current pool of data can be transformed into a ordered/diffable object in a deterministic fashion
13:46:58 <colonelqubit> (The simplest way to do that seemed like just making it ordered in the first place)
13:47:29 <colonelqubit> (or I should say: The simplest way to accomplish that *and confirm that it doesn't break* is making it ordered)
13:48:05 <beluga_> sophi: I am reading the study, but I have had profile corruptions in dev builds with no extensions.. what exactly is the point?
13:48:32 <beluga_> whatever is the cause, it is a real problem and diffing might help
13:49:00 <colonelqubit> #action File an enhancement request for a script that normalizes and diffs two user profiles (mjayfrancis)
13:49:01 <sophi> beluga_: I'll write on the list, that was one of the conclusion, but I don't remember all, need to read it again
13:49:13 <beluga_> 32 pages :)
13:49:28 <colonelqubit> Okay, let's move on
13:49:45 <sophi> beluga_: well, it's quite verbose but the facts are in less pages ;)
13:49:57 <colonelqubit> Access control for certain Bugzilla fields
13:50:13 <colonelqubit> I've got updated patches live on the test VM
13:50:24 <colonelqubit> http://bugzilla-test.documentfoundation.org/
13:50:43 <colonelqubit> If you don't have an account there, please make one...or three ;-)
13:51:01 <beluga_> ok I see that priority is now restricted
13:51:05 <colonelqubit> Here's the current (intended) behavior:
13:51:28 <colonelqubit> 1) Setting/changing priority is restricted to the 'contributors' and 'admin' group
13:52:27 <colonelqubit> 2) Severity can be set/changed by anyone, but only 'admin' are allowed to mark a bugs as a 'blocker' (which is tentatively being renamed 'very critical'
13:52:32 <colonelqubit> )
13:53:08 <colonelqubit> If a non-admin tries to mark a bug as 'blocker', the system will demote the severity to 'critical'
13:54:48 <colonelqubit> Those are the basic rules. If anyone needs me to add/remove them from the 'contributors' group in the test VM, let me or one of the other admins know
13:55:48 <colonelqubit> Big thanks to early feedback by Beluga
13:55:56 <colonelqubit> Anyone have q's?
13:56:28 <beluga_> colonelqubit: works https://bugzilla-test.documentfoundation.org/show_bug.cgi?id=89083
13:56:49 <beluga_> colonelqubit: you should discuss recruiting at the conference
13:56:59 <colonelqubit> beluga_: great
13:57:11 <beluga_> thinking about a message displayed to new reporters
13:57:26 <beluga_> for the first couple of report submissions
13:57:53 <beluga_> referring to beginner triage, irc, maybe a couple of named mentors w/ emails added
13:57:58 <colonelqubit> okay, sounds like there are no q's about the patches, so let's talk about New stuff
13:58:03 <colonelqubit> #topic New topics
13:58:23 <colonelqubit> beluga_: So, recruiting and other QA activities at the conference
13:59:08 <colonelqubit> We have a few QA talks, CorNouws wants to run a QA roundtable type event, and there was interest in doing some QA triaging concurrently with the Hackfest
14:00:41 <colonelqubit> Talks should all be listed in the program. We should make sure that relevant QA ideas are considered for implementation after the conference
14:01:26 <colonelqubit> I'm not sure if Cor has a time planned for the roundtable, so I'll check with him
14:01:42 <sophi> colonelqubit: it's in the program on the site
14:02:00 <colonelqubit> sophi: ah, excellent!
14:02:17 <sophi> should be Thursday afternoon
14:02:51 <colonelqubit> sophi: is that the 'QA Lightning Talks' ?
14:02:58 <sophi> colonelqubit: yes
14:03:29 <colonelqubit> Great -- it'll be at 15:00
14:05:22 <colonelqubit> Re: the hackfest, I need to check with the organizers and confirm that we can have some QA activities, triaging, etc.. running as a part of that event
14:05:51 <IZBot> News from tdfnew: [Bug 94056] Editing <https://bugs.documentfoundation.org/show_bug.cgi?id=94056>
14:05:59 <colonelqubit> #action Check with hackfest organizers about small group working on QA stuff (Robinson)
14:06:31 <colonelqubit> beluga_: Suggestions about recruiting at Aarhus?
14:06:32 * sophi has a phone call now, see you later
14:06:36 * colonelqubit waves
14:07:10 <beluga_> colonelqubit: well not @ Aarhus, but in BZ
14:07:23 <colonelqubit> beluga_: Ah, okay. That's good as well
14:07:28 <beluga_> but if you could discuss recruiting strategies there
14:07:36 <beluga_> and how to automate it in BZ
14:07:45 <beluga_> and getting people to sign up as mentors
14:07:47 * colonelqubit nods -- I think that Cor mentioned recruitment
14:08:12 <colonelqubit> beluga_: Do you think that continuity in IRC is important?
14:08:13 <beluga_> maybe mentor list can be pulled from a wiki page
14:08:25 <beluga_> yes irc is good for mentoring
14:09:24 <colonelqubit> e.g. if someone shows up and nobody is here to answer q's, I expect that some will be less likely to return
14:10:18 <beluga_> there can be a short explanation about the nature of irc then
14:10:45 <beluga_> if we don't go openhatch's route with a dedicated Welcomebot :)
14:11:04 <beluga_> basically, "you are supposed to leave it running"
14:11:22 * colonelqubit hmms
14:11:24 <beluga_> it's not a phone call that you just hang up after a while :)
14:11:41 <beluga_> and anyways, I would include my email
14:11:59 <beluga_> no one has emailed me that they faced silence on irc so far
14:12:00 <colonelqubit> yeah, persistence on IRC can be a novelty
14:13:25 <colonelqubit> beluga_: so what concrete items would you propose?
14:13:51 <beluga_> to agree on the automated method of recruiting in BZ
14:14:11 * colonelqubit nods
14:14:13 <beluga_> work out the details @ the conf
14:14:55 <colonelqubit> yeah, I do think we need to make sure that anything automated is not annoying at all
14:15:47 <colonelqubit> e.g. don't send more than 1-2 automated messages, etc.
14:16:10 <beluga_> display it in BZ after submission
14:16:19 * colonelqubit knows that some systems get pretty excited about sending status updates, e.g. Meetup
14:16:47 <colonelqubit> beluga_: and would you display it each time, or just for the first couple of times one submits a bug?
14:16:59 <beluga_> first couple of times
14:17:53 <colonelqubit> As much as I initially was wary of 'gamification', I do think that there can be some very positive effects
14:18:25 <beluga_> anyway, it can be seen as advertizing, not with the goal of immediate results, but building a presence
14:18:37 * colonelqubit agrees
14:18:40 <mjayfrancis> I don't always have time to chat with people while I'm working even though I'm possibly the only one around in some time zones - but to be honest I see more people confused about what "QA" means than new people actually turning up about bugs directly
14:18:59 <mjayfrancis> I.e. they're looking for general answers
14:19:10 <beluga_> questions & answers yep
14:19:22 <mjayfrancis> Rename the channel to -bugs ;)
14:19:30 <colonelqubit> minus bugs?
14:19:50 <mjayfrancis> rather than -qa
14:20:10 <colonelqubit> ;-)
14:20:43 <colonelqubit> mjayfrancis: do you think that any of the looking-for-answers types might be recruited into QA?
14:21:04 <mjayfrancis> Well who knows, recruiting the impossible is more beluga's field ;)
14:21:15 <colonelqubit> I would guess the percentage would be quite low, although it may be a matter of lowering the threshold to completing the first QA-related task
14:21:25 <dave_largo> join #libreoffice-bugs :)
14:21:55 <beluga_> can we get an irc redirect :P
14:22:33 <dave_largo> I used Draw heavily the last few days, and it's a lot less twitchy than it was in the past.
14:22:50 <dave_largo> I probably haven't used it this much in a few years.
14:23:20 <colonelqubit> I think that this is where something like gamification could shine, as it would provide a structure in which shy people and those who wouldn't imagine that they could be a part of QA could slowly be brought into the fold
14:23:30 <dave_largo> There are some bugs in the area of setting the background image using Impress templates.
14:24:09 <dave_largo> But it's working great these days.
14:24:29 <colonelqubit> beluga_: As it was your suggestion for discussion, could you write up some thoughts about how we might best interact with bug filers re: automated messages, etc?
14:24:45 <beluga_> colonelqubit: yes
14:25:03 <colonelqubit> #action Write up ideas for automated messages for Bugzilla --> for discussion @ Aarhus (Beluga)
14:25:45 * colonelqubit looks at the topics list
14:25:46 <colonelqubit> Oh yes, finding appropriate bugs for hackfests/librefests
14:26:31 <colonelqubit> It's often an issue for us to find appropriate bugs that can be tackled by new(and newish) QA folks at community events
14:27:02 <beluga_> colonelqubit: there
14:27:08 <beluga_> are always bugs to retest
14:27:13 <colonelqubit> Any suggestions on how we can make it easier to identify/filter-out these gems?
14:27:43 <beluga_> fileopen & NEW?
14:27:59 <beluga_> dead easy, those
14:28:32 * colonelqubit nods -- yep, that's a good set
14:31:24 <colonelqubit> We have a few minor notes on the BugTriage page (https://wiki.documentfoundation.org/QA/BugTriage#Step_1._Find_Bugs_to_Triage), but could definitely use a separate page detailing more easy pieces
14:32:10 <beluga_> colonelqubit: this needs updating https://wiki.documentfoundation.org/QA/Bugzilla/Useful_Queries
14:32:28 <colonelqubit> beluga_: yeah, that page has been sort of a catch-all for various queries
14:33:09 <colonelqubit> it should probably be overhauled, and possibly split apart into a couple of pages
14:33:34 <beluga_> cloph said TDF Site bugs might be obsolete now and certainly new ones should go to redmine
14:33:50 * colonelqubit agrees with that
14:33:51 <mjayfrancis> There's so many of them, and so much to do though. Wrt "gamification", Bugzilla is a big ball of mud which makes it hard to see the actual triage work which needs doing
14:34:15 <mjayfrancis> Whereas what is really needed to capture ephemeral labour is more "swipe left, swipe right"
14:34:22 <colonelqubit> mjayfrancis: I agree
14:34:29 <mjayfrancis> Something to point out small, finite pieces of work
14:35:51 <colonelqubit> One simple aspect is: steps to reproduce
14:35:54 <IZBot> News from tdfnew: [Bug 94057] HELP Element bascode is missing in xmlhelp.dtd <https://bugs.documentfoundation.org/show_bug.cgi?id=94057> || [Bug 94058] WIKIHELP Syntax highlighting for Basic is broken <https://bugs.documentfoundation.org/show_bug.cgi?id=94058> || [Bug 94059] HELPAUTHORING the element bascode is not supported <https://bugs.documentfoundation.org/show_bug.cgi?id=94059>
14:36:41 <colonelqubit> it may be somewhat pedantic, but if someone files a bug and it doesn't have an enumerated list of steps to take to reproduce, I'm generally ok with it being triaged into NEEDINFO with a polite request for repro steps
14:37:46 <colonelqubit> That's a bit more work than just swiping left or right, but it's a somewhat small work chunk
14:38:34 <colonelqubit> I was also thinking about conducting in-person testing, just so I could talk with ordinary people about what is confusing/scares them away from QA
14:39:15 <colonelqubit> maybe there are some minor interface things we could do to make the team more approachable and improve chances of retention
14:40:55 <colonelqubit> I think that's all the topics that were brought up so far.
14:41:10 <colonelqubit> Any other topics we should discuss?
14:41:24 <beluga_> have one of those helpdesk chat widgets pop up in BZ
14:41:36 <beluga_> "Beluga is available for chat!"
14:41:44 <colonelqubit> "Live Person", with the stock image?
14:41:52 <beluga_> yeah a handsome beluga
14:42:02 <beluga_> stock marine mammal footage
14:42:12 <mjayfrancis> Partly in preparation for giving a talk, I've been working through some bugs in the  4.1/4.2 region which have been previously bibisected but not bisected
14:42:24 <mjayfrancis> I have a full bibisect for 4.2 and one's building for 4.1
14:42:44 <mjayfrancis> They're incremental builds though, which requires a pinch of salt to be taken in some cases
14:42:49 <colonelqubit> beluga_: having better integration/linking from bz -> qa-irc isn't the worst idea...
14:43:03 <mjayfrancis> Still, the list is 10 or so smaller than when I started
14:43:10 <colonelqubit> mjayfrancis: awesome!
14:43:23 <beluga_> yeah we already pull stuff from bz to irc, now we need to push people from bz to irc :)
14:44:01 <mjayfrancis> Unfortunately there are quite a lot which are still stuck in black holes - with the greatest of respect to some now semi-retired high volume committers, the habit of committing long sequences which don't individually compile can be very unhelpful
14:44:21 <colonelqubit> #action Make proposal for a small (SMALL!) patch to point people on Bugzilla to #libreoffice-qa IRC channel (Beluga)
14:44:35 <mjayfrancis> Particularly when the original person isn't around any more to bother about them
14:44:57 <colonelqubit> mjayfrancis: hopefully norbert's work with jenkins and ci is discouraging such behavior going forward
14:45:23 <mjayfrancis> Sure, I think that's helped, and will continue to provided people actually use it
14:46:31 <colonelqubit> mjayfrancis: I haven't had many cycles to use on that -- so it's somewhat optional to run one's commits through the build farm?
14:47:10 <mjayfrancis> Developers get commit rights direct to git, so it's optional
14:47:30 <mjayfrancis> Generally I send mine through, but what I do is low volume and I have the luxury of taking my time to consider
14:47:34 <colonelqubit> mjayfrancis: sure, for those who have commit privs
14:47:51 <mjayfrancis> More or less anyone who sticks around for more than a month or so
14:48:04 <colonelqubit> ahh...but a good portion of commits are just merged and pushed by those reviewers with commit privs
14:49:54 <colonelqubit> mjayfrancis: do you think it would be worth it to keep stats on which commits/authors/reviewers are in the 'not buildable' (or otherwise unusable) pile?
14:50:42 <beluga_> colonelqubit: look, an embeddable irc widget https://kiwiirc.com/embedding
14:50:44 <mjayfrancis> Probably not especially, those with the largest volume I can think of are as mentioned at least semi-retired
14:50:54 <colonelqubit> mjayfrancis: okay, fair enough
14:50:57 <mjayfrancis> And otherwise, I don't want to make a big political fight out of it
14:51:10 <mjayfrancis> More flies with honey, etc.
14:51:25 <mjayfrancis> Better to gently persuade that it's a good idea
14:51:49 <colonelqubit> yeah, it would be tricky to get the goodness out of it in terms of improving our process without all of the negatives
14:53:06 <colonelqubit> Okay, any other topics?
14:55:42 <colonelqubit> Sounds like that's a wrap. Our next meeting is scheduled for the 23rd, but that's during the conference, so we may have to shift it by a week
14:56:12 <colonelqubit> thanks all!
14:56:15 <colonelqubit> #endmeeting