11:33:10 <colonelqubit> #startmeeting
11:33:10 <IZBot> Meeting started Wed Jul  1 11:33:10 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
11:33:10 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
11:33:37 <colonelqubit> Hi all! Hopefully this earlier time will allow some of you to join much more easily!
11:33:47 <cloph> fyi: build uploaded (helppacks still need a few mins, but those are irrelevant)
11:33:57 <sophi> colonelqubit: +1
11:34:08 <mjayfrancis> Likewise
11:34:21 <colonelqubit> Anyone else here?
11:34:31 <mjayfrancis> beluga: Ping?
11:34:32 <colonelqubit> beluga, raal, ahoneybun?
11:35:05 <colonelqubit> #topic Action Items
11:35:43 <colonelqubit> Not much on the list right now -- I punted on some Bugzilla changes as I was going to be on the road moving this week
11:36:20 <colonelqubit> I'm hoping to jump back into that work at the end of this week when my feet touch solid ground in Texas
11:36:42 <IZBot> News from tdfnew: [Bug 92477] Freeze when cancel a open file dialog for ImageMap Editor <https://bugs.documentfoundation.org/show_bug.cgi?id=92477>
11:37:10 <colonelqubit> Let's see ... I have a note here about daily builds of master for win 64bit
11:37:17 <colonelqubit> cloph: are we producing those again?
11:37:41 <cloph> yes
11:37:44 <colonelqubit> http://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/
11:38:09 * colonelqubit tries to remember who specifically was asking after those...perhaps jphillipz
11:38:30 <cloph> http://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/current/ → today's build.
11:38:42 <colonelqubit> steve-_-: you here?
11:39:33 <colonelqubit> I have a note for us to monitor  tdf#87373
11:39:34 <IZBot> LibreOffice-graphics stack major/high NEW [Mac OS X] Bad text spacing https://bugs.documentfoundation.org/show_bug.cgi?id=87373
11:39:49 <colonelqubit> Not sure if we need to continue with that on our radar...
11:40:02 <sophi> colonelqubit: also tdf#92443
11:40:03 <IZBot> LibreOffice-UI critical/medium NEW And again - no visible menu entrys and empty dialogs https://bugs.documentfoundation.org/show_bug.cgi?id=92443
11:40:27 * colonelqubit nods -- yep, was going to get to that one for New business :-)
11:40:36 <colonelqubit> #topic New Business
11:40:59 <colonelqubit> sophi: tell us about tdf#92443
11:41:01 <IZBot> LibreOffice-UI critical/medium NEW And again - no visible menu entrys and empty dialogs https://bugs.documentfoundation.org/show_bug.cgi?id=92443
11:41:31 <sophi> colonelqubit: it has been bisected, maybe make it a MAB?
11:42:07 <colonelqubit> sophi: it's affecting all dialogs, it appears?
11:42:33 <sophi> colonelqubit: I don't know, I can't test it
11:43:17 * colonelqubit thinks jphillipz would appreciate the minimalist menu layout...
11:43:17 <colonelqubit> ;-)
11:44:03 <sophi> colonelqubit: the other bugs #92269 #92014 and #91485 was discussed in the ESC
11:44:05 <IZBot> LibreOffice-UI major/highest VERIFIED FIXED UI:Cursors other than the default work but are not displayed https://bugs.documentfoundation.org/show_bug.cgi?id=91485
11:44:36 * colonelqubit nods
11:44:36 <sophi> s/was/were/
11:44:41 <cloph> #92269
11:44:42 <IZBot> LibreOffice-LibreOffice blocker/highest NEW 5.0.0.1 Win 64 Explorer Crash after single click on any LO file in folder. (shlxthdl.dll  / propertyhdl.dll property handler problem?) https://bugs.documentfoundation.org/show_bug.cgi?id=92269
11:44:46 <cloph> #92014
11:44:47 <IZBot> LibreOffice-Writer blocker/highest RESOLVED FIXED Writer: 64-bit builds of 5.0.0beta for Windows crash (w automatic spell-checking), other LO components unaffected https://bugs.documentfoundation.org/show_bug.cgi?id=92014
11:45:23 <cloph> only the explorer one was not fixed in rc2
11:45:34 <steve-_-> colonelqubit: yes here. re: #87373 seems well have to live with that bug for now. there's been improvement and remaining issues are related to certain zoom level and not 100% reproducible and hard to fix from what norbert said (I talked to him about that bug earlier today)
11:45:35 <IZBot> LibreOffice-graphics stack major/high NEW [Mac OS X] Bad text spacing https://bugs.documentfoundation.org/show_bug.cgi?id=87373
11:45:52 * colonelqubit . o O (...all the responses at once! ...)
11:46:14 <colonelqubit> sophi: for #92443, if it's affecting multiple documents, then I think it may be a MAB
11:46:15 <IZBot> LibreOffice-UI critical/medium NEW And again - no visible menu entrys and empty dialogs https://bugs.documentfoundation.org/show_bug.cgi?id=92443
11:46:52 <colonelqubit> sophi:  looks like it might rely on macros?
11:46:54 <steve-_-> MAB still used? I thought that one would have to go...
11:47:20 <colonelqubit> steve-_-: yep, hopefully we can excise the term soon
11:47:25 <sophi> steve-_-: no, it's my internal memory which is not updated ;)
11:48:15 <colonelqubit> cloph: can you provide a brief summary of #92269 and the latest build?
11:48:17 <IZBot> LibreOffice-LibreOffice blocker/highest NEW 5.0.0.1 Win 64 Explorer Crash after single click on any LO file in folder. (shlxthdl.dll  / propertyhdl.dll property handler problem?) https://bugs.documentfoundation.org/show_bug.cgi?id=92269
11:48:57 <cloph> The bug is fixed - but I
11:49:02 <colonelqubit> cloph: (you can just copy-paste what you wrote earlier)
11:49:20 <cloph> 'd be happy if people could test in various versions of windows - also regarding how the date is formatted in the tooltip
11:49:32 <mjayfrancis> Have to disappear for a bit now - my personal task for the next week is to decide if the UI testing work I've been doing is going enough in the right direction to give a talk on it at libocon, then submit a proposal if so (deadline is the 15th)
11:49:41 <cloph> I provided a 64bit build for testing here: http://dev-downloads.libreoffice.org/temporary/5.0.0.2_92269/
11:50:04 <colonelqubit> cloph: and that's just for internal QA testing, right?
11:50:36 <cloph> well, internal as to all interested and understand that this is not replacing rc2
11:50:39 <sophi> cloph: will ask on the QA FR list after the meeting
11:50:56 <cloph> and re date I mean tdf#89609
11:50:58 <IZBot> LibreOffice-filters and storage normal/medium NEW Explorer shell extension fails to convert date into locale specific string (sub-second precision ISO date → "strange date-information") https://bugs.documentfoundation.org/show_bug.cgi?id=89609
11:51:38 <cloph> esp. want to know whether the same formatting problem occurs on older versions of windows/whether the version of windows also affects it.
11:51:39 <colonelqubit> Okay, so two bugs to test against the temporary "5.0.0.2_92269" build
11:51:47 <colonelqubit> great!
11:52:24 <colonelqubit> mjayfrancis: anything else you wanted to bring up here?
11:53:36 <colonelqubit> Looks like a no
11:53:48 <steve-_-> colonelqubit:  think he's off for a meal...
11:53:51 * colonelqubit nods
11:54:27 <colonelqubit> UNCONFIRMED bug count is up a bit to 386
11:55:14 <colonelqubit> I know that beluga has been working on recruitment -- I think that chewing through all of the incoming bugs can often just be an issue of our numbers
11:56:06 <colonelqubit> I'm going to send out an email and ask people about what takes the most time for them when triaging
11:56:46 <sophi> colonelqubit: reproducing :)
11:57:00 <colonelqubit> some things are hard to optimize, especially when a big part of triaging is wet-ware and not software ;-)  But even marginal speedups can help us
11:57:49 <colonelqubit> #action Ask QA list about slowest parts of triage (Robinson)
11:58:03 <steve-_-> not sure if OS related bugs could be better dealt with i.e. is a bug win, osx, linux only, what if 2 of those affected? so if you want to triage, being able to quickly sort incoming bugs for the OS you have would be helpful. I know it's possible via BZ search but it's a bit complicated
11:59:25 <colonelqubit> steve-_-: Most incoming bugs are cross-platform, so perhaps we could filter UNCONFIRMED bugs that have more than 1 or 2 comments and then by a particular OS?
12:00:33 <steve-_-> I'm somewhat unhappy about the hardware / OS fields
12:00:39 * colonelqubit agrees
12:01:16 <colonelqubit> it's tricky because there are so many points of data, including word-length for hardware, OS, and LibreOffice
12:02:04 <steve-_-> the hardware fields are very confusing. and most new users won#t even know what those entries are. I also never heard about "PA-RISC (HP) once in my live. and then the OS is confusing because linux has all the distributions but for win / osx there's no further disambiguation
12:02:32 <steve-_-> HP-UX?
12:02:45 <colonelqubit> steve-_-: yep, that's HP's Unix
12:02:54 <steve-_-> is that used by humans?
12:03:20 <colonelqubit> I know a couple of people who work at HP -- I'll try to remember to ask them the next time I see them ;-)
12:03:25 * mjayfrancis wanders back
12:03:38 <colonelqubit> mjayfrancis: heya!
12:03:47 <steve-_-> didn't mean to take this OT. just saying that filtering bugs can be tricky for triagers.
12:03:50 <mjayfrancis> colonelqubit: Just an honourable mention to shm_get for tackling tdf#88941 - which is apparently turning out to be a bear
12:03:52 <IZBot> LibreOffice-LibreOffice critical/highest NEW Writer/Calc/Draw/Impress lose formatting for justified text when exporting to PDF on OS X builds https://bugs.documentfoundation.org/show_bug.cgi?id=88941
12:04:05 <colonelqubit> mjayfrancis: just discussing some thoughts on improving triage/bug-wrangling
12:04:10 <steve-_-> maybe it would be nice to gather some important searches in the wiki (a few are there already) to give triagers a good entry point
12:05:04 <colonelqubit> steve-_-: https://wiki.documentfoundation.org/QA/Bugzilla/Useful_Queries
12:05:33 <colonelqubit> steve-_-: Improvements to that page are always greatly appreciated :-)
12:07:49 <steve-_-> colonelqubit:  nice.
12:08:39 <colonelqubit> Anything else?
12:08:41 <sophi> colonelqubit: could we discuss the BH sessions? we need more testing on the alpha/beta versions
12:08:52 <steve-_-> have there been complaints about disabling izbot asklo notifications?
12:08:59 <steve-_-> wiki UI editing?
12:09:05 <colonelqubit> steve-_-: not that I know of
12:09:21 <colonelqubit> steve-_-: for wiki stuff, DennisRoczek|afk might have some input :-)
12:09:26 <mjayfrancis> Consider this my un-complaint about the lack of forwarded comment spam
12:09:38 <colonelqubit> sophi: yes, let's talk about BugHunting sessions
12:09:43 <steve-_-> yep this turns out more complicated than anticipated. but things are moving (slowly)
12:09:58 <colonelqubit> #topic BugHunting Sessions
12:10:01 <sophi> colonelqubit: BTW, I've written https://wiki.documentfoundation.org/BugHunting_Organization
12:10:21 <colonelqubit> sophi: Do you think it's a matter of recruiting more people, or having more people testing different setups?
12:10:28 <sophi> colonelqubit: maybe we should begin earlier and organize a BH on the last alpha
12:10:53 <sophi> colonelqubit: during the BH everybody should concentrate on testing more than triaging
12:11:22 <sophi> colonelqubit: so it's revisiting the process during the session and maybe add one more
12:11:24 <cloph> yeah, testing during those bh sessions would be great for alpha and beta.
12:11:58 <sophi> cloph: last alpha or even earlier ?
12:12:07 <colonelqubit> sophi: do you think having more sessions will lose some focus, or do you think we can keep up the energy?
12:12:35 <sophi> colonelqubit: I think we can keep up the energy
12:12:42 * colonelqubit nods
12:13:22 <cloph> ideally many people would test alphas early, but I guess for a bhs, the last alpha is enough.
12:13:41 <sophi> colonelqubit: but people should really concentrate on testing only and do triaging after, even if there is bad stats after, that would mean a good testing :)
12:14:06 <sophi> cloph: ok, thanks
12:14:17 <cloph> maybe dividing the session in "today (or the newxt two hours) is writer smoketesting!" or similar might help to get focused testing
12:14:18 <colonelqubit> cloph: I think that starting with the alphas provides some structure for the BHS
12:14:36 <colonelqubit> otherwise, it's easy to just see it as testing daily builds
12:14:39 <steve-_-> cloph: about early testing: using nightlies here as standard LO use case. I think though, that more people would be willing to do that, if better update mechanisms existed. meaning easy option to switch channels and updates should be one click
12:14:46 <sophi> cloph: yes, good idea :)
12:15:30 <cloph> steve-_-: for windows there is SiGUI - that lets you install hundreds of versions in parallel and also can poll for new versions
12:15:40 <cloph> and on linux/Mac you can install side-by-side anyway.
12:16:03 <sophi> steve-_-: SIGUI is used by the FR QA team, it's really helpful
12:16:12 <steve-_-> cloph:  true. but how to update nightlies? download full package, mount dmg, drag to programs folder etc. lots of hussle
12:16:54 <cloph> yeah - so you mean GSoC project that tries to add mozilla's update mechanism?
12:16:56 * colonelqubit wonders if the GSoC updater work could also be used w/nightlies for QA
12:17:09 <cloph> Using partial-downloads, etc surely is something for the future, but nothing for short-term...
12:17:16 <mjayfrancis> I had an idea - or rather changed my mind - about the (Linux) releases repository
12:17:31 <steve-_-> cloph:  yes. that should imo be a high priority item. finding a cross platform solution that works for various channels would be outstanding
12:17:36 <mjayfrancis> It's not especially useful to bibisect on it across different major versions anyway,
12:17:51 <mjayfrancis> so what about we make it a live repo with a branch for each major branch
12:17:53 <colonelqubit> mjayfrancis: because they're tips, or?
12:18:32 * colonelqubit puts on his Shepherd hat
12:18:36 <mjayfrancis> Well, the reason it's not useful to bibisect across the flattened release list is because bugs get backported, so you will get a complex pattern of broken/fixed/broken/fixed
12:18:49 <cloph> mjayfrancis: that then works for people regularily doing QA - but for people who want to start might be a let-down (why should they downlaod Gigabytes of repositors, when they want to test with the latest daily)
12:18:54 <colonelqubit> mjayfrancis: yep
12:18:56 <cloph> so can only be an addition, not a replacement.
12:19:41 <mjayfrancis> Putting it in a branch structure will still allow checkout by revision tag, and that repo isn't a replacement for the main live master repo(s) anyway
12:19:46 <cloph> BTW: the linux debugutil tinderbox does push to a "living repo" in that matter
12:19:53 <cloph> (master only though)
12:20:02 <mjayfrancis> The use case is different
12:20:12 <colonelqubit> because of git's all-or-nothing nature, I'd suggest multiple repos instead of multiple branches in one repo
12:20:57 <mjayfrancis> I'm only talking about the releases repo for this - it's pretty small to begin with, compared to the live repos
12:21:03 <mjayfrancis> 3.5G for all the releases in history
12:21:04 <colonelqubit> ah, okay
12:22:14 <colonelqubit> It sounds like we have a number of good ideas regarding BHS's and about testing in general. If anyone has something concrete, let's discuss it on the QA List
12:22:39 <sophi> colonelqubit: I'll make a proposal for BH sessions
12:22:43 * colonelqubit nods
12:22:58 <colonelqubit> sophi: I think that structure can be our friend, especially if we make it simple for newcomers to join
12:23:24 <sophi> colonelqubit: yes
12:23:46 * colonelqubit isn't entirely convinced that BHS's would be/should be our best onboarding environment, but they can definitely be one of the best times to bring in newbies
12:24:22 <DennisRoczek|afk> colonelqubit: here?
12:24:38 <sophi> colonelqubit: that's not the same people, those who are testing and reporting bugs may not be interested by triaging
12:24:58 <colonelqubit> DennisRoczek|afk: (we were just briefly mentioning the wiki)
12:25:06 <DennisRoczek|afk> colonelqubit: steve-_-: izbot's reports for askbot are disabled in #libreoffice-qa
12:25:18 <sophi> colonelqubit: but if we can keep them from one session to another it would be great
12:25:43 <DennisRoczek|afk> steve-_-: visual editor is still on my list. it is nearly finish. just a small glitch, but i didn't had to fix it (or betetr saying to find out what is breaking it)
12:25:53 <colonelqubit> sophi: Oh, yes indeed -- we may have some QA folks who only work on one side of testing
12:26:01 <sophi> colonelqubit: yes
12:26:11 <steve-_-> DennisRoczek|afk: that is great news. thx for keeping us in the loop
12:26:26 * colonelqubit wonders if it would be helpful for us to be more specific on the QA/Team page
12:26:51 <DennisRoczek|afk> the wmf (wikimedia foundation) did a bad job regarding visual editor. it is more beta without any documentation for sysadmins / devs
12:27:32 <colonelqubit> we have one column for 'key activities/remarks', but perhaps more info about which specific OSes on which we can test, etc.. might be helpful
12:28:23 <sophi> DennisRoczek|afk: don't think about that, it's not good for you ;)
12:28:34 <colonelqubit> Perhaps: Test on win8.1, win10;  Triage bugs on OSX 9+; etc.."
12:28:55 <steve-_-> DennisRoczek|afk: interesting. in wikipedia it seems to work very well and reliably. so you think it's beta functionality wise or documentation wise? and if it works well, it's really odd they do such a bad job at documenting it...
12:29:24 <colonelqubit> sophi: do you think it would be helpful for us to get people to explicitly *sign up* for BHS?
12:29:38 <DennisRoczek|afk> sophi: well it's exactly the reason why i left wikipedia - they (the wmf) didn't and still don't listen to the users (users in sense of editors at wikipedia, in sense of community and in sense of development of the mediawiki software)
12:29:48 <colonelqubit> I know that we wish to have more mentors sign up, but perhaps having participants sign up could help get better buy-in
12:29:54 <DennisRoczek|afk> or in sense of sysadmin using wmf(!) extensions
12:30:17 <sophi> colonelqubit: I don't think so, keeps it simple, open, etc...
12:30:26 <DennisRoczek> err, lost connection?!?
12:30:36 <colonelqubit> sophi: okay, sounds good
12:30:40 <steve-_-> DennisRoczek: 2 topics in parallel here atm
12:30:52 <DennisRoczek> steve-_-: no, irc connection
12:31:02 * colonelqubit hands DennisRoczek a spare IRC
12:31:32 <DennisRoczek> steve-_-: well the visual editor is in now way stable. it misses too much and the editors at wikipedia are beta testers :-( and the install instructions are a joke
12:31:37 <colonelqubit> Okay, looks like we're reaching the end of our hour
12:31:49 <colonelqubit> #topic Wrapping Up
12:32:04 <colonelqubit> Anything else we should mention during the meeting?
12:33:25 <steve-_-> https://bugs.documentfoundation.org/show_bug.cgi?id=88941 but not a lot to talk about. it#s being worked by norbert he said.
12:33:27 <IZBot> bug 88941: LibreOffice-LibreOffice critical/highest NEW Writer/Calc/Draw/Impress lose formatting for justified text when exporting to PDF on OS X builds
12:33:50 <steve-_-> shm_get: can I assign you or you don#t like that(?) for #88941 to reflect this is being worked on
12:33:51 <IZBot> LibreOffice-LibreOffice critical/highest NEW Writer/Calc/Draw/Impress lose formatting for justified text when exporting to PDF on OS X builds https://bugs.documentfoundation.org/show_bug.cgi?id=88941
12:34:07 <colonelqubit> steve-_-: yep, mjayfrancis mentioned Norbert's heroic efforts there :-)
12:34:56 <colonelqubit> Okay, thanks all for joining!  Hopefully the earlier time worked well for all our European folks
12:34:56 <steve-_-> colonelqubit:  thx for leading the meeting
12:35:04 <colonelqubit> steve-_-: welcome!
12:35:51 <colonelqubit> We'll have our next meeting on July 15th (in two weeks). Let's stick with this new time, as it seems to work pretty well for us
12:36:14 <colonelqubit> #endmeeting