19:25:17 <colonelqubit> #startmeeting
19:25:17 <IZBot> Meeting started Wed Jun  3 19:25:17 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
19:25:17 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:25:22 <colonelqubit> raal: perfect timing ;-)
19:26:12 <colonelqubit> Okay, let's look at our UNCONFIRMED bugs
19:26:27 <colonelqubit> hmm...we've zoomed all the way up to 371 UNCONFIRMED
19:27:06 <colonelqubit> we might need to organize a bug-squishing party or something
19:27:35 <colonelqubit> wish that I could invite everyone over to my place for an evening event: Bug squishing + free dinner
19:28:19 <colonelqubit> ahoneybun: Any thoughts on how we can improve our bug-triaging stats?
19:29:00 <ahoneybun> I don't have knowledge of the current way things are being done now
19:29:45 <colonelqubit> ahoneybun: fair enough
19:30:06 <jorendc> not sure about the rise
19:30:28 <colonelqubit> jorendc: how so?
19:30:47 <jorendc> we always see some 'zoome up' when a major release is comming...?
19:31:14 <colonelqubit> it depends
19:31:28 <colonelqubit> but yes, people have been reporting a bit more
19:31:39 <colonelqubit> I know that the BugHunting Session was very successful
19:31:46 <colonelqubit> (hey -- it's on our agenda! ;-)
19:31:46 <jorendc> indeed
19:31:54 <colonelqubit> but that resulted in a large # of bugs being filed
19:31:54 <jorendc> so I'm not 'afraid' of the short rise of bugs
19:32:01 <colonelqubit> So we do have to compensate over time
19:32:24 <colonelqubit> I'm mostly concerned about bugs not getting the attention that they need for a while
19:32:37 <colonelqubit> with 50 bugs, it's a lot harder for ones to hide
19:32:47 <colonelqubit> with ~400, it's much easier for many to slip through the cracks
19:33:16 <jorendc> true, but I saw some very fast feedback when the summary contains 'crash' or somethign like that
19:33:23 <colonelqubit> e.g. we have tons that were last changed back in April
19:33:44 <jorendc> so I think we have good 'filters' and bugscreeners
19:33:48 <colonelqubit> based on my non-scientific look at my scrollbars, I'd say 1/3rd :P
19:34:37 * colonelqubit nods
19:34:52 <colonelqubit> mjayfrancis: perhaps gone?
19:37:12 <colonelqubit> well, we can take a look at some past items
19:37:16 <colonelqubit> steve-_-: you still here?
19:37:29 <jorendc> looks like we are in a dessert :)
19:37:34 <jorendc> let's go through the other points
19:37:47 <steve-_-> yes, but actually working on stuff will listening to design hangout as radio station and lurking here for extra procrastination power
19:38:02 <jorendc> conclusion about previous point: lets not get concerned to early, lets see the numbers for upcomming weeks
19:38:02 <colonelqubit> steve-_-: cool. Was just wondering if you knew what was left with image testing on OSX
19:38:14 <colonelqubit> jorendc: indeed
19:38:22 <steve-_-> colonelqubit: good question. is there anything?
19:38:25 * steve-_- looks at the wiki
19:38:27 <colonelqubit> (I was going to see if anyone else appeared and decided to chime -in :-)
19:39:19 <colonelqubit> steve-_-: I'm not sure. I'll take a look at some point. I've been release engineer this week, too, so that's been extra work to carry
19:39:56 <colonelqubit> Walrus flag will have to punt again
19:40:15 <colonelqubit> #topic MAB's are being replaced
19:40:34 <colonelqubit> So as Joel mentioned in  his email, we're replacing MABs with Importance fields
19:40:49 <colonelqubit> priority/severity should hopefully give an indication about each of the bugs
19:41:03 <jorendc> agreed :)
19:41:18 <jorendc> what priority/severity combinations does hit the 'MAB'-mark?
19:42:10 <colonelqubit> we're hoping to get that code merged-in soon to our Bugzilla instance, at which point we'll start to put most people who've shown aptititude or interest in triage into the group with editing powers
19:42:14 <colonelqubit> jorendc: what combination?
19:43:05 <colonelqubit> priority of high or highest should be enough to get some strong attention
19:43:11 <jorendc> okay
19:43:37 <colonelqubit> but we'll use the highest rung to indicate the "MAB" status
19:44:18 <colonelqubit> we had a little chat about the "blocker" severity. While we can imagine bugs that are that bad, they are very, very rare
19:44:41 <colonelqubit> They're so rare that it seems like we'd just have a conversation about them
19:45:00 <jorendc> true +1
19:45:10 <colonelqubit> such as "This critical bug HAS to be fixed before we go forward"
19:45:20 <colonelqubit> We could even put something in the Whiteboard or Keywords for that
19:45:39 <colonelqubit> Personally I think it's fine to have the entry in the drop-down
19:45:48 <steve-_-> colonelqubit:  should I be seeing media testing somewhere?
19:45:54 <steve-_-> it's not under projects
19:46:08 <colonelqubit> https://wiki.documentfoundation.org/Media_Support/Summary
19:46:28 <colonelqubit> and once we restrict access to the fields, hopefully we'll see people be judicious about how they use Blocker
19:46:37 <jorendc> colonelqubit: I'd like to only have 1 field to mark such bugs (BLOCKER in this case)
19:47:06 <colonelqubit> so you'd want to have one field for severity + priority?
19:47:16 <colonelqubit> or?  /me isn't sure..
19:47:34 <jorendc> colonelqubit: no, but not AND blocker as severity AND some keyword or whiteboard status
19:47:44 <steve-_-> colonelqubit:  vector images and docmuent file formats missing
19:47:46 <steve-_-> for osyx
19:47:52 * colonelqubit nods
19:47:55 <colonelqubit> (at steve-_-)
19:48:12 <colonelqubit> jorendc: ah yes, I see
19:48:27 <colonelqubit> I personally think that it'll be much simpler once we feel like we can trust those fields more
19:48:29 <jorendc> just blocker should do if done correctly of course
19:48:36 <jorendc> yups
19:48:57 <colonelqubit> similarly, I hope to have time to roll out some more BZ upgrades
19:49:20 <jorendc> but I'm not for a kind of 'let's create something else because we don't do it correct right now'
19:50:01 <colonelqubit> jorendc: oh, definitely
19:50:28 <colonelqubit> that being said, I am sensitive to the fact that as a project with many volunteers, we may have to do things differently than a company with many employees such as Canonical or RedHat
19:50:48 <jorendc> colonelqubit: what do you mean exactly?
19:51:10 <colonelqubit> Sometimes our processes need to adapt to be flexible for volunteers
19:51:21 <jorendc> sure
19:51:26 <colonelqubit> so instead of just training everyone how to use the tool, we might add a tooltip (e.g. what I did for NEEDINFO status)
19:51:37 <jorendc> +1
19:52:09 <colonelqubit> #topic BugHunting Session 5.0
19:52:16 <colonelqubit> So I think we already talked a bit about this one
19:52:25 <colonelqubit> went very well; got some great feedback
19:52:38 <colonelqubit> We're still needing some testing done on 64bit Windows builds
19:53:31 <jorendc> looks like our x64 builds are broken?
19:53:46 * colonelqubit nods
19:53:54 <colonelqubit> I believe that Norbert was looking into that
19:54:19 <colonelqubit> I thought that Cloph was back this week, but apparently he's off for 2 weeks, so I'll email him about the status of 64bit tb's
19:55:04 <jorendc> :)
19:55:15 <colonelqubit> jorendc, ahoneybun: If any of you (or anyone else) is currently building for win64 native, it'd be great to get some feedback
19:55:36 <ahoneybun> building?
19:55:43 * jorendc only builds on linux
19:55:58 <colonelqubit> jorendc: it's new -- native win64 builds
19:56:06 <colonelqubit> (that's part of the reason we need to test them)
19:56:43 <jorendc> yups
19:56:50 <ahoneybun> I have Windows machine in my housr
19:56:55 <ahoneybun> *housr
19:58:06 <colonelqubit> ahoneybun: yeah, getting a win dev environment up and running is a bit more challenging, but it'd be cool to see if that works out for you
19:58:36 <ahoneybun> tbh I have no desire to have a Windows machine in any sense
19:59:01 <ahoneybun> I mean I could use the key from my current laptop on another machine
19:59:12 <ahoneybun> but finding isos is damn hard
19:59:19 <ahoneybun> uncracked ones
19:59:50 <Kardos> can't you download them from microsoft?
20:00:12 <ahoneybun> with a membership thing
20:00:17 <colonelqubit> sometimes the software is tied to particular hardware
20:00:37 <ahoneybun> I have a ISO just the thing will not show up on my computer
20:00:49 <ahoneybun> when I put it on a USB, but anyway off topic maybe
20:01:00 <Kardos> virtualbox?
20:01:32 <colonelqubit> ahoneybun: we can talk more about that later -- perhaps one of the netbooks might work out for you, too
20:01:50 <ahoneybun> I could Kardos
20:01:51 <Kardos> ah, MS doesn't provide unfettered ISOs anymore. cancel that
20:01:52 <colonelqubit> #topic Other topics
20:02:24 <colonelqubit> Let's see...we talked about win64, Bug Hunting Session
20:02:31 <colonelqubit> Oh! Android builds
20:02:39 <colonelqubit> who's currently running them/testing them?
20:02:55 <jorendc> I did install the beta one (of collabora itself)
20:02:58 <raal> me
20:03:11 <jorendc> looks good (not tested them with advanced documents yet)
20:03:11 <colonelqubit> Great! How are they running for y'all?
20:03:20 <colonelqubit> Please do test and let us know
20:03:24 <colonelqubit> we've got builds for 5.0 out here:
20:03:37 <jorendc> I already saw some bug reports related to our android viewer
20:03:53 <colonelqubit> https://www.libreoffice.org/download/android-viewer
20:04:27 <colonelqubit> We've got the latest TDF builds in the Google Play store, and I'm working on getting them into F-droid as well
20:05:27 * ahoneybun installs from the Play Store
20:05:56 * jorendc has to run
20:06:03 <colonelqubit> ahoneybun: please do show that off when you're at SELF and Akademy
20:06:08 <jorendc> o/ c heers
20:06:10 <colonelqubit> jorendc: anything else from you?
20:06:18 <jorendc> not I'm aware of :)
20:06:27 <colonelqubit> ahoneybun: anything from you?
20:06:28 <ahoneybun> I might use it for my talk at SELF colonelqubit
20:06:36 <colonelqubit> great!
20:06:47 <ahoneybun> can it control a slideshow?
20:07:00 <colonelqubit> ahoneybun: the Android Impress Remote can
20:07:04 <colonelqubit> (separate android app)
20:07:05 <ahoneybun> oh
20:07:21 <colonelqubit> Perhaps eventually, we can just run right from the phone/tablet
20:07:30 <colonelqubit> (over WiFi, natch)
20:07:38 <ahoneybun> I'm going to try this out now
20:07:41 <ahoneybun> well in a min
20:08:23 <colonelqubit> Cool
20:08:27 <colonelqubit> raal: anything more from you?
20:08:35 <raal> win10 will be released 08/2015 - is someone running LO on win10?
20:08:36 <colonelqubit> or arnaud_versini ;-)
20:08:46 <colonelqubit> raal: That is a great question
20:08:53 <ahoneybun> damn KDE Connect is amazing
20:09:20 <colonelqubit> raal: If we aren't already, we should be testing. Where are they in the cycle?  beta builds?
20:09:52 <raal> colonelqubit: yes, these builds are available
20:10:17 <colonelqubit> #action Make sure we've got a plan to test on Windows 10 (Robinson)
20:10:21 <raal> should be final in summer
20:10:35 <ahoneybun> it takes awhile to render
20:10:37 <raal> with free upgrade from win7 and 8
20:10:38 <colonelqubit> #action  Make sure Win64-bit-native builds are available as dailys
20:11:03 <ahoneybun> load something
20:11:15 <colonelqubit> #action Send materials to ahoneybun (Robinson)
20:11:25 <raal> so I expect lots of win10
20:11:42 <colonelqubit> raal: have you had a chance to poke at it yet?  (like at a mall or etc..)
20:12:06 <raal> \i have full ssd, so cannot create new VM
20:12:49 * colonelqubit nods
20:13:24 <colonelqubit> Okay, I think that's about it for the meeting
20:13:33 <colonelqubit> Thanks, all!  It has been fun!
20:13:45 <colonelqubit> Our next meeting is June 17th
20:14:12 <colonelqubit> The one after that might be up in the air, as I'm moving to Texas
20:14:52 <colonelqubit> Enjoy your testing. It's great to hear that the 50max bibisect repository is working well
20:14:55 * colonelqubit waves
20:15:34 <colonelqubit> #endmeeting