19:54:07 <colonelqubit> #startmeeting
19:54:07 <IZBot> Meeting started Wed May 20 19:54:07 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
19:54:07 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:54:23 <colonelqubit> Let's see what's been going on this week
19:54:31 <colonelqubit> UNCONFIRMED bugs: 313
19:55:08 <colonelqubit> I expect that we'll see a bit of a dip in that number when we get people excited about the BugHunting Session
19:57:16 <colonelqubit> speaking of which, beluga_ -- have you invited any newcomers or others to join us?
19:57:35 <beluga_> colonelqubit: well I have done general recruiting
19:57:46 <beluga_> https://sourceforge.net/p/forge/helpwanted/testers/thread/dae9bfa9/ http://www.reddit.com/r/libreoffice/comments/36glx5/join_libreoffice_qa_team_and_make_it_easier_for/
19:57:58 <colonelqubit> I keep on jumping around here from one piece to another, and haven't had a chance to keep an eye on the channel as much lately...
19:58:06 <colonelqubit> Good, good
19:58:17 <beluga_> one person responded to the SF thread after only 3 minutes.. just today they did this task: https://wiki.documentfoundation.org/QA/Bugzilla/Gardening#Task:_Remove_commas_from_the_whiteboard
19:58:40 * colonelqubit nods -- excellent!
19:58:50 <beluga_> and I noticed they cleaned the caps in whiteboard tags :) like EasyHack -> easyHack
19:58:55 <colonelqubit> beluga_: Did we make a post to r/libreoffice about the BugHunting session?
19:59:05 <beluga_> not yet
19:59:19 <colonelqubit> raal: you here?
20:00:05 <colonelqubit> beluga_: Thoughts on the best way for us to invite people via reddit?
20:00:09 <beluga_> I also advertized Joel's (art directed by moggi) MSO template interop project http://www.reddit.com/r/libreoffice/comments/36ldyv/mso_2013_template_interop_project/
20:00:33 <colonelqubit> we could just say 'Hey, we're having a BugHunting Session! Join us!" -- but perhaps some other messaging would work better?
20:00:34 <beluga_> well I think we could even invite them via r/linux and/or r/opensource
20:00:39 * colonelqubit nods
20:01:00 <beluga_> I think posting it on the day it starts would make sense
20:01:08 <beluga_> everything disappears so quickly in reddit..
20:01:44 <colonelqubit> yep -- some people like to plan ahead on the calendar, but "walkup" business is also good -- perhaps even better
20:01:44 <beluga_> r/libreoffice is obviously not a high-traffic subreddit
20:01:58 <colonelqubit> jorendc: you still here?
20:03:18 <colonelqubit> beluga_: If you want to mock-up some language, that'd be handy
20:03:36 <colonelqubit> Feel free to make a section at the bottom of https://wiki.documentfoundation.org/BugHunting_Session_5.0.0.0 or put it on the Talk page, etc..
20:03:55 <colonelqubit> it would be good for us to keep track of how we're recruiting and what makes the biggest impact
20:04:49 <beluga_> if posting to reddit, I would simply make a link post to that wiki page
20:04:57 <colonelqubit> okay, fair enough
20:04:57 <beluga_> and then follow up to any questions
20:05:09 <beluga_> I'll add myself to the mentor list
20:06:08 <colonelqubit> #topic VCL Pointers
20:06:27 <colonelqubit> How are we doing with these bugs?
20:06:30 * colonelqubit digs up the meta bug
20:06:39 <colonelqubit> https://bugs.documentfoundation.org/show_bug.cgi?id=91310
20:06:41 <IZBot> bug 91310: LibreOffice-graphics stack normal/medium NEW [META] Fallout from VclPtr merge
20:07:44 <beluga_> devs have been fixing them furiously
20:07:54 * colonelqubit nods
20:09:30 <colonelqubit> Any info I should share back with devs?
20:09:59 <beluga_> "you break it, you fix it"
20:10:03 * colonelqubit laughs
20:10:17 <colonelqubit> Yep, hopefully our testing has been extensive enough to identify and fix what's broken
20:11:01 <colonelqubit> We'll see what kind of volume we can get done this weekend
20:11:31 <colonelqubit> #topic Bugzilla (mix)
20:11:50 <colonelqubit> Let's see -- Bugzilla will get upgraded this week.
20:12:18 <colonelqubit> We have the BugHunting Session, so I haven't decided what day to roll out changes... maybe Saturday night?  (quieter)
20:12:34 <beluga_> 4.4.9?
20:12:37 * colonelqubit nods
20:13:12 <colonelqubit> beluga_: Amusing that LO and Bugzilla are both about to release 5.0
20:13:13 <beluga_> BZ 5.0 blocker list has been shifting between 5 and a couple.. currently 2 https://bugzilla.mozilla.org/buglist.cgi?f1=flagtypes.name&o1=equals&resolution=---&query_format=advanced&v1=blocking5.0%2B&product=Bugzilla
20:13:15 <colonelqubit> ;-)
20:13:20 <beluga_> :P
20:14:33 <colonelqubit> I'll catch up with Joel, and we can determine when his changes to the Importance field can be deployed. We'll also look at the Guided Forms.
20:14:55 <colonelqubit> We don't have to deploy everything at once, but that might end up being simplest
20:16:27 <colonelqubit> #topic General
20:16:40 <colonelqubit> Let's see... anything else under the general topic
20:16:52 <beluga_> ok let's go through our mjayfrancis-related news
20:16:54 <colonelqubit> beluga_: you have news from mjayfrancis, right?
20:17:03 <beluga_> I have good news and very good news
20:17:13 <colonelqubit> :-)
20:17:29 <beluga_> I'll start with the good, re: bibisect: "now that 5.0 has branched I've set the last piece of 5.0 master building - including assembly it should be ready early next week"
20:17:39 <colonelqubit> marvy, marvy
20:17:56 <beluga_> then the very good news are about automated UI testing
20:18:19 <colonelqubit> I'm updating notes on bibisecting repos, so I'll touch base with him to make sure we get that documented asap
20:18:37 <colonelqubit> beluga_: so it's about a robot?
20:18:39 <beluga_> the VclPtr merge kind of amplified the interest to automated testing of the UI
20:19:29 <beluga_> moggi said that he is developing some approach of his own, I don't recall any details
20:19:32 <colonelqubit> Indeed -- some of the pain of testing was large
20:19:55 <colonelqubit> (too bad he's not here to share :-)
20:20:02 <beluga_> then raal dropped by and started talking about existing tools, like what were mentioned on the QA list in March by a RedHat employee
20:20:03 <colonelqubit> (moggi, that is)
20:20:29 <beluga_> mjayfrancis got interested in Dogtail, which is from RedHat.. it uses Python.. already works with v. 3 btw.
20:21:02 <beluga_> so long story short, today was the first time a bug got confirmed using Dogtail! https://bugs.documentfoundation.org/show_bug.cgi?id=91403
20:21:04 <IZBot> bug 91403: LibreOffice-Writer major/medium NEW Crash in Insert - Fields - More Fields...
20:21:28 <colonelqubit> that's great news!
20:21:28 <beluga_> mjayfrancis commented related to that testing script: "The mini-framework I'm writing makes it easier to write tests than how that one was structured, I just needed that one not to have any more dependencies"
20:22:37 <beluga_> testing with Dogtail employs LibO's accessibility features
20:23:00 <colonelqubit> beluga_: which is a win-win
20:23:12 <beluga_> sure, it will bring more attention to a11y..
20:23:18 <colonelqubit> as we definitely want to maintain good support there
20:23:32 <beluga_> everyone talked about how bad LibO's a11y code is..
20:23:42 <beluga_> so a good chance to revamp it
20:23:50 <colonelqubit> Yeah, I think there are two parts
20:23:58 <colonelqubit> 1) What's in place
20:23:58 <colonelqubit> 2) Maintenance
20:24:25 <colonelqubit> Automated testing will massively help with #2
20:25:04 <beluga_> yep devs dogfooding their UI code with a11y features all the time
20:25:18 <colonelqubit> I'm not sure what the install base is for LibreOffice + screen reader, but it's much smaller group discovering bugs, and then of course only some fraction of those people become bug reporters
20:26:14 <colonelqubit> I guess one trouble there is that if it's using the a11y interface, then it won't be too easy for it to discover/uncover missing a11y support
20:27:14 <beluga_> well that would be up for the test writers I guess
20:27:58 <colonelqubit> Yep
20:28:14 <colonelqubit> beluga_: So what's next with dogtail?
20:28:26 <colonelqubit> Do we have docs on the wiki?
20:28:48 <beluga_> mjayfrancis is writing a mini-framework for easier test writing, like I quoted
20:29:21 <beluga_> Python 3 version of Dogtail should be released pretty soon, as the devs said already 2,5 months ago that it just needs testing.. and Fedora 23 will have Python 3 by default
20:29:45 <beluga_> this has just gone on for a few days, so no docs yet :)
20:30:43 <colonelqubit> beluga_: ah, okay
20:30:56 <colonelqubit> just figured that it might be a clever carrot to pull in some new people
20:31:08 <colonelqubit> and get some others to be more involved
20:31:34 <beluga_> yes there will be hundreds of tests to write
20:32:04 <Kardos> ... and maintain
20:32:20 <beluga_> and who knows, where this will lead.. at least some bug reports will be way easier and faster to repro
20:32:32 <IZBot> News from asklibo: Calc file won't open by double-click <http://ask.libreoffice.org/en/question/1123/calc-file-wont-open-by-double-click/>
20:32:58 <colonelqubit> Kardos: well, hopefully we can make sure that something clever happens when tests fall over
20:35:00 <Kardos> maybe we can aim for dozens instead of hundreds ;P
20:36:19 <beluga_> well mjayfrancis mentioned the number of individual dialogs.. I'm not sure what the exact number was.. something like 700 perhaps
20:36:53 <Kardos> im not sure what one of these tests will entail
20:37:13 <Kardos> but if theres 700 dialogs, and each time one gets changed, you also gotta update the test, that's a real maintenance cost
20:38:07 <beluga_> Kardos: not necessarily, if a11y is maintained at the same time I think
20:38:19 <beluga_> well I don't know the inner workings..
20:38:34 <Kardos> would it be like doxygen, the test is *right there* in the code?
20:38:59 <beluga_> Dogtail uses Python scripts
20:39:46 <beluga_> but who knows, what will become "the official way".. we have to see what moggi comes up with
20:41:30 <Kardos> hmmmmmmmm
20:42:01 <Kardos> so you still have to write a guide for each one with the detail of "click file"  "click open" "select cookie.odt" "select insert" ...
20:42:36 <Kardos> if the gui is /stable/ they shouldn't need a lot of attention once written
20:42:47 <Kardos> also
20:42:51 <Kardos> what kind of bugs will it catch?
20:43:13 <Kardos> will it catch graphics corruption? bad painting kinds of stuff
20:43:34 <Kardos> or will it only fail when a menu item disappears that it's expecting to find
20:43:55 * Kardos is skeptical.
20:44:11 <colonelqubit> Kardos: well, if it's based on the a11y, I'm not sure about the graphics-related/repaint/etc issues
20:44:12 <beluga_> Kardos: why are you skeptical of using it for finding crashes?
20:44:28 <Kardos> ah, it could find a crash
20:44:38 <beluga_> Kardos: #91403
20:44:45 <IZBot> LibreOffice-Writer major/medium NEW Crash in Insert - Fields - More Fields... https://bugs.documentfoundation.org/show_bug.cgi?id=91403
20:44:49 <Kardos> i was thinking more along the lines of gui changing
20:45:31 <Kardos> will it catch document rendering problems?
20:45:55 <Kardos> eg, #91145
20:46:01 <IZBot> LibreOffice-Writer normal/medium NEW UI: Set Cell Background Color in Table Broken in Writer 5.0 https://bugs.documentfoundation.org/show_bug.cgi?id=91145
20:47:14 <beluga_> Kardos: I wouldn't think so
20:47:53 <beluga_> colonelqubit: btw. one thing to keep in mind for the bug hunt is that 5.0 profile corruption occurred recently for many people: http://lists.freedesktop.org/archives/libreoffice-qa/2015-May/008722.html Including me
20:48:19 <beluga_> I thought the Win build was messed up, but then I read that discussion and reset my profile
20:49:06 <colonelqubit> yeah, UserProfile issues are definitely something that merits further discussion
20:49:53 <colonelqubit> IIRC, there was talk about more investigation into good vs. corrupted profiles
20:50:05 <colonelqubit> some kind of user-profile reporting tool
20:50:12 <beluga_> apparently the profile code is not good quality (not designed, but evolved in a Frankenstein-like manner)
20:50:15 <colonelqubit> I don't think that's got traction recently
20:50:51 * colonelqubit wonders if we could bisect a profile in some fashin
20:50:53 <colonelqubit> fashion
20:51:26 <colonelqubit> so, take existing profile and a clean new one, and then replace half of the old contents with new ones, and see if that fixes the problems
20:51:57 <Kardos> is each profile entry independent?
20:52:03 <Kardos> could be lots of false positives
20:52:06 <colonelqubit> beluga_: whatever we do here, we've got to make it simple enough that we're not spending inordinate amounts of time on testing a given profile
20:52:19 <colonelqubit> Kardos: I haven't looked at the structure much
20:52:37 <colonelqubit> Unfortunately, some issues are cut and dry like crashes
20:52:40 <colonelqubit> *aren't
20:57:47 <colonelqubit> But I think it's interesting enough that we should spend more time here
20:58:44 <IZBot> News from tdfnew: [Bug 91416] EDITING: Crash on changing value in simple spreadsheet <https://bugs.documentfoundation.org/show_bug.cgi?id=91416>
20:59:02 <colonelqubit> #action Investigate what we can do to track down and fix UserProfile issues
20:59:20 <colonelqubit> beluga_: any other news from mjayfrancis?
20:59:29 <beluga_> nope
21:01:28 <colonelqubit> Okay, I think that's all I see on the agenda
21:01:46 <colonelqubit> Kardos: anything else relevant we should cover?
21:03:35 <colonelqubit> arnaud_versini: anything from your end? :-)
21:04:50 <colonelqubit> I'll take that as a no
21:05:23 <Kardos> ithink we're good
21:05:39 <colonelqubit> Okay, the BugHunting Session starts on Friday (22nd) and runs through Sunday
21:06:03 <colonelqubit> although if you want to get a head start, feel free to go ahead and be a rebel :P
21:06:36 <colonelqubit> beluga_: if you could post to Reddit at the optimal time (or times?  I assume too many posts are frowned upon), that'd be great
21:06:57 <beluga_> colonelqubit: yep
21:07:19 <colonelqubit> Our next meeting is in two weeks, which is June 3rd
21:08:36 <colonelqubit> I hope to see you there!
21:08:41 <colonelqubit> #endmeeting