18:41:56 <colonelqubit> #startmeeting
18:41:56 <IZBot> Meeting started Wed Apr 22 18:41:56 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
18:41:56 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:43:08 <colonelqubit> UNCONFIRMED at 304
18:43:17 <colonelqubit> man, we just can't seem to move that needle, can we?
18:43:26 <colonelqubit> hitting a wall
18:43:39 <beluga_> colonelqubit: we keep moving it back and then watching the tide rise again :)
18:43:52 <beluga_> it's a hobby of sorts
18:44:09 * colonelqubit wonders if we're starting to get down to the 'muck', as it were
18:44:26 <colonelqubit> there will be a certain # of bug reports that are really tough to triage or repro
18:45:26 <colonelqubit> Sorting through the bugs that are over 2 weeks old, many are challenging
18:46:27 <colonelqubit> Okay, let's take a look at those action items
18:46:31 <colonelqubit> #topic Action Items
18:46:44 <colonelqubit> Steve around?
18:46:54 <beluga_> nope
18:47:12 <colonelqubit> mjayfrancis we think is conked out :P
18:47:32 <colonelqubit> well.... we can pass on a number of items
18:47:56 <colonelqubit> #topic Versions in Bugzilla
18:48:11 <colonelqubit> I sent out an email earlier this week asking about 4.5-master and 5.0-master
18:48:51 <colonelqubit> we renamed the next release, so we've got an interesting situation where we have master builds in the same series that are named 4.5.xxxx and 5.0.xxxx
18:49:16 <colonelqubit> Some people suggested just renaming the version in Bugzilla, but that might be confusing for anyone who doesn't know that the renaming took place
18:49:45 <colonelqubit> beluga_: thoughts?
18:50:09 <beluga_> I think renaming is fine..
18:50:38 <colonelqubit> and people have to guess?
18:51:12 <beluga_> guess what? that renaming happened?
18:51:15 <colonelqubit> perhaps not that many other people have a master buidld installed
18:51:25 <beluga_> yes that's what I was thinking
18:51:55 <colonelqubit> well, all of the Android builds are master buidls
18:52:28 <raal> keep both, it's consistent with currentversions
18:52:40 <raal> zou have rc1, rc2 etc..
18:52:48 * colonelqubit shrugs -- yeah, that seems okay to me
18:52:56 <raal> zou =you
18:53:11 <colonelqubit> I hate having version explosion, but this one isn't a technical decision
18:53:45 <colonelqubit> Hopefully we can figure out a saner numbering system, so we don't have branches renamed midway through :-)
18:54:34 <colonelqubit> Anyone else want to weigh in?
18:56:03 <colonelqubit> #topic General Discussion
18:56:05 <raal> btw 4.3.6release is missing?
18:56:17 * colonelqubit goes to take a peek
18:56:42 <colonelqubit> was that 4.3.6.2?
18:57:11 <raal> :-) probably, i'm using master not sure
18:57:22 <beluga_> colonelqubit: must have been yes, checked old versions directory
18:57:29 <beluga_> http://downloadarchive.documentfoundation.org/libreoffice/old/
18:57:44 <beluga_> in general news, we are slaying old bugs https://bugs.documentfoundation.org/page.cgi?id=weekly-bug-summary.html
18:58:08 <colonelqubit> Indeed!
18:58:30 <colonelqubit> And I see someone in particular waaay out in front of the pack of bug closers ;-)
18:58:45 <beluga_> colonelqubit: I didn't get a reply from you about this #67135 should it be moved to Redmine?
18:58:46 <IZBot> LibreOffice-WWW normal/medium NEW BUGZILLA: FDO does not allow to set specific Windows OS, but BSA does https://bugs.documentfoundation.org/show_bug.cgi?id=67135
18:59:14 <beluga_> I killed all the BSA-related ones.. that gave a nice jump to the murder stats
18:59:54 <beluga_> I've been all over Joel's April 1st ping.. lots of WFM
18:59:57 <colonelqubit> (4.3.6.2 rc -> 4.3.6.2 release)
19:00:05 <raal> http://blog.documentfoundation.org/2015/04/17/first-bug-hunting-session-for-libreoffice-5-0/   - promote in BZ? banner?
19:00:18 <colonelqubit> raal: yep, sounds good
19:00:34 <colonelqubit> Do you want to make up a banner of the same size as usual?
19:00:54 * colonelqubit has been swamped the lst couple of weeks
19:01:08 <colonelqubit> Otherwise, I can get to it soon
19:01:18 <raal> colonelqubit: I think its not good idea, i'm not graphic man
19:01:26 * colonelqubit smiles
19:01:30 <colonelqubit> okay,
19:01:48 <colonelqubit> #action Robinson will make a Bugzilla banner for BugHunting Session 5.0
19:02:48 <colonelqubit> What's next?
19:03:00 <IZBot> News from asklibo: libreoffce doen't work in 64bit ubuntu,help!!!!!! <http://ask.libreoffice.org/en/question/46166/libreoffce-doent-work-in-64bit-ubuntuhelp/>
19:03:05 <colonelqubit> Any news from mjayfrancis re: bibisect repos?
19:03:15 * ahoneybun can make banners
19:03:40 <colonelqubit> Cool -- I'll send you the basic information
19:03:47 <ahoneybun> ok got it
19:04:09 <beluga_> colonelqubit: well the release repo was completed a week ago
19:04:14 <colonelqubit> #action Robinson will send ahoneybun information about making Bugzilla banners
19:04:29 <beluga_> I haven't tested yet.. will install Ubuntu 15.04 in a VM and try it in that
19:05:17 <colonelqubit> ahoneybun: there are some other graphic things that would be nice to make  -- e.g. we coudl make up some banners ahead of time for upcoming events like Software Freedom Day and the Annual Conference
19:05:27 <colonelqubit> Maybe a new QA T-shirt design?
19:05:35 <colonelqubit> We can chat :-)
19:05:41 <ahoneybun> of course :)
19:06:23 <sophi> ahoneybun: we also need banners for bug hunting sessions :)
19:06:38 <colonelqubit> sophi's here!
19:07:15 <ahoneybun> sophi: give colonelqubit the sizes and I'll work on a few ideas
19:07:28 * ahoneybun puts it on his to-do
19:07:38 * colonelqubit waits for sophi to send him some trapezoid shapes or something crazy :P
19:07:56 <colonelqubit> Okay, all. Anything else?
19:08:09 <raal> Android testing
19:08:19 <raal> status quo?
19:08:21 <colonelqubit> Ah yes, and sophi is here!
19:08:34 <colonelqubit> raal: We've got some MozTrap tests written, and I wrote up some notes on installing the daily
19:08:40 <beluga_> colonelqubit: yeah that one bug that I thought should perhaps be moved to Redmine.. or closed instead?
19:08:50 <colonelqubit> https://wiki.documentfoundation.org/Android#Daily_Builds
19:09:20 <colonelqubit> (just FYI, I might be temporarily kicked offline in 2 minutes)
19:09:28 <colonelqubit> beluga_: bug #?
19:09:42 <beluga_> #67135
19:09:43 <IZBot> LibreOffice-WWW normal/medium NEW BUGZILLA: FDO does not allow to set specific Windows OS, but BSA does https://bugs.documentfoundation.org/show_bug.cgi?id=67135
19:10:02 <raal> I saw announcement from collabora today. So is it possible to start the tests?
19:10:48 <colonelqubit> beluga_: yep, feel free to move that to Redmine; we can possibly address that as a part of Guided Forms
19:10:48 <raal> I have moztrap account and android installed
19:11:02 <ahoneybun> (might have to go soon as well, not sure)
19:11:14 <colonelqubit> raal: have you looked at the tests yet?
19:11:24 <raal> colonelqubit: little
19:13:48 <raal> for example :Open an empty Calc document:  I'm not sure if it's possible in android
19:14:09 <raal> there is not button new document
19:17:50 <colonelqubit> hmm, back?
19:17:55 <colonelqubit> sorry about that
19:17:57 <beluga_> colonelqubit: #77014 we don't allow blockers, right?
19:17:58 <IZBot> LibreOffice-Writer blocker/medium NEW Words in input fields are broken between lines at the end of line https://bugs.documentfoundation.org/show_bug.cgi?id=77014
19:18:09 <colonelqubit> beluga_: in general, we dont' use that status, correct
19:18:49 <colonelqubit> beluga_: have you seen the wording about dropping them down one level?
19:18:54 <colonelqubit> I think Bjoern wrote it...
19:19:23 <beluga_> stock messages in the wiki?
19:19:54 <beluga_> unable to locate stock messages
19:20:40 <colonelqubit> yeah, lemme look for it
19:20:44 <colonelqubit> (it should go on the wiki..)
19:21:17 <ahoneybun> colonelqubit: g2g
19:21:24 <ahoneybun> bye guys
19:21:53 * colonelqubit waves
19:21:57 <colonelqubit> beluga_: I don't see it
19:22:06 <colonelqubit> but in general, we don't really use 'blocker'
19:22:13 <beluga_> yep
19:22:17 <colonelqubit> Mostly, things are just marked as a MAB
19:22:24 <colonelqubit> if it's super-serious, then talk to devs
19:22:41 <beluga_> yet the priority flow chart has blocker
19:22:43 <colonelqubit> I think that we should either remove it, or have clear guidelines on when to use it
19:22:49 <beluga_> https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
19:23:11 <colonelqubit> yes, it does, but IIRC it could be clearer
19:23:56 <colonelqubit> I think people gloss-over part #2 of that chart: Does it happen frequently w/clean installs
19:24:05 <colonelqubit> doing clean installs is actually a pain
19:24:59 <colonelqubit> And I believe that devs have actively discouraged use of 'blocker', as the term means something very specific
19:27:42 <ertai_NL> hi
19:27:53 <CorNouws> ertai_NL: hi :)
19:28:11 <beluga_> hey where did these 2 guys come from?
19:28:12 <CorNouws> ertai_NL: congrats with FC-Philips ;)
19:28:28 <ertai_NL> thnx.. we are the champions!!
19:28:40 <colonelqubit> Here's the table of Severity vs. Priority:
19:28:43 <CorNouws> ertai_NL: yeah :)
19:28:44 <colonelqubit> https://bugs.documentfoundation.org/report.cgi?x_axis_field=priority&y_axis_field=bug_severity&z_axis_field=&no_redirect=1&query_format=report-table&short_desc_type=allwordssubstr&short_desc=&product=LibreOffice&resolution=---&longdesc_type=allwordssubstr&longdesc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_id=&bug_id_type=
19:30:25 <ertai_NL> hi colonelqubit
19:30:43 <ertai_NL> beluga_: from outerspace..
19:31:23 <beluga_> I hope they're not hooligans
19:31:53 <ertai_NL> no.. just a fan.. I don't fight about it
19:32:17 * beluga_ is relieved
19:33:07 <IZBot> News from asklibo: Network install on Windows Server 2008 R2 64 bit <http://ask.libreoffice.org/en/question/49773/network-install-on-windows-server-2008-r2-64-bit/> || calc 4.3 english How do I go about adding non-number items in a column? <http://ask.libreoffice.org/en/question/49772/calc-43-english-how-do-i-go-about-adding-non-number-items-in-a-column/>
19:33:52 <beluga_> qubit keeps disappearing into outerspace
19:33:58 <colonelqubit> beluga_: yeah, sorry about that
19:34:02 <colonelqubit> fighting with network here
19:34:13 <colonelqubit> did you see the chart?
19:34:58 <colonelqubit> Might be somewhat useful for us to keep a better eye on the distribution there
19:35:18 <colonelqubit> But I've digressed a bit ;-)
19:35:26 <colonelqubit> Any other relevant topics for us to discuss?
19:35:31 <beluga_> colonelqubit: the chart didn't appear
19:35:46 <beluga_> or do I have to do something else after that screen?
19:35:50 <colonelqubit> https://bugs.documentfoundation.org/report.cgi?x_axis_field=priority&y_axis_field=bug_severity&z_axis_field=&no_redirect=1&query_format=report-table&short_desc_type=allwordssubstr&short_desc=&product=LibreOffice&resolution=---&longdesc_type=allwordssubstr&longdesc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_id=&bug_id_type=
19:36:06 <beluga_> no chart
19:36:22 <colonelqubit> beluga_: sorry, table
19:36:31 <colonelqubit> but yes, a chart of that would be nice
19:36:37 * colonelqubit must be imagining things in his head...
19:36:37 <beluga_> no table either
19:36:38 <colonelqubit> :P
19:36:48 <beluga_> Bugzilla allows you to view and track the state of the bug database in all manner of exciting ways.
19:37:25 <beluga_> it just shows the report screen
19:37:29 <colonelqubit> no table from that link?  are you logged-in?
19:37:35 <beluga_> yes logged in
19:38:21 <colonelqubit> ah, being chopped off
19:39:24 <colonelqubit> https://bugs.documentfoundation.org/report.cgi?x_axis_field=priority&y_axis_field=bug_severity&z_axis_field=&no_redirect=1&query_format=report-table&short_desc_type=allwordssubstr&short_desc=&product=LibreOffice&resolution=---&longdesc_type=allwordssubstr&longdesc=&bug_file_loc_type=allwordssubstr&
19:39:31 <colonelqubit> bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_id=&bug_id_type=anyexact&emailassigned_to1=1&emailtype1=substring&email1=&emailtype2=substring&email2=&emailtype3=substring&email3=&chfieldvalue=&chfieldfrom=&chfieldto=Now&j_top=AND&f1=noop&o1=noop&v1=&format=table&action=wrap
19:39:47 <colonelqubit> (maybe some limit in this IRC client)
19:39:53 <colonelqubit> sdfsdf
19:39:57 <colonelqubit> yeah
19:40:11 <colonelqubit> Anyhow, combine those together to get one url
19:40:34 <beluga_> colonelqubit: I got it!
19:40:35 <colonelqubit> Or here's a shortner version: http://ur1.ca/k86nt
19:41:03 <beluga_> I never understood that thing :) now is the first time I'm seeing a result
19:41:05 <IZBot> News from tdfnew: [Bug 90788] An irritating bug with a font <https://bugs.documentfoundation.org/show_bug.cgi?id=90788> || [Bug 90779] Editing with F2 after Fill Down not possible <https://bugs.documentfoundation.org/show_bug.cgi?id=90779>
19:41:23 <ertai_NL> a trivial with highest priority?
19:41:27 <colonelqubit> we should definitely review the 32 blockers
19:41:32 <colonelqubit> ertai_NL: yeah... :P
19:41:39 <beluga_> that is pretty useful
19:41:52 <colonelqubit> restricting access to some of those fields is on my todo list soon :-)
19:43:01 <colonelqubit> Okay, we're at about the hour mark now. Any more topics for us to address?
19:44:47 <beluga_> I think not.. let's keep punching those bugs and see where we're at in 2 weeks
19:45:16 <colonelqubit> Yep, let's keep up the pressure on the UNCONFIRMED bugs.
19:45:37 <colonelqubit> Please use tags like [hard to repro] to help us stay focused on the bugs that are tractable
19:46:14 <colonelqubit> And feel free to send hard bugs my way!
19:46:18 * colonelqubit waves
19:46:42 <colonelqubit> Our next meeting is May 6th
19:46:56 <colonelqubit> #endmeeting