18:44:28 <colonelqubit> #startmeeting
18:44:28 <IZBot> Meeting started Wed Feb 11 18:44:28 2015 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
18:44:28 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:44:56 * colonelqubit looks down to see if he has 4 feet
18:44:57 <JBFaure> Hi all :-)
18:45:10 * colonelqubit waves
18:45:16 <jab_> hi
18:45:22 <sophi> JBFaure: hello :)
18:45:23 <colonelqubit> JBFaure: how's it going? What marvelous things have you for us this week?
18:45:27 <beluga> hey hey hey
18:46:33 * colonelqubit peers around
18:46:38 <colonelqubit> jmadero: you in class?
18:47:00 <colonelqubit> ertai_NL: poke
18:47:07 <colonelqubit> mjayfrancis: you here?
18:47:27 <colonelqubit> Sooo... since we last talked
18:47:32 <JBFaure> colonelqubit: I did not have time to search bugs in sorting function in Calc, /me busy with L10n  and local flamewars ;-)
18:47:44 <colonelqubit> JBFaure: ah, sounds like fun
18:48:05 <JBFaure> sophi: hello :-)
18:48:11 <sophi> colonelqubit: joy of the FR community :)
18:48:25 <colonelqubit> where's Italo?  I think he'd say something about "passion" about now
18:48:39 <colonelqubit> firey passion...
18:48:41 <IZBot> News from tdfnew: [Bug 89314] Cannot paste pictures <https://bugs.documentfoundation.org/show_bug.cgi?id=89314>
18:48:41 <sophi> colonelqubit: sort of :)
18:48:56 <colonelqubit> So... Bugzilla is apparently up right now
18:49:27 <colonelqubit> I know that it's been a little flakey lately. Big thanks to cloph for tending to it when it gets fussy
18:49:56 <colonelqubit> If we continue to see problems, we'll plan some more invasive changes
18:50:12 <colonelqubit> FOSDEM happened -- it was great to see so many of you there!
18:50:14 <jab_> bugzilla is broken again
18:50:27 <jab_> nginx timeout looks very small. at least i cannot save my changes
18:50:38 <sophi> colonelqubit: was great to see you too!
18:51:08 <colonelqubit> jab_: hmm, loads for me here...
18:51:12 <colonelqubit> ((slowly0)
18:51:16 <colonelqubit> (slowly)
18:51:58 <colonelqubit> I'll take another look after the meeting
18:52:11 <colonelqubit> Speaking of Bugzilla, I'm upgrading us to 4.4.8
18:52:33 <colonelqubit> But I want to test it out a bit first, so please poke at https://bugzilla-test.documentfoundation.org/ today
18:52:55 <IZBot> News from asklibo: Can LibreOffice be configured to show filename extensions <http://ask.libreoffice.org/en/question/46193/can-libreoffice-be-configured-to-show-filename-extensions/> || In Impress, I do not get an animation pane. <http://ask.libreoffice.org/en/question/46191/in-impress-i-do-not-get-an-animation-pane/> || Can Calc default print grid be set to ON? <http://ask.libreoffice.org/en/question/46036/can-calc-default-print-grid-be-set-to-on/> || Convert docx to mediawiki and preserve [[Image:]] <http://ask.libreoffice.org/en/question/46188/convert-docx-to-mediawiki-and-preserve-image/> || How to define the active cell <http://ask.libreoffice.org/en/question/46137/how-to-define-the-active-cell/> || version 4.2.6.3, EN, Impress, Ubuntu 14.04, EN, How to insert music into existing slide show <http://ask.libreoffice.org/en/question/46183/version-4263-en-impress-ubuntu-1404-en-how-to-insert-music-into-existing-slide-show/> || How to split multiple rows in Calc? <http://ask.libreoffice.org/en/question/46156/how-to-split-multiple-rows-in-calc/> || How do I install label extentions <http://ask.libreoffice.org/en/question/46162/how-do-i-install-label-extentions/> || libreoffce doen't work in 64bit ubuntu,help!!!!!! <http://ask.libreoffice.org/en/question/46166/libreoffce-doent-work-in-64bit-ubuntuhelp/> || What is this and how to remove it (Excel document)? <http://ask.libreoffice.org/en/question/46163/what-is-this-and-how-to-remove-it-excel-document/> || If I make master slides in Impress, sometimes I see (wrong) or (good) after the name. Deleting that kind of slides is not possible. How can I do that? <http://ask.libreoffice.org/en/question/46160/if-i-make-master-slides-in-impress-sometimes-i-see-wrong-or-good-after-the-name-deleting-that-kind-of-slides-is-not-possible-how-can-i-do-that/> || Feature Feedback from a Writer <http://ask.libreoffice.org/en/question/46161/feature-feedback-from-a-writer/> || Feature Req: Link Defaults (_blank) <http://ask.libreoffice.org/en/question/46158/feature-req-link-defaults-_blank/> || Copying styles between diagrams <http://ask.libreoffice.org/en/question/46125/copying-styles-between-diagrams/> || from where to download 4.2.4.1. LibreOffice <http://ask.libreoffice.org/en/question/46153/from-where-to-download-4241-libreoffice/> || Impress version 4.4.0.3 can't insert /bed any video into slides <http://ask.libreoffice.org/en/question/46148/impress-version-4403-cant-insert-bed-any-video-into-slides/> || pasting spreadsheet data without linefeed at end <http://ask.libreoffice.org/en/question/46097/pasting-spreadsheet-data-without-linefeed-at-end/> || spell check <http://ask.libreoffice.org/en/question/46115/spell-check/> || Wizards in Base do not run <http://ask.libreoffice.org/en/question/46138/wizards-in-base-do-not-run/> || download LibreOffice version 4.1.4.2. <http://ask.libreoffice.org/en/question/46132/download-libreoffice-version-4142/> || Error de lectura <http://ask.libreoffice.org/es/question/46066/error-de-lectura/> || "old style figures" <http://ask.libreoffice.org/en/question/46128/old-style-figures/> || LO Writer 4.2.8.2-2 Freezing - restart required Fedora 20 <http://ask.libreoffice.org/en/question/46122/lo-writer-4282-2-freezing-restart-required-fedora-20/> || How to populate foreign key on child record creation <http://ask.libreoffice.org/en/question/46055/how-to-populate-foreign-key-on-child-record-creation/> || Calcの図形描画オブジェクトのスタイルを設定するには? <http://ask.libreoffice.org/ja/question/46060/calcnotu-xing-miao-hua-obuziekutonosutairuwoshe-ding-suruniha/> || Calc 4.2.7.2 , Czech lanquage AutoCorrec wrong number format <http://ask.libreoffice.org/en/question/46067/calc-4272-czech-lanquage-autocorrec-wrong-number-format/> || In Writer, (4252) how do I get rid of the terms today, yesterday, a long time ago? <http://ask.libreoffice.org/en/question/46116/in-writer-4252-how-do-i-get-rid-of-the-terms-today-yesterday-a-long-time-ago/> || ¿Como poner los temas de iconos en el nuevo LibreOffice? <http://ask.libreoffice.org/es/question/46026/como-poner-los-temas-de-iconos-en-el-nuevo-libreoffice/> || Upgrade to 4.4.0.3 broke printing <http://ask.libreoffice.org/en/question/45699/upgrade-to-4403-broke-printing/> || Which directory do I put Python macros in LibreOffice on the Mac <http://ask.libreoffice.org/en/question/46112/which-directory-do-i-put-python-macros-in-libreoffice-on-the-mac/>
18:53:00 <colonelqubit> That's live with all of our data from bugzilla, so your passwords will be the same. Dump's a few days old
18:53:31 <sophi> colonelqubit: when is the end testing period?
18:53:46 <beluga> sophi: no end in sight
18:53:47 <colonelqubit> sophi: suggestions?  Maybe a day from now?
18:54:01 <beluga> we will always test some new version :)
18:54:02 <colonelqubit> The diff from 4.4.6 -> 4.4.8 is pretty small
18:54:07 <sophi> colonelqubit: ok, your today is my tonight so ;)
18:54:15 <colonelqubit> sophi: yeah, so 24h
18:54:22 <sophi> colonelqubit: ok, thanks
18:54:29 <colonelqubit> sophi: at least we'll always have brussels... ;-)
18:54:44 <sophi> colonelqubit: lol
18:55:14 <colonelqubit> FOSDEM: Beer everywhere, and no water fountains
18:55:29 <beluga> so the D stands for dehydration
18:55:46 <colonelqubit> On the topic of Bugzilla, big thanks to jmadero for starting work on cleaning up the keywords
18:56:11 <colonelqubit> I believe that there's still some work to be done there, so if you have time -- please go read his email and help out
18:56:48 <colonelqubit> #topic BSA
18:56:51 <sophi> colonelqubit: I've tried but finally closed 2 bugs and forget about the keywords :(
18:57:08 <jmadero> colonelqubit: am in class - for bugzilla would be good to get help (see my email)
18:57:11 <colonelqubit> sophi: yeah, no worries there -- we'll figure it out as we go :-)
18:57:12 <jmadero> need to remove some of those keywords
18:57:15 <jmadero> can't say more now sorry
18:57:28 <colonelqubit> jmadero: do you have link for that email?
18:57:54 <beluga> I'll dig the link
18:57:59 * colonelqubit thanks beluga
18:58:21 <sophi> colonelqubit: http://nabble.documentfoundation.org/Libreoffice-qa-Keywords-tt4138492.html
18:58:23 <colonelqubit> Regarding the BSA, it looks like we're going to test-out using Bugzilla Guided Forms
18:58:47 <beluga> yeah that's the thread
18:59:10 <colonelqubit> The guided forms should help new users who aren't as familiar with our Bugzilla file their first bug reports about LibreOffice
18:59:53 <colonelqubit> I was hoping ertai_NL would be here, but I'll just give him an action item :-)
19:00:49 <colonelqubit> #action Rob will (hopefully have time to) tell us more about Bugzilla Guided Forms by the next meeting :-)
19:01:27 <colonelqubit> #topic New volunteers
19:01:53 <colonelqubit> One of the things that I discussed with a couple of people at FOSDEM was some thoughts about how we can better recruit new people into the project
19:02:06 <jmadero> colonelqubit: another thing, again, can't talk (sorry) is if we can default to "LibreOffice" product (see redmine ticket)
19:02:12 <jmadero> I really dislike the product list that we have already :-/
19:02:40 <sophi> jmadero: agreed, it's difficult to find his way in it
19:02:40 <colonelqubit> jmadero: my idea there was to have the get-help/bug link go to the guided form for LibreOffice
19:03:07 <jab_> hi, i'm a new volunteer. i live in northern germany and work at a local university
19:03:09 <colonelqubit> So basically the default link we provide is the BSA-replacement
19:03:13 <jmadero> how many bugs are realistically being reported against these new products
19:03:15 <jmadero> 0.001%
19:03:23 * colonelqubit waves to jab_
19:03:32 <sophi> jab_: welcome aboard :)
19:03:35 <colonelqubit> jmadero: yeah, small number. That's why the BSA can just point directly to LibreOffice (IMHO)
19:03:42 <colonelqubit> "BSA-replacement"
19:04:12 <sophi> JBFaure: that means that there will be no more BSA in French
19:04:26 <colonelqubit> sophi: actually.... that's a different story
19:04:40 <Liongold> If I can jump in, I think the multilingual BSA can be kept.
19:04:49 <sophi> colonelqubit: what do you mean?
19:05:03 <Liongold> It should work because as far as I know it does not connect to Bugzilla.
19:05:13 <colonelqubit> sophi: if it directly emails to the FR mailing list, I think it's fine to leave that part as-is
19:05:13 <JBFaure> bugzilla-test has problem to access attachments
19:05:15 <sophi> Liongold: right
19:05:26 <sophi> colonelqubit: ok
19:05:28 <colonelqubit> JBFaure: ah yes, urls are probably off. One second
19:05:43 <colonelqubit> sophi: it's a different URL for the FR-BSA, right?
19:06:03 <sophi> colonelqubit: yes, I think it doesn't work currently, not sure
19:06:53 <JBFaure> sophi: I can't remember when somebody sent a bug report using FR-BSA
19:06:54 <Liongold> sophi: The problem shouldn't be hard to fix I think. Right colonelqubit ?
19:06:56 <colonelqubit> #action Sophie will file bug(s) re: the FR-BSA (to Robinson/Cloph)
19:07:19 <sophi> JBFaure: it doesn't work currently, it redirects to BZ from what I see
19:07:37 <sophi> JBFaure: maybe since the new design on the site
19:07:45 <colonelqubit> Liongold: I think it should be pretty straightforward. Rob had some of the BSA infra running on the Bugzilla VM. We'll just need to put that in salt
19:08:25 <colonelqubit> JBFaure: let's talk attachments after the meeting :-)
19:08:38 <JBFaure> colonelqubit: ok :-)
19:09:23 <colonelqubit> JBFaure: if it's just a cert issue, then that's probably a known problem
19:10:12 <colonelqubit> If we're done on the BSA topic?
19:10:31 <colonelqubit> Okay, back to volunteers
19:10:53 <colonelqubit> I was going to mention that we have a big conference coming up in California next week, and I'm going to be doing some recruiting
19:11:06 <colonelqubit> As always, if you have suggestions about how we can recruit/retain, please do share :-)
19:11:25 <colonelqubit> jab_: as a new community member, your input would be great!
19:12:00 <jab_> colonelqubit, well as faculty member i would suggest to give the work out to students ;-)
19:12:06 * colonelqubit nods
19:12:15 <colonelqubit> jmadero's a big fan of us connecting w/universities
19:12:38 <jmadero> jab_: would be incredible if we could get an independent study course
19:12:41 <jab_> otherwise its probably a good way to just ask people who did write good bug reports
19:12:42 <jmadero> students get units for working with us
19:12:52 <jmadero> our project is great "real world" experience
19:12:56 <colonelqubit> Like GSoC, it can take some legwork, but I agree that it's a valuable target
19:12:59 <jab_> like beluga did with me
19:13:03 <beluga> I would suggest starting with very simple things.. the motivation to continue is up to the individual
19:13:10 <colonelqubit> I've got a couple of UCLA students helping out at the booth at SCALE next week
19:13:31 * colonelqubit will cleverly see if they'd like to become even more involved with the project :-)
19:13:55 <jab_> i can supervise bachelor or masters thesis projects but it has to be a closed topic
19:13:55 <colonelqubit> beluga: start w/very simple thigns for the students to do?
19:13:57 <sophi> colonelqubit: BTW I've updated MozTrap to RC1 ;)
19:14:11 <beluga> just saying: "you can start with simple comments and if you get into it, start looking into more thorough testing"
19:14:23 <colonelqubit> sophi: awesome!  Thanks for being the ringmaster over there :-)
19:14:39 <jab_> the problem is: it has to involve some research. at least for master thesis projects
19:15:00 <beluga> jab_: maybe regressions would be a good research topic?
19:15:03 <sophi> colonelqubit: yes, but it's a simple thing to enter the project ;)
19:15:16 <colonelqubit> jab_: I think the potential for research is pretty big
19:15:29 <colonelqubit> Big-picture for LibreOffice, there are a number of directions that the project can go
19:16:02 <jab_> the other way would be to offer a study course. but that is quite a process and i would have to ask my professors first. would start earliest 18 month from now
19:16:09 <colonelqubit> Research into user-interface design, new methods of reduction/calculation of large spreadsheets and data sets, etc..
19:16:50 <jab_> we are an institute for systems engineering
19:16:57 <colonelqubit> Cool
19:17:55 <jab_> we do distributed or adaptive systems. thats probably another direction of research
19:18:26 <colonelqubit> jmadero: maybe we could set up a meeting?
19:18:36 <colonelqubit> I think Marc Pare has some connections up in Canada as well
19:19:00 <colonelqubit> might be good to brainstorm some frameworks in which TDF/LO could work with a university
19:19:35 <beluga> colonelqubit: re: Canada - http://ucosp.ca/
19:19:37 <colonelqubit> We'd want some strong community members to help test it out
19:20:27 <beluga> colonelqubit: well, VALS SoC would be a good framework as it matures
19:20:40 <colonelqubit> The first university or two, we'd need to have strong support on the ground there to make sure that we can work through any initial hurdles
19:20:45 <beluga> jab_: are you familiar with http://semesterofcode.com/ ?
19:21:30 <jab_> beluga, no. i know GSoC
19:21:54 <beluga> jab_: that one is for EU unis
19:22:17 <colonelqubit> Okay, so let's see... action item?
19:22:17 <jab_> we did GSoC before. so this may work
19:22:57 <colonelqubit> #action jmadero, jab_, and beluga will chat about our strategy of collaborating with universities
19:23:38 <colonelqubit> Okay, I think that's basically it from me
19:24:30 <beluga> I have a small question: if we see bug reports coming from a company, should we encourage them to have a colleague confirm their reports immediately? I'm thinking Studio Storti specifically now
19:24:43 <JBFaure> sorry, dinner time for me ;-)
19:24:45 <colonelqubit> UNCONFIRMED bug count is down to 278 -- So we're continuing to chip away!
19:24:55 <colonelqubit> beluga: yes, definitely
19:25:05 <beluga> ok I will contact them
19:25:09 * colonelqubit thinks
19:25:39 <colonelqubit> So bug confirmation has 2 purposes
19:25:47 <colonelqubit> 1) It makes sure that people aren't smoking crack
19:25:56 <jmadero> I'm more than happy to help develop an independent study syllabus
19:26:03 <jmadero> but we need a test school to say they're willing to talk
19:26:06 <jmadero> so far I've had zero luck
19:26:09 <colonelqubit> 2) It makes sure that it's not an issue of a single crack-smoking machine
19:26:54 <colonelqubit> For example, jphilips has a machine or two that act differently from any other machine out there -- even his other machines
19:27:09 <colonelqubit> #topic General Discussion
19:27:53 <colonelqubit> So bug confirmation is important to make sure that we don't waste dev time chasing down a bug that only happens on 1 machine
19:28:12 <colonelqubit> But I think we should trust Studio Storti :-)
19:28:32 <colonelqubit> So -- who has stuff to bring up/discuss?
19:28:34 <beluga> one action item could be for jmadero to make the second NEW mass-ping.. should we go for < 1 year olds?
19:28:45 <jmadero> beluga: yes it's on my list but I'm trying to do it a little differently
19:28:50 <jmadero> might wait until March 1st, apologies
19:29:02 <colonelqubit> beluga: what did the 1-year-olds ever do to you?
19:29:33 <colonelqubit> :-)
19:30:17 <beluga> they just sit there silently judging me
19:30:30 <jmadero> beluga: one good thing would be to dig through NEEDINFO that have QA commented
19:30:39 <jmadero> most are probably invalid or new at this point
19:30:46 <beluga> jmadero: again?
19:30:55 <jmadero> beluga: we'll talk later
19:30:56 <jmadero> sorry
19:31:01 <jmadero> 3 minutes
19:31:47 <jab_> i have to go home now. see you tomorrow
19:31:48 <beluga> ok I can't think of anything else
19:32:20 * colonelqubit waves to jab_
19:32:25 <colonelqubit> thanks for joining!
19:32:36 <colonelqubit> beluga: how are we doing with older UNCONFIRMED bugs?
19:32:41 <colonelqubit> (or newer ones as well)
19:32:55 <colonelqubit> What percentage are hard to triage?
19:32:57 <beluga> colonelqubit: well jab_ actually tackled some of the hard ones from my list
19:33:04 <colonelqubit> That's great
19:33:16 * sophi away for diner
19:33:26 * colonelqubit waves goodbye to sophi
19:33:39 <sophi> Bye all!
19:33:55 <colonelqubit> beluga: I think we should have a discussion at some point about what to do with the hard ones
19:34:31 <beluga> colonelqubit: I'll keep maintaining my hard bug list for the time being, as an art project if nothing else.. would be nice to get the Bugzilla API wiki thing going after BZ 5.0 upgrade, so we can see at a glance what the situation is (which ones are NEEDINFO etc.)
19:34:42 <colonelqubit> basically:
19:34:44 <colonelqubit> - We've tested on the same system/same LO version
19:34:46 <colonelqubit> - gotten a test document
19:34:48 <colonelqubit> - good repro steps exist
19:34:50 <colonelqubit> - user claims they can repro on other machines
19:34:51 <Liongold> sophi: Bye
19:35:00 <jmadero> beluga: ping
19:35:03 <jmadero> I have about 5
19:35:03 <colonelqubit> beluga: yep, feel free to file a bug about that in redmine if you haven't already
19:35:06 <beluga> jmadero: yeah
19:35:31 <jmadero> beluga: so the issue is that I mass ping, and users don't read the freaking message
19:35:35 <jmadero> so they'll comment, and not change the status
19:35:40 <colonelqubit> Okay, sounds like we're losing people at an accelerating rate, so it's about time to sign-off :-)
19:35:40 <jmadero> every single round I have to dig through those ones
19:35:50 <jmadero> the alternative is just to close all as INVALID because they didn't follow instructions
19:36:01 <jmadero> (i.e., changing to UNCONFIRMED)
19:36:02 <colonelqubit> Big thanks to all of you for showing up!  If you have an ACTION item, please remember to follow-up with it
19:36:04 <beluga> jmadero: you're talking about NEEDINFO ping?
19:36:10 <jmadero> beluga: yes after the ping
19:36:18 <colonelqubit> Liongold: any final words?
19:36:58 <jmadero> beluga: because ideally I ping, and a user responds, and then the user changes the status - unfortunately that doesn't happen often
19:37:06 <colonelqubit> Okay, bye all!
19:37:09 <jmadero> beluga: I'll mass close now and whatever is left over needs looked at
19:37:10 <beluga> jmadero: I'll look into them periodically until we get a feature in BZ that makes scrutiny easier
19:37:11 <colonelqubit> #endmeeting