19:05:13 <colonelqubit> #startmeeting
19:05:13 <IZBot> Meeting started Wed Dec 17 19:05:13 2014 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
19:05:13 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:05:37 <colonelqubit> UNCONFIRMED: we have 502 bugs
19:05:42 <colonelqubit> y'all are awesome!
19:06:09 <colonelqubit> sophi: could you please describe the current idea re: UX bugs?
19:06:24 <colonelqubit> (also, welcome, arnaud_versini :-)
19:06:47 <arnaud_versini> colonelqubit: Hi :-)
19:07:03 <sophi> colonelqubit: this is all said by Stuart: Guess issue can simply be set new on opening, and always assign to ux-advise component.  Work flow would be to keep  these issues open (or maybe needinfo) in ux-advise until Design/UX-advise folks agree to move it forward for development, or close it out.
19:07:27 <colonelqubit> arnaud_versini: to bring you and anyone reading the minutes up to speed -- we're talking about how to deal with UX bugs (see thread here: http://nabble.documentfoundation.org/RFE-process-between-QA-and-UX-tt4132849.html)
19:07:49 * arnaud_versini is reading
19:09:27 <sophi> colonelqubit: I don't see a need to discuss it over and over, just let try it and see if both teams are happy with that
19:09:28 <colonelqubit> sophi: sounds good
19:09:52 <sophi> colonelqubit: ok :)
19:10:08 <colonelqubit> sophi: so for any UX bugs QA sees, can we toss those into UX-advise?
19:10:19 <sophi> colonelqubit: yes
19:10:23 <jmadero> sophi: and NEW or NEEDINFO?
19:10:33 <sophi> jmadero: yes
19:10:36 * colonelqubit laughs
19:10:37 <jmadero> which one ?
19:10:47 <colonelqubit> jmadero: sounds like UX will use NEW/NEEDINFO themselves
19:10:49 <jphilipz> i'll set them to NEW
19:10:59 <jmadero> sophi: what am I setting them to?
19:11:12 <sophi> jmadero: new
19:11:17 * colonelqubit nods
19:11:17 <jmadero> okay
19:11:27 <jmadero> then I am no longer doing any commits on UX issues
19:11:33 <arnaud_versini> NEDDINFO is better I think for dev to know that they should wait for this bug
19:11:34 <jmadero> because I have no clue when they are accepted and when they aren't
19:11:43 <jmadero> arnaud_versini: I agree - but we've been outvoted ;)
19:11:45 <colonelqubit> arnaud_versini: but the bug will be assigned to UX
19:12:00 <arnaud_versini> jmadero: I'm connecting another time to be more than one
19:12:02 <colonelqubit> theoretically, one shouldn't take an assigned bug
19:12:30 <jmadero> sophi: so we expect UX team to discuss, and to unassign UX team when they decide?
19:12:34 <jmadero> and set it back to default?
19:12:55 * colonelqubit likes this plan
19:12:58 <jphilipz> quoting from my email that didnt get in the thread
19:13:08 <jmadero> sophi: and additionally to set the component correctly?
19:13:11 <jphilipz> "As i'm opening enhancement requests, sometimes i seek the advise of more experienced users to know whether the enhancement is a good idea or not."
19:13:13 <sophi> jmadero: no, they have them, they deal with them, solve it or close it
19:13:18 <jphilipz> "If the QA team doesnt wish to give their input into these enhancement requests, then i think the simplest thing to do is to set them all as ux-advise rather than what i currently do of assigning it to the component and CC ux-advise."
19:13:29 <jmadero> sophi: +1, sounds good, so I'm done implementing UX enhancements, fantastic
19:13:38 <jmadero> I think we're all on the same page now
19:13:45 <jmadero> jphilipz: please set to ux-advise also
19:13:52 <jmadero> if you refuse, so be it, but it seems like that's the agreed upon workflow
19:13:54 <jmadero> from virtually everyone
19:14:01 <jphilipz> jmadero: well i wasnt sure what was UX, but now i am :D
19:14:15 <jmadero> yes - but you are one voice, and if you set to ux-advise it assigns the bug
19:14:17 <jphilipz> so will do
19:14:21 <jmadero> thus making it so other devs don't take it
19:14:22 <jmadero> thanks!
19:14:28 <jmadero> :-D everyone is happy, we can move on
19:14:29 <colonelqubit> jmadero: ideally, I can imagine UX removing themselves from assignment, but only if
19:14:31 <colonelqubit> 1) It turns out not to be an enhancement or UX issue
19:14:32 <jmadero> sophi: you'll email list?
19:14:33 <colonelqubit> 2) They triage it/get it ready for another dev to handle
19:14:38 <sophi> jmadero: yes
19:14:41 <jmadero> +100
19:14:43 * jmadero is happy
19:15:10 * sophi is happy when jmadero is happy ;)
19:15:17 <jmadero> that's a rarity ;)
19:15:20 <jmadero> that I'm happy lol
19:15:23 <jphilipz> lol
19:15:26 <colonelqubit> #action sophi will email out new guidelines about UX bugs
19:15:47 <colonelqubit> we should update BugTriage page as well on the wiki
19:16:07 <colonelqubit> sophi: can you do that, too?
19:16:15 <colonelqubit> or I can do it
19:16:36 <sophi> colonelqubit: as you want, I can do it if you don't :)
19:17:04 <colonelqubit> #action sophi/robinson will make sure BugTriage page gets updated with UX bug guidelines
19:17:21 <colonelqubit> Okay, let's see
19:17:40 <colonelqubit> Housekeeping stuff: first off, our next meeting would be in 2 weeks which is Dec 31st.
19:17:46 <colonelqubit> Is anyone going to be around then?
19:18:10 <mjayfrancis> (… and not inebriated?)
19:18:17 <arnaud_versini> colonelqubit: I'll be in the plane, not here, bad idea I think
19:18:17 <sophi> colonelqubit: not me
19:18:53 <sophi> colonelqubit: I think anyone in Europe will be away
19:18:57 * colonelqubit nods
19:19:18 <colonelqubit> Okay, we'll have a totally optional (even more optional than most weeks!) meeting
19:19:24 <colonelqubit> Bring something tasty to drink
19:19:51 <colonelqubit> There is no goal to get any real work done
19:20:10 <colonelqubit> But if someone thinks up something good, we won't prohibit it
19:20:12 <colonelqubit> :-)
19:20:34 <colonelqubit> Okay, so on to this meeting
19:20:56 <colonelqubit> Last week we chatted w/markus and got agreement that all dev /unit test bugs are going to the dev list
19:21:29 <colonelqubit> I haven't heard anything negative about that decision, so it sounds solid
19:21:48 <colonelqubit> I updated the BugReport page with that information
19:21:59 <colonelqubit> https://wiki.documentfoundation.org/QA/BugReport#Not_all_bugs_go_to_Bugzilla
19:22:04 <arnaud_versini> colonelqubit: how many emails does it generate per day ?
19:22:33 <colonelqubit> arnaud_versini: total # of questions about building/unit tests to the dev list is probably 4 a week?
19:22:36 <colonelqubit> it's small
19:22:52 <colonelqubit> but I think the problem is that bugs were getting lost in Bugzilla, and we weren't responding to new developers
19:23:26 <arnaud_versini> colonelqubit: I'm just thinking that 1 thousand mail per day I won't read them all :-)
19:23:34 * colonelqubit nods
19:23:45 <colonelqubit> the dev list is high-traffic w/commits, but I filter them
19:24:05 <colonelqubit> The 2nd decision we had last week was re: bugs fixed in a newer version: https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/RESOLVED#Fixed_in_a_newer_version
19:24:31 <colonelqubit> Another corner-case, but good that we came to agreement
19:24:57 <colonelqubit> I have a few stats to pass along, but first, who has something to discuss?
19:26:29 <colonelqubit> problematic bugs?
19:28:35 <colonelqubit> Anyone using bibisect44 yet?
19:28:53 <arnaud_versini> colonelqubit: Sorry I'm filling a new bug :-)
19:29:04 <mjayfrancis> Yes to bibisect44
19:29:14 <colonelqubit> arnaud_versini: but we already have so many!
19:29:44 <colonelqubit> mjayfrancis: good
19:30:15 <mjayfrancis> bibisect requests down to… 31, when I checked earlier?
19:30:57 <mjayfrancis> It's been a busy few days with work, but getting ever closer to the bottom nonetheless
19:31:25 <colonelqubit> I assume that the 64-commit range is narrow enough for devs?
19:32:33 <colonelqubit> mjayfrancis: yep, 34 right now
19:32:46 <mjayfrancis> For me, sometimes it's just obvious what the guilty commit is just from reading the commit logs in the range. The rest need follow-up source bisection
19:32:53 <mjayfrancis> The range size doesn't seem excessive
19:34:07 <mjayfrancis> As previously mentioned, when we get ~to the bottom, I will see about bisecting more of them down to commit granularity. One more more old-model distributions in VMs will be needed
19:35:00 <colonelqubit> mjayfrancis: oh, we'll need to distribute VMs set up for bibisecting?
19:35:48 <mjayfrancis> I've had some success shepherding bibisected bugs through to the responsible or other devs, but without a plausible specific commit to point at few of them are going to have the inclination or time to take a given bug any further
19:37:17 <mjayfrancis> I've got more than enough horsepower locally now to source bisect bugs with some speed, I just need to set up some older toolchains. Ubuntu 14.04 can't compile any particularly old version of LO, the dependencies just aren't right any more
19:37:29 <colonelqubit> If we had a fast enough network, it would be neat to be able to do on-demand building of old versions
19:37:41 <IZBot> News from fdonew: [Bug 87419] SIDEBAR bad looking sidebar docked on the left side <https://bugs.freedesktop.org/show_bug.cgi?id=87419>
19:37:55 <colonelqubit> so basically you run bibisect, and then at the last stages, you use POWERFUL_BUILD_MACHINE to build and send down those last builds
19:38:12 <mjayfrancis> Machine-s, plural :) but yes
19:38:19 <arnaud_versini> colonelqubit: Sorry a new one
19:38:27 <colonelqubit> but I think there's a remedy there: Do it in the cloud
19:38:29 <sophi> colonelqubit: but we have an archive with old version
19:38:41 <mjayfrancis> There are two, which between them can build a tree in ~40 minutes
19:38:41 <colonelqubit> sophi: right, I mean for bisecting down to a single commit
19:38:55 <sophi> colonelqubit: ah sorry didn't read all
19:39:08 <colonelqubit> :-) no worries -- you're probably distracted with your legos
19:39:09 <arnaud_versini> colonelqubit: bibisecting is mandatory first
19:39:21 <mjayfrancis> colonelqubit: My bandwidth to the outside world is spotty at best. For me at least, doing it locally is the answer
19:39:35 <colonelqubit> oh man, I have to dig those out when I get home to my parents' place!  Legos are so nifty!
19:39:56 <colonelqubit> arnaud_versini: oh, certainly
19:40:09 <sophi> colonelqubit: no l10n is eating me all ;)
19:40:36 <colonelqubit> but for people who don't have that computing power locally, being able to use x2go means that we wouldn't have to download anything
19:40:46 <colonelqubit> (or VNC)
19:40:59 <colonelqubit> I'll look into that more in the future
19:41:36 <colonelqubit> Speaking of which .... we're going to have cloud servers available for the BugHunting Session this week. You'll just need an x2go client to connect
19:43:05 <colonelqubit> https://wiki.documentfoundation.org/BugHunting_Session_4.4.0_RC1
19:44:34 <colonelqubit> I know that many of you already test locally, but feedback on the instructions is always helpful -- I'll link to it from the wiki page above
19:44:51 <colonelqubit> (I'll have the instructions up by Friday)
19:47:24 <colonelqubit> Okay, people, anything else?
19:47:41 <arnaud_versini> colonelqubit: I'll retest instructions on openSUSE if you want
19:47:49 <colonelqubit> yeah, that'd be great
19:49:02 <colonelqubit> Quick Stats round-up:
19:49:16 <colonelqubit> UNCONFIRMED bugs dropped below 500 before settling around 500ish
19:49:36 <colonelqubit> An early X-mas present!  (Although I hear talk about pushing that number even lower)
19:50:30 <colonelqubit> Other stats held even -- needAdvice, preBibisect
19:51:09 <colonelqubit> Regressions in 4.4, 4.3, and 4.2 dropped across the board, which combined with keeping the UNCONFIRMED count low is great
19:51:48 <colonelqubit> And bibisected bugs jumped up to 219 from 185 (woot!)
19:52:19 <arnaud_versini> colonelqubit: You means bibisected and closed ?
19:52:44 <colonelqubit> (well, that was a woot for QA; those are still open ... :P )
19:53:26 <arnaud_versini> colonelqubit: I don't understand, we bibisect and there is less bug bibisected ?
19:54:19 <arnaud_versini> colonelqubit: Sorry, my mistake :-D
19:54:42 <colonelqubit> yeah, should have said "up from 185 to 219"
19:54:58 <colonelqubit> at least latin english is not
19:55:07 <colonelqubit> (regarding word position wherever you like)
19:55:07 <arnaud_versini> colonelqubit: My logic and my english is bad ... :-)
19:56:46 <mjayfrancis> Sentences any order in can be, if Yoda to speak like willing you are :)
19:57:03 <colonelqubit> pas aussi horrible que le francais a moi...
19:57:15 <colonelqubit> (le francais je parles?)
19:57:36 * colonelqubit battre des ailes
19:58:09 <colonelqubit> Okay, I don't want to keep you for ever
19:58:22 <colonelqubit> So any other items to discuss? Holiday plans to announce?
19:58:38 <sophi> nothing on my side
19:58:47 <colonelqubit> I'd invite you all over for Christmas, but you're so far awaaaay
19:58:49 <arnaud_versini> colonelqubit: I'm going to Paris on saturday :-)
19:59:14 * colonelqubit decorated his tree with hard drive platters
19:59:17 <sophi> colonelqubit: thanks :)
20:00:00 <sophi> arnaud_versini: you spend Christmas in Paris
20:00:42 <arnaud_versini> sophi: Near Paris
20:00:59 <sophi> arnaud_versini: ok
20:01:21 <sophi> Bye all!
20:01:59 <colonelqubit> Okay, one last thing: Bugzilla Migration has been confirmed for January 24th
20:02:17 <arnaud_versini> colonelqubit: I really think December is better on this date
20:02:26 <colonelqubit> I wanted to tell y'all first -- I'll send out emails, etc.. with more info
20:02:29 <jmadero> arnaud_versini: we are not ready
20:02:32 <jmadero> December is not better
20:02:40 <jmadero> and with holidays if something goes wrong, we're screwed
20:02:51 <colonelqubit> arnaud_versini: it's a question of getting everyone we need together from TDF and FDO
20:02:58 <colonelqubit> and January 24th works out for that
20:03:00 <jmadero> and being available for problems ;)
20:03:04 <jmadero> colonelqubit: I'm happy to hear that :-D
20:03:06 <colonelqubit> that too, yes :-)
20:03:23 <jmadero> thanks for your work
20:03:27 <colonelqubit> Have a Happy Holidays everyone!
20:04:06 <colonelqubit> Drive safely, and take it easy on the egg nog if you'll be on snowy/slick roads.
20:04:31 * colonelqubit waves
20:04:38 <colonelqubit> jmadero: thanks ;-)
20:05:51 <colonelqubit> #endmeeting