17:50:44 <colonelqubit> #startmeeting
17:50:44 <IZBot> Meeting started Wed Oct 22 17:50:44 2014 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
17:50:44 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:51:01 * colonelqubit waves -- who's here?  Say hi!
17:51:11 <beluga_> hi!
17:51:40 <Liongold> hi, if I may
17:52:32 <colonelqubit> okay, I know that sophi, arnaud_versini, and a few others are around here somewhere :-)
17:52:48 <colonelqubit> Our UNCONFIRMED bug count has indeed broken 750
17:52:56 <colonelqubit> (down to 746)
17:53:21 <colonelqubit> A big thanks to everyone who's been triaging and slowly lowering that number down
17:54:12 <colonelqubit> This Sunday is our first 'LibreFest' -- a combination Hackfest and Bug-Triaging-Bee in Seattle, and I'm hoping to introduce a number of people to QA at that point
17:54:37 <sophi> colonelqubit: great :)
17:54:39 * colonelqubit goes to check on numbers
17:55:03 <colonelqubit> We've got 22 people signed up right now, and another 5 who are maybes.
17:55:35 <colonelqubit> The response we've gotten has been great, with a number of students from University of Washington and Seattle Colleges
17:55:55 <colonelqubit> Are any of you going to be joining us online?
17:57:00 <beluga_> I would like to join you on IRC to see how it goes
17:57:00 <colonelqubit> Feel free to add yourself here: https://wiki.documentfoundation.org/Events/2014/Seattle_LibreFest#Remote_Participants
17:57:29 <colonelqubit> Okay, needAdvice bugs have held steady at (19)
17:57:51 <beluga_> new guy here.. today I finished going through all open FILEOPEN bugs and next I will attack UNCONFIRMED ones
17:57:53 <colonelqubit> PLEASE do not be shy about tagging bugs for review
17:58:04 <colonelqubit> beluga_: awesome!
17:58:26 <sophi> +1 :)
17:58:34 <beluga_> that is why I'm the weekly bug closing champion currently ;)
17:59:01 <colonelqubit> beluga_: well you're always welcome here :-)
17:59:04 <beluga_> I love the smell of WORKSFORME in the morning
17:59:08 * colonelqubit laughs
17:59:23 <colonelqubit> beluga_: Have you had a chance to use the bibisect repositories yet?
17:59:47 <beluga_> colonelqubit: nope, I guess will get to them in time
18:00:06 <colonelqubit> beluga_: If you have any questions, feel free to just ask
18:00:14 <beluga_> this is kind of slippery slope, one day I just decide it would be fun to test how many bugs work, then suddenly I'm in the QA team
18:00:55 <colonelqubit> beluga_: that's why we have these support^H^H^H^H^H^H organizing meetings
18:01:15 <beluga_> jay mentored me in some things in the last couple of days
18:01:26 <colonelqubit> Cool, jphilipz_meeting is a hoopy frood
18:01:57 <colonelqubit> Speaking about bibisect, let's take a look at our regressions
18:02:41 <colonelqubit> Regressions against 4.3 and 4.2 have both held steady, with 4.3 remaining exactly the same at 81, and 4.2 dropping down to 111
18:03:03 <colonelqubit> bibisected bugs is up to 171 (good work, guys!)
18:03:53 <colonelqubit> and bibisected regressions (bigger # is better) is 173
18:04:02 <colonelqubit> beluga_: what OS do you run?
18:04:44 <beluga_> colonelqubit: I've done the testing at the office, where I have Win 7.. but at home I also have Manjaro Linux
18:04:49 * colonelqubit nods
18:05:07 <beluga_> colonelqubit: so I've tested some Linux-specific ones at home
18:05:42 <vsfoote> beluga_: be sure to dig into the MOZ trap tests as well
18:05:57 <colonelqubit> For those of you in the QA Team testing on OS X, we could use some help with bibisected bugs that have version = preBibisect
18:06:06 <colonelqubit> Query: https://bugs.freedesktop.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=NEEDINFO&list_id=483370&product=LibreOffice&query_format=advanced&version=PreBibisect
18:06:59 <colonelqubit> Because we have a bibisect repo for OS X that includes alpha/beta/release builds going back to 3.3, we can still squeeze out a little more information about these regressions
18:08:25 <colonelqubit> Okay, now that we've got the stats out of the way, what topics would you guys like to discuss?
18:09:04 <sophi> colonelqubit: just a question: are you ok with the BH planing?
18:09:06 <vsfoote> https://bugs.freedesktop.org/show_bug.cgi?id=84854
18:09:09 <IZBot> bug 84854: LibreOffice-Spreadsheet critical/highest NEW Calc issues with screen drawing(all Windows and 32-bit Linux)
18:09:15 <colonelqubit> Any bugs for the ESC?
18:09:25 <colonelqubit> aaaand vsfoote beats me to it! :-)
18:09:46 <vsfoote> Robinson, can you check with David T. and ESC regards reverting?
18:10:16 <beluga_> yeah I need therapeutic discussions about that Calc blackness *shudder*
18:10:36 <colonelqubit> sophi: I believe so. I was going to ping you about that after the conference/librefest
18:10:37 <IZBot> News from asklibo: Separador decimal no Calc apenas para um documento <http://ask.libreoffice.org/pt-br/question/41487/separador-decimal-no-calc-apenas-para-um-documento/> || Can I open old pc files in Mac Libreoffice? <http://ask.libreoffice.org/en/question/41486/can-i-open-old-pc-files-in-mac-libreoffice/> || Build only the Calc <http://ask.libreoffice.org/en/question/41485/build-only-the-calc/>
18:10:52 <beluga_> charts and buttons in Calc are messed up in 4.4 alpha
18:11:06 <sophi> colonelqubit: ok, no problem, we have already send the announce on the social media
18:11:44 <colonelqubit> sophi: yep, I saw that. Do you have a list of the steps/tasks you did in the past for each Bug Hunting Session?
18:11:57 <colonelqubit> (like a cheat sheet :-))
18:12:10 <sophi> colonelqubit: oh no, nothing like that
18:12:17 <colonelqubit> ok
18:12:59 <sophi> colonelqubit: send me a mail with what you'd like me to collect and I'll do it :)
18:13:11 <colonelqubit> sophi: will do
18:13:32 <sophi> colonelqubit: ok, thanks
18:13:33 <colonelqubit> #action Email sophie about BH tasks and scheduling
18:14:17 <sophi> colonelqubit: however there is a task on redmine to monitor the planing, but you may want to add things there
18:14:26 * colonelqubit nods
18:14:39 <colonelqubit> vsfoote: I'm quickly reading through 84854
18:16:16 <colonelqubit> beluga_: is the problem you mention w/charts and buttons the same thing as 84854?
18:17:09 <beluga_> colonelqubit: I would tend to believe yes, because I remember all the issues appearing simultaneously.. as I've been testing since Sept 19th.
18:17:53 <vsfoote> Luke B. bisected 84854 down with own builds on 32-bit Linux to the Fraction  refactoring to use boost::rational -- only affecting 32-bit builds
18:18:23 <beluga_> vsfoote: have you noticed the rendering issues with charts and buttons?
18:18:31 <colonelqubit> beluga_: are you using a 32bit build?
18:18:52 <beluga_> buttons are invisible.. I'm using the daily builds from libreoffice.org. I don't know where to get 64-bit builds
18:19:21 <vsfoote> beluga_: there are no 64-bit builds for Windows...
18:20:00 <colonelqubit> Planning bug for 4.4.0 BH Sessions is https://redmine.documentfoundation.org/issues/515
18:20:49 <vsfoote> Nothing jumps out regards charts & buttons -- which component?
18:21:17 <beluga_> Calc
18:22:03 <colonelqubit> Any other bugs or topics that you'd like to discuss?
18:22:43 <sophi> colonelqubit: it's ok for me
18:23:11 <beluga_> I remember in 4.4 alpha the buttons in this test case were invisible: https://bugs.freedesktop.org/show_bug.cgi?id=60673
18:23:11 <colonelqubit> Don't be shy, people, feel free to mention anything QA-related! :-)
18:23:13 <IZBot> bug 60673: LibreOffice-Spreadsheet normal/medium NEW FILEOPEN Diacritic characters in form button labels are lost when importing XLSX from MS Office 2013
18:24:01 <beluga_> then you can try any chart like this for instance: https://bugs.freedesktop.org/show_bug.cgi?id=51671
18:24:04 <IZBot> bug 51671: LibreOffice-Chart normal/medium NEW [XLS] FILEOPEN particular .XLS uses all chart data instead of first row for Legend
18:25:41 <colonelqubit> beluga_, vsfoote: I'll let you guys chat further about the invisibility issue
18:25:47 <beluga_> well. here's one bug that I always like to discuss: https://bugs.freedesktop.org/show_bug.cgi?id=84127 Comment 10 from me is perhaps the most relevant, if you are overwhelmed by the long discussion
18:25:49 <IZBot> bug 84127: LibreOffice-Writer normal/medium UNCONFIRMED FILESAVE/FILEOPEN arrangement not saved/retained
18:27:27 <colonelqubit> beluga_: so some weird issue with linked vs. embedded graphics?
18:28:35 * colonelqubit laughs. I see that the repro docs are from someone at UW (uni. of washington)
18:28:44 <colonelqubit> I was just on the campus yesterday :-)
18:29:59 <beluga_> colonelqubit: then you are my only hope at solving that one! find the guy and beg him to make a proper test case
18:30:02 <sophi> beluga_: to remove links and embed a picture, just do Edit > Links
18:30:49 <beluga_> sophi: ok I guess I'll add that as a comment, thanks
18:32:22 <colonelqubit> beluga_: okay, got an email address. I'll invite him :-)
18:32:36 <colonelqubit> (The LibreFest on Sunday is at UW)
18:32:49 <ertai_NL> hi
18:32:55 <colonelqubit> Okay, I'm going to wrap things up
18:33:00 * colonelqubit waves
18:33:11 <colonelqubit> ertai_NL: Got anything you'd like to bring up in the QA Meeting?
18:33:26 <ertai_NL> no.
18:33:55 <colonelqubit> #action Invite Paul DeStefano (UW student) to the LibreFest (so he can repro his bug :-)
18:34:19 <colonelqubit> Okay, thanks very much everyone for joining the meeting!
18:34:25 <colonelqubit> We'll have another one in 2 weeks, which is...
18:34:30 * colonelqubit checks the calendar...
18:34:54 <colonelqubit> November 5th
18:35:06 <beluga_> thanks, colonelqubit, this meeting was a dream come true
18:35:07 <sophi> colonelqubit: thanks for chairing the meeting :)
18:35:20 <colonelqubit> Cheers!
18:35:31 * colonelqubit wanders off to track down people at UW
18:35:32 <sophi> bye all!
18:35:35 <ertai_NL> sorry I was to late..
18:35:39 <ertai_NL> colonelqubit: bye..
18:35:47 <colonelqubit> ertai_NL: no worries!
18:35:58 <colonelqubit> #endmeeting