18:07:36 <colonelqubit> #startmeeting
18:07:36 <IZBot> Meeting started Wed Oct  8 18:07:36 2014 UTC.  The chair is colonelqubit. Plugin info at http://wiki.debian.org/MeetBot.
18:07:36 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:07:38 <Galina> he he
18:08:12 <colonelqubit> Okay, so who's here? jphilipz, jmadero_falling is 20% here
18:08:32 <jphilipz> sorry colonelqubit have to run now :)
18:08:36 <colonelqubit> noooo
18:08:44 * colonelqubit waves goodbye
18:09:11 <colonelqubit> jphilipz: I'll be doing some load-testing of Bugzilla in teh next few days. I'll let you know more
18:10:06 <Liongold> colonelqubit: In the weekend?
18:10:56 <colonelqubit> Liongold: Probably Thu-Friday. Saturday I'm out
18:11:20 <Liongold> colonelqubit: I'll be able to help Friday at this time probably if you want.
18:11:22 <colonelqubit> I might be at the GNOME Boston Summit on Sunday, so could help coordinate from there
18:11:31 <colonelqubit> Liongold: awesome!
18:12:18 <colonelqubit> #action Robinson will send out an email to coordinate load-testing (aiming for Friday)
18:12:22 * colonelqubit waves to vsfoote
18:12:29 <Liongold> colonelqubit: Just tell me ewhat's needed
18:12:37 <Liongold> Do you want my email?
18:12:40 <jphilipz> colonelqubit: look forward to seeing it
18:12:43 <colonelqubit> Liongold: I have it :-)
18:13:10 <colonelqubit> vsfoote: Have any topics relevant for QA to discuss or for me to take to ESC?
18:13:19 <Liongold> colonelqubit: Oh ok
18:13:24 <vsfoote> nada
18:14:08 <vsfoote> QA etherpad looks to be down, dropped out during design mtg...
18:14:32 <colonelqubit> vsfoote: hmm, yes. that's a problem
18:14:36 <jphilipz> by vsfoote, glad to finally see ya on irc :)
18:15:16 <vsfoote> Hi Jay, fought with Google+ long enough
18:15:27 <colonelqubit> cloph: Do you know why the etherpad might be down? http://pad.documentfoundation.org/p/qa
18:16:22 <jphilipz> well i hope to see ya next week vsfoote :)
18:19:59 <colonelqubit> Okay, quick update on stats:
18:20:02 <colonelqubit> UNCONFIRMED: 831 (down almost 100 from last meeting!)
18:20:04 <colonelqubit> needAdvice: 19 (down)
18:20:06 <colonelqubit> Regressions in 4.3: Up to 81 (from 66)
18:20:08 <colonelqubit> Regressions in 4.2: Stable around 110
18:20:10 <colonelqubit> Bibibsected bugs open and Bibisected regressions: staying stable around 150-160
18:20:52 <colonelqubit> I've had two bugs reported for discussion.
18:20:55 <colonelqubit> https://bugs.libreoffice.org/show_bug.cgi?id=82288
18:20:58 <IZBot> bug 82288: LibreOffice-Installation major/high RESOLVED FIXED deb / rpm master installation builds broken because of missing core05 package
18:21:35 <colonelqubit> Big thanks to cl0ph for getting that one fixed.
18:22:20 <colonelqubit> PLEASE let me know if you're running into additional problems with daily builds of master
18:22:53 <colonelqubit> Next bug: https://bugs.libreoffice.org/show_bug.cgi?id=81633
18:22:54 <IZBot> bug 81633: LibreOffice-Spreadsheet major/high RESOLVED FIXED Sorting shouldn't always automatically adjust references.
18:23:41 <colonelqubit> JBF isn't here -- does anyone else want to discuss?
18:23:57 <jmadero_falling> what is there to discuss
18:23:57 <vsfoote> Any ideas about doing a Windows bibisect service,  I keep a lot of the TB39 masters on hand to manually convolvle down on an issue, but coverage is a little spotty
18:24:12 <jmadero_falling> vsfoote: it's on the list - quite hard to accomplish
18:24:33 <jmadero_falling> vsfoote: Windows has a lot of issues with git pulling, Florian did quite a bit of work and it was tediously slow
18:24:42 <jmadero_falling> colonelqubit: what is there to discuss with that one?
18:24:46 <jmadero_falling> I think it's pretty clear
18:24:50 <colonelqubit> jmadero_falling: I think JBF brought this point up already, but it would be good for us to catch potential problematic bugfixes earlier in the cycle
18:25:01 <colonelqubit> that's a really tough challenge for us, though
18:25:02 <jmadero_falling> colonelqubit: well I don't have time to talk about the bigger picture
18:25:08 <jmadero_falling> I have time to talk about that one bug
18:25:12 <jmadero_falling> the fix fixed a MUCH bigger problem
18:25:17 <jmadero_falling> Kohei put in a shit ton of work
18:25:28 <jmadero_falling> those people should have been running dailies to help catch whatever issue they saw at an earlier stage
18:25:33 <jmadero_falling> we're not reverting the patch
18:25:35 <jmadero_falling> and we're not backporting the fix
18:25:40 <jmadero_falling> that's where were at
18:25:53 <colonelqubit> Fair enough. I don't know a lot about the particular issue, but I do realize that it's important for us to try to keep things stable for our userbase
18:26:05 <jmadero_falling> not if stable means that a shitty workflow existed
18:26:08 <jmadero_falling> and they got "used" to a bug
18:26:13 <jmadero_falling> and now complain about the bug being fixed
18:26:33 <jmadero_falling> colonelqubit: so the issue was that when you sorted, formulas were tracking the cell, vs. the value
18:26:35 <jmadero_falling> which was a huge problem
18:26:49 <colonelqubit> jmadero_falling: So one question is: "how long has this behavior persisted in LibreOffice?"
18:26:52 <jmadero_falling> Kohei was kind enough to add an option in 4.4 that now allows users to reintroduce the bug
18:26:58 <jmadero_falling> colonelqubit: who knows, it was a bug
18:27:07 <jmadero_falling> I'm not going to argue about people getting used to bugs
18:27:16 <jmadero_falling> it was a bug, that was incredibly hard to fix
18:27:18 <colonelqubit> you might think the behavior is dumb. I might think it's dumb. But if there are users who want to use it, then that's something I think we should consider
18:27:29 <jmadero_falling> Kohei got slammed with complaints after committing an insane amount of time to fix it
18:27:44 <jmadero_falling> I have nothing else to say about it
18:27:48 <jmadero_falling> there is zero chance of backporting
18:27:52 <colonelqubit> I think it's unfortunate that the optional workaround won't make it into the same branch as the bugfix.
18:27:55 <jmadero_falling> it has a new string, there is a hard rule about not backporting for those
18:28:05 <colonelqubit> (I understand why it won't, but that's unfortunate for a portion of our userbase)
18:28:14 <jmadero_falling> honestly, then they should help earlier in the cycle
18:28:28 <colonelqubit> jmadero_falling: sure, we'd like them to
18:28:33 <jmadero_falling> we can't consider how fixing a bug is going to cause some corner case users who got used to the bug
18:28:49 <jmadero_falling> we can't predict I should say
18:28:50 <colonelqubit> but I think it's myopic and aggrandizing to think that our userbase would understand issues on that level
18:28:58 <jmadero_falling> again, I don't have time to talk about that
18:29:01 <colonelqubit> Most of our users have a computer and push keys
18:29:02 <jmadero_falling> I have time to say what it is with this bug
18:29:08 <jmadero_falling> not reverting, not backporting
18:29:12 <jmadero_falling> they can use 4.2 or w/e until 4.4 comes out
18:29:14 <colonelqubit> jmadero_falling: fair enough
18:29:36 <colonelqubit> I figured the issue was relevant for discussion during the QA meeting as a part of 'bigger picture' stuff
18:29:40 <jmadero_falling> and we can suggest to all these users to commit time earlier in the cycle to hepl
18:29:42 <jmadero_falling> help*
18:29:45 <colonelqubit> But I think we can cover that at the ESC meeting
18:29:55 <jmadero_falling> ...just a heads up, there will be anger if you bring it up
18:29:58 <jmadero_falling> I can almost guarantee that
18:30:05 <jmadero_falling> so just be prepared
18:30:11 <colonelqubit> jmadero_falling: It was already added to the agenda
18:30:11 <jmadero_falling> when a developer puts in time to fix a freaking bug
18:30:19 <jmadero_falling> and after the fact users wnat the bug REINTRODUCED
18:30:30 <jmadero_falling> it's a good way to tell devs to just stop caring
18:30:58 <colonelqubit> jmadero_falling: We're not talking about fixing a color problem where pressing the green button actually made red text
18:31:24 <jmadero_falling> again, all of that is irrelevant to the points
18:31:25 <colonelqubit> we're talking about a nuanced behavior regarding formulae and spreadsheet cells.
18:31:28 <jmadero_falling> the points is we can't predict everything
18:31:34 <jmadero_falling> users have an obligation to get more involved earlier in the cycle
18:31:36 <jmadero_falling> or wait for fixes
18:31:40 <colonelqubit> Certainly. And if we want more user involvement, we need to make that clear
18:31:52 <jmadero_falling> sure - so suggest that to the small portion of users complaining
18:31:56 <colonelqubit> we can't just wave our hands around behind the scenes and say "users should know this"
18:32:02 <jmadero_falling> while the majority of users are more than thrilled that the BUG was fixed
18:32:03 <jmadero_falling> lol
18:32:10 <colonelqubit> If that's what we expect from our userbase, then it should be on our website
18:32:20 <jmadero_falling> no one reads that stuff
18:32:24 <jmadero_falling> I mean feel free to add whatever you want
18:32:36 <colonelqubit> If we expect our users to help us find bugs using daily builds, then we should make those daily builds more accessible
18:32:36 <jmadero_falling> but if you think 1 paragraph of text telling users to get more involved
18:32:41 <jmadero_falling> is going to resolve the issue that came up here
18:32:47 <jmadero_falling> I think you're being very . . . um
18:32:48 <jmadero_falling> optimistic
18:32:51 <colonelqubit> I'm not sure it's going to fix all the problems
18:33:04 <jmadero_falling> okay but I think we are where we are with this bug
18:33:08 <jmadero_falling> Kohei is awesome, he fixed a bug
18:33:11 <jmadero_falling> some users want the bug reintroduced
18:33:16 <jmadero_falling> so in 4.4 they'll have that option
18:33:25 <jmadero_falling> else, they can use 4.1 or 4.2 until that time
18:33:26 <colonelqubit> but I think it's pretty insane to think that people are going to know that they should read the instructions in the basement watercloset, behind the locked door marked "beware of walrus"
18:33:27 <jmadero_falling> both of which work fine
18:33:53 <colonelqubit> we have to give our users at least some modicum of notification of what we're providing (and what we're /not/ providing)
18:34:05 <jmadero_falling> I think our stuff is pretty clear
18:34:08 <jmadero_falling> but we can agree to disagree
18:34:21 <jmadero_falling> and I think common sense says "bitching after the fact is unlikely to get good results"
18:34:43 <colonelqubit> jmadero_falling: One big question: was the change in place before 4.2.6-secfix?
18:34:47 <jmadero_falling> our website has big freaking "get involved" stuff all over the place
18:35:01 <jmadero_falling> colonelqubit: yes I think they will have to use last release of 4.1
18:35:12 <jmadero_falling> of use one of the builds prior to 4.2.5 I believe
18:35:15 <jmadero_falling> but I forget exactly
18:35:19 <IZBot> News from fdonew: [Bug 84809] EDITING:Draw/Presentation crashes if document contains a push button with small height <https://bugs.freedesktop.org/show_bug.cgi?id=84809> || [Bug 84810] crash in paste special when combine options link and format <https://bugs.freedesktop.org/show_bug.cgi?id=84810>
18:35:48 <colonelqubit> jmadero_falling: it asks people to get involved. I don't think it says anything about using daily builds
18:35:53 <colonelqubit> except for testing
18:35:59 <jmadero_falling> that's what it is for....
18:36:01 <jmadero_falling> testing
18:36:02 <jmadero_falling> lol
18:36:08 <jmadero_falling> we surely don't want to encourage non testers to use it
18:36:14 <jmadero_falling> without a big fat warning about all the problems they probably will face
18:36:44 <colonelqubit> jmadero_falling: Right, but if you're an average small business owner, who uses this 'feature' in your calculations (or whatever), then if you don't using the daily builds, then you won't know there's a problem until we push out the new version
18:37:07 <jmadero_falling> yes, so then they can go back to an older version
18:37:12 <jmadero_falling> maybe we should make it clearer how to do that
18:37:22 <jmadero_falling> you can't have your cake and eat it to
18:37:26 <vsfoote> sure but they complain about having to stay with the older version
18:37:28 <jmadero_falling> not contribute at all, and then complain about fixes after the fact
18:37:29 <colonelqubit> jmadero_falling: 4.1 is EOL, IIRC
18:37:43 <jmadero_falling> this is literally going around in circles
18:37:46 <jmadero_falling> this is the situation we're in
18:37:53 <jmadero_falling> there is no way to resolve it
18:37:55 <jmadero_falling> it's the nature of the game
18:37:58 <colonelqubit> jmadero_falling: I think there's a good way to address it
18:38:06 <colonelqubit> I totally agree that it's not going to make everyone happy
18:38:17 <vsfoote> which is???
18:38:21 <jmadero_falling> yes I'd love to hear it
18:38:38 <colonelqubit> but I think that if we're more up-front about what we provide, then that's going to make us look better
18:38:44 <jmadero_falling> what does that mean
18:38:47 <jmadero_falling> those are just words that mean nothing to me
18:38:53 <colonelqubit> In a nutshell: We provide builds of LibreOffice
18:38:53 <jmadero_falling> sorry - give me something concrete
18:39:01 <vsfoote> how much more up front can we be when sysadmin won't even test dailys
18:39:04 <colonelqubit> if you want support for a particular feature, then you can buy it from someone
18:39:15 <jmadero_falling> sure, I have no issue with that
18:39:20 <colonelqubit> otherwise, you get what we publish
18:39:21 <jmadero_falling> and I suggest talking about it on the private marketing list
18:39:29 <jmadero_falling> to see if we should clarify something on the main page
18:39:46 <jmadero_falling> I am not opposed to that at all, but I see that as not stopping or mitigating this at all
18:39:48 <vsfoote> no no no -- pay as you go corrupts the project
18:39:53 <jmadero_falling> not pay as you go
18:39:58 <jmadero_falling> vsfoote: read my comment here: https://bugs.freedesktop.org/show_bug.cgi?id=80846
18:39:59 <jmadero_falling> last one
18:40:00 <IZBot> bug 80846: LibreOffice-Spreadsheet major/highest REOPENED Undo after reference cell deletion not updating dependent cell
18:40:02 <colonelqubit> Right now I think that people get a certain impression about what we're providing with our builds, etc.
18:40:10 <jmadero_falling> for free of course . . .
18:40:12 <jmadero_falling> from volunteers
18:40:19 <jmadero_falling> who contribute millions of dollars of their time for nothing
18:40:28 <jmadero_falling> there is so little respect from some of our users that it's mind boggling
18:40:36 <jmadero_falling> let me say again SOME of our users
18:40:40 <jmadero_falling> the majority are quite awesome ;)
18:40:43 <colonelqubit> jmadero_falling: sure, sure
18:41:07 <jmadero_falling> vsfoote: so that's just being up front
18:41:08 <colonelqubit> vsfoote: Would you be in favor of more language describing what we provide in TDF builds?
18:41:10 <jmadero_falling> there is no "pay as you go"
18:41:13 <jmadero_falling> it's just identifying the reality
18:41:22 * colonelqubit nods
18:41:25 <jmadero_falling> but the reality is that you CAN pay for fixes
18:41:28 <jmadero_falling> that is an option, we should not hide it
18:41:32 <jmadero_falling> and we should encourage it for enterprise users
18:41:35 * colonelqubit completely agrees
18:41:38 <jmadero_falling> it helps the project, not hurts it
18:41:42 <colonelqubit> jmadero_falling: did I tell you about what Inkscape is doing?
18:41:47 <jmadero_falling> no
18:41:51 <jmadero_falling> other than that their wiki sucks
18:42:00 <colonelqubit> lol
18:42:18 <colonelqubit> They're taking an interesting approach to development/fundraising: http://www.inkscape.org/en/contribute/funded-devel/
18:42:37 <jmadero_falling> ah too much text right now
18:42:44 <jmadero_falling> synopsis of it
18:42:48 <jmadero_falling> hire a fundraising coordinator
18:42:56 <jmadero_falling> and do something with funds for fixes
18:43:13 <colonelqubit> http://libregraphicsworld.org/blog/entry/inkscape-starts-encouraging-paid-development
18:43:19 <colonelqubit> that might be a bit more readable
18:43:21 <vsfoote> sure, but paid development as the core function does not further the project
18:43:30 <jmadero_falling> it has nothing to do with core function
18:43:33 <jmadero_falling> we don't pay developers
18:43:36 <jmadero_falling> TDF has no developers on staff
18:43:45 <jmadero_falling> we encourage an ecosystem where businesses can build models around fixing bugs for LibreOffice
18:43:51 <vsfoote> paid development tends to regress, and support stability in prrior builds retaining builds past EOL
18:43:52 <jmadero_falling> so I just literally list the facts
18:44:09 <jmadero_falling> the alternative is letting users yell and scream about how important their own bug is
18:44:13 <colonelqubit> Right -- it's not the direction that we're choosing, but I think it's relevant for us to see what other projects are doing
18:44:15 <jmadero_falling> and we have NO power to tell anyone what to fix
18:44:18 <vsfoote> TDF has no paid developers, but project members do
18:44:27 <jmadero_falling> vsfoote: yes - and thus the option is there
18:44:31 <jmadero_falling> we have no control over them
18:44:36 <jmadero_falling> nor do we want control over them
18:44:42 <jmadero_falling> so by saying "there is an option"
18:44:48 <jmadero_falling> it's just informing our users, which IMHO is always right
18:44:49 <jmadero_falling> and good
18:44:53 <vsfoote> and shuld we encourage the model to shift more toward maintenance of legacy EOL, those same devs won't be availalbe to move the project forward
18:45:06 <jmadero_falling> what does that even mean encourage?
18:45:09 <jmadero_falling> they do what they do
18:45:14 <jmadero_falling> we don't tell them anything
18:45:25 <jmadero_falling> we don't tell them, encourage them, control them
18:45:28 <jmadero_falling> etc . . . etc . . .
18:45:40 <jmadero_falling> but we have had enterprise users actually say "I wish there was paid support" and we can say THERE IS!!!!
18:45:43 <colonelqubit> One thing I think we can do as a project is to identify both problem areas and ideas for improvements
18:45:57 <jmadero_falling> so colonelqubit I suggest pinging the marketing list
18:46:02 <jmadero_falling> see what others think
18:46:06 <jmadero_falling> I'm not against what was said at all
18:46:12 <jmadero_falling> but I think others will have opinions similar to vsfoote
18:46:21 <colonelqubit> jmadero_falling: the priv list, probably. We aren't supposed to use the regular one right now
18:46:21 <jmadero_falling> so feel free to flush that out ;)
18:46:29 <jmadero_falling> yes the priv
18:47:07 * colonelqubit doesn't even understand how one is supposed to use Redmine bugs for communication
18:47:14 <colonelqubit> Anyhow.. :-)
18:47:25 <colonelqubit> So, action item for me
18:48:39 <colonelqubit> #action Robinson: Chat with marketing about how we can more accurately convey what LibreOffice/TDF provides (and does not provide) in our builds; Clearer options for paid support?
18:49:13 <colonelqubit> Just one more thing on my list: Seattle LibreFest
18:49:21 <colonelqubit> https://wiki.documentfoundation.org/Events/2014/Seattle_LibreFest
18:50:01 <colonelqubit> We've got 3 devs and me showing up on Sunday Oct 26th (10:00 PST) for a Hackfest + Bug Triaging Bee.
18:50:14 <colonelqubit> If anyone would like to hop on IRC and join us, that would be great
18:52:01 <colonelqubit> If you like, we can possibly use Google Hangouts so people (or at least their heads) can join us in the room
18:52:33 <colonelqubit> #action Robinson: See if there's already a projector in room 242 of the Communications Building
18:53:28 <colonelqubit> Anything else?
18:53:31 <vsfoote> hey
18:53:41 <colonelqubit> ...is for horses
18:54:00 <colonelqubit> vsfoote: got any other items?
18:54:04 <vsfoote> anyone been able to work with the TB39 dailys and get useable WinDbg logs?
18:54:47 <vsfoote> can bypass the first instance errors, but get clobbered with unpassable
18:55:24 <vsfoote> r/unpassable/uresumable/ errors
18:56:12 <vsfoote> crickets?
18:56:34 <vsfoote> nobody looks at the Windows builds :(
18:56:53 <colonelqubit> vsfoote: sorry about that
18:57:32 <colonelqubit> #endmeeting