19:08:24 <thorsten> #startmeeting
19:08:25 <IZBot> Meeting started Thu Jan 10 19:08:24 2019 UTC.  The chair is thorsten. Plugin info at http://wiki.debian.org/MeetBot.
19:08:26 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:08:29 <izabela> we want to know when the builder machines will be ready
19:08:48 <thorsten> optional jitsi: https://jitsi.documentfoundation.org/lectures
19:09:34 <erAck> regarding the video lessons.. they should had provided the teacher a clip-on microphone, him turning away from the mic all the time is quite annoying
19:09:36 <thorsten> I'm not really up to date TBH,
19:09:58 <thorsten> cloph Sweetshark: any updates on build VMs / HW?
19:10:58 <thorsten> #topic c++ learning - intro & updates
19:11:18 <Sweetshark> thorsten: not from me, sorry. I fire-and-forgot this to cloph/floeff over Christmas. Seems it got under the wheels :/
19:11:21 <thorsten> izabela: want to quickly report back on progress?
19:11:42 <thorsten> izabela: and whoever else is here from openlabs please raise a hand :)
19:12:12 <klevis> Hi, sorry... I was watching the video lecture
19:12:28 <thorsten> heya klevis
19:12:38 <thorsten> 'evening vranicieva!
19:12:48 <vranicieva> Good evening!
19:13:04 <vranicieva> It's funny, I was trying to log in for 10 minutes now
19:13:39 <vranicieva> It worked just now
19:14:01 <thorsten> vranicieva: no worries, you didn't miss out on anything
19:14:42 <ericJmorey> Hello everyone. Are we discussing the c++ workshop video?
19:14:46 * Sweetshark repinged cloph&floeff about the builders ...
19:14:56 <thorsten> hi ericJmorey
19:15:21 <thorsten> #topic c++ learning - questions & answers on the video
19:15:47 <ericJmorey> thorsten thank you
19:15:54 <erAck> reference link:
19:15:57 <erAck> #link https://en.cppreference.com/w/cpp/container
19:16:15 <thorsten> yeah lets open up for Q & A - who watched the thing, izabela klevis vranicieva ericJmorey ?
19:17:45 <klevis> I could only sit and watch today like half an hour ago, watched until the Queues
19:18:06 * Sweetshark watched the thing, I will write a libreoffice patch with the example code. planned to do that for today, but: the sniffles interfered. Will do on the weekend.
19:19:07 <izabela> Eva and I watched together but works in easy hacks
19:19:08 <ericJmorey> I watched yesterday and took very poor notes, but I have a question or 2
19:19:43 <thorsten> ericJmorey: now is the time to ask :)
19:19:49 <izabela> i found this https://bugs.documentfoundation.org/show_bug.cgi?id=39593
19:19:51 <IZBot> bug 39593: LibreOffice-LibreOffice normal/medium NEW copy/paste code detector / fixing
19:21:00 <erAck> Sweetshark: that's your easyHack
19:22:25 <thorsten> izabela: perhaps a tad more challenging would be tdf#119996 - also an option?
19:22:27 <IZBot> LibreOffice-UI enhancement/low NEW Remove support for GNOME Shell application menu https://bugs.documentfoundation.org/show_bug.cgi?id=119996
19:23:58 <Sweetshark> erAck: that seems to be one of the old ones I copied over from the wiki. lemme see what that is about.
19:24:42 <ericJmorey> My first question is how do you (people actually developing software) use vectors, linked lists, stacks, queues, etc, given that the lecture used some non-standard libraries (not sure if that is the correct term) for string manipulation and abstract data types. Did you write your own or use some sort of standard based on the project you're working
19:24:43 <ericJmorey> with, or something else?
19:24:48 <vranicieva> It's been a while now being involved in these lectures in learning c++ and personally I would like to know the process how to solve an easy hack. Just for the sake to not get on the same questions all over again
19:26:23 <buovjaga> Sweetshark: people have been asking about it on the list https://lists.freedesktop.org/archives/libreoffice/2019-January/081672.html
19:26:34 <thorsten> vranicieva: right - how about tdf#42982 or tdf#88205 then, izabela could mentor you there directly?
19:26:36 <IZBot> LibreOffice-LibreOffice normal/medium NEW Adapt uses of css::uno::Sequence to use initializer_list ctor https://bugs.documentfoundation.org/show_bug.cgi?id=88205
19:27:19 <erAck> ericJmorey: we have an own string class implementation, rtl::OUString; for containers we use the std:: containers
19:27:32 <thorsten> ericJmorey: you can basically freely combine those - since the containers are generic,
19:27:57 <thorsten> ericJmorey: they can store whatever you need, so knowledge of that is universally useful
19:29:36 <Sweetshark> ericJmorey: this is why I would write a LibreOffice version for that. FWIW vectors in the lecture are just stl vectors, so no difference. they used a different/homegrown linked link instead of the stl one, but nothing they did in the lecture is fundamentally different for an stl list. (Just some functions are named a bit different in the stl. One I noticed was "peek()" instead of "top()". But the
19:29:38 <Sweetshark> principles are the same.
19:30:02 <izabela> i made a commit at tdf#42982 during hackfest in Munich
19:30:04 <IZBot> LibreOffice-LibreOffice minor/medium NEW improve UNO API error reporting https://bugs.documentfoundation.org/show_bug.cgi?id=42982
19:30:13 <erAck> yeah vector was a bad example here, but Stack and Queue instead
19:30:15 <ericJmorey> "vectors in the lecture are just stl vectors" didn't realize this, thank you.
19:31:22 <izabela> it is what i have talked with Bjorn, start with something people can solve together to understand the process
19:31:23 <ericJmorey> "(Just some functions are named a bit different in the stl. One I noticed was "peek()" instead of "top()". But theprinciples are the same."  This is what I was trying to get at. Thanks again.
19:34:35 <ericJmorey> Question 2 (a bit meta): I didn't have time to do a good search but does anyone know if Mr Stepp posted the slides for his lectures anywhere?
19:36:48 <Sweetshark> ericJmorey: I think they are posted on the Stanford website for the lecture, but you need a login as a stanford student, which costs a bit of pocket change ...
19:37:54 <Sweetshark> buovjaga: hmm, no clue what this simian stuff is ...
19:38:50 <thorsten> Sweetshark: copypasta sniffing
19:38:55 <ericJmorey> Sweetshark That's a bit inconvenient. oh well.
19:39:40 <Sweetshark> FWIW, with regards to EasyHacks I looked for topic UI, difficulty beginner, skill Cpp and found:
19:39:42 <Sweetshark> https://bugs.documentfoundation.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&bug_status=NEEDINFO&keywords=topicUI%2C%20skillCpp%2C%20difficultyBeginner%2C%20easyHack%2C%20&keywords_type=allwords&list_id=893063&product=LibreOffice&query_format=advanced&resolution=---
19:39:55 <ziad_marghany> Hi everyone, I have a question but it is somehow not very related to today's lecture
19:40:32 <ziad_marghany> I have been using C++ for nearly two years but mainly for learning competitive programming
19:40:36 <buovjaga> Sweetshark: from your copy/paste easyhack :)
19:41:00 <ziad_marghany> and you can say that I only write what is called C style C++
19:41:05 <buovjaga> Sweetshark: you recommended it in 2011 and it stuck "A good copy and paste detector is [http://www.harukizaemon.com/simian/ Simian]."
19:41:35 <buovjaga> then in 2017 I recommended pmd https://bugs.documentfoundation.org/show_bug.cgi?id=39593#c26
19:41:38 <IZBot> bug 39593: LibreOffice-LibreOffice normal/medium NEW copy/paste code detector / fixing
19:41:56 <ziad_marghany> And I would like to improve myself in C++ but I don't know how
19:42:06 <ziad_marghany> the language is a bit overwhelming
19:42:14 <Sweetshark> which isnt too much unfortunately. 97555 needs work with htietze, I guess. 120563 is currently taken, 54169 seems OSX only, 53524 seems also to be taken. that leaves tdf#11996 which might be a start.
19:42:16 <IZBot> no TDF bug with number 11996
19:42:35 <ericJmorey> I think I get the the conceptual ideas from the video, but seeing more examples would be nice. Could someone link to some code that demonstrates the use of linked lists, vectors, queues, or stacks?
19:42:38 <Sweetshark> IZBot: tdf#119996, you git.
19:42:40 <IZBot> LibreOffice-UI enhancement/low NEW Remove support for GNOME Shell application menu https://bugs.documentfoundation.org/show_bug.cgi?id=119996
19:42:44 <erAck> ericJmorey ziad_marghany : if you want written material, I can recommend again
19:42:46 <erAck> #link http://www.icce.rug.nl/documents/cplusplus/
19:43:04 <htietze> Sweetshark: commented on 97555
19:43:38 <ziad_marghany> erAck I will take a look at it thank you
19:44:02 <ericJmorey> erAck nice! thank you!
19:44:17 <Sweetshark> 119996 is removal of code, so not too flashy from the UI impact, but still, it seems reasonably doable and is a change one might see from the outside.
19:44:58 <thorsten> #topic c++ learning - easy hacks to work on
19:45:07 <ziad_marghany> I have another question, people who learn more by doing, what kind of projects I can focus on to help me raise my C++ skills ?
19:45:19 <ericJmorey> Does Libre Office use a stack for its undo function?
19:45:20 <ziad_marghany> sorry for my bad english
19:45:49 <ziad_marghany> I meant I am from the people who learn more by doing, what projects I can do to raise my C++ skills?
19:46:15 <Sweetshark> buovjaga: ah! Its not "my" EasyHack. I copied the EasyHacks over from the wiki in the early days. EasyHacks with bug # < 50000 and me as reporter: I dont have much of a clue about. If we find nobody enthusiastic about those we should close them.
19:46:16 <thorsten> ziad_marghany: people around here tend to recommend libreoffice ;)
19:46:33 <ericJmorey> thorsten When you say easy hacks to work on. What do you mean by "hacks"?
19:46:53 <thorsten> !easyhack
19:46:54 <IZBot> "easyhack" could be entry-level task for beginners/intermediates, see »Easy Hacks«
19:48:25 <ericJmorey> see »Easy Hacks« ... where?
19:48:33 <izabela> @Sweetshark we are enthusiastic to work this those, if are a good starting point
19:48:35 <Sweetshark> !easy Hacks
19:48:36 <IZBot> "easy Hacks" could be a nice list of small tasks for newcomers to get familiar with the code base. See http://wiki.documentfoundation.org/Easy_Hacks for a full list. Also consider the list of open EasyHack bugs in our bugzilla at http://tinyurl.com/38juotz.
19:49:15 <thorsten> #link https://bugs.documentfoundation.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&bug_status=NEEDINFO&keywords=topicUI%2C%20skillCpp%2C%20difficultyBeginner%2C%20easyHack%2C%20&keywords_type=allwords&list_id=893063&product=LibreOffice&query_format=advanced&resolution=---
19:52:04 <Sweetshark> izabela: 119996 looks decent as a start to me: https://bugs.documentfoundation.org/show_bug.cgi?id=119996.
19:52:04 <ericJmorey> FYI the result of the search behind the tiny URL is: Zarro Boogs found.
19:52:07 <IZBot> bug 119996: LibreOffice-UI enhancement/low NEW Remove support for GNOME Shell application menu
19:52:39 <Sweetshark> izabela: It has this link to commits that need to be reverted: https://cgit.freedesktop.org/libreoffice/core/log/?qt=grep&q=fdo%2348835
19:53:04 <Sweetshark> izabela: In the best case: revert those changes, rebuild, done. ;)
19:53:05 <thorsten> #info izabela to look into easy hack tdf#119996
19:53:07 <IZBot> LibreOffice-UI enhancement/low NEW Remove support for GNOME Shell application menu https://bugs.documentfoundation.org/show_bug.cgi?id=119996
19:54:26 <Sweetshark> izabela: of course there might be some trouble, e.g. reverting doesnt work because too much changed, or compiling doesnt work. when that happens, ask here on how to solve that ..
19:55:04 <ericJmorey> I'm saving a session tabs of the linked resources. Thanks for providing them.
19:55:37 <thorsten> vranicieva: you ok starting with tdf#42982 or tdf#88205 ?
19:55:39 <IZBot> LibreOffice-LibreOffice normal/medium NEW Adapt uses of css::uno::Sequence to use initializer_list ctor https://bugs.documentfoundation.org/show_bug.cgi?id=88205
19:56:24 <vranicieva> Yes, I am looking at them
19:56:26 <izabela> i am checking the links you sent to understand what are you tlking about
19:56:39 <thorsten> neato
19:56:51 <thorsten> #info vranicieva looks into tdf#42982 or tdf#88205
19:56:53 <IZBot> LibreOffice-LibreOffice normal/medium NEW Adapt uses of css::uno::Sequence to use initializer_list ctor https://bugs.documentfoundation.org/show_bug.cgi?id=88205
19:57:45 <izabela> what is neato?
19:58:39 <thorsten> eh sorry for the jargon - neat, basically
19:59:58 <thorsten> #topic c++ learning - wrap-up & next tasks
20:00:44 <ericJmorey> I have to get going and my cat will probably jump on the keyboard if I leave this session open while I'm gone. So I'm signing off. Thanks for setting up this workshop. I'll check the log posted to see if I miss anything. Thanks again.
20:01:07 <thorsten> ericJmorey: you're welcome, thx for joining
20:01:18 <izabela> next time we come up with good questions about building and bug fixing
20:01:29 <thorsten> Sweetshark or erack: any suggestions wrt next video / lecture?
20:02:04 <Sweetshark> thorsten: next time will be FOSDEM for most of use wouldnt it?
20:02:17 <thorsten> hmm yeah, hackfest even
20:02:19 <erAck> thorsten: hum.. no; don't the lecture videos contiue where we left off?
20:02:57 <thorsten> erack: yeah likely; got a link to stick into the minutes?
20:03:05 <erAck> Sweetshark: isn't next on Jan-24?
20:03:51 <erAck> thorsten: I don't even have the link at hand for the recent one.. let me see if browser history spits something out
20:03:53 <Sweetshark> next video is "sets & maps", definitively something one can use with LibreOffice
20:04:07 <Sweetshark> https://www.youtube.com/watch?v=Eisp8H2_FG4&index=6&list=PLT0wqqmbAFnfdRRCnzqY943MDyaNa3KSy&t=0s
20:04:09 <IZBot> YouTube - CS 106B 18wi Lecture 05: Sets, Maps by: martystepp
20:04:10 <erAck> o/
20:05:04 <Sweetshark> and I will upload the stack example as libreoffice source code over the weekend.
20:05:08 <thorsten> #info next video https://www.youtube.com/watch?v=Eisp8H2_FG4&index=6&list=PLT0wqqmbAFnfdRRCnzqY943MDyaNa3KSy&t=0s
20:05:09 <IZBot> YouTube - CS 106B 18wi Lecture 05: Sets, Maps by: martystepp
20:05:24 <thorsten> #action Sweetshark will upload stack example to gerrit
20:05:47 <Sweetshark> .oO(dammit, now its in the minutes)
20:07:05 <thorsten> ok - so is there anything else for the moment?
20:07:29 <thorsten> (of course folks will stay in the channel, so further questions can be asked)
20:07:48 <izabela> so, next time is fosdem or jan 24?
20:08:17 <thorsten> Sweetshark: ^ - I'd side with erAck there, prolly useful to stick to the 2 weeks cadence,
20:08:47 <thorsten> and then use it to prep the fosdem hackfest with specific hacks?
20:09:16 <Sweetshark> thorsten: Works for me (33c3)
20:09:33 <thorsten> #info next session Jan 24th, 19:00 UTC
20:09:52 <buovjaga> I guess the tinyurl in IZBot's memory is ancient as it has a query with "Summary: EasyHacks"
20:09:58 <thorsten> gr8, so I suppose we have a wrap
20:10:46 <buovjaga> and naturally links to bugs.freedesktop.org :)
20:10:47 <klevis> Thanks for the materials and for your time! See you at the next meeting :)
20:11:06 <thorsten> izabela klevis vranicieva ziad_marghany - ok to close for today?
20:11:13 <Sweetshark> izabela, thorsten: oh, can you maybe quickly test jitsi on meet.jit.si?
20:11:25 <thorsten> test what? :)
20:11:53 <thorsten> #endmeeting