15:01:14 <x1sc0> #startmeeting
15:01:15 <IZBot> Meeting started Wed Nov 28 15:01:14 2018 UTC.  The chair is x1sc0. Plugin info at http://wiki.debian.org/MeetBot.
15:01:16 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:27 <x1sc0> so let's start the QA meeting
15:01:33 <x1sc0> anyone around ?
15:01:48 <buovjaga> yeah
15:02:03 <x1sc0> hello there
15:02:13 <x1sc0> let's wait a few minutes
15:02:32 <x1sc0> we will start with the recurrent tasks you proposed in the last meeting first
15:04:27 <sophi> x1sc0: hello!
15:04:36 <x1sc0> hi sophi
15:05:11 <x1sc0> so let's get started with the recurrent tasks
15:05:21 <x1sc0> #topic recurrent tasks
15:05:50 <x1sc0> buovjaga, sophi anyone you would like to propose for the BZ contributors group ?
15:06:39 <buovjaga> I think my contacts still have not become regulars :(
15:06:47 <sophi> x1sc0: I need to have a look at it first :)
15:07:11 <x1sc0> buovjaga, is there any place where the list of contributors can be checked ?
15:07:37 <buovjaga> x1sc0: I will add Vera
15:07:58 <x1sc0> yep, it makes sense
15:08:25 <buovjaga> x1sc0: doesn't seem like it
15:08:26 <IZBot> News from tdfnew: [Bug 121760] Can't delete wrong file in extensions (LO Draw) <https://bugs.documentfoundation.org/show_bug.cgi?id=121760>
15:08:44 <x1sc0> it would make things easier
15:08:46 * buovjaga does a search
15:09:25 <buovjaga> x1sc0: found a way!! https://bugs.documentfoundation.org/editusers.cgi?action=list&matchvalue=login_name&matchstr=&matchtype=substr&grouprestrict=1&groupid=27&is_enabled=1
15:09:48 <x1sc0> nice!
15:10:03 <buovjaga> x1sc0: so: going first to editusers, leave the input field blank and just check the checkbox to restrict -> contributors group
15:10:22 <buovjaga> kind of non-intuitive, but great that we have it
15:10:23 <x1sc0> #action x1sc0: clean up the list
15:11:04 <buovjaga> well this meeting was already useful :)
15:11:06 <x1sc0> I think once we have the list clean, it can help us to improve -> https://wiki.documentfoundation.org/QA/Team
15:11:27 <buovjaga> I don't know if the list is very dirty, it is not old :)
15:11:45 <sophi> yes, thanks for the link :)
15:12:21 <x1sc0> i see some unfamiliar names...
15:13:17 <x1sc0> although it might take a while
15:13:29 <buovjaga> of course, we should remember to add new developers in there
15:13:30 <x1sc0> we have 430 users right now
15:13:40 <x1sc0> yep
15:14:02 <buovjaga> yes, we added all the ones from the wiki dev list (the ones that were active, I think)
15:14:05 <x1sc0> #action x1sc0 add new developers
15:15:06 <x1sc0> in the end, I think no one in the list has ever caused problems
15:15:40 <x1sc0> so adding new people is more important than deleting the old one
15:16:18 <buovjaga> right on
15:16:43 <x1sc0> ok, next recurrent topic
15:16:50 <sophi> x1sc0: the only one I see is Urmas but he seems quiete now
15:16:57 <x1sc0> any wiki page that needs to be updated ?
15:17:47 <buovjaga> I can't think of any
15:18:34 <x1sc0> buovjaga, how important do you consider https://wiki.documentfoundation.org/QA/Team ?
15:19:21 <x1sc0> doesn't seems updated
15:19:21 <buovjaga> x1sc0: well, as important as any contact page :)  but for sure it is a chore to maintain
15:19:41 <buovjaga> yep, that is the one that needs updating :)
15:20:12 <buovjaga> it is always a bit difficult to decide, who to move to alumni
15:20:43 <x1sc0> I'm wondering if we should reach people directly to ask them to get added to the list
15:20:56 <buovjaga> #action buovjaga: clean up QA/Team wiki page regarding alumni
15:21:01 <x1sc0> but I don't see much benefit of doing it
15:21:46 <x1sc0> kompi, I belive you should be in that list
15:22:43 <buovjaga> I think I will remove the Jabber etc. column
15:23:17 <x1sc0> some people seems to be inactive nowadays
15:23:29 <hussam> djredaux: hello. Did you find a time period for when the text rendering bug in slideshows regressed?
15:24:04 <buovjaga> x1sc0: yes I will move them to alumni after careful consideration
15:24:32 <x1sc0> buovjaga, we can have a telegram id columns instead
15:25:08 <x1sc0> since it's used and bridged to IRC
15:25:55 <x1sc0> well, next topic
15:26:50 <x1sc0> #info Please add your observations about QA to https://nextcloud.documentfoundation.org/s/2qbepFYXXan4ief before the end of the month
15:27:27 <x1sc0> we already have some info
15:27:35 <x1sc0> but some more is appreciated
15:28:21 <buovjaga> I have collected some and will add it
15:28:29 <x1sc0> nice!
15:29:01 <x1sc0> I added the link to my bookmarks so everytime I see something worth it to mention I add it directly
15:30:14 <x1sc0> next topic
15:30:29 <x1sc0> #topic needsTriage keyword
15:30:55 <x1sc0> so buovjaga, I believe this topic goes back to the first QA meeting we had in Brno, isn't it ?
15:31:08 <x1sc0> when we talked about having a new status
15:31:43 <buovjaga> x1sc0: sure. But what about your script, wouldn't it being accessible through a web interface help with this? I guess we wanted to avoid adding anything new to keywords or statuses
15:32:22 <x1sc0> yep, that's was the other topic in the agenda :D
15:32:27 <x1sc0> they come together anyway
15:32:51 <x1sc0> so, I believe it's doable
15:33:06 <x1sc0> for sure it's, although I've never done it before
15:33:40 <x1sc0> so, I was wondering, if instead of publishing it in a web
15:34:10 <x1sc0> we could try with a cron email instead
15:34:19 <x1sc0> sent to the people interested
15:34:54 <x1sc0> right now, we do it for the mentoring information
15:34:58 <buovjaga> maybe, if someone is interested :)  I am not interested in such an interface personally
15:35:16 <buovjaga> I prefer to work on my own pace, sometimes there are long breaks
15:36:07 <x1sc0> yep, some days I have to force myself to do it
15:36:12 <x1sc0> because someone needs to do it
15:36:30 <x1sc0> but it takes time, and might be boring :)
15:37:13 <x1sc0> good thing about sending the email/publishing it in a web is we have a log for each day
15:37:30 <x1sc0> but it's pointless if no one but me looks into it
15:38:42 <IZBot> News from tdfnew: [Bug 121761] Increase accuracy of rounded corners in those custom shapes that use command X and Y <https://bugs.documentfoundation.org/show_bug.cgi?id=121761>
15:39:02 <x1sc0> otoh, we could use the keyword
15:39:27 <buovjaga> we could, if people are fine with adding it
15:39:50 <buovjaga> I tried to remember why we did not do anything and the only thing I could think of was the avoidance of clutter/complexity
15:40:10 <x1sc0> my fear is, people starts to use it hoping someone else will check it and in the end it's just me triaging those bugs
15:40:48 <buovjaga> x1sc0: but the idea was to have it always there when you report a bug
15:41:05 <x1sc0> buovjaga, in that meeting we talked about adding a new status, which would have made things more complicated
15:41:06 <buovjaga> of course, if you have already fully triaged it while reporting, it is useless :)
15:41:22 <buovjaga> yes, but later we discussed the keyword as well
15:41:32 <buovjaga> I think it took like a year to finish the discussion
15:42:31 <x1sc0> good thing of using the keyword instead of the status is it's easier to revert it in case it doesn't work
15:43:07 <x1sc0> in case we had to use one, personally I would prefer the keyword
15:44:04 <x1sc0> maybe we can move this discussion to the mailing list for a wider audience
15:44:16 <buovjaga> x1sc0: yes, maybe CC dev list
15:44:40 <buovjaga> I tried to find older discussions from ml via web search, but failed
15:45:06 <x1sc0> yep, I remember you mentioned an email from cor, but I couldn't find it
15:46:31 <buovjaga> we have to look in the Sent folder of Cor :P
15:46:43 <x1sc0> :D
15:46:51 <buovjaga> mailing lists are sometimes not the most accessible...
15:48:09 <x1sc0> anyway, as per today, I don't see a big problem wrt this matter
15:48:38 <x1sc0> I don't think many bugs get forgotten once confirmed forever
15:49:21 <buovjaga> yes, some people go through recent NEW reports and it has always been like this
15:49:30 <buovjaga> the bug mailing list exists, after all
15:49:47 <x1sc0> in the worst case, they get reping 1 year later, and kompi jumps in
15:50:01 <buovjaga> kommander kompi reports for duty
15:51:19 <buovjaga> the KDE folks also had this same discussion recently
15:51:39 <x1sc0> do you have a link ?
15:52:20 <iplaw67> hey, mind if I join in ?
15:52:31 <x1sc0> iplaw67, hi there, sure!
15:52:39 <iplaw67> for once, I'm actually here !
15:52:46 <x1sc0> welcome
15:52:57 <x1sc0> we only have 8 minutes left
15:52:58 <iplaw67> what purpose would the new flag serve ?
15:53:03 <buovjaga> x1sc0: it was on kde-community. Looks like they did not add an extra keyword. They changed status names, they now have REPORTED and CONFIRMED
15:53:07 <djredaux> Just getting here myself - just finished reading over the meeting comments.
15:53:12 <iplaw67> as opposed to unconfirmed
15:53:30 <x1sc0> djredaux, welcome
15:53:32 <buovjaga> iplaw67: as opposed to NEW. NEW being potentially lighter triaged
15:53:43 <iplaw67> buovjaga: ah,kk, Isee
15:53:49 <sophi> djredaux: iplaw67: hi guys!
15:53:55 <buovjaga> iplaw67: having the needsTriage keyword removed would signal that heavy triage has been done
15:54:03 <x1sc0> buovjaga, so they just changed the names ?
15:54:23 <buovjaga> x1sc0: yeah. I can look for a link to the discussion so you can check it after the meeting
15:54:36 <x1sc0> UNCONFIRMED -> REPORTED / NEW -> CONFIRMED
15:54:46 <x1sc0> it doesn't fix anything :D
15:55:11 <iplaw67> and what does Triage require that confirmation doesn't ?
15:55:27 <iplaw67> (thinks he has missed a chunk of debates in QA here)
15:55:48 <x1sc0> to me, a triaged bugs mean, it's confirmed, checked with older versions, and have a metabug ( if needed )
15:56:01 <iplaw67> x1sc0: ah, ok
15:56:22 <x1sc0> but it's not always the case
15:56:25 <sophi> iplaw67: people not used to QA can confirm but not triage for example
15:57:04 <bearon> it feels a bit arbitrary to me
15:57:10 <x1sc0> sometimes we don't have a specific metabug, or it's a recent issue after an enhancement has been implemented
15:57:16 <iplaw67> sophi: ok
15:57:30 <bearon> like, what if you can check back to some version, but not to the oldest?
15:57:50 <iplaw67> yeah, that problem is classic on MacOS because of Java
15:58:21 <iplaw67> e.g. with Base
15:58:27 <x1sc0> yep, it's difficult to find a rule that can be used, in case we want one
15:58:41 <bearon> perhaps listing bugs without a meta bug could cover most of the untriaged bugs
15:59:11 <buovjaga> but unconfirmed are added to meta bugs all the time
15:59:16 <iplaw67> I get the impression that it is a bit of an extra flag for nothing, at least insofar as most of my QA work is concerned
15:59:32 <x1sc0> yep, and adding to metabugs doesn't mean you checked with older versions
15:59:41 <buovjaga> iplaw67: the keyword would be added by default, requiring no effort from you
15:59:58 <iplaw67> buovjaga: gotta love automation :-)
16:00:26 <iplaw67> buovjaga: so how would the machine decide what was triaged ?
16:00:35 <x1sc0> well, you will need to remove it once it's triage
16:01:00 <x1sc0> but people might forget to do it
16:01:08 <bearon> checking with older version could be tackled by looking for bugs that don't have regression / implementationError keywords, and the version isn't 3.3.0 (or at least something like 4.0)
16:01:14 <iplaw67> x1sc0: I would have to rebuild my queries then
16:01:22 <buovjaga> then we have to punish those people with electric shocks
16:01:34 <x1sc0> :D
16:01:48 <buovjaga> we have to think solution-centric ;)
16:01:50 <djredaux> I've not considered the attaching to meta bug as part of the triage process, will do that going forward then.
16:02:19 <x1sc0> metabugs help to find dupes
16:02:38 <bearon> metabugs help with everything :)
16:02:42 <buovjaga> bearon: this discussion was resurrected as raal was concerned about the effects of self-confirming
16:02:45 <bearon> fine, almost everything ;)
16:03:00 <bearon> buovjaga: oh, i'm concerned about that as well
16:03:14 <iplaw67> do we have enough Qaers on Mac for this to work ?
16:03:18 <bearon> that's why you don't see me doing that very often
16:03:28 <iplaw67> I sometimes have no choice but to confirm my own bugs
16:03:47 <bearon> buovjaga: there were those NISZ WFMs that turned out to be non-WFMs as well...
16:03:48 <iplaw67> otherwise they can sit around for months
16:03:48 <buovjaga> looks like I misremembered KDE having this discussion... it was just a lot about status names in general
16:04:08 <x1sc0> well, I check self-confirmed bugs using the script, which brings us to the previous topic, should the results from the script be published? would anyone check the results except me ?
16:04:08 <buovjaga> bearon: yeah, kind of hard to fight non-WFMs
16:04:36 <bearon> buovjaga: the other day i found a WFM that was closed years ago, but was never actually working :D
16:04:44 <iplaw67> x1sc0: I'm more likely to respond to a mail, than a weblink
16:05:01 <iplaw67> although, that doesn't mean I'll actually do anything ;-)
16:06:14 <x1sc0> yep, I check it daily, otherwise the list becomes really long
16:06:44 <x1sc0> so, I would care much about self-confirmed bugs, at least for now
16:07:10 <x1sc0> I keep an eye on them
16:07:16 <bearon> x1sc0: i can't promise anything, but it could be a good list to look at
16:07:27 <iplaw67> so, currently I have several queries targeted to unconfirmed bugs and specific areas of LO, would I then have to add the needsTriage flag to them, or just switch to that flag ?
16:08:03 <iplaw67> still trying to understand how it would affect my current workflow
16:08:04 <x1sc0> iplaw67, well, we haven't decide whether we will use it or not
16:08:26 <x1sc0> but I guess you would just need to add the flag
16:08:48 <buovjaga> if we decide not to add anything, we can add some clear guidelines in the wiki on what to search for, if concerned about these matters
16:08:53 <IZBot> News from tdfnew: [Bug 121762] Image and Frame Toolbars active in Tabbed UI when selecting an image in Writer <https://bugs.documentfoundation.org/show_bug.cgi?id=121762> || [Bug 121763] Image and Frame Toolbars active in Tabbed UI when selecting an image in Calc <https://bugs.documentfoundation.org/show_bug.cgi?id=121763> || [Bug 121764] Drawing Object Properties Toolbar active in Tabbed UI when selecting a shape in Calc <https://bugs.documentfoundation.org/show_bug.cgi?id=121764> || [Bug 121765] Table toolbar active in Tabbed UI when creating/selecting a table in Writer/Draw/Impress <https://bugs.documentfoundation.org/show_bug.cgi?id=121765> || [Bug 121766] Media Playback toolbar active in Tabbed UI when inserting/selecting a media file in Calc/Draw <https://bugs.documentfoundation.org/show_bug.cgi?id=121766>
16:09:12 * bearon would prefer that
16:09:35 <iplaw67> yeah, I think I'm with bearon on that
16:10:03 <x1sc0> bearon, good to know. most likely I'll change it to mail me/you automatically at some point
16:10:18 <x1sc0> nowadays, I run the script every morning
16:10:19 <iplaw67> although I'll be the first to admit that I haven't looked through the QA pages in a while
16:10:26 <djredaux> Wasn't the question at the moment; should you publish the list of bugs that where confirmed by the initial reporter? on that I'd say why not, mail works.
16:10:32 <bearon> x1sc0: i'm down to getting an e-mail
16:10:40 <bearon> per day
16:10:59 <bearon> or down on? English is hard ;)
16:11:17 <x1sc0> down with ?
16:11:20 <iplaw67> or even up for
16:11:30 <djredaux> once daily
16:11:56 <bearon> right, down with, thanks :)
16:12:03 <x1sc0> I ask if more people is interested once I do it
16:12:23 <x1sc0> don't expect it next week though
16:12:40 <djredaux> x1sc0: you could include me in that, sure
16:12:45 <bearon> if there's significant interest for this, there could be a separate qa stat list
16:12:46 <x1sc0> buovjaga, and yeah, I prefer you approach as well
16:13:23 <iplaw67> x1sc0: seems fair enough
16:14:05 <x1sc0> #action x1sc0 cron the script
16:14:36 <bearon> at some point i was considering triaging each bug i encountered to 3.3.0 vs regression / implementationError, but it's far less straightforward than it seems...
16:14:37 <x1sc0> #action add some clear guidelines in the wiki on what to search for
16:15:11 <bearon> considering how little implementationError is used, and how much work it is to verify that
16:15:38 <djredaux> bearon: I use release versions 6.x -> 5.4 and the aoo 4.1.6
16:16:24 <djredaux> likely it would be worth the time to add the LO 4.x releases though.
16:17:20 <bearon> djredaux: if it's not a hassle, having something like 3.3.0, 4.0.0, 4.4.0 and 5.0.0 at your disposal is useful
16:17:34 <bearon> in addition
16:17:35 <iplaw67> bearon: I currently have at least one .X release back to LO36, and then a 330
16:17:57 <bearon> that's great :)
16:17:58 <x1sc0> this is how the output from the script looks like: https://paste.ee/p/jz0nV
16:18:06 <djredaux> I have the bibsect repos back through the 4.x and do use those, but I wasn't getting a lot of results with specific findings.
16:18:06 <iplaw67> bearon: on Mac this is incredibly slow however
16:18:39 <iplaw67> don't know what it is like on other OSes
16:18:49 <bearon> iplaw67: do you use an SSD?
16:19:01 <x1sc0> so, I think we have a consensus on not to add the keyword nor the new status
16:19:15 <iplaw67> bearon: in my MBPro, yes, but not on the Macmini
16:19:34 <x1sc0> but make the script results public by email / mailing list
16:19:48 <x1sc0> and add some clear guidelines in the wiki
16:19:58 <x1sc0> isn't it ?
16:20:08 <iplaw67> x1sc0: I'm ok with that
16:20:09 <djredaux> yes, that is how I understood it.
16:20:26 <bearon> iplaw67: i just installed one in my old iMac, it was a huge pain, but i expect good results
16:21:22 <bearon> if you use the Mac mini for triaging, it might be worth considering
16:22:16 <x1sc0> ok, thanks
16:22:19 <bearon> my system startup is already wonderful, but i haven't tried an LO stuff since
16:22:20 <iplaw67> bearon: yeah, will have to give it some consideration, or just buy a new Macmini :-)
16:22:40 <iplaw67> I've just about expired the tax write off on the old one :-)
16:23:06 <x1sc0> btw, bearon, iplaw67, djredaux please add your comment to https://nextcloud.documentfoundation.org/s/2qbepFYXXan4ief if you find anything worth it to mention to the monthly qa report
16:23:07 <bearon> iplaw67: i imagine adding the SSD is a lot more cost effective :)
16:23:22 <bearon> of, it's the end of month again
16:24:09 <x1sc0> yep, time goes by so fast
16:24:13 <x1sc0> closing the meeting btw
16:24:16 <djredaux> x1sc0: OK. If there is a minute still I have a quick question
16:24:33 <x1sc0> djredaux, sure
16:25:01 <iplaw67> x1sc0: can't think of anything off hand
16:25:04 <bearon> iplaw67: i bought a slightly used 500GB one for $80 or so, though installing it sure was a hassle
16:25:29 <iplaw67> bearon: I didn't realize you could even do that with an iMac
16:25:31 <djredaux> I'll ask anyway - bibisect rpos, I ran into a bump with the 6.3 version change in master, is there something still pending to do there?
16:26:33 <bearon> iplaw67: i replaced the old HDD, sure you can do that :)
16:26:46 <x1sc0> djredaux, they are in the oven -> https://gerrit.libreoffice.org/#/admin/projects/?filter=bibisect
16:26:56 <bearon> fixing it in the case might be a bit problematic
16:27:01 <iplaw67> bearon: will document up on that this weekend
16:27:01 <x1sc0> most likely they will be available next week
16:27:16 <x1sc0> djredaux, please report the issue meanwhile
16:27:22 <x1sc0> maybe it can be bisected in 6.2
16:27:29 <bearon> iplaw67: clonezilla is a great tool for copying disk to disk
16:28:14 <iplaw67> bearon: yes, but doesn't clonezilla require an identical size partition on the target ?
16:28:36 <iplaw67> seems to recall that was the case last time I tried it out
16:28:48 <djredaux> I can wait, no problem. There is an issue right now I couldn't hit with bibisect using 6.2 and my daily repo now is set to 6.3 and just a few iterations (it generated an error when I tried to update it the other day, and included a list of 4 comitts which would be lost)
16:29:05 <bearon> iplaw67: in this case the original disk was 320GB, i copied disk to disk, and later enlarged the partition in macOS
16:29:10 <bearon> marcoagpinto: hey
16:29:17 <iplaw67> bearon: oh right
16:29:18 <x1sc0> #endmeeting