16:00:44 <x1sc0> #startmeeting
16:00:44 <IZBot> Meeting started Tue Sep 26 16:00:44 2017 UTC.  The chair is x1sc0. Plugin info at http://wiki.debian.org/MeetBot.
16:00:44 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:01 <x1sc0> so, let's start the QA meeting
16:01:16 <x1sc0> #topic rollcall
16:01:21 <x1sc0> anybody present ?
16:01:27 <bearon> here
16:01:28 <libreofficeqa-tg> <philipz> i'm here :D
16:01:30 * sophi here
16:01:34 <x1sc0> wow, nice
16:01:41 <x1sc0> buovjaga, ?
16:01:52 <libreofficeqa-tg> <philipz> @ThomasLendo ping
16:02:27 <x1sc0> let's wait a couple of minutes to see if someone else joins
16:03:06 <x1sc0> in this meeting I would like to talk about the upcoming LibreOffice conference
16:03:32 <x1sc0> although I have a couple of others things to mention too
16:04:01 <x1sc0> Does anybody have any topic to be discussed during the meeting too ?
16:04:32 <libreofficeqa-tg> <philipz> nothing comes to mind, i'm just observing :D
16:04:54 <x1sc0> great :D
16:05:09 <x1sc0> well, so let's get started with the first topic
16:05:21 <bearon> x1sc0: do you have info on the planned reddit AMA/AUA? who're going to be answering questions?
16:06:10 <x1sc0> bearon, as far as I know, TDF staff will be answering questions
16:06:18 <x1sc0> sophi might have more info about it
16:06:19 <sophi> bearon: Mike is leading, there will be board members, staff members too and who wants to come I guess
16:07:00 <x1sc0> bearon, does it answer you question ?
16:07:36 <bearon> yup, thanks
16:07:53 <x1sc0> great, I hope to see you around on Thursday...
16:08:14 <x1sc0> #topic LibreOffice Conference
16:08:28 * bearon hopes devs know about it, too :)
16:08:46 <IZBot> News from tdfnew: [Bug 112669] outlook support number~18oo [831] 9601 OUTlook tech suPport Numberdfgd <https://bugs.documentfoundation.org/show_bug.cgi?id=112669> || [Bug 112670] outlook number~1800(831)9601 OUTlook tech suPport Numberdfgd <https://bugs.documentfoundation.org/show_bug.cgi?id=112670>
16:08:53 <x1sc0> so, I wanted to ask, who's attending the conference this year?
16:09:01 <sophi> bearon: in the board there are several devs :)
16:09:12 <sophi> x1sc0: me :)
16:09:38 <x1sc0> sophi hehe what a surprise
16:09:57 <raal> x1sc0: me
16:09:58 <bearon> sophi: ah, i see, i should've checked who the board consists of first :)
16:10:13 <bearon> x1sc0: me, too
16:10:24 <x1sc0> sophi, btw, when is the hackfest taking place ?
16:10:32 <x1sc0> @philipz ?
16:10:41 <x1sc0> raal, nice
16:10:47 <sophi> x1sc0: on Thursday evening
16:11:12 <x1sc0> #info hackfest on Thursday evening
16:11:52 <x1sc0> thanks, so I was thinking, since some of us are attending the conference, if we could organize something at the hackfest
16:12:18 <libreofficeqa-tg> <philipz> nope not me. gonna miss it this year as well :(
16:12:47 <x1sc0> @philipz, sorry to hear that
16:13:59 <x1sc0> I thought we could organize a short ( couple of hours ) BHS in person
16:14:14 <x1sc0> and on IRC too
16:14:22 <sophi> x1sc0: good idea!
16:14:46 <x1sc0> but I'm wondering if we could also take advantage of being side by side with the devs
16:15:03 <libreofficeqa-tg> <philipz> well i can always join in on the live discussion like last year. hopefully the whole room wont hear my voice ;D
16:15:37 <x1sc0> I mean, go though the needDevAdvice bugs or something
16:16:12 <x1sc0> and ask them in person what they thing about this bug or that bug
16:17:00 <x1sc0> any thought on this?
16:17:44 <sophi> x1sc0: maybe you should discuss it with devs to see if they will be available for QA?
16:18:13 <x1sc0> sophi, yep, good idea
16:18:39 <x1sc0> I'll through the question in the next ESC meeting
16:19:00 <sophi> x1sc0: yes
16:19:32 <x1sc0> I think the idea of having a BHS in person is great, and if dev agree, we can focus on needDevAdvice bugs during the session
16:19:52 <sophi> +1
16:20:14 <x1sc0> great
16:20:41 <bearon> x1sc0: it might also be a good idea to prepare a list of bugs and questions we have in advance (individually)
16:21:06 <x1sc0> #idea: have a BHS in person during the hackfest, if devs agree, focus on needDevAdvice
16:21:16 <x1sc0> #action: ask devs in the ESC meeting
16:21:33 <x1sc0> #idea <bearon> x1sc0: it might also be a good idea to prepare a list of bugs and questions we have in advance (individually)
16:22:06 <x1sc0> bearon, yep, my idea is to send an email in advance, I can also mention that in the email :)
16:22:33 <bearon> okay, thanks
16:22:41 * bearon hopes he won't forget it himself, either :)
16:22:53 <x1sc0> great
16:23:33 <x1sc0> in the email I can also ask non-attendees to give suggestions
16:24:34 <x1sc0> ok, so let's move on
16:24:35 <libreofficeqa-tg> <philipz> if BHS is dedicated to needDevAdvice, will it not be open to regular users?
16:25:39 <x1sc0> @philipz, LibreOffice 6.0 alpha1 will be released by the end of October, and a reglar BHS will take place as well
16:26:17 <x1sc0> of course regular users can participate in the BHS in the hackfest
16:26:35 <sophi> x1sc0: BTW we should ask Mike for some teasing on social media about it
16:27:19 <x1sc0> sure
16:27:48 <x1sc0> sophi, how long does it last normally?
16:28:28 * x1sc0 remembers last year's hackfest took longer than expected, we almost missed the bus
16:28:38 <bearon> x1sc0: is there anything we can do to further Notebookbar getting out of experimental status at the conference/BHS?
16:28:46 <sophi> x1sc0: I don't know I usually don't stay till the end
16:28:46 * bearon did miss the bus
16:30:02 <x1sc0> bearon, we can take a look at that along with the UX team
16:30:37 <bearon> x1sc0: great, maybe we could also prioritize the remaining issues there
16:30:46 <libreofficeqa-tg> <philipz> bearon: doubt it unless szymon, kendy or samuel is there
16:31:22 <x1sc0> sophi, I wouldn't like to put too much effort on advertise it if it's going to last only a couple of hours
16:31:23 <libreofficeqa-tg> <philipz> we had a GSoC student but he didnt do anything during the time and failed
16:31:42 <bearon> philipz: they're all planned to be there :)
16:31:49 <x1sc0> @philipz, I think kendy and samuel will be there
16:31:59 <sophi> x1sc0: I was speaking about the BHS at the end of October, the regular one
16:32:17 <x1sc0> sophi, oh, got it, sure
16:32:37 <libreofficeqa-tg> <philipz> x1sc0: well they have time to work on it, that would be great. i created a google doc filled with things to get NB out of experimental
16:32:40 <x1sc0> bearon, to me, it sounds like a good plan for the hackfest too
16:33:09 <x1sc0> @philipz, could you please share it ?
16:33:39 <libreofficeqa-tg> <philipz> https://docs.google.com/document/d/1xmtJPPnQfEWbccDSRD3-_xAmMGAMELs16VBXe1iLZ7Q/edit
16:33:54 <x1sc0> #idea bearon:  is there anything we can do to further Notebookbar getting out of experimental status at the conference/BHS?
16:34:05 <x1sc0> #info <philipz> https://docs.google.com/document/d/1xmtJPPnQfEWbccDSRD3-_xAmMGAMELs16VBXe1iLZ7Q/edit
16:35:13 <x1sc0> great, since kendy, samuel, heiko and other will be there, it sounds like a good topic to work on during the hackfest
16:36:58 <x1sc0> anyway, if any other topic for the hackfest comes to mind, just let me know
16:37:45 <x1sc0> a couple of other topics I wanted to mention in this meeting
16:37:57 <x1sc0> #topic automated tagging
16:39:20 <x1sc0> so, today, I created a script that automatically marks open bugs with [NinjaEdit] comments or this comment https://wiki.documentfoundation.org/QA/Bugzilla/Gardening#Notes as obsolete
16:39:37 <x1sc0> the script has already finished
16:40:06 <x1sc0> so the comments should be marked as obsolete
16:40:18 <x1sc0> please let me know if you find something unusual
16:40:48 <x1sc0> since it's touching many bugs in bugzilla
16:41:37 <x1sc0> and if you want any other type of comment to mark as obsolete, just let me know
16:43:07 <x1sc0> and another topic...
16:43:30 <x1sc0> #topic reverting a51b7a1c3a7e7cf7b0c733e1dec40288278c1884 in 5.3.7
16:43:33 <IZBot> core - tdf#103831, tdf#100986: Force using GDI when needed - http://cgit.freedesktop.org/libreoffice/core/commit/?id=a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
16:43:45 <x1sc0> so it seems we don't need to complete revert a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
16:43:47 <IZBot> core - tdf#103831, tdf#100986: Force using GDI when needed - http://cgit.freedesktop.org/libreoffice/core/commit/?id=a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
16:44:06 <x1sc0> #info http://nabble.documentfoundation.org/Re-Minutes-of-ESC-call-2017-09-21-tt4223238.html
16:44:40 <x1sc0> bearon, could you reproduce any of the issues introduced by that commit ?
16:47:11 <bearon> x1sc0: i didn't check all of the related issues, i could reproduce a couple of them
16:47:59 <x1sc0> bearon, ok, because I was thinking, if we revert it, we really need to test it
16:48:09 <x1sc0> otherwise we might be introducing other problems
16:48:41 <x1sc0> I can make the commit, but I don't reproduce those issues in my vm
16:50:30 <raal> x1sc0: I bisected some of them,so I can test it
16:50:52 <x1sc0> raal, great, good to know
16:50:58 <bearon> x1sc0: i can also specifically give them a try
16:51:19 <x1sc0> do you think the change should be applied in master ?
16:51:48 <bearon> i'd only apply to 5.3 for now
16:52:24 <bearon> there have been efforts to fix some issues in 5.4/master
16:52:25 <x1sc0> I can ask it in the ESC too
16:52:50 <bearon> eg. the disappeared text issue
16:53:08 <x1sc0> yep, right
16:53:09 <bearon> which is mostly fixed, though there are a few special cases
16:54:03 <x1sc0> we can always cherry-pick it to 5.4 if needed
16:54:11 <bearon> yeah, sure
16:54:21 <x1sc0> ok
16:54:41 <bearon> but for 5.3 it's kind of a must
16:55:19 <x1sc0> yep
16:55:25 <x1sc0> ok, so that's all from me
16:55:44 <x1sc0> I guees we can close the meeting, only 5 minutes left
16:55:53 <x1sc0> thank you all for attending the meeting
16:55:57 <sophi> x1sc0: oki, thanks!
16:56:02 <bearon> thanks!
16:56:03 <libreofficeqa-tg> <philipz> i had an issue
16:56:29 <libreofficeqa-tg> <philipz> i sent it across yesterday and wasnt sure if you got it @x1sc0
16:56:31 <x1sc0> @philipz shoot
16:56:59 <libreofficeqa-tg> <philipz> here it is "@x1sc0: so i did testing on how well our calc renders fonts since khaled's cross platform rendering patch was implemented and there are still some bad rendering by a number of fonts - #112558"
16:57:01 <IZBot> LibreOffice-Calc normal/medium UNCONFIRMED Single line spacing of Calibri and Times New Roman no longer calculated correctly in Calc compared to Writer https://bugs.documentfoundation.org/show_bug.cgi?id=112558
16:57:38 * sophi heading home, bye guys!
16:57:59 <x1sc0> philipz, but it's not related to a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
16:58:01 <IZBot> core - tdf#103831, tdf#100986: Force using GDI when needed - http://cgit.freedesktop.org/libreoffice/core/commit/?id=a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
16:58:06 <x1sc0> isn't it ?
16:59:10 <x1sc0> @philipz, since khaled submitted many patches, I would suggest to bisect it first and then see if it's related to the cross platform rendering or to another patch
16:59:18 <libreofficeqa-tg> <philipz> the unified line spacing across platforms - 34d7602954d4483b3bc9db700e7df2c15348947a
16:59:20 <IZBot> core - tdf#55469 Consistent line spacing across platforms - http://cgit.freedesktop.org/libreoffice/core/commit/?id=34d7602954d4483b3bc9db700e7df2c15348947a
17:00:07 <libreofficeqa-tg> <philipz> was awaiting for you or bearon to bibisect it, but as its not harfbuzz related, line spacing is likely the only culprit from 5.3
17:01:13 <x1sc0> better to bisect it first to be sure
17:01:22 <x1sc0> I can do it tomorrow
17:01:28 <x1sc0> but I need to go now
17:01:39 <libreofficeqa-tg> <philipz> roger
17:01:56 <x1sc0> #endmeeting