17:00:28 <x1sc0> #startmeeting
17:00:28 <IZBot> Meeting started Tue May 30 17:00:28 2017 UTC.  The chair is x1sc0. Plugin info at http://wiki.debian.org/MeetBot.
17:00:28 <IZBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:49 <x1sc0> hi bearon buovjaga
17:00:57 <bearon> hey
17:01:02 <x1sc0> someone else for the QA meeting ?
17:01:07 <x1sc0> #topic rollcall
17:01:10 <buovjaga> hi
17:01:39 * cloph_away is here, but closing down soon, then off for dinner..
17:02:23 <x1sc0> while we wait a couple of minutes for someone else to join
17:02:33 <x1sc0> is there any topic you would like to discuss during the meeting ?
17:03:49 <buovjaga> x1sc0: telegram channel
17:04:06 <x1sc0> ok
17:04:17 <cloph_away> just FYI: just retriggered data collection for the dashboard, but that is rate-limited and should not cause any issues
17:04:52 <bearon> x1sc0: i want to bring up bibisect repos briefly, but it's not of particular importance, after the meeting is fine as well
17:05:12 <cloph_away> oh, maybe for topic: when it the deadline for having the build for bughunt session?
17:05:14 <x1sc0> bearon, we can talk about it during the meeting as well, no problem
17:05:41 <x1sc0> cloph_away, next BHS is planned for June 09
17:05:47 <x1sc0> actually that's the first topic of the day
17:06:07 <x1sc0> well, let's get started
17:06:23 <x1sc0> #topic Next Bug Hunting Session
17:06:35 <x1sc0> #link https://wiki.documentfoundation.org/QA/BugHuntingSession/5.4.0Beta2
17:06:47 <x1sc0> #info planned for June 09
17:06:51 <x1sc0> cloph_away, is the date ok ?
17:07:01 <x1sc0> or should we postpone it ?
17:07:19 <bearon> so it's not Friday for a change?
17:07:23 <cloph_away> #action x1sc0 remind cloph/others in ESC about BHS on Friday of tagging-week, so "hard deadline" for Tag on Tuesday
17:07:46 <cloph_away> it's friday in my calendar
17:07:56 <cloph_away> or do you mean you don't want to have it on Friday?
17:08:29 <x1sc0> ouch, it's on 7, June
17:08:43 <x1sc0> Bhs's page is incorrect
17:08:49 <bearon> Friday it is :)
17:08:52 <x1sc0> cloph_away, ok, will do
17:09:33 <x1sc0> #action x1sc0: send blogpost about it
17:09:42 <x1sc0> for this BHS I have and idea
17:10:02 <x1sc0> since Mike has the 'contribute' stickers
17:10:17 <x1sc0> I thought it would be a good idea to hang stickers to participant
17:10:22 <x1sc0> what do you think ?
17:11:19 <x1sc0> at the same time, I thought we could give 3 stickers if someone finds a critical bugs ( providing detailed steps and so on )
17:12:21 <x1sc0> any opinion on that ?
17:12:40 <bearon> x1sc0: how does handing out stickers work? they have to e-mail their address somewhere?
17:13:29 <x1sc0> bearon, yes, if they want the sticker ( some doesn't ) they need to email the address
17:13:57 <x1sc0> M-Saunders_away, is doing that for the month of LibreOffice
17:13:58 <bearon> sounds good to me
17:14:05 <x1sc0> and he has some stickers left
17:14:29 <x1sc0> I think it's worth a try
17:14:43 <x1sc0> I'll mention that in the blogpost
17:14:43 <bearon> absolutely
17:15:19 <x1sc0> #info don't forget to add yourself to https://wiki.documentfoundation.org/QA/BugHuntingSession/5.4.0Beta2
17:16:17 <x1sc0> ok, next topic
17:16:29 <x1sc0> #topic bibisect repositories
17:16:40 <x1sc0> bearon, please
17:17:38 <bearon> ok, it's really quick, so there are a few longer ranges that failed building in their respective repos, for example the 800-commit one in 5.4, that hasn't been addressed, yet, right?
17:17:51 <bearon> i was wondering if it would be possible to create a separate repo just for that range
17:18:34 * cloph_away needs to run, shutting down the place..
17:18:38 <bearon> and it could coexist with the regular 5.4 win bibisect repo (at least in that case)
17:19:30 <x1sc0> bearon, yes, It hasn't been addressed, Norbert told me it's not that straightforward to fix it, and it needs quite some time and effort to fixt it
17:19:31 <IZBot> News from tdfnew: [Bug 108248] Clear direct formatting doesnt remove paragraph background color <https://bugs.documentfoundation.org/show_bug.cgi?id=108248>
17:19:48 <bearon> there's also another in 5.3 that is 250~ or so commits, not sure how hard to fix that and produce builds for the range
17:20:25 <x1sc0> so we have 3 holes in the win repos ?
17:20:38 <bearon> x1sc0: what's the 3rd?
17:21:00 <x1sc0> ah ok, misread it, just 2
17:21:36 <bearon> i guess one could run through the repos with a script and count the lines in the commit message to see if there's anything else and if it's worth dealing with
17:22:22 <bearon> i ran into these two so far, but of course there are issues when the build doesn't start or something... i'm afraid nothing can be done there
17:23:18 <bearon> x1sc0: the question is, is adding a preemptive fix, and producing builds is hard in itself, or rebuilding the whole repo with such a fixed range is hard
17:23:24 <bearon> x1sc0: because this would eliminate the 2nd part
17:23:28 <bearon> but not the 1st
17:23:52 <bearon> anyway, it's just a thought, no need to decide on it right away
17:24:18 <x1sc0> the problem with those 2 ranges failing is that we don't know if there're other changes causing problems in between as well
17:26:09 <bearon> x1sc0: that's true, i guess we won't know until we try
17:26:23 <x1sc0> bearon, well, we need to find while it's failing in the first place, then fix it and start to build the repo again, finally we hope no other changes broke the build as well and if they do, we need to fix those failures as well
17:27:46 <x1sc0> Norbert knows the code much more than I do, and he told me it took quite some time to fix it one time he did it...
17:28:06 <bearon> yeah, i see
17:28:39 <bearon> x1sc0: one more thing, could you please add oldest tag to win 5.4 bibisect repo, and latest tags to other repos that are not supposed to be updated anymore
17:28:42 <x1sc0> at least we have the linux repos, however, sometimes the issue is just reproducible on Window
17:28:56 <x1sc0> bearon, ok, will do
17:29:00 <bearon> thanks!
17:29:01 <bearon> i think we can move on
17:29:23 <x1sc0> bearon, anyway, I'll take a look at the '250' range
17:29:37 <x1sc0> it sounds easier to fix than the biggest one
17:30:06 <bearon> x1sc0: hopefully, who knows :)
17:30:20 <x1sc0> yep, who knows
17:30:36 <x1sc0> #action x1sc0 add tag to repos
17:31:09 <x1sc0> #action x1sc0 take a look at holes in win repo
17:31:15 <x1sc0> ok, let's move on
17:31:19 <x1sc0> buovjaga, are you with us ?
17:31:39 <buovjaga> yes
17:31:52 <x1sc0> #topic telegram group
17:32:07 <x1sc0> go ahead then
17:32:21 <buovjaga> So having a group in a proprietary platform is silly in itself (why not Facebook?), but when we don't have a bridge, it is downright problematic.
17:32:46 <buovjaga> I think it should be required that if some team sets up a Telegram channel, a bridge must be set up
17:33:18 <buovjaga> The bridge bot in #libreoffice-telegram is not maintained very actively as can be seen here: https://github.com/RITlug/teleirc/issues/33#issuecomment-304726407
17:33:37 <buovjaga> There is a more featureful bridge here: https://github.com/FruitieX/teleirc/ it even supports all media from Telegram
17:33:46 <buovjaga> even videos, it seems
17:34:33 <x1sc0> ok
17:34:46 <x1sc0> one question, should it be bridged to this channel or to a new one ?
17:36:20 <buovjaga> x1sc0: why to a new one?
17:36:32 <buovjaga> if the point is to work in QA, it *must* be bridged here
17:36:43 <x1sc0> ok, just asking to be sure
17:36:52 <buovjaga> we must have some control over the fragmentation of comm channels
17:37:23 <x1sc0> so everything in this channel will be seen there too, or just thing from there here ?
17:37:24 <buovjaga> ideally we'd kick Telegram's ass with something better and open, but we don't have limitless budget
17:37:40 <buovjaga> completely transparency between the groups, just like #libreoffice-telegram
17:37:48 <buovjaga> except with a better bot
17:38:04 <buovjaga> because now on #libo-telegram I am missing images all the time and it is very disappointing
17:38:26 <buovjaga> ppl just post "wow" and I go "hmm, it must be an image"
17:39:48 <bearon> it must be some sexy writer document you'll never be able to see :P
17:40:33 <x1sc0> but, if we post everything we say here in there, IMHO, the telegram group will get unuseless
17:40:50 <buovjaga> un-useless sounds good :)
17:41:04 <buovjaga> that's what I'm hoping.. now it's useless, then it would be un-useless aka useful
17:42:01 <buovjaga> x1sc0: please explain why you don't want to fully bridge?
17:42:20 <x1sc0> useless I meant :D
17:43:22 <x1sc0> I'm just wondering, if we bridge both channels, can we, at least, ban the IZBot ?
17:44:16 <x1sc0> don't display the IZBot there, otherwise, it would make the telegram channel difficult to use...
17:45:04 <buovjaga> well I guess it can be ignored, but what is the point of a Telegram QA channel, if bug reports are not of interest?
17:45:45 <x1sc0> it's going to make it really difficult to follow
17:46:18 <x1sc0> it's just my opinion, but I think that is what is going to happen
17:46:38 <buovjaga> why would it be difficult? time flows linearly, bots or not, right?
17:47:05 <buovjaga> it's not like the bot messages will make some fracture in time-space continuum and the telegram messages start to crumble
17:47:41 <buovjaga> if you use the telegram group to drink beer, then I would understand, but if you use it to triage bugs, then bug reports should be pretty central..
17:48:15 <buovjaga> but it's a detail.. the important thing is to bridge the channels - if the intention actually is to do work in that group?
17:48:17 <x1sc0> it'll make the group annoying, and people will just ignore it
17:48:42 <buovjaga> ok, so sounds like people are annoyed by work in there
17:48:59 <bearon> i agree that the bot would be important
17:49:02 <x1sc0> buovjaga, yep, people don't use for work
17:49:09 <bearon> there aren't that many bug reports
17:49:28 <bearon> during the past hour there was 1
17:49:31 <buovjaga> what's the point of the channel, if people don't use it for work?
17:49:39 <bearon> fiesta~
17:49:48 <buovjaga> so they really just drink beer in there? :(
17:50:11 * buovjaga goes and shoots himself in the head
17:50:44 <x1sc0> it's useful for end users willing to work on testlink for instance
17:51:15 <x1sc0> more for general questions
17:51:23 <buovjaga> so Telegram users are genetically good for working in Testlink?
17:52:47 <x1sc0> end users are good for working in Teslink, we're using offering 2 different ways of communicating
17:53:13 <buovjaga> well they're not end users anymore after doing QA
17:54:49 <bearon> x1sc0: there isn't that much activity in this channel, is there? (IRC, i mean)
17:55:13 <x1sc0> since the telegram channel is quite quiet, my suggestion would be: Ok, let's bridge both channel, but without the IZBot
17:55:41 <marcoagpinto> >:) <- It is the cola demon here!
17:56:06 <bearon> x1sc0: do people want it to be quiet?
17:57:20 <x1sc0> bearon, I'm pretty sure they will leave the channel if they get too much notifications
17:57:26 <x1sc0> anyway, I can ask in the channel
17:57:29 <buovjaga> I think only Microsoft wants us to be quiet
17:57:43 <x1sc0> what is their opinion, anyway, I'm fine with bridging both channels
17:57:43 <buovjaga> so if you want silence, you are working for MS
17:58:12 <bearon> x1sc0: btw, how many users are in the QA telegram channel?
17:58:25 <x1sc0> 23
17:58:26 <buovjaga> this sounds really scary and crazy: "they will leave the channel if they get too much notifications "
17:59:33 <bearon> that's a decent number
17:59:45 * bearon was afraid the group would be empty
18:00:16 <x1sc0> buovjaga, that's my opinion and I think that is what will happen
18:00:21 <x1sc0> but let's try anyway
18:00:45 <buovjaga> well then we are living in a mad world
18:01:04 <bearon> btw, jphilipz would've liked the telegram channel mentioned in the topic and in the wiki as well
18:01:26 <bearon> buovjaga: we already know we are :)
18:01:46 <x1sc0> for a long time :D
18:02:19 <x1sc0> #action x1sc0 set up the bridge between telegram and IRC
18:02:36 <x1sc0> ok, it's 18:00 UTC already
18:02:42 <x1sc0> closing the meeting now...
18:03:00 <x1sc0> #endmeeting